linuxgurugamer

[1.5.*] ScienceAlert ReAlerted : Experiment availability

Recommended Posts

6 hours ago, EliteMaster512 said:

Hello all, do we know if an update to the CKAN for 1.6 is in the works?

No clue.

6 hours ago, EliteMaster512 said:

Or will I have to install this manually?

Just 2 posts above yours, I've explained how to install this mod via CKAN for a 1.6 install. It got pictures and stuff :)

Share this post


Link to post
Share on other sites
Posted (edited)

New reelase, 1.9.5.2

  • Fixed saving of profiles
  • Fixed loading of profiles
  • Some optimizations by reducing duplicate calls
  • Following due to changes in KSP:
    • Changed the OnLoad in the ScienceAlertProfileManager to calling a CoRoutine so it can wait until the scene is ready
    • Changed the OnVesselChange in the ScienceAlertProfileManager to calling a CoRoutine so it can wait until the OnLoad is complete
Edited by linuxgurugamer
  • Like 2

Share this post


Link to post
Share on other sites

@linuxgurugamer I'm curious though: The online version file is not updated yet. Is that something you have automated and the script didn't run yet or did you forget it?

Share this post


Link to post
Share on other sites
1 minute ago, 4x4cheesecake said:

@linuxgurugamer I'm curious though: The online version file is not updated yet. Is that something you have automated and the script didn't run yet or did you forget it?

It gets updated 2x a day, 6am and 6pm, I'll force it to run now, though

  • Like 1

Share this post


Link to post
Share on other sites

When experiments are available, the icon for ScienceAlert on the stock toolbar is blank.  When science isn't available, the icon for it is the green bottle on the stock toolbar.   Any idea on how that can be fixed to show the correct icons on the stock toolbar or not be blank when science is available?

Share this post


Link to post
Share on other sites
1 minute ago, linuxgurugamer said:

It gets updated 2x a day, 6am and 6pm, I'll force it to run now, though

I see. I know that CKAN can take a while but I got curious when AVC didn't notify me. Thanks for the info :)

Share this post


Link to post
Share on other sites
1 minute ago, 4x4cheesecake said:

I see. I know that CKAN can take a while but I got curious when AVC didn't notify me. Thanks for the info :)

Should be ok now

Share this post


Link to post
Share on other sites
Posted (edited)
46 minutes ago, TriggeredSnake said:

Will it be 1.6 compatible?

It is and even though the thread title still says [1.5.*], I'm pretty sure that the latest release is compiled for 1.6 (especially because it is listed for 1.6.0 on CKAN and spacedock).

Since 1.5. and 1.6. didn't provide huge changes to the KSP API and the engine version didn't change neither, most mods from 1.4 still work perfectly fine in 1.5 and 1.6.

Edited by 4x4cheesecake

Share this post


Link to post
Share on other sites
15 hours ago, 4x4cheesecake said:

It is and even though the thread title still says [1.5.*], I'm pretty sure that the latest release is compiled for 1.6 (especially because it is listed for 1.6.0 on CKAN and spacedock).

Since 1.5. and 1.6. didn't provide huge changes to the KSP API and the engine version didn't change neither, most mods from 1.4 still work perfectly fine in 1.5 and 1.6.

Oh good! Thanks!

Share this post


Link to post
Share on other sites
Posted (edited)

FWIW (as I have little time for debugging KSP ATM), I tried 1.9.5.2 on KSP 1.5.1, and I'm seeing a consistent 20FPS+ performance hit (vsync @60 -> ~40) while in flight. Nothing interesting is being logged, and the mod appears to otherwise work fine.

Edited by steve_v

Share this post


Link to post
Share on other sites

Hmm... did anyone here made own settings and can remember if he had to load it every time before a flight?
I'm pretty sure it was only on the first start (or the first time on a new game), now its just "default" every time and I have to change it before a flight to my saved profile

Share this post


Link to post
Share on other sites

I just got this, and started a new game.  When I go on EVA and get an EVA report, then hit keep, it doesnt show it for review on my kerbal or when I get back to my capsule.  Transmitting data does not seem to work even when having an external antenna.

Edited by traisjames

Share this post


Link to post
Share on other sites
12 hours ago, GerAseR said:

Hmm... did anyone here made own settings and can remember if he had to load it every time before a flight?
I'm pretty sure it was only on the first start (or the first time on a new game), now its just "default" every time and I have to change it before a flight to my saved profile

Log file, please, also, what version of KSP and what version of the  mod?

4 hours ago, traisjames said:

I just got this, and started a new game.  When I go on EVA and get an EVA report, then hit keep, it doesnt show it for review on my kerbal or when I get back to my capsule.  Transmitting data does not seem to work even when having an external antenna.

Did you install the dependencies?

Quote

 

Share this post


Link to post
Share on other sites

Yep.  Here are all mods installed:

Spoiler

KSP: 1.6.1 (Unix) - Unity: 2017.1.3p1 - OS: Mac OS X 10.14.3
[x] Science! - 5.17
Advanced Jet Engine - 2.10
AdvancedFlyByWire - 1.8.1.3
AGExt - 2.3.3.8
Alternate Resource Panel - 2.9.3
Asteroid Recycling Tech - 0.13
AtmosphereAutopilot - 1.5.11
Aviation Lights - 4.0.5
B9 Part Switch - 2.4.5
CapCom Mission Control On The Go - 1.0.2.10
ClickThroughBlocker - 0.1.6.10
Community Category Kit - 4.0
Community Resource Pack - 1.0
Community Terrain Texture Pack - 1.0.4
Contract Configurator - 1.27.1
Contract Parser - 1.0.8
Contracts Window Plus - 1.0.9.2
DangIt - 0.7.18.2
DMagic Orbital Science - 1.4.2
Docking Port Alignment Indicator - 6.8.2.3
DynamicBatteryStorage - 1.3.3
Filter Extensions - 3.2.2.15
Firespitter Unofficial - 7.9.0.1
FMRS (Flight Manager For Reusable Stages) - 1.2.7.4
Freight Transport Tech - 0.10
FShangarExtender - 3.5.2
HideEmptyTechTreeNodes - 1.0.5
Infernal Robotics - 3.0
Infernal Robotics Sequencer - 3.0
Interstellar Fuel Switch - 3.6.17.3
JanitorsCloset - 0.3.4.5
Karbonite - 0.12
KAS - 1.1.6876.38030
Kerbal Actuators - 1.6
Kerbal Alarm Clock - 3.10
Kerbal Engineer Redux - 1.1.5.4
Kerbal Foundries - 2.2.6.16
Kerbal Inventory System - 1.16.6876.37464
Kerbal Planetary Base Systems - 1.6.6
kOS - 1.1.5.2
KramaxAutoPilotContinued - 0.3.6.2
KSP Interstellar Extended - 1.20.16.3
KSP_Proximity - 0.3
KSP-AVC Plugin - 1.2.0.7
KSPWheel - 0.11.9.27
ModularFlightIntegrator - 1.2.6
NearFutureAeronautics - 1.0.2
NearFutureConstruction - 1.0.4
NearFutureElectrical - 0.10.2
NearFutureLaunchVehicles - 1.1.7
NearFutureProps - 0.3.5
NearFutureSolar - 0.8.13
NearFutureSpacecraft - 1.0.1
Parking Brake - 0.1.0.1
PatchManager - 0.0.16.4
Photon Sailor - 1.4.6.3
Precise Maneuver - 2.4.1
Procedural Parts - 1.2.12
Progress Parser - 1.0.10
PWBFuelBalancerRestored - 0.1.5.5
QuantumStrutsContinued - 1.7.3.3
RCS Build Aid - 0.9.7.4
Recovery Controller - 0.0.3.4
RemoteTech - 1.9.1.131
RemoteTech-StockConfigs - 1.0.1
ResearchBodies - 1.9.8
ResonantOrbitCalculator - 0.0.3.4
SCANsat - 1.1.8.10
ScienceAlert - 1.9.5.3
ScienceLabInfo - 0.9.1
SituationModuleInfo - 1.3.3.1
SolverEngines - 3.7.3
StageRecovery - 1.9.0.4
Surface Mounted Lights - 1.11.6951.3656
TAC Life Support - 0.13.11
The World Beyond - 1.1.1
TimeControl - 2.9.5
Toolbar - 1.7.17.15
ToolbarControl - 0.1.6.20
TweakScale - 2.4.0.7
Universal Storage 2 - 1.5.1.9
USI Core - 0.7
USI Tools - 0.12
Waypoint Manager - 2.7.4
 

I started a new science game and did a few experiments.  Here is the archive:  https://imgur.com/BTJS6px

Edited by traisjames

Share this post


Link to post
Share on other sites

 

On 1/12/2019 at 5:35 PM, GerAseR said:

Hmm... did anyone here made own settings and can remember if he had to load it every time before a flight?
I'm pretty sure it was only on the first start (or the first time on a new game), now its just "default" every time and I have to change it before a flight to my saved profile

So, the profile is being saved, but you need to load it before a flight?

 

Share this post


Link to post
Share on other sites
On 1/14/2019 at 9:12 PM, linuxgurugamer said:

 

So, the profile is being saved, but you need to load it before a flight?

 

Yes, before every flight. Can't remember if it was that way before i updated to 1.6..1 

EDIT:
Just did a clean install with all mods again and it works just like it should. Thanks for your time!

Edited by GerAseR

Share this post


Link to post
Share on other sites
On 1/13/2019 at 1:37 AM, traisjames said:

I just got this, and started a new game.  When I go on EVA and get an EVA report, then hit keep, it doesnt show it for review on my kerbal or when I get back to my capsule.  Transmitting data does not seem to work even when having an external antenna.

I tested this, don't see it.  I was able to go on EVA, get science, keep it, return to the capsule and transmit it down (with an external antenna).

I need more info, a log file, and if possible a video showing it not working

On 1/3/2019 at 7:43 PM, steve_v said:

FWIW (as I have little time for debugging KSP ATM), I tried 1.9.5.2 on KSP 1.5.1, and I'm seeing a consistent 20FPS+ performance hit (vsync @60 -> ~40) while in flight. Nothing interesting is being logged, and the mod appears to otherwise work fine.

Curious, is that happening while the icon is animated?

Share this post


Link to post
Share on other sites
10 minutes ago, linuxgurugamer said:

is that happening while the icon is animated?

I did not test this travelling over already completed biomes specifically (my test case being an aircraft on Kerbin) or switching off experiment monitoring to prevent the animation.
I don't recall there being any noticeable difference wrt the icon animating or not though, it looked like a consistent performance hit whenever in flight.

Re-testing the same craft I first noticed this with, the problem appears to be considerably reduced.
Either the cause was addressed in 1.9.5.3 or my testing is flawed.
I'm still seeing a framerate hit with Science Alert installed, but it's now a very acceptable one.

[x]Science, fwiw, still murders performance while the 'here and now" window is open, though that one has not been updated recently and what I am using is an unofficial build.


If you have any further investigation in mind, I can likely oblige. Let me know what you need and I'll clone my install to test it.

Share this post


Link to post
Share on other sites
1 hour ago, steve_v said:

I did not test this travelling over already completed biomes specifically (my test case being an aircraft on Kerbin) or switching off experiment monitoring to prevent the animation.
I don't recall there being any noticeable difference wrt the icon animating or not though, it looked like a consistent performance hit whenever in flight.

Re-testing the same craft I first noticed this with, the problem appears to be considerably reduced.

Ok, that was a long shot, but I needed to know.  The animated icon is manual, so there is a decent amount of processing going on for that.

I don't remember exactly, but I do know there were some improvements made in the recent builds.  Given what it does, it's impossible to avoid all impact, it does need to do things in order to do it's thing :-)

For now, I'll consider it resolved.

[x] Science, does things in a different way, and is checking ALL biomes & experiments.  I believe that there was an unofficial build which fixed that particular issue, no idea when it was done.  The unofficial build simply disabled checks for biomes which the current vessel wasn't around (I don't remember the details)

  • Like 1

Share this post


Link to post
Share on other sites

Hi @linuxgurugamer could you add alerts based on contracts?
Example:
Magneto Scan ist maxed out so 0% science, but if a contract pops up an wants a new scan to transmit or return, it would be nice if i would get a new alert based on the contract goals.
 

Possible or did i miss something in the settings?

Share this post


Link to post
Share on other sites
41 minutes ago, GerAseR said:

Hi @linuxgurugamer could you add alerts based on contracts?
Example:
Magneto Scan ist maxed out so 0% science, but if a contract pops up an wants a new scan to transmit or return, it would be nice if i would get a new alert based on the contract goals.
 

Possible or did i miss something in the settings?

Sorry, no.  That is outside the scope of this mod

  • Like 1

Share this post


Link to post
Share on other sites
6 hours ago, linuxgurugamer said:

Sorry, no.  That is outside the scope of this mod

Ok, hoped its perhaps just a little thing that you can implement from KAC...
Thanks for your time again!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now