Jump to content

[1.9.x] ScienceAlert ReAlerted : Experiment availability, now with DMagic support


Recommended Posts

3 hours ago, bpiltz said:

Was using this in an older save file, but with current KSP version.  Started a new career to get the biome features in Breaking Ground that wouldn't work unless you start with a clean save file.  Well, now this mod is barely notifying biomes when science is available.  I say "barely", because it does do it sometimes, but is missing the biome cues 90% of the time.  I have it set to always notify if any available science.  First launch on launchpad with science instruments and it detects no science available.

Hmmm.  Well, first off, it hasnt been updated yet for 1.7.  Second, if you dont provide a log file, no help can be provided.  Third, if you need to know where the log file is, look at my sig

Link to post
Share on other sites

linuxgurugamer,

so I played around with re-installing the mod on a new save file after the KSP 1.7.3 came out yesterday.  while doing that I discovered that if I check the option to enable SCANsat integration in Science Alert settings, that's when it breaks the science notification.  toggle it off and available science alert comes back.  I guess I'll leave that toggled off.  I do use SCANSat, but not sure what that toggle does.

I guess I must have toggled it on in my old save file at a time when no science was available, so I missed seeing the second order effect.

Link to post
Share on other sites
18 hours ago, bpiltz said:

linuxgurugamer,

so I played around with re-installing the mod on a new save file after the KSP 1.7.3 came out yesterday.  while doing that I discovered that if I check the option to enable SCANsat integration in Science Alert settings, that's when it breaks the science notification.  toggle it off and available science alert comes back.  I guess I'll leave that toggled off.  I do use SCANSat, but not sure what that toggle does.

I guess I must have toggled it on in my old save file at a time when no science was available, so I missed seeing the second order effect.

Silly question, did you have Scansat installed?

Link to post
Share on other sites
On 7/12/2019 at 6:26 PM, bpiltz said:

linuxgurugamer,

so I played around with re-installing the mod on a new save file after the KSP 1.7.3 came out yesterday.  while doing that I discovered that if I check the option to enable SCANsat integration in Science Alert settings, that's when it breaks the science notification.  toggle it off and available science alert comes back.  I guess I'll leave that toggled off.  I do use SCANSat, but not sure what that toggle does.

I guess I must have toggled it on in my old save file at a time when no science was available, so I missed seeing the second order effect.

Would be useful to see a log file

Link to post
Share on other sites
On 7/12/2019 at 6:26 PM, bpiltz said:

linuxgurugamer,

so I played around with re-installing the mod on a new save file after the KSP 1.7.3 came out yesterday.  while doing that I discovered that if I check the option to enable SCANsat integration in Science Alert settings, that's when it breaks the science notification.  toggle it off and available science alert comes back.  I guess I'll leave that toggled off.  I do use SCANSat, but not sure what that toggle does.

I guess I must have toggled it on in my old save file at a time when no science was available, so I missed seeing the second order effect.

As described in the OP:

SCANsat support

  • Enable SCANsat integration in the additional options menu
  • With this option enabled, you will only receive biome-associated alerts if you have mapped that portion of the planet's surface
  • Non-biome specific alerts will still occur as normal

Conclusion:  It's working as expected.

Link to post
Share on other sites
  • 1 month later...

I don't want to be one of those "Why wont it work, make it work!" guys. I know you have taken on a ton of depreciated mods and I am eternally thankful for the many you took on that I still use today. Science Alert is on my top 5 if not my number 1 mod for quality of life mods. I tried to use others but they either miss some experiments (maybe I'm doing something wrong) or just don't work the way I expect them too. Any way I just wanted to ask if 1.7 Science Alert is working as expected and its something wrong with me or is it in the works being fixed? Or maybe your waiting for the anticipated 1.8(?) texture revamp update? I can see the icon working, it stops warp on finding an experiment but the UI is no where to be found. Again thank you for your hard work.

Link to post
Share on other sites
2 hours ago, TheKnave said:

I don't want to be one of those "Why wont it work, make it work!" guys. I know you have taken on a ton of depreciated mods and I am eternally thankful for the many you took on that I still use today. Science Alert is on my top 5 if not my number 1 mod for quality of life mods. I tried to use others but they either miss some experiments (maybe I'm doing something wrong) or just don't work the way I expect them too. Any way I just wanted to ask if 1.7 Science Alert is working as expected and its something wrong with me or is it in the works being fixed? Or maybe your waiting for the anticipated 1.8(?) texture revamp update? I can see the icon working, it stops warp on finding an experiment but the UI is no where to be found. Again thank you for your hard work.

Its not perfect, but it should be working.  Did you click the button?  I believe there are options to set which say whether the ui should be shown or not (been a while since I played a science based game)

Link to post
Share on other sites
2 hours ago, Cuna said:

CKAN shows no tick box to install, has not for a while.

anyone know why?

Change your CKAN settings to consider 1.6 as compatible 

New Release, 1.9.7

  • Added Install Checker
  • Updated AssemblyVersion
     
Link to post
Share on other sites

I've tried to install this mod twice (dragged the folder into gameData, same as any other mod), but it doesn't seem to show up in game. No error messages, but no button for scienceAlert. I used both the version from SpaceDock and the latest version from Github, neither seemed to work. I even made a new career file (someone else mentioned that) and it still wasn't showing up. Am I missing something? Is there a conflict with moduleManager or something?

Link to post
Share on other sites
5 hours ago, NewSwiss said:

I've tried to install this mod twice (dragged the folder into gameData, same as any other mod), but it doesn't seem to show up in game. No error messages, but no button for scienceAlert. I used both the version from SpaceDock and the latest version from Github, neither seemed to work. I even made a new career file (someone else mentioned that) and it still wasn't showing up. Am I missing something? Is there a conflict with moduleManager or something?

are the dependencies (see OP) installed?

Link to post
Share on other sites
  • 1 month later...
  • 3 weeks later...

Minor update, 1.9.8.1

  • Thanks to @Gordon_Dry for this:
    • Simplification of  zzz_fix_biomeMask_situationMask_0.cfg
    • Sanity fix for RP-0 (RP-1)
    • Update zzz_fix_biomeMask_situationMask_0.cfg
    • See
      • https://forum.kerbalspaceprogram.com/index.php?/topic/175772-15-*
    • and following posts. A simplification of the patch.
       
Link to post
Share on other sites

New release, 1.9.8.2

  • Replaced embedded resource images with files
  • Removed 120 lines related to embedded resource images
  • Found a static GUISkin which was causing the options window to be double width
  • Commented out a line in Settings which was setting the background to null
  • Restored the missing controls to close the window, lock the window, etc
Edited by linuxgurugamer
Link to post
Share on other sites

Possible bug: ScienceAlert Realerted has problems with wedge AMS and Mystery Goo experiments from Universal Storage II mod; the experiments show up in the window, but when activated via ScienceAlert they can't be reset and data can't be collected from them. 

Additionally, OrbitalScience wedge parts in Universal Storage II mod can't be activated at all using ScienceAlert. 

Both mods worked well with each other in 1.7.3. I also posted about this problem in Universal Storage II topic.

Link to post
Share on other sites
23 minutes ago, Physical Copy said:

Possible bug: ScienceAlert Realerted has problems with wedge AMS and Mystery Goo experiments from Universal Storage II mod; the experiments show up in the window, but when activated via ScienceAlert they can't be reset and data can't be collected from them. 

Additionally, OrbitalScience wedge parts in Universal Storage II mod can't be activated at all using ScienceAlert. 

Both mods worked well with each other in 1.7.3. I also posted about this problem in Universal Storage II topic.

You need to post a log file before I’ll look into this

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...