Jump to content

[1.9.x] ScienceAlert ReAlerted : Experiment availability, now with DMagic support


Recommended Posts

On 2/5/2020 at 7:40 PM, Crixomix said:

I'm experiencing something weird with science alert where it won't work on the DMagic science items (attempted with magnetometer boom and plasma wave one.) It tells me "can't be done right now" but I can just right click on the boom and make it run science. Log is provided:

https://www.dropbox.com/s/o82t14e2vt0uyy6/KSP.log?dl=0

EDIT: Further, I noticed I didn't have the "dmagicanimategeneric" (or something like that, not at my KSP computer at the moment) mod installed, and I thought ooh maybe that's the issue. So I then installed said mod through CKAN, and then it didn't fix the issue.

It's a limitation of this and most if not all other science monitors/gatherers.  Nonstock science modules are not supported.

Link to post
Share on other sites
1 hour ago, linuxgurugamer said:

It's a limitation of this and most if not all other science monitors/gatherers.  Nonstock science modules are not supported.

Really? I've been able to use either this mod or X-science here and now to utilize Dmagic before so I figured it was a bug. So was it just lucky that it did work for all that time and now it's normal that it doesn't? Or does it just mean something changed on the DMagic end that means this mod no longer can operate those science experiments? Too bad though. Thanks for the answer!

Edited by Crixomix
Link to post
Share on other sites
2 minutes ago, Crixomix said:

Really? I've been able to use either this mod or X-science here and now to utilize Dmagic before so I figured it was a bug. So was it just lucky that it did work for all that time and now it's normal that it doesn't? Or does it just mean something changed on the DMagic end that means this mod no longer can operate those science experiments? Too bad though. Thanks for the answer!

All I can say is that the mod does not have any reference to the DMagic experiments.  Never did.  Maybe X-Science, but that's not under my control

Link to post
Share on other sites

Getting a Unity crash that's a PITA to track down, but my latest data suggests ScienceAlertRealerted. Symptom is a crash to desktop with a Unity error. I can't consistently reproduce it, but it is always on a scene change, usually to the KSP center. Thought for a while it was from SImpleLogistics, but just now got one on a game I started without that mod, blowing that hypothesis. Zer0Kerbal pointed me at the KSP.log, which is a bit more informative to me than Player.log. In particular, I see in the current version of it

[ERR 15:46:23.046] ScienceAlert: Failed to create crewReport ScienceSubject. If you can manage to reproduce this error, let me know.

[ERR 15:46:23.046] ScienceAlert: Exception was: System.NullReferenceException: Object reference not set to an instance of an object
  at ScienceAlert.ProfileData.ScienceAlertProfileManager.get_ActiveProfile () [0x00019] in <81f9088edb0c4a7286f07a604524968c>:0
  at ScienceAlert.Experiments.ExperimentObserver.UpdateStatus (ExperimentSituations experimentSituation, System.Boolean& newReport) [0x0026e] in <81f9088edb0c4a7286f07a604524968c>:0

Links to the whole KSP.log (and Player.log, which you ask for), along with error.log and crash.dmp from the crash directory.

https://www.dropbox.com/s/whzs806zu78nj0p/KSP.log?dl=0

https://www.dropbox.com/s/6bp0hldrxh8vgah/Player.log?dl=0

https://www.dropbox.com/s/dz6out1yyti4we9/error.log?dl=0

https://www.dropbox.com/s/lfrmr8tz283ms02/crash.dmp?dl=0

 

KSP 1.8.1 on WIndows 10, with the following mods (this list generated by CKAN)

B9 Part Switch (B9PartSwitch v2.13.0)
ClickThrough Blocker (ClickThroughBlocker 0.1.9.5)
Community Category Kit (CommunityCategoryKit 5.0.0.0)
Community Resource Pack (CommunityResourcePack 1.3.0.0)
Easy Vessel Switch (EVS) (EasyVesselSwitch 2.0)
Extraplanetary Launchpads (ExtraPlanetaryLaunchpads 6.7.0.0)
GravityTurn Continued (GravityTurnContinued 2:1.7.7)
KEI (KEI 1.2.10.1)
Kerbal Alarm Clock (KerbalAlarmClock v3.12.0.0)
Kerbal Attachment System (KAS 1.5)
Kerbal Engineer Redux (KerbalEngineerRedux 1.1.7.1)
Kerbal Inventory System (KIS 1.24)
Kerbal Planetary Base Systems (KerbalPlanetaryBaseSystems v1.6.10)
Kerbal Stats (KerbalStats 3.1.0)
MechJeb 2 (MechJeb2 2.9.1.0)
MissingHistory (MissingHistory 1.8.1)
Module Manager (ModuleManager 4.1.3)
Near Future IVA Props (NearFutureProps 1:0.6.1)
Precise Maneuver (PreciseManeuver 2:2.4.4)
Progressive Colonization System (ProgressiveColonizationSystem v2.1.0)
ScienceAlert ReAlerted (ScienceAlert 1.9.8.6)
Stockalike Station Parts Expansion Redux (StationPartsExpansionRedux 1.3.2)
Toolbar Controller (ToolbarController 1:0.1.9.4)
TriggerAu Flags (TriggerAu-Flags v2.9.3.0)
Waypoint Manager (WaypointManager 2.8.1)


Per CKAN, all of them but Gravity Turn claim to be ok for KSP 1.8.1. User reports say gravity turn is ok, and I was getting these crashes before I added it just yesterday.

Hmm. As I'm typing thta, it occurs to me that Progressive Colonization System does add some science experiments and I didn't get any of these crashes on this game until right after I  did the first of those experiments. Maybe related? If ScienceAlertReAlerted isn't getting along well with Progressive Colonization, I suppose I could stop using Science AlertReAlerted for this career. It's a nice convenience, but not indispensable, whereas Progressive Colonization System was the whole reason for this particular career.

 

Link to post
Share on other sites

I wish I could say that i fixed it, but this is a random crash which happens to many people, with a wide variety of mods.  I've had this happen without Science Alert.

Various googling seems to indicate that it may be a Unity issue

Thank you for the report, I will look at it

Link to post
Share on other sites

Sorry to bother again. This time I believe I have found a bug with stock science interaction with sciencealert.. When I run the SC-9001 Science Junior from the sciencealert menu, and then hit "keep" on the resulting menu, I no longer have access to the data. When I right click on the science Jr, the only option is to "observe materials" but if I try to, it says "no more samples can be collected". Also worth noting that the doors on the part don't open when clicking the button, even though it does run the experiment and show the data popup window. I was able to get around this because I use the action groups editing mod and I could bind the "reset materials bay" to a hotkey, which then would reset it, but that option wasn't available in the right-click menu, nor could I "view data" via the right click menu like you usually can. Also, for reference, x-science here and now seemed to run the experiment as usual and open the science bay doors and then I could properly interact with the data via rick clicking on the science JR.

KSP.log provided here. https://www.dropbox.com/s/o82t14e2vt0uyy6/KSP.log?dl=0

Also, you definitely don't get enough thank-yous for all the awesome mods you keep working for us. So thank you! Seriously. You are a huge service to the community.

Edited by Crixomix
Link to post
Share on other sites

Kopernicus adds the ability to create custom science experiments for terrain scatters on planet surfaces. These experiments are triggered when coming into a specific range of a terrain scatter.

ScienceAlert is picking up the experiments and letting anyone perform them at any range:

I was wondering if you are willing to support the additions in Kopernicus changes so that people are able to use ScienceAlert without being able to cheat! Thank you.

SS_02-14-2020_20-36-40.png

 

Link to post
Share on other sites
On 2/5/2020 at 7:40 PM, Crixomix said:

I'm experiencing something weird with science alert where it won't work on the DMagic science items (attempted with magnetometer boom and plasma wave one.) It tells me "can't be done right now" but I can just right click on the boom and make it run science. Log is provided:

https://www.dropbox.com/s/o82t14e2vt0uyy6/KSP.log?dl=0

EDIT: Further, I noticed I didn't have the "dmagicanimategeneric" (or something like that, not at my KSP computer at the moment) mod installed, and I thought ooh maybe that's the issue. So I then installed said mod through CKAN, and then it didn't fix the issue.

 

Yep, I have the same issue here. It appears to also affect the non-Dmagic Dmagic science such as Probes Plus's magnetometer booms.

 

EDIT: you can ignore me. I somehow skipped an entire page of the thread (that you already commented on this exact problem). :p

Edited by captainradish
Link to post
Share on other sites
  • 4 weeks later...
On 2/15/2020 at 6:25 PM, captainradish said:

Yep, I have the same issue here. It appears to also affect the non-Dmagic Dmagic science such as Probes Plus's magnetometer booms.

 

EDIT: you can ignore me. I somehow skipped an entire page of the thread (that you already commented on this exact problem). :p

Confirm that I successfully used Science Alert (before realerted) with Dmagic and Universal storage in 1.5-1.6 time. Now with Universal storage 2 and Science alert realerted - something is not working.

@linuxgurugamer, understood your position, just making comment that it worked somehow before, so some people (including me) could treat new behaviour as a bug, wich it isn't based on your response. Any chance Dmagic integration could be added as a new feature? When you pass small biome and try to gather oll the science by pixelhunting your science equipment - you can have a bad day ))

Link to post
Share on other sites
9 hours ago, pr4ger said:

Confirm that I successfully used Science Alert (before realerted) with Dmagic and Universal storage in 1.5-1.6 time. Now with Universal storage 2 and Science alert realerted - something is not working.

Are you sure? "Before ReAlerted" was maintained up to KSP 1.3.1 and I would expect the mod to break in any KSP version above 1.4.

Anyway, the part of the code which is used to deploy the experiments relies on the stock "ModuleScienceExperiment" but DMagic OrbitalScience uses a modified (derived) "DMModuleScienceAnimate" to handle the experiments.

Well, ScienceAlert could invoke the "DeployExperiment" event instead of the method and it should work with both, stock experiments and at least OrbitalScience but it's up to LGG to decide if he actually want to support other mods which may or may not increases the maintenance work.

Link to post
Share on other sites
On 3/13/2020 at 9:26 PM, 4x4cheesecake said:

Are you sure? "Before ReAlerted" was maintained up to KSP 1.3.1 and I would expect the mod to break in any KSP version above 1.4.

Anyway, the part of the code which is used to deploy the experiments relies on the stock "ModuleScienceExperiment" but DMagic OrbitalScience uses a modified (derived) "DMModuleScienceAnimate" to handle the experiments.

Well, ScienceAlert could invoke the "DeployExperiment" event instead of the method and it should work with both, stock experiments and at least OrbitalScience but it's up to LGG to decide if he actually want to support other mods which may or may not increases the maintenance work.

I may be wrong with version numbers because I am playing since 0.25, but I had Science alert + Dmagic combo working. Thanks for correcting me.

Link to post
Share on other sites
  • 2 weeks later...
  • 2 weeks later...
  • 4 weeks later...

Has someone observed a bug where an experiment (like the Mystery Goo) says after clicking the button of the experiment in ScienceAlert: "no more samples can be collected", and the experiment cannot be used anymore  at all afterwards?

Edited by ndiver
Link to post
Share on other sites
19 hours ago, ndiver said:

Has someone observed a bug where an experiment (like the Mystery Goo) says after clicking the button of the experiment in ScienceAlert: "no more samples can be collected", and the experiment cannot be used anymore  at all afterwards?

Yes, as discussed directly above your post, its to do with the mods that you are using replacing the stock module with 'DMModuleScienceAnimate' which this mod does not support.

Link to post
Share on other sites
7 minutes ago, Poodmund said:

Yes, as discussed directly above your post, its to do with the mods that you are using replacing the stock module with 'DMModuleScienceAnimate' which this mod does not support.

Indeed, I did not noticed and the forum was not sending me to this message, sorry and thanks :)
So if I understand properly, there is currently no solution excepted to not click on the buttons, and just use ScienceAlert as a science alert?

Edited by ndiver
Link to post
Share on other sites

Is it possible to "reset" science experiment to make them "re-alert"?
(Maybe somehwere else, not compuslory in this mod.)

Need/Want to fill a new science station (MPL at Dres) with already transmitted science results.
Have a lot of Science Probes at several muns/planets and manually selecting dozens of experiments
is very annoying.

Thanks in advance for tips and hints.

Edited by Jansn67
Link to post
Share on other sites
15 hours ago, ndiver said:

Indeed, I did not noticed and the forum was not sending me to this message, sorry and thanks :)
So if I understand properly, there is currently no solution excepted to not click on the buttons, and just use ScienceAlert as a science alert?

A little patience and you will be rewarded for your patience

15 hours ago, Jansn67 said:

Is it possible to "reset" science experiment to make them "re-alert"?
(Maybe somehwere else, not compuslory in this mod.)

It depends on the experiment.  If you haven't collected the data, you can reset it when reviewing the data.  Otherwise you will need a scientist.

 

Link to post
Share on other sites
5 hours ago, linuxgurugamer said:

It depends on the experiment.  If you haven't collected the data, you can reset it when reviewing the data.  Otherwise you will need a scientist.

Thanks for answering fast.

I ment resetting after already transmitted home/to RnD and the bar in the result window is empty.
(it must be "checked as transmited" somewhere in the persistent file, but i cant anything yet... !?)

Link to post
Share on other sites
On 5/3/2020 at 6:21 AM, Jansn67 said:

Thanks for answering fast.

I ment resetting after already transmitted home/to RnD and the bar in the result window is empty.
(it must be "checked as transmited" somewhere in the persistent file, but i cant anything yet... !?)

Depending on the experiment, you would need a scientist to reset it.

 

For all, I have ScienceAlert working with the @DMagic experiments.  However, I found a small bug in one of the APIs, and am waiting for the mod to get updated before releasing the new version; I will need to compile it against the new version before release.

Link to post
Share on other sites

New release, 1.9.8.7

  • Fixed Collect all to be visible even when only one science container on vessel
  • a single Kerbal doesn't have a "collect all" action.
  • Added support for the DMagic experiments
  • Added support for DMModuleScienceAnimateGeneric
  • Added check for old version of DMModuleScienceAnimateGeneric (disables if less than 0.23)
  • Thanks to githb user @Fitiales:
    • Added spanish translation

Important Note:  only works with v0.23 of DMModuleAnimateGeneric, just released today

Edited by linuxgurugamer
Link to post
Share on other sites
8 hours ago, DfA-DoM said:

Sorry to bother, but there seems to have an issue with the "science found" toolbar icon (the one with the yellow spark), which is displayed as blurry when science data is fetcheable.

-D-

Thank you, I'll take a look at it.  Which toolbar, the stock toolbar or the Blizzy toolbar?

Also, have you changed the scaling of the game UI at all?

Edited by linuxgurugamer
Link to post
Share on other sites
On 5/8/2020 at 11:52 PM, linuxgurugamer said:

Thank you, I'll take a look at it.  Which toolbar, the stock toolbar or the Blizzy toolbar?

Also, have you changed the scaling of the game UI at all?

This was on the stock toolbar, with the regular scaling

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...