Katten

[1.4.5] AnimatedAttachment 2.1.1 - now with animated surface attachments! (2018-08-19)

Recommended Posts

6 hours ago, ThePixeledFox said:

great looking mod , if only i could find the parts in the game ? ksp version 1.4.5 no expansion , no other mods .

There are no parts; this is a plug-in to allow parts makers to add animation to their parts more easily, or surface-mount parts to existing animated parts. Do be careful doing this though, there can be entertaining and explosive side-effects in some cases!

I'm finding that often I'll launch a craft with a part attached to an animated surface, and although it's well-aligned in the VAB or SPH it goes wildly out of position when placed in the game world. Sometimes this means your attached item is floating 30 meters up in space, other times it can destroy the runway completely... Still, for every time it goes wacky, there's a time it saves me SO much fiddling about that I'm happy to live with the consequences!

Share this post


Link to post
Share on other sites

 

On 9/25/2018 at 11:48 PM, eberkain said:

Is there a way to make the joints stronger.  I tried making a robot arm with the parts in RocketEmporium and it just wiggles like a wet noodle when I put any weight on the other end. 

Hi! Yes, in stock settings, choose Advanced Tweakables, and you can select the joint strengths in the VAB
 

On 9/28/2018 at 4:37 PM, ThePixeledFox said:

great looking mod , if only i could find the parts in the game ? ksp version 1.4.5 no expansion , no other mods .

Indeed, no parts in this mod. There are parts in my other mod, Rocket Emporium, that uses AA. =)

Share this post


Link to post
Share on other sites

Field testing report with a bug...

Was tinkering with Nertea's new NearFuture Spacecraft pack, and slapped a pair of strakes onto the "skirt" section of the Elara biconic capsule. Upon Launch, they moved around the skirt, and one promptly exploded. The movement persists when I revert to the VAB. Disabling the AnimatedAttachment function promptly clears the issue.

Share this post


Link to post
Share on other sites
On 11/16/2018 at 6:56 PM, MaverickSawyer said:

Field testing report with a bug...

Was tinkering with Nertea's new NearFuture Spacecraft pack, and slapped a pair of strakes onto the "skirt" section of the Elara biconic capsule. Upon Launch, they moved around the skirt, and one promptly exploded. The movement persists when I revert to the VAB. Disabling the AnimatedAttachment function promptly clears the issue.

@Katten, @MaverickSawyer,

I saw something similar when trying out the pre-release of the NFS biconic as well in 1.5.1; elevons on the edge of the skirt getting randomly relocated after vessel loading into flight.  I didn't originally attribute this to AA, but I've recently seen similar effects when attaching USI airbags to the RB-1 capsule.  It didn't seem like I was snapping to the petal attachment nodes (are they on the inner or outer surface?).  In some launches to flight, the air bags would suddenly get relocated in random, asymmetric, locations around the capsule body.  I've had a little better luck so far attaching the airbags on the outside first, then OXSTATs on the inner petal surface seem to grab the airbags, but it may be that I'm just lucking out in not crossing some invisible line.  I'm wondering if there's a common collider-related problem.

 

Edited by KSPrynk

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now