Dafni

The 1.3.1 Club

Recommended Posts

Hello everybody!

I am wondering how many of you are still playing 1.3.1, and why?

1.3.1 is a great version of KSP,  it has an extensive suite of mods and is relatively low on bugs. Plus it runs pretty smooth and stable for me. And on top of all that it feels like the last true Squad version we had, before T2 came along. Somehow the whole feel of the game, and the community here too, changed for me.

At first I was excited for all the parts the DLC would bring, and when they finally came around we had some pretty serious bugs in the base game. Now, 3 hotfix patches later, some of those severe issues are still unresolved and somehow I just cant be bothered anymore. I would like to try out the new parts and additions, and some days I mess around a bit, but most of the time I am happy to play around with different 1.3.1 installs.

Once the drag occlusion of Kerbals in Command Seats gets fixed, and some mods get updated, I might take the plunge though. Lets see.

How about you guys? Are you happy with 1.4.3? Do you play any other version? Do you think I miss out? All input is welcome.

 

thanks

Daf

Share this post


Link to post
Share on other sites

I play 1.3.1 as well. Most stable version I ever played, no crashes, huge list of compatible mods, good performance. To me it is a pretty solid version.

I have no plans for upgrading it as my current career is going great, but perhaps I will do a separate install and try 1.4.x for the first time. 

Share this post


Link to post
Share on other sites

Still running v1.2.2; Too deep into the save, with over 90 flights in progress. I'll wait a while.

Share this post


Link to post
Share on other sites

1.3.1 too, and some 1.2.2, for the foreseeable future.

I would have stuck with 1.2.2 entirely to avoid some of the bugs introduced by 1.3, but the noticeably longer load time (even on SSD and without mods), the quicker time-to-failure, and a few quality-of-life improvements sorely missing from 1.2.2 ended up outweighing the irritations and I started to use 1.3.1 more. There was also still the lingering hope that we were getting close to 'just one more patch or two' away from a reasonably definitive version... but then the 1.3.x patches stopped, way too soon. I would've really liked to have a 1.3.x version that didn't get null ref exceptions at almost every scene or craft load/exit, for one, but mostly the game moves on so I just ignore it.

Then the long-awaited 1.4 came around ridden with a list of regressions and new bugs, and between those and other things I really don't want to rehash, it frankly squashed my hope for a definitive version. There is a bit of performance improvement and a few nice small additions, but none of those (nor the expansion) have tempted me to move away from 1.3.1.

 

2 hours ago, Dafni said:

Somehow the whole feel of the game, and the community here too, changed for me.

Indeed. I could've said those words, almost verbatim.

So... it is looking like 1.4 will be a complete skip - I'll stick with the 'lesser evils' of 1.3.1 and 1.2.2 for the time being. We'll see what 1.5 brings. One can hope.

Share this post


Link to post
Share on other sites

I'm still running 1.3.1 for all the reasons previously mentioned.

I'm having such a good time with my current game, I may hold out to 1.5.

Keep having fun everyone.

MM

Share this post


Link to post
Share on other sites

I've been back and forth between 1.3.1 and 1.4+ some, and still hanging on to 1.3.1.  Since 1.4.3 came out, I've been primarily playing it, but I'm seriously thinking about jumping back to my 1.3.1 save the last few days.  The only reason I haven't is my 1.4.3 save has had the probes launched for Outer Planets Mod destinations starting to arrive.  1.4.3 is better than the previous ones, but I think 1.3.1 still runs smoother.

Share this post


Link to post
Share on other sites

I'm guilty of playing 1.3.1 as well, I have just too many mods, some of them weren't updated to 1.4+ and my save is more than 2 years old. So far I launch 1.4 only when I want to play a Making History mission or participate in a challenge.

Share this post


Link to post
Share on other sites

A lot of people just don't wanna update, or some mods are only compatible/stable in older versions

 

the RO save I just set up is in 1.2.2, as I prefer visual enhancement related stuff, and it seems like Scatterer in 1.3.1 is bugged on scaled up worlds.

Edited by Steeeeve

Share this post


Link to post
Share on other sites

1.3.1 is stable, and pretty bug-free. With most mods updated to it, 1.3 is a blast, and has all my main games.

That said, I do use 1.4.1 for KCT.

Edited by SiriusRocketry

Share this post


Link to post
Share on other sites
16 hours ago, Dafni said:

I am wondering how many of you are still playing 1.3.1, and why?

Count me as one, as my input devices do not work in 1.4.x.

1 hour ago, SiriusRocketry said:

1.3.1 is stable, and pretty bug-free.

It does crash occasionally, and the whole jumping / exploding landed vessels thing is pretty frustrating. I'd rate it "playable", but certainly not "bug free"... I'm still waiting for this mythical "1.0" release, the one with no serious bugs or regressions.

Share this post


Link to post
Share on other sites

Still running 1.3.1.  I'm so ingrained in the old school thinking that every update will break my save, I don't update.   I usually wait for the mods to come around before updating anyways.  I do have 4.3 and the DLC downloaded, I just haven't unpacked them.

I've also found 1.3.1 pretty darn stable too, even with a decently modded game.  That said, I had the first bouncy ship bug the other day.  Anybody have a link to the no-bouncy-ship-upon-loading mod?  I thought I had it bookmarked....

Share this post


Link to post
Share on other sites

Haven't even downloaded 1.4 versions. I hear there's some different stuff. Maybe I'll consider upgrading after I get some ships to the outer planets and back.

Share this post


Link to post
Share on other sites
1 hour ago, Gargamel said:

I had the first bouncy ship bug the other day.  Anybody have a link to the no-bouncy-ship-upon-loading mod?

Probably this one:

I note that Squad hasn't entirely fixed this yet either...

Edited by steve_v

Share this post


Link to post
Share on other sites

I'm still on 1.3.1 but more because I like my current set of mods and career game.  I have bought 1.4.x and the expansion but not played it a huge amount as I'm more interested in how far I can take my current career.  1.3.1 isn't perfect - the ships-bouncing-on-load thing is probably the worst problem (sorted by WorldStabilizer mod), and my career game crashes very often - a consequence of having too many mods and too many vessels.  I think the actual crash issue relates to to the amount of time it's taking to (auto)save the game so if anyone knows how to increase the time it's allowed to do this can you let me know and I'll tweak it up a bit.

 

Share this post


Link to post
Share on other sites

My original career, started under 1.3, has been transitioned to 1.4.3 -- never actually ran on 1.3.1.

However: recently, a series of YouTube videos (by Grayduster) gave me the Realism Overhaul bug -- and now I'm running a 1.3.1 install with (count 'em) fifty-seven mods, producing in excess of 55,000 patches  Thank heavens for loading from cache; it takes ten minutes or more to start up the game if I change a mod.  It uses not quite 10 GB during start, backing down to just over 9 at steady state -- which isn't bad, really (not TOO many extra parts packs in the setup).  And surprisingly (at least to me), there doesn't seem to be a noticeable performance hit with RSS/RO/RP-1/Principia compared to stock at the same graphic quality.

Share this post


Link to post
Share on other sites

You will REALLY miss out on

OPM-E when it finally comes out in like 1.8

Share this post


Link to post
Share on other sites
On 6/18/2018 at 8:51 PM, Dafni said:

At first I was excited for all the parts the DLC would bring, and when they finally came around we had some pretty serious bugs in the base game.

That; right above.

All software; every release; always the same.  Change isn't always good; and newer isn't always better.

1.2 broke mining and then 1.3 broke mining again.  Those were  a mandatory career restart right there.  One of those took me out of KSP for nearly twelve months due to the discouragement.

So, no: I don't go through the initial excitement phase anytime ever anymore.  I have 1.0.1, 1.2.1, 1.3.1 and 1.4.3 all side-by-side.  1.3.1 is my business version.  I won't go to 1.>3 until some thorough testing of everything I depend upon including cloning my production Orbit world to a newer version.  And I'll easily wait a year (and some more patches and some better reviews) before I begin serious testing.

I won't say software is not hard.  Or that Squad don't do a great job!  But the world wasn't always in such a break-neck rush...

Edited by Hotel26

Share this post


Link to post
Share on other sites

I've updated to each 1.4.x version as it's come out without much thought. I never found any bugs that were bad enough to roll back. Granted, I play a lot less these days than I used to.

Share this post


Link to post
Share on other sites

I've not had any success with 1.4.x so I'm been hanging out in Club 1.3.1.  Making quite a profit from contracts through multiple SENTINELs and hauling my Grand Tour Ship around the system.

Share this post


Link to post
Share on other sites
18 minutes ago, Trann said:

hauling my Grand Tour Ship around the system.

GRAND TOUR?!?!?!?!??!?!?!?!??!?! I'm doing one here:

 

Share this post


Link to post
Share on other sites

Mmmm...its been a long time since ive played 1.3.1.

As the @5thHorseman said when a new version comes along he just updates as a matter of course.....I do the same.

I have noticed on 1.4.3 my gameplay isn't as smooth as i think it used to be...this thread has got me thinking.

Could be a good idea to play 1.3.1 alongside 1.4.3 to compare....

 

Edited by maceemiller

Share this post


Link to post
Share on other sites

For myself personally still on 1.3.0. The only particular reason is that it works, my files are on it as well as my mods and I don't particularly feel like updating things. I have 1.3.1 and 1.4.x downloaded, it's just really more 1.3.0 is nicely holding everything. 

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.