Jump to content
  • 0

Can someone explain what this output log is trying to tell me?


Question

5 answers to this question

Recommended Posts

  • 0

The passage you quoted is not enough. We need the full log in order to have a clue about the issue (and, even then, it's not guaranteed).

Link to post
Share on other sites
  • 0

I think I know the general idea of what ksp is trying to get help for.

Before I say, what exactly does this rocket look like and did it work before and what has changed since then? Not just ksp I’m talking OS and driver updates, just cos those had done weird things usually fixed by reinstalling. Probably not tho if it is just this on craft.

Anyhow, I’m gonna take a wild guess and say that you may want to reinstall your mods and probably scrap that rocket. For whatever reason ksp or unity, (don’t know without full log, craft file, and reproduction steps, just put them on google drive and link) while attempting to “build” something, probably your rocket, it is missing information needed about the last loaded object to go on to the next loading object. This results in your game crashing on you because it can’t handle that exception. As for why, probably a config in the mod or a craft file is just not ok. 

Gonna need more info to see if I was even in the ballpark with that. Blury pictures aren’t gonna cut it, sorry.

 

Edited by Mark Kerbin
Link to post
Share on other sites
  • 0
On 6/24/2018 at 11:03 AM, Electrodium said:

Checked out the output log but unsure how to read it.

Looked for output log, found random image. Unsure how to read it.

Obligatory link to support request instructions (though it is getting a little outdated):

For anyone to have a hope of diagnosing your problem, they're going to need the full log and a list of mods, with versions, as a minimum. If you can narrow it down to a certain mod causing the problem (using the standard binary sort on your mod list), this will go much easier.
Linking the craft file and a list of mods required to load it may also be of use.

With the information you have provided so far, all I can say is: Likely something to do with autostruts, possibly an outdated mod. But with only that image to go by, a guess is the best you will get.

Edited by steve_v
Link to post
Share on other sites
  • 0

Unfortunately the output log has been overwritten since then (I'm an idiot and forgot to save it), but I found that turning off autostrut for the large tanks of the rocket stopped the crash. The log mentions autostrutting and through process of elimination I found the issue was the first stage procedural parts.

Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...