• 0
Electrodium

Can someone explain what this output log is trying to tell me?

Question

Having a consistent issue with a certain rocket using modded parts (primarily Procedural Parts) that causes my game to CTD when moving to the pad from the VAB. Checked out the output log but unsure how to read it:

https://imgur.com/a/aF8oy82

Share this post


Link to post
Share on other sites

5 answers to this question

Recommended Posts

  • 0

The passage you quoted is not enough. We need the full log in order to have a clue about the issue (and, even then, it's not guaranteed).

Share this post


Link to post
Share on other sites
  • 0

I think I know the general idea of what ksp is trying to get help for.

Before I say, what exactly does this rocket look like and did it work before and what has changed since then? Not just ksp I’m talking OS and driver updates, just cos those had done weird things usually fixed by reinstalling. Probably not tho if it is just this on craft.

Anyhow, I’m gonna take a wild guess and say that you may want to reinstall your mods and probably scrap that rocket. For whatever reason ksp or unity, (don’t know without full log, craft file, and reproduction steps, just put them on google drive and link) while attempting to “build” something, probably your rocket, it is missing information needed about the last loaded object to go on to the next loading object. This results in your game crashing on you because it can’t handle that exception. As for why, probably a config in the mod or a craft file is just not ok. 

Gonna need more info to see if I was even in the ballpark with that. Blury pictures aren’t gonna cut it, sorry.

 

Edited by Mark Kerbin

Share this post


Link to post
Share on other sites
  • 0
On 6/24/2018 at 11:03 AM, Electrodium said:

Checked out the output log but unsure how to read it.

Looked for output log, found random image. Unsure how to read it.

Obligatory link to support request instructions (though it is getting a little outdated):

For anyone to have a hope of diagnosing your problem, they're going to need the full log and a list of mods, with versions, as a minimum. If you can narrow it down to a certain mod causing the problem (using the standard binary sort on your mod list), this will go much easier.
Linking the craft file and a list of mods required to load it may also be of use.

With the information you have provided so far, all I can say is: Likely something to do with autostruts, possibly an outdated mod. But with only that image to go by, a guess is the best you will get.

Edited by steve_v

Share this post


Link to post
Share on other sites
  • 0

Unfortunately the output log has been overwritten since then (I'm an idiot and forgot to save it), but I found that turning off autostrut for the large tanks of the rocket stopped the crash. The log mentions autostrutting and through process of elimination I found the issue was the first stage procedural parts.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now