Jump to content

[1.12.x] PEBKAC Industries: Launch Escape System


linuxgurugamer
 Share

Recommended Posts

On 5/31/2019 at 11:10 AM, oOScarfacEOo said:

The Mk 2 (BPC) has some issues. If you're using a chute on top of the Mk1-3 command pod, the command pod is clipping through the BPC and if you're using the SM-6A Service Module and the Junior Docking Port (Apollo like configuration) the BPC is too short. As KSP has an integrated fairing system wouldn't it be better to completely remove the BPC version and add the fairing functionality to the LES Mk2 just top-down and remove the ability to jettison it so it will stay in one piece? So it could be used in various configurations with the Mk1-3 Command Pod and also with other Pods.

Za9cSQD.jpg

bEWYIZ0.jpg

I've noted the same. It's really not an issue (and it only matters, for me, "on the way" to SDHI anyway), and you can get around it but it's nice to see other people noticing too.

Link to comment
Share on other sites

On 5/31/2019 at 11:10 AM, oOScarfacEOo said:

The Mk 2 (BPC) has some issues. If you're using a chute on top of the Mk1-3 command pod, the command pod is clipping through the BPC and if you're using the SM-6A Service Module and the Junior Docking Port (Apollo like configuration) the BPC is too short. As KSP has an integrated fairing system wouldn't it be better to completely remove the BPC version and add the fairing functionality to the LES Mk2 just top-down and remove the ability to jettison it so it will stay in one piece? So it could be used in various configurations with the Mk1-3 Command Pod and also with other Pods.

Za9cSQD.jpg

bEWYIZ0.jpg

It's been a while since I looked at it, but check to see if there are two attach nodes, one lower than the other.  I suspect that you may be using the lower attach node when you need to be using the higher one

Link to comment
Share on other sites

  • 1 month later...

Hey @linuxgurugamer,

I don't know if this is a bug or expected behavior, but using the Mk1-3 LES with boost cover, I have parts that are occluded by the cover that are overheating. I realize this could be conduction or otherwise normal, but I wasn't sure. Screenshots and logs here: https://1drv.ms/u/s!AoyHZiRU1jT-zbxAInUTbpCSIz2-Ig?e=KCxeA9

Thanks for maintaining this as part of your stable (harem? population? flock?) of mods. 

Update: Immediately after posting, my brain returned from vacation and recalled the thermal debug menu. Yep, it was conduction. Nothing to see here. :blush:

Edited by eightiesboi
Conduction was the culprit
Link to comment
Share on other sites

44 minutes ago, eightiesboi said:

Hey @linuxgurugamer,

I don't know if this is a bug or expected behavior, but using the Mk1-3 LES with boost cover, I have parts that are occluded by the cover that are overheating. I realize this could be conduction or otherwise normal, but I wasn't sure. Screenshots and logs here: https://1drv.ms/u/s!AoyHZiRU1jT-zbxAInUTbpCSIz2-Ig?e=KCxeA9

Thanks for maintaining this as part of your stable (harem? population? flock?) of mods. 

Update: Immediately after posting, my brain returned from vacation and recalled the thermal debug menu. Yep, it was conduction. Nothing to see here. :blush:

Thanks for updating with the solution

Link to comment
Share on other sites

  • 5 weeks later...
  • 4 weeks later...

I found a significant glitch with the current version (though I think it was there before) - if I use the upper attachment node, the tower fails to jetison - it gets stuck on top and the "jettison" option can be spammed forever, triggering decoupler sound but not actually jettisoning the tower.

EDIT: actually, now that I tested it a bit more, it seems to be actually triggered by the offset tool as well. And when using the lower node, the tower sometimes just separates and flies off during abort, or gets stuck regardless. Overall, no matter what I do the tower fails to separate 9/10 times.

EDIT2: I managed to fix this by removing one of the nodes from the config file, at least as long as I don't use offset tools. I cloned the part to have one version with normal node location and one with higher (I actually moved it 0.2 up so that it aligns better in Apollo configuration). This might be the best way to avoid this bug, it seems that the plugin responsible for abort sequence goes awry when there are more attachment nodes present.

Edited by m4ti140
Link to comment
Share on other sites

  • 6 months later...
On 11/27/2019 at 6:16 PM, m4ti140 said:

<snip>

I have encountered this same issue, however the Mk2-X does jettison properly when placed using the bottom node, but for the first time going to the launchpad after the part has been placed. For example, if I place the part, go to the launch pad, it will work properly, but as soon as I revert to the VAB (revert to launch works fine), it will no longer jettison properly when launched again, unless a new part is attached from the menu in the VAB. This leads me to believe that it isn't because of the node placement, and it isn't because of colliders, as it remains part of the same vessel when it fails to jettison, the same 'jettison spamming' issue appears for me as well.

Link to comment
Share on other sites

  • 1 month later...

I thought of this game and mod today for the first time in a long while. Thank you @linuxgurugamer for continuing to look after the mod. I am surprised once again to learn that anybody else in the community thinks protecting these little Kerbals is all that important. I'm sorry that it fails sometimes.

Looking back over this thread, the only thing I can contribute is that the "command pod bits poking through the fairing" is behavior I saw in development at times. I can't remember if I addressed it then, or left it alone. I think it kind of looks more like the actual Apollo Lower BPC, with the window, etc, sticking through. It shouldn't make any difference to performance (or at least it didn't used to) and you can offset the part "up" a bit if it bothers you. Or just use the part variant that doesn't have the lower BPC.

Thanks again @linuxgurugamer for taking this one over.  I still have very little time to play this game, unfortunately :(

Link to comment
Share on other sites

  • 1 year later...

This is weird, if I attach the smaller LES to a rocket, when it launches, the rocket stays stationary, the LES starts overheating and blows up, then the rocket launches "normally".  If I stage the LES, it flies away (as I think it should), and it also appears to act correctly if the abort command is used.

Edited by S4qFBxkFFg
Link to comment
Share on other sites

18 minutes ago, S4qFBxkFFg said:

This is weird, if I attach the smaller LES to a rocket, when it launches, the rocket stays stationary, the LES starts overheating and blows up, then the rocket launches "normally".  If I stage the LES, it flies away (as I think it should), and it also appears to act correctly if the abort command is used.

No logs, no support

Link to comment
Share on other sites

  • 2 months later...

GameData\Pebkac\Parts\LaunchEscape\pebkac_mk1_LES.cfg
got just

    MODULE
    {
        name = ModulePebkacLesController2
    }

and both
GameData\Pebkac\Parts\LaunchEscape\pebkac_mk2_LES.cfg
GameData\Pebkac\Parts\LaunchEscape\pebkac_mk2_LES_noBPC.cfg
got

    MODULE
    {
        name = ModulePebkacLesController2
        hasPitchControl = True
        stagingEnabled = True
    }

I wonder it at least

        stagingEnabled = True

should be in the first as well?

Link to comment
Share on other sites

  • 7 months later...
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...