• 2
UomoCapra

KSP Enhanced Edition 2nd patch is live!

Question

Hello everyone!

The second patch for Kerbal Space Program: Enhanced Edition is live!

This patch includes many bug fixes and improvements. We are also implementing new quality-of-life features taken directly from feedback provided by the community, such as the addition of Physwarp to the Radial Menu, the option to disable trim in the Mini-Settings, the inclusion of cursor speed settings, and more!

If you want to continue helping us out by providing us with feedback and bug-reports, you can do so through our Bugtracker.

Check out this patch's Changelog for further details:

========================= KSP Enhanced Edition Patch 2 =======================

+++Changes
* Added preview metadata to vessels. This fixes some issues and improves overall performance whenever vessels are being listed. 
* Add physwarp to Radial Menu 
* Option to disable trim in mini settings
* Modify response when using L-stick to move PAW sliders 
* Added cursor speed setting
* Added EVA functions to left/right dpad radial menus 
+++Fixed Bugs
* Editor text input box does not scroll horizontally 
* Game blocks using only emojis as quicksave name during a flight
* In precision control mode the Roll/Pitch/Yaw inputs are locked
* Opening the debug screen after a crash locks the game
* Title loses functionality when pausing the game while switching to the 'Crew' tab
* Rename flag window focus can be lost performing a set of actions on Simplified preset
* App Region becomes unresponsive using Simplified control scheme
* "Space Center" button can be focused and pressed at any moment using Simplified controls preset
* It is not possible to scroll through the 'Settings' menu when in the VAB and SPH
* Cursor disappears in the Space Center when closing the KSPedia with 'Time Warp' enabled 
* 'Select An App' feature has no functionality when creating a new subcategory in the VAB or SPH 
* The title loses functionality and freezes when the user rapidly deletes saves in the pause menu on the Career home screen.
* Broken input when using timewarp while planting a flag
* The application crashes when loading a save after planting a flag
* Flag cannot be changed when selecting 'Change Flag' from the pause menu in VAB
* Parts may no longer be interacted with after returning to the Space Center with a 'Confirm delete' prompt open
* The reset button cannot be used with the cursor enabled in the 'Actions' tab
* Title loses functionality after entering the pause menu while deleting a player made craft
* The A/Cross button remains on screen if all Applicants are hired on the Assigned or Lost tabs in the Astronaut Complex
* A Null Reference Exception occurs when selecting a single part after moving a part stack in the Staging Editor.
* Time Warp Mode' becomes stuck on the screen after resuming from a paused state on the 'Space Center' 
* Title becomes stuck in the 'Change a Flag' menu when attempting to dismiss the menu after previously entering it through the pause menu
* Changing a flag from the 'Space Center' allows the menu to become overlapped with other menus 
* There will be a non-functional 'Remove' option for 'Lost' K.I.A. Kerbals in the Astronaut Complex. 
* The Title terminates while scrolling through the list of ships with a large number of created ships
* Cursor disappears when resuming the title with the cursor previously on any of the advanced mode features
* There is incorrect Options text in the Basic Flight Tutorial on Xbox One. 
* The user is taken to a non functional KSC screen when selecting Recover Vessel during flight Training missions.
* Mission to Tylo Trophy is getting awarded too early
* Collect Data dialog is not capturing the Cross button
* Using look around with EVA makes it move
* Title loses functionality after pausing while reverting to the VAB from the 'Launch Pad'
* In Radial preset, map "Force Physwarp" to a key combo
* Directional buttons make Kerbals rotate while on EVA
* Selecting 'Controls' from the pause menu in the VAB/SPH will block the user
* The 'Pause Menu' can no longer be accessed after deleting a 'Custom Category' in the VAB/SPH
* Changing controls preset before placing the command module in the editor will cause many parts to remain locked
* Ambiguous Circle button terminology is displayed in the second Dialog box of the "Getting Started and Basic Construction" training 
* Fine move does not work when Angle Snap is toggled off in the Vehicle Assembly Building or Space Plane Hanger.
* The title loads a save file incorrectly and loses most functionality when bringing up the pause menu as a save file is loading while in gameplay.
* NREs are generated and players are unable to dismiss the 'Quicksave As...' prompt after reconnecting a controller during flight
* Difficulty options are lost when entering the VAB after editing settings in the Space Center during gameplay.
* Space Center buttons lose functionality after signing back into the active profile in the VAB and SPH 'Change Flag' menu and returning to the Title Screen
* Controls screen will remain on screen until title is closed and reopened if Flight Results screen appears prior to closing
* The 'QuickSave' button prompt has no functionality in the 'Continue Saved Game' menu when there is no created saved data
* PAWs require multiple button presses to appear 
* The User is unable to delete a save file when in gameplay.

Thank you and happy launchings!

  • Like 2

Share this post


Link to post
Share on other sites

Recommended Posts

  • 1

I love you guys, I really do, but man. Did your QA sit down and test this on a normal Xbox? The bugs seem to be worse so far. Unable to set certain functions on custom actions and after launching a ship and reverting and then editing causes the ship to revert to it’s original state (before the edit) after launching again. This took less than 30 minutes for me to give up after trying the update for the first time. I think I’m going to just have to take a hiatus. Love ya Squad, I just wish this game could be playable. 

Share this post


Link to post
Share on other sites
  • 1

 

17 hours ago, Homedawgian said:

I love you guys, I really do, but man. Did your QA sit down and test this on a normal Xbox? The bugs seem to be worse so far. Unable to set certain functions on custom actions and after launching a ship and reverting and then editing causes the ship to revert to it’s original state (before the edit) after launching again. This took less than 30 minutes for me to give up after trying the update for the first time. I think I’m going to just have to take a hiatus. Love ya Squad, I just wish this game could be playable. 

What Gives for you? I don't seem to get any bugs other than the console crash. I'm on PS4, so maybe you are different.

Share this post


Link to post
Share on other sites
  • 1
12 hours ago, Thomas, a Kerbonaut said:

KSP EE could have some sort of system that allows the player to adjust the size of the screen.

It would be great if it was related to mods. I’d definitely buy it.

I believe that the PS4 machine has some screen settings that may fix the problem. I don't know about Xbox though.

I'd like to see a few more Space Station parts, mainly for variety. But I'd really love to see some permanent Mun base parts, so my console Kerbals have something to do.

If switching mods on and off are possible, it would be great to see a mod dedicated to Aeroplanes and atmospheric flight. As well as a dedicated remote base builder. But I think that the console game is already running at capacity.

Share this post


Link to post
Share on other sites
  • 1
Posted (edited)

Here's the issues I've been having since the update came out, everything was fine before the 2nd update by the way, now when I go to do an EVA  JEB gets stuck to where I can't move him  or re-board the craft, I have to shut the game down  restart game to be able to get back inside, other issues are after getting into space an going back to build another rocket the parts will not lock together, I have to shut the game down an restart it, yet again. As stated before I never had any of these issues before the 2nd patch came out everything worked fine.

I can't get the parts of the craft  to work with presets ( like solar panels would open with 1 and  2 being another set of solar panels)  will not allow me to put them in there.

Docking has become a nightmare again where I am lined up an they just bump like they won't connect.

The physwarp when used does this. you launch add physwarp to speed things up have an issues something blows up,  I would go back to fix the mistake only to find when I launch again I find parts would be raining down on me.  I ave stopped using physwrap for this reason.

An KSP is the game I play the most on ps4 more then any other game, especially after watching Scott Manley video's it just gets me in the mood more for KSP.

 

I have no idea how to submit bug reports on these issues.

I use controller preset Cursor if that helps

Edited by canufixit
to add something I forgot

Share this post


Link to post
Share on other sites
  • 0

Awesome!!! I don't play console that much, but this should bring some smiles! :D

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

Waiting for console to catch up with PC - at least add some mod support - still haven’t deleted it yet though ;).  

Share this post


Link to post
Share on other sites
  • 0

I've only ever played Kerbal Space Program on PS4, I was so thrilled to see the update come through on my PS4 today!

I'll be checking out these changes, thanks for keeping us console players in the loop!

This is a fantastic game. I'm so thrilled at how much this game has improved over the early console release.

You folks have done an excellent job on a very complex game.

Cheers all around!!

also,

Looking forward to some Expansion Paks or DLC! :cool:

Share this post


Link to post
Share on other sites
  • 0

KSP EE could have some sort of system that allows the player to adjust the size of the screen. I don’t know why my game is always cropped, and I can’t see all the informations in the screen. I can’t either change anything in my TV settings, only to even worse. Is it possible to add this setting in the next patch of the game ? Thanks.

On 7/20/2018 at 1:52 AM, GrouchyDevotee said:

Looking forward to some Expansion Paks or DLC! :cool:

It would be great if it was related to mods. I’d definitely buy it. Goat simulator has a system in which you can turn on and off pre installed mods.

Share this post


Link to post
Share on other sites
  • 0

New to the forums, but not new to the hassle of this game on console. (PS4)

The new patch has brought new bugs to the game, everything from not being able to do EVA's  revert back to hanger as well as docking and rockets engines that the sound just keeps on playing even after you have shut them down. 

I tried the physwarp but it only cause more issues with the game I have to shut the game down an restart it to get some of these under control, but they just keep showing up, Now I can't even build anything It just will not allowing to connect parts together.

 

 

 

 

Share this post


Link to post
Share on other sites
  • 0

So... did anybody played it for the longer time?

Is it now fully playable? (I dont mind some minor bugs. But I dont want some gamebreaking ones that will corrupt saves, lock controls, etc)

Share this post


Link to post
Share on other sites
  • 0
2 hours ago, Agarwel said:

So... did anybody played it for the longer time?

Is it now fully playable? (I dont mind some minor bugs. But I dont want some gamebreaking ones that will corrupt saves, lock controls, etc)

I played at this weekend for some hours, i havent encountered gamebreaking bugs, but ive also encountered none since ee release. The maneuvernode still resets when u hit the targets soi and u r in mapview, but thats also not in the changelog for being solved

Share this post


Link to post
Share on other sites
  • 0
23 hours ago, canufixit said:

Here's the issues I've been having since the update came out, everything was fine before the 2nd update by the way, now when I go to do an EVA  JEB gets stuck to where I can't move him  or re-board the craft, I have to shut the game down  restart game to be able to get back inside, other issues are after getting into space an going back to build another rocket the parts will not lock together, I have to shut the game down an restart it, yet again. As stated before I never had any of these issues before the 2nd patch came out everything worked fine.

I can't get the parts of the craft  to work with presets ( like solar panels would open with 1 and  2 being another set of solar panels)  will not allow me to put them in there.

Docking has become a nightmare again where I am lined up an they just bump like they won't connect.

The physwarp when used does this. you launch add physwarp to speed things up have an issues something blows up,  I would go back to fix the mistake only to find when I launch again I find parts would be raining down on me.  I ave stopped using physwrap for this reason.

An KSP is the game I play the most on ps4 more then any other game, especially after watching Scott Manley video's it just gets me in the mood more for KSP.

 

I have no idea how to submit bug reports on these issues.

I use controller preset Cursor if that helps

That's weird. I have been playing for the past week on this patch, and encountered no serious bugs. The only bug i found is that when you have a high flexibility interplanetary spacecraft joined by docking ports, and you time warp while it wobbles, bits disconnect randomly, but i can live with that. I have so far found only 1 bug, on the ps4 while in cursor mode.

Share this post


Link to post
Share on other sites
  • 0

I realize you might not be having the same issues as me, but I tell you that there is something very wrong.

My career game save is useless unless I can get the game back to before the 2nd patch. I have even had these issues in sandbox an science mode So I don't know what would be causing it.

I have delete the game an did a reinstall but it still didn't help.

Only thing I changed in the settings from after the patch came out, Thursday was the cursor speed turned it down to 20%.

Share this post


Link to post
Share on other sites
  • 0

This is a good patch. I've experienced no bugs or glitches since the update!

Share this post


Link to post
Share on other sites
  • 0

Hi, new ish to ksp on ps4 (around three months). Since the patch I've noticed some new issues, the first and most frustrating is maneuver nodes. In the middle of a burn, when you leave an SOI, the target deselects itself and the node's required Delta shoots up to like 10k m/s. So then you have to start a new maneuver node and try to get it to where it was supposed to be in the first place. Happens every time I try to go to Duna. 

 

The second issue is that I cannot eva. The kerbal leaves the craft, but sits on the ladder and I have no option to move them or let go, or even re board. I can make them take an eva report, and even once on Duna, a surface sample. But I can't get back in the command pod, or move at all. If I try to time warp or leave to a different craft either by using "switch to" or tracking station I'm met with a message that says you can't do that while a kerbal is on the ladder. To use tracking station at all it had to revert to a previous quicksand. I was having fun prior to the patch, just the odd game crash here and there, but now I can barely get any function out of the game. 

Share this post


Link to post
Share on other sites
  • 0
Posted (edited)
On 21 July 2018 at 8:49 PM, DunaManiac said:

 

What Gives for you? I don't seem to get any bugs other than the console crash. I'm on PS4, so maybe you are different.

So can you confirm that you still get crashing on PS4 AFTER this latest update? I get this bug a lot so I was just curious. Thanks. 

 

Edited by Reacherfan

Share this post


Link to post
Share on other sites
  • 0
10 hours ago, Jeauxbin said:

Hi, new ish to ksp on ps4 (around three months). Since the patch I've noticed some new issues, the first and most frustrating is maneuver nodes. In the middle of a burn, when you leave an SOI, the target deselects itself and the node's required Delta shoots up to like 10k m/s. So then you have to start a new maneuver node and try to get it to where it was supposed to be in the first place. Happens every time I try to go to Duna. 

 

Does it looks anything like this? i get maneuvernode resets since ee release, they only happen when im in mapview if i stay in "normal view" focus on the ship it works. I do all interplanetaryburns that way as kind of a workaround

Share this post


Link to post
Share on other sites
  • 0

I have spent like 10 hours on my friends PC but besides that 100% Xbox 

Besides the fact that steering when you fly a spacecraft is very hard and asparagus staging doesnt work on complex builds console ksp is very much playable and I would recoomend it to anyone who isnt a pc gamer 

Share this post


Link to post
Share on other sites
  • 0
On 7/27/2018 at 8:12 AM, PrvDancer85 said:

Does it looks anything like this? i get maneuvernode resets since ee release, they only happen when im in mapview if i stay in "normal view" focus on the ship it works. I do all interplanetaryburns that way as kind of a workaround

Yeah that's it. That's just annoying, but it did seem to work in non map view. Nowhere near as annoying as the inability to eva though. 

Share this post


Link to post
Share on other sites
  • 0
On 7/27/2018 at 10:36 AM, Reacherfan said:

So can you confirm that you still get crashing on PS4 AFTER this latest update? I get this bug a lot so I was just curious. Thanks. 

 

Oddly enough, no. But the crashes don't happen a lot for me, so this information is probably not valid.

Share this post


Link to post
Share on other sites
  • 0

So I got to play this game with no issues on Friday night (8 hours), come Monday all the problems seem to rise again, I did not change one thing in settings at all, I did use physwrap I am wondering if that is causing the problems I am having, anyone else having issues when turning on physwrap?

An I don not have any issues with the game crashing (ps4) it does lag out  (frame rate drop) from time to time, when getting close to my super station.

An is there a limit on how many items you should have in space?

Share this post


Link to post
Share on other sites
  • 0

I am new to KSP, but i have a problem that normally should have been fixed with this update when i read it correctly:
I am playing on Xbox and sometimes when I try to open Part Action Menus the do not open. The buttons just dont work, even if I use different presets and new controllers. At first when the bug appeared I could fix it most times via restarting the game. Now either redownloading, restarting or switching controllers does not work anymore and the second try to run a science campaign is getting totally unplayable. It happens at VAB and also in flight. Sometimes it hits engines, sometimes staging, but most of the time when i try to start experiments like Mystery Goo containers. And when campaigns run longer I get these bugs more frequently until  is literally unplayable. I can not seem to find a pattern though, happens to small ships and big ones alike.

Is there any workaround? I would not like to wait for the next patch, i have so much fun with this awesome game when it works :/

Share this post


Link to post
Share on other sites
  • 0

Hey all, I'm new, I found my way here thanks to the EVA bug mentioned by Jeauxbin. I have been able to get around it, but seemingly by pure luck, as I can't re-create my success.

I figured I might as well join the forum, I've been reading threads found through google searches since I bought the game a few months ago. For now I just want to stay updated on this patch since it's causing some serious issues for me. If anyone finds a repeatable work-around for the EVA bug, my life will be much easier.

Share this post


Link to post
Share on other sites
  • 0
On 7/24/2018 at 10:26 AM, canufixit said:

I have no idea how to submit bug reports on these issues.

 

bugs.kerbalspaceprogram.com

Thats the official bugtracker.  You need to make an account and post your EE-specific bugs there for them to be seen by the devs. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now