Jump to content
  • 0

Issues with Galieo's planet pack and planet mods in general.


-Solstice-
 Share

Question

So for the past few days I have been trying to figure out exactly what is wrong with planet mods. I use CKAN to install planet mods and they never end up working as in the new planets and such do not end up in the game at all.  If anyone can help me with this I would be thankful, feel free to ask questions about this.

This is my folder for the Gamedata. 

6CcgcuO.png

Link to comment
Share on other sites

13 answers to this question

Recommended Posts

  • 1

Looks like Modular Flight Integrator is missing. Doesn't Kopernicus require that?

Check the release download links for Kopernicus again; this should include a compatible version of Modular Flight Integrator and Module Manager.

(oops - didn't notice the KSP 1.3.1 version. Here's a Kopernicus backport for KSP 1.3.1.)

When I first set up a KSP installation for a planet pack, I'll have just Kopernicus and its included dependent add-ons installed, then launch KSP with the stock planetary system just to make sure it works. I know Kopernicus works if the main menu screen starts at a different location above Kerbin than it does without it. After that, I'll add the planet pack and test again.

Once the planet pack works I then will add visual add-ons if they're applicable, then gameplay add-ons such as Ferram Aerospace, and finally part add-ons, in that order. I'll re-test after each major change.

Edited by Gordon Fecyk
Missed KSP 1.3.1 reference
Link to comment
Share on other sites

  • 1
22 minutes ago, Gordon Fecyk said:

Looks like Modular Flight Integrator is missing. Doesn't Kopernicus require that?

Nothing in the Kopernicus download is optional. ModularFlightIndicator is required. Upvote for spotting that. :)

This shouldn't even be happening, assuming Kopernicus is also installed through CKAN.

Edited by JadeOfMaar
Link to comment
Share on other sites

  • 0

For GPP specifically, you'd better follow installation instructions from the official Github download page:

https://github.com/Galileo88/Galileos-Planet-Pack/releases

(choose you version there, I'm not sure which one is the latest for 1.3.1)

The first step in that instruction is: remove all installed mods. I've seen issues on my computer when I installed some mods first, and then GPP. So, it's a reall good idea to start with installing GPP, verifying that it works and only after that adding other mods.

Link to comment
Share on other sites

  • 0
7 hours ago, Califorum said:

where would I find a module flight indicator file?

Download the kopernicus 1.3.1 backport, the Modular Flight Integrator is in the zip file. You probably got the 1.3.1 - 9 backport installed right now, so you should download the same version again to grap the Modular Flight Integrator, or if you want to use the latest release, reinstall kopernicus as well.

Link to comment
Share on other sites

  • 0

That's probably why none of the visual mods EVER install right with CKAN. I've installed Kopernicus a few times with CKAN and it always forces you to download dependancies.....but this is the first I am hearing of ModularFlightIndicator.....so I imagine Kopernicus is set up wrong on CKAN, it has never forced me to install it.

At least as far as I can recall....

Edited by JoE Smash
Link to comment
Share on other sites

  • 0
13 hours ago, 4x4cheesecake said:

Download the kopernicus 1.3.1 backport, the Modular Flight Integrator is in the zip file. You probably got the 1.3.1 - 9 backport installed right now, so you should download the same version again to grap the Modular Flight Integrator, or if you want to use the latest release, reinstall kopernicus as well.

Alright so I have done exactly that, I removed all other mods except for GPP and this is what happens. 

7nkUO5O.jpg

And this here is my Gamedata folder. 

S28VUZ3.png

Link to comment
Share on other sites

  • 0
24 minutes ago, Califorum said:

Oops, forgot that one. I installed it, and put it into the GameData folder though it still comes up with the same message.

Ok, while waiting for a response, I installed KSP 1.3.1 as well, tried it on my own and it works perfectly fine so I have to assume that during the whole fixing process, things messed up a bit and different mod versions scrambled together.

Best would be to start from the beginning: I just installed the GPP with all dependencies via CKAN so this should work fine for you as well.

First of all, start CKAN, select the 'installed' filter and unselect every single mod:


0o8yVJ2.png

Then, open your KSP install directory, open the GameData folder and delete every folder and every file except for the 'Squad' folder

Just to be sure, hit 'Refresh' in CKAN, wait until the repository is up to date and don't forget to switch the filter back to 'compatible'. Than search for 'GPP' (just this one for now), select it and hit 'Apply changes'.

CKAN will detect all dependencies (incl. Modular Flight Manager ;) ) and it should look like this:

vtLKyZx.png

Hit 'Apply' in the lower right corner and a new page will show up, showing you some recommend mods. Unselect all of them for now, we just want to get GPP working and other mods can be installed later as well :)

Hit 'Continue' and again...another page shows up, listing some other mods suggested to be useful for you. They should be unselected by default, if not, do it on your own.

Hit 'Continue' again and CKAN starts installing GPP and the dependencies. As soon as this is done, try if it is working now :)

I'm sorry if I sound like talking to a kid, this is not meant to be a personal affront, I just want to be sure that there are no misunderstandings and these will happen really quick if you try to explain something in a foreign language ;)

Edited by 4x4cheesecake
Link to comment
Share on other sites

This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...