Theysen

[1.4.5] Real Solar System v13.1 [03 Sep 2018]

Recommended Posts

I'd like to report a bug...

 

https://imgur.com/5DmBOzp

 

At least visually I was well away from any colliders of Deimos... according to my instrumentation I was 10km above it. 

Please, please don't tell me this happened because some of my engineers are still working in imperial units?

Share this post


Link to post
Share on other sites
On 11/29/2018 at 6:24 PM, David H said:

I can't get this to work.
 

Title says 1.4.5 yet it says

 

So is it 1.4 or 1.3.
I tried both 1.3 it says to use 1.4. I tried 1.4 and it doesn't work either. 

http://prntscr.com/loqgpi
When it loading it was a small window. It had all the launch site icons but to small window.
When I expanded to full screen the icons blacked out.
I have all the mods and a few that have nothing to do with rss.
http://prntscr.com/loqjbo

I am also seriously confused about this

Edited by TheEpicRanger6

Share this post


Link to post
Share on other sites

 

I just successfully reinstalled Real Solar System in Version 1.4.5 by following the steps listed, *but,* using 1.4.5 instead of 1.3.1. The links to mods should go to their respective proper versions -- do not use the latest, as they will often not work with the older KSP version.

 

This was a full reinstall on a fresh game however.

Share this post


Link to post
Share on other sites
7 hours ago, TheEpicRanger6 said:

I am also seriously confused about this

Confused about what?
You need to be more specific.
Which version is the mod good for.
1.3 or 1.4

If it tells you to it's good for 1.4 then it should work with 1.4. Not tell you to download 1.3.

I tried it. It doesn't work for me. I can not get it to work. I completely removed everything. Added each mod on the page 1 by 1. IT DOESN'T WORK FOR ME. What is wrong.
I would be willing to share the screen and show exactly what I'm doing.
As far as I know. Some of the mods required are specifically for scaling the system. What's wrong with putting them in to 1 folder to be downloaded.
Ease of use attract more people to your product.

Share this post


Link to post
Share on other sites
4 hours ago, David H said:

What's wrong with putting them in to 1 folder to be downloaded.

  • Because if a third party dependency plugin has a bug in it that needs to be fixed by its developer then you don't want to have to do a new release of your own to stay current.
  • Because you don't want to accidentally overwrite a newer version of that third party dependency if players are forced to reinstall your mod.
  • It makes you responsible and liable (not in a legal sense but still) for your users having the latest version of someone else's mod.
Edited by Starwaster

Share this post


Link to post
Share on other sites
2 hours ago, Starwaster said:
  • Because if a third party dependency plugin has a bug in it that needs to be fixed by its developer then you don't want to have to do a new release of your own to stay current.
  • Because you don't want to accidentally overwrite a newer version of that third party dependency if players are forced to reinstall your mod.
  • It makes you responsible and liable (not in a legal sense but still) for your users having the latest version of someone else's mod.

Mods have module mgr inside their folder. Mods are hidden inside a subfolder inside subfolder.
They don't update their links. Some links go to pages that no longer exist. Some to older versions.
Check your links.
Some mods have their op a complete mess. People don't want or can't read through your mumbo jumbo looking for a link.
Read a few sentences about your mod. A few pics and download.

A simple format would make things easier.
DOWNLOAD

Dependencies

Optional to flesh out the experience
Optional to add to forum.

Or the format on this mod.
However I still can't get it to work.


There are still people 1st time playing the game.
1st time installing mods. 1st time not using the steam workshop.

 


People. Don't over analyze it. I said SOME. That does not mean every single 1.

Just because you can find the links.
Know how to program.
Spend hours on end in github curse and everywhere else downloading mods. 
Doesn't mean everyone can.

And ^ is not pointing at you star.
I know someone wants to say something.

Edited by David H

Share this post


Link to post
Share on other sites

If anyone is playing RSS with the Making history expansion, you may like this patch to turn off the stock launch sites. 

Does anyone know if it is possible or necessary to do a NEEDS block for the expansion?

@Kopernicus:FOR[RealSolarSystem]
{removeLaunchSites = Island_Airfield, Desert_Launch_Site, Desert_Airfield, Desert_GroundObjects,  Woomerang_Launch_Site, Woomerang_GroundObjects}

 

Share this post


Link to post
Share on other sites
6 hours ago, Phineas Freak said:

@Nightside This should be patched either way since RSS uses KSCSwitcher for selecting launch sites.

They were still showing up in the map, and VAB launch button for me.

Maybe I have an outdated version of kscswitcher though.

Share this post


Link to post
Share on other sites

I am having the Floating Tiles problem in Ksp 1.3.1 RO/Rp1 + scaterrer and RRSVE.
Is this not fixable?

I have tried Scaterer different versions like 0.0320b and kopernicus too..
Not using DX11 nor OGL

Edited by Agustin

Share this post


Link to post
Share on other sites

If you have the same floating tiles thing that most people have, it only seems to happen on reentry from suborbital flights.  If you quicksave then quickload at apogee, it shouldn't happen.

Share this post


Link to post
Share on other sites

Okay. So everyone just lives with this issue then? suborbital rockets is the first thing you do when playing in RP1, so everytime I come back down terrain disappears. There's nothing that fixes it? okay.......

Share this post


Link to post
Share on other sites
1 hour ago, Agustin said:

Okay. So everyone just lives with this issue then? suborbital rockets is the first thing you do when playing in RP1, so everytime I come back down terrain disappears. There's nothing that fixes it? okay.......

Yes, everybody has just been living with it but there is definitely something that fixes it. It's been awhile since I played with RSS running but I do play with a scaled up Kerbol (10x scale) and I haven't seen that problem in awhile. I didn't realize it was still a thing for RSS.

The problem has to do with fading out the terrain BEFORE scaled space has faded in. Those are supposed to happen either simultaneously or overlapping each other.... Unfortunately, I don't remember exactly what needs to be changed but it's most likely controlled through the Kopernicus configuration node for the planet.

  • Like 1

Share this post


Link to post
Share on other sites

OK, if something could be changed in a CFG then somebody could share it.

Share this post


Link to post
Share on other sites
12 hours ago, RoboRay said:

Go right ahead!

Yeah I don't think so.... I've been poking at this for a few days now and it's got nothing to do with what I thought it was...  POSSIBLY not deactivating the PQS (which  happens at 167km AFTER fade out) might stop it.... maybe 

Share this post


Link to post
Share on other sites

I need help, when I load in RO, it always works, until the part where it says ~4000 Patches and Module manager: FINALS, it always crashes. Can someone tell me why this happens

Share this post


Link to post
Share on other sites

Possibly you are running out of RAM .

Module Manager is unlikely to cause the program to crash, even if you had a badly written patch.

Share this post


Link to post
Share on other sites

Hi, everyone knows if there is any update on progress for 1.6 ? Performances are very impressives with this last version so it would be great to use it with RSS.

  • Like 2

Share this post


Link to post
Share on other sites

Hello!! Thank you for mode..

 

But.. Where I can get some RVE?

Share this post


Link to post
Share on other sites

please skip 1.5 and release a 1.6 version, as it have solved the stutter in vab while placing parts bug

Share this post


Link to post
Share on other sites

Hello, let me start my first post ever on the forums by saying how much I enjoy this mod. I just picked up KSP a few weeks back and installed version 1.3.1, I'm pretty sure that's the one, with the intent of using this mod. At any rate, I have been making progress and have enjoyed myself immensely. What I wanted to ask about is the very short daylight periods compared to the unmoded version of KSP. I am using the Early Bird mod to adjust the time the sun comes up; however, the daylight period still seems to pass much to quickly. Does this sound correct due to the way system inclination was implemented; or, is it possible that something went wrong during installation through CKAN

Thank you for the time and effort you put into this amazing mod; and, thank you for any clarification you can provide on my question about the short daylight periods. 

Share this post


Link to post
Share on other sites
Posted (edited)

Hello!

 

I have some problem... When my pod entering to Erath atmosphere here no aerobraking as this video :( 

 

 

 

In my RSS speed  is constantly increasing in atmosphere :( Version KSP 1.4.2. 

 

May be it is FAR? I an using KSP 1.4.2, but FAR for 1.3.1 version....

Edited by Irenicus

Share this post


Link to post
Share on other sites
3 hours ago, Irenicus said:

Hello!

 

I have some problem... When my pod entering to Erath atmosphere here no aerobraking as this video :( 

In my RSS speed  is constantly increasing in atmosphere :( Version KSP 1.4.2. 

May be it is FAR? I an using KSP 1.4.2, but FAR for 1.3.1 version....

The problem is not FAR. The problem is that your expectations need adjusting. Yes,  your speed will appear to go up during the early stages of reentry in the upper atmosphere. You should consider your velocity to have two components: Vertical and horizontal. There is not enough braking happening to slow the vertical component appreciably. Look at your video; I refer you to the terminal velocity entry. Terminal velocity is the velocity at which drag forces exceed the pull of gravity.  You will not see noticeable vertical slowing until your vertical velocity approaches or exceeds terminal velocity. 

There's really nothing unusual happening your video. Welcome to RSS and FAR; don't expect it to behave like stock, otherwise what was the point of installing them?

Also, don't deploy your chutes so early. You got away with it but you almost burned them. To give you a real life example, Apollo didn't deploy it's drogue chutes until just over 7km altitude (Just under Mach 1 IIRC, but they used barometric pressure as the trigger for deployment). The mains deployed at just over 3km altitude immediately after drogue chute detachment.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now