Theysen

[1.4.5] Real Solar System v13.1 [03 Sep 2018]

Recommended Posts

On 2/6/2019 at 10:28 AM, Blyet Nye the Soviet Guy said:

please give the reigns of this mod to someone

It's already in your hands.  Your pull requests will be much appreciated.

Share this post


Link to post
Share on other sites
5 hours ago, RoboRay said:

It's already in your hands.  Your pull requests will be much appreciated.

That's ok for code changes and IFF code changes are required to get it functional for the next release.

It doesn't do a thing towards pushing RSS towards a new release.

Share this post


Link to post
Share on other sites
On 2/6/2019 at 7:41 PM, siimav said:

If you want to use this mod then you should downgrade KSP to version 1.3.1 or 1.4.5. In case you also care about making the game pretty, then I would recommend 1.3.1  because RSSVE does not currently work on any higher versions.

Even though the current release of RSS might also partially work on newer KSP versions, part of it's functionality will definitely be locked down by version checks. Getting a fully working copy for KSP 1.5 or 1.6 requires some knowledge of Git/GitHub + editing and recompiling C# code.

I really want to use this mod to get into ksp cinematics but my computer just can't really handle anything below 1.5. 

Share this post


Link to post
Share on other sites
On 2/6/2019 at 4:22 PM, Observe said:

Agreed. I was able to get RSS working fine (for me) in KSP 1.6. However, what is RSS without Earth clouds and pretty water? For that, I had to go back to KSP 1.3. There is no current way around it.

I do miss some of the game improvements that have been made since KSP 1.3 and various mod improvements that have been made and which are not backward compatible with 1.3.

At the end of the day (for now), if you want to play with Real Solar System at its best, run it in KSP 1.3x with RSSVE (visual enhancements).

Are you certain? I'm currently running KSP 1.4.5 with RSS and RSSVE successfully, after a little tinkering. There are glitches (somewhat transparent planet at ~100 km, flickering in orbit after launch) but it *is* running with waves in the ocean and clouds in the sky.

Share this post


Link to post
Share on other sites

First off I want to say how much I really enjoy this mod and how much it improves my gameplay. Thanks so much for the hard work you guys do to bring  mods like this. In saying this I was hoping there is someone in this thread that can help me with an issue I have been fighting for sometime now and can not trace down the cause. Details:

Kerbal Version:

1.2.2

Major Mods:

RSS/RO/RP-0/RSSVE all the required mods.

Several others that may or may not apply.

Issue:

All appears to run well with the exception of my Tracking Station where I do not get the planet list on the left. It will however list asteroids I am tracking and any other craft I have in orbit. I was hoping with review of the data below someone could assist me to figure this out.

Logs:

Output log -  OutPut Log

KSP Log -  KSP Log

 

ScreenShot of the condition -  Screenshot

 

Any help Is much appreciated. Thanks for all your work for our community.

Edited by cpcannon

Share this post


Link to post
Share on other sites
2 hours ago, cpcannon said:

First off I want to say how much I really enjoy this mod and how much it improves my gameplay. Thanks so much for the hard work you guys do to bring  mods like this. In saying this I was hoping there is someone in this thread that can help me with an issue I have been fighting for sometime now and can not trace down the cause. Details:

Kerbal Version:

1.2.2

Major Mods:

RSS/RO/RP-0/RSSVE all the required mods.

Several others that may or may not apply.

Issue:

All appears to run well with the exception of my Tracking Station where I do not get the planet list on the left. It will however list asteroids I am tracking and any other craft I have in orbit. I was hoping with review of the data below someone could assist me to figure this out.

Logs:

Output log -  OutPut Log

KSP Log -  KSP Log

 

ScreenShot of the condition -  ScreenShot

 

Any help Is much appreciated. Thanks for all your work for our community.

I can’t open that link, so I’m just guessing but I think the ships being sorted by planets is from dMagic’s mod.

Share this post


Link to post
Share on other sites
6 minutes ago, Nightside said:

I can’t open that link, so I’m just guessing but I think the ships being sorted by planets is from dMagic’s mod.

Sorry Google Drive Is being crazy. Here is an imjur link Tracking Station.

 

Edited by cpcannon
Failed Hyper Link.

Share this post


Link to post
Share on other sites
52 minutes ago, cpcannon said:

Sorry Google Drive Is being crazy. Here is an imjur link Tracking Station.

 

That looks like the normal tracking station. 

Are you thinking of this mod?

 

Share this post


Link to post
Share on other sites
Just now, Nightside said:

That looks like the normal tracking station. 

Are you thinking of this mod?

 

I guess I have been mistaken. I thought the stock game with no mods showed the planet list on the left in tracking station. If it is good then i am terribly sorry for wasting your time and I thank you for your feed back.

Share this post


Link to post
Share on other sites

I can't wait to transform my KSP from a game to a simulator!! Please update it to 1.6.1!

Share this post


Link to post
Share on other sites
3 hours ago, rocketpark said:

I can't wait to transform my KSP from a game to a simulator!! Please update it to 1.6.1!

Welcome to the forums @rocketpark. Real Solar System should be working fine in 1.6.1 (just make sure you are using the right version of Kopernicus for your KSP).

RSS is an incredible mod in its own right but you will soon realize that stock rockets are too small, weak and heavy to cut it in the real world. The most realistic experience will come from a full Realism Overhaul install, but that is still back on KSP 1.4.5, so you would have to download that version for the full experience.

Share this post


Link to post
Share on other sites

Hi and epic work on this great mod.

 

I am running 1.6.1 and have noticed that the biome locations for Saturn's moons don't seem to match up with the surface - easily noticeable by looking at Iapetus or Tethys and hitting "Biomes Visible from alt-f12 .It's apparent at Tethys where the major crater feature is visible on the northern hemisphere but the biome shows as being on the southern hemisphere. Iapetus' large impact crater is also visible in the opposite hemisphere to what's shown on the biome map.

It seems that the moons themselves have had their surfaces flipped upside down, or something - as the north pole biomes are correctly at the north pole and vice versa, but the surface features themselves are flipped around the equator. This theory seems supported by the observation of Mimas' large equatorial crater being in almost exactly the correct position but other surface features also are flipped around the equator.

Or maybe it's just me?

Share this post


Link to post
Share on other sites

Ok so I went back to a fairly old 1.3.1 install, and Saturn's moons are all upside down on there as well! Is the problem

a) somebody laced my coffee

b) I am a rookie who has messed up both of my installs

c) RSS has had upside down saturn moons for some time without anybody (including me) noticing XD

 

And before you say it, yes I do live in Australia, and no this does not explain the problem.

Edited by Deddly

Share this post


Link to post
Share on other sites

Hi,

I'm new to RSS but should the Communitron 16 have a range of 10M ? it only reaches a quarter to the moon :-(

Share this post


Link to post
Share on other sites
2 hours ago, MacLuky said:

Hi,

I'm new to RSS but should the Communitron 16 have a range of 10M ? it only reaches a quarter to the moon :-(

Realism Overhaul will adjust antenna ranges where appropriate for realistic ranges and data rates. You should consider using it if you're going to play with RSS.

If you're not going to then you should at least grab the communications configs for the antennae.

Share this post


Link to post
Share on other sites

TLDR - Some moons seem messed up. I made github issue. Nevermind me.

 

Apologies if my two posts earlier wasted anybody's time, my observations listed there concerning Saturn's moons were flawed and honestly it has taken me a good while to figure out what is actually happening.

I have made the following observations on both my 1.3.1 and 1.6.1 installs.

Enceladus: Surface is like, east/west reversed when compared with reality. Linear surface features can be observed to be pointing north west when in reality they point north east, etc. Compare images from wikipedia vs ingame to see what I mean - all the lines are backwards. Can't tell what's going on with the biome map here.

Dione: As with Enceladus, surface features are east-west reversed. Biome map is way off but I can't figure out exactly how.

Rhea: As above, features are east-west reversed. Biome map is... not correlating with the surface.

Titan: Can't see jack. No useful observations.

Iapetus: This one threw me at first. The surface features here are actually completely correct, but the Biome map seems rotated around the axis of rotation by 180 degrees - showing the Turgis crater on the biome map over the lighter side of the moon. This one is super, super weird. Detailed observations at bottom of post.

Tethys + Mimas: surface features are correct relative to reality, but the biome map has been flipped around the equator; that is, longitude of surface features match the biome map, but latitudes of the biome map have been flipped from north to south.

 

Apologies for the wall of text. Might anybody else be able to verify any of the above for me? I don't see any problems with any other moons on either install - Uranus/Jupiter's moons are all fine, they match their biomes and RL maps.

EDIT: I take that last line back - Jupiter's moons do not seem fine on either install. Observations across both installs match and are listed below.

Io: Has surface features east-west reversed as per Dione/Enceladus/Rhea above.

Europa: Perfect. No problems here, matches reality and biome map.

Ganymede: As Io, has east-west reversed. Surface features running east in game that should run west etc

Callisto: Perfect, matches reality and biome map.

 

Ok it's nap time. Will look at Uranus moons also but the first I looked at was fine in all respects.

 

Another EDIT: Just installed a completely fresh 1.3.1 with only RSS and Kopernicus, all above observations repeated and confirmed.

 

ANOTHER edit. BOTH of my observations on Iapetus were wrong, this one is HELLA WEIRD! What a mind... cluck this has been.

Iapetus surface matches reality, but the only way the surface of Iapetus matches the biome map everywhere, is if you flip the biome map around the equator, like described with Mimas/Tethys. But the red biome (named Turgis) is the exception, it does not actually line up with the Turgis crater, it's been either misnamed or misplaced. Once the biome map is flipped 180 around the equator, everything looks great, except the existing red biome needs to be renamed to "Engelier" because that's the name of the crater it is then on top of, or it needs to be moved to the actual Turgis crater. which is over the other side and on the opposite hemisphere.

 

omg do I get a cookie? I think I have low blood sugar

 

 

Edited by TheBok
Found more wacky things

Share this post


Link to post
Share on other sites
On 2/23/2019 at 5:46 PM, Nightside said:

Welcome to the forums @rocketpark. Real Solar System should be working fine in 1.6.1 (just make sure you are using the right version of Kopernicus for your KSP).

RSS is an incredible mod in its own right but you will soon realize that stock rockets are too small, weak and heavy to cut it in the real world. The most realistic experience will come from a full Realism Overhaul install, but that is still back on KSP 1.4.5, so you would have to download that version for the full experience.

It is not working fine in 1.6.

Share this post


Link to post
Share on other sites
1 hour ago, Blyet Nye the Soviet Guy said:

It is not working fine in 1.6.

What is not working? It’s working for me on a lean install (but I haven’t been much beyond LEO in a while)

Share this post


Link to post
Share on other sites

Парашюты не открываются на Марсе, после столкновения с поверхность высотомер показывает 9000 м

[Moderator note: this translates as "Parachutes do not open on Mars, after a collision with the surface the altimeter shows 9000 m]

Edited by Snark
Note added by moderator

Share this post


Link to post
Share on other sites
13 minutes ago, vlad500 said:

Парашюты не открываются на Марсе, после столкновения с поверхность высотомер показывает 9000 м

Hi @vlad500, and welcome to the forums!  :)

Please try to keep questions in the English-language forums in English only, per forum rule 2.3.c.  If you'd like to post in Russian, there's a place for that. 

Спасибо!

Share this post


Link to post
Share on other sites

Parachutes do not open on Mars, after a collision with the surface, the altimeter shows 9000 m

Edited by vlad500

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now