Theysen

[1.6.1] Real Solar System v16.2 [19 Apr 2019]

Recommended Posts

Any plans of adding ground scatter like rocks?

Share this post


Link to post
Share on other sites
33 minutes ago, Tonas1997 said:

Any plans of adding ground scatter like rocks?

You know, I broached that very subject in the RO Discord channel  and the response was lukewarm at best.

That aside, Kopernicus has some issues that can in certain circumstances result in tremendous loss of performance  by enabling surface features (their proper term so as not to confuse them with terrain scatter) under circumstances in which they should not spawn and in quantities greater than they should spawn. So far the only viable workaround is custom terrain quality settings that can reduce the range at which they are created and by reducing the number of them created. That unfortunately tends to spread them over a wider area which makes the rarer ones harder to find. 

Share this post


Link to post
Share on other sites

I'm having a problem with RSS. I have gotten it working, mostly, in 1.7.3. However, all of the engines have ISPs that are too high. They all seem to be about 30% better than usual. For example, a Terrier has a vac ISP of 586.The improved ISPs are across the board. Every engine is more efficient. I don't like this, it takes the challenge out. It's basically like playing stock, but with a different solar system. The challenge is gone.

Does anyone know what setting can be changed to get the original ISP values back?

Share this post


Link to post
Share on other sites
3 hours ago, RocketBlam said:

I'm having a problem with RSS. I have gotten it working, mostly, in 1.7.3. However, all of the engines have ISPs that are too high. They all seem to be about 30% better than usual. For example, a Terrier has a vac ISP of 586.The improved ISPs are across the board. Every engine is more efficient. I don't like this, it takes the challenge out. It's basically like playing stock, but with a different solar system. The challenge is gone.

Does anyone know what setting can be changed to get the original ISP values back?

I'm quite sure it's not RSS' fault. It must have been a different mod causing it.

Share this post


Link to post
Share on other sites
On 8/2/2019 at 11:51 PM, RocketBlam said:

I'm having a problem with RSS. I have gotten it working, mostly, in 1.7.3. However, all of the engines have ISPs that are too high. They all seem to be about 30% better than usual. For example, a Terrier has a vac ISP of 586.The improved ISPs are across the board. Every engine is more efficient. I don't like this, it takes the challenge out. It's basically like playing stock, but with a different solar system. The challenge is gone.

Does anyone know what setting can be changed to get the original ISP values back?

As @Darkherring says that is is NOT RSS. Another mod is responsible for that. There's no 'setting' you can adjust, you need to find the mod responsible and uninstall it. Install Real Fuels if you haven't already and download a proper engine pack for it. Since you're playing RSS I suggest downloading Realism Overhaul if you haven't already.  (not an absolute necessity; you could get by with the stockalike engine pack and appropriately sized tanks)

You don't say anything about what mods you have installed so it's not going to be possible to say anything further without more information.

Share this post


Link to post
Share on other sites

i am using the latest version of rss and kopernicus in 1.7.3, however, the solar panel is not working. 

if i delete rss, remain kopernicus in my gamedata, the solar panel works. 

if i add the rss, it doesn't work. 

i dont know if it the problem of kopernicus or rss. i've seen other people saying that their solarpanels dont work as mine. they said that deleting the file “solarpanel.cfg "in the folder gamedata/kopernicus/config seems to be working,  however it is not for me. i've reinstalled that mods several times and it just doesnt work. 

backing to 1.7.1 or 1.6.1 seem to be a good way,  but i've tried and it stays in the original kerbin. 

i've post a similar post in the kopernicus thread, on one is answering. 

 i got confused and dont know what to do now.   (forgive my spelling) 

press the alt+F12 and it shows:

Error: Timing FI threw during Update: System. NulIReference Exception: Object
reference not set to an Instance of an object
at Kopernicus.Components.KopernicusStar.SunbodyFlux
(ModularFI.ModularFlightIntegrator flightIntegrator) [0x00000) In <filename unknown>:0
at ModularFIModularFllghtIntegrator. CalculateSunBodyFlux () [Ox00000]In <filename unknown>:0
at FlightIntegrator. ThermoPrecalculate () [Oxo0000] In <filename unknown: 0
at FlightIntegrator Update () [Ox00000] in <filename unknown>: 0
at ModularFLModularFllghtintegrator. TimedUpdate O [ax0000o] In <filename unknown>: 0
at TimingFI. Update () [Ox00000] In <filename unknown>:0
Exception: NullReferenceException: Object reference not set to an instance of an object.

Exception: NullReferenceException

 Exception: NullReferenceException

does anyone knows what to do ? thank u!

 

 

Share this post


Link to post
Share on other sites
On 7/22/2019 at 5:50 PM, Starwaster said:

You know, I broached that very subject in the RO Discord channel  and the response was lukewarm at best.

That aside, Kopernicus has some issues that can in certain circumstances result in tremendous loss of performance  by enabling surface features (their proper term so as not to confuse them with terrain scatter) under circumstances in which they should not spawn and in quantities greater than they should spawn. So far the only viable workaround is custom terrain quality settings that can reduce the range at which they are created and by reducing the number of them created. That unfortunately tends to spread them over a wider area which makes the rarer ones harder to find. 

I take it from this that there's no way to get Breaking Ground surface features (i.e. those used with scanning arms) on RSS planets? I just want to confirm this is an RSS limitation and not something resulting from some strange combination of mods I have installed. 

Share this post


Link to post
Share on other sites
29 minutes ago, GP_LeChuck said:

I take it from this that there's no way to get Breaking Ground surface features (i.e. those used with scanning arms) on RSS planets? I just want to confirm this is an RSS limitation and not something resulting from some strange combination of mods I have installed. 

It's a matter of creating a set of ROC_DEFINITION configs with appropriate Frequency values so that they spawn in appropriate numbers that won't tank your CPU or FPS. There is an issue which aggravates performance issues when on oceanless bodies that Kopernicus will address in a later update.  (note actually related to the ROC issue but the issues compound each other)

Also, RSS would require a set of terrain quality settings appropriate for each planet; I think there was talk about that happening.

Finally, there's a value in each player's settings.cfg which would probably have to be modified to an appropriate value to further inhibit unwanted ROC spawning but it's not patchable by ModuleManager so would have to be set by the player or possibly by plugin... I've thought of proposing such a change for Kopernicus but haven't had a chance to put together the request. (I'd want to be able to suggest a precise course of action)

So, TL;DR it's totally doable and a player could probably even do it on their own but in the absence of an official solution (which is doable) would have to deal with performance issues on their own as well.

Share this post


Link to post
Share on other sites
12 hours ago, Max.10.07 said:

Uhh it looks like you screwed up the download link. The "https://github.com/KSP-RO/RealSolarSystem/releases/tag/v16.2" text (6.2 is not part of the link) actually links to https://github.com/KSP-RO/RealSolarSystem/releases/tag/v14.0.0, which looks like has caused issues for some people earlier in this thread, as well as me, just a heads up.

thank you! now it's working !

Share this post


Link to post
Share on other sites
On 8/5/2019 at 8:02 PM, Starwaster said:

It's a matter of creating a set of ROC_DEFINITION configs with appropriate Frequency values so that they spawn in appropriate numbers that won't tank your CPU or FPS. There is an issue which aggravates performance issues when on oceanless bodies that Kopernicus will address in a later update.  (note actually related to the ROC issue but the issues compound each other)

Also, RSS would require a set of terrain quality settings appropriate for each planet; I think there was talk about that happening.

Finally, there's a value in each player's settings.cfg which would probably have to be modified to an appropriate value to further inhibit unwanted ROC spawning but it's not patchable by ModuleManager so would have to be set by the player or possibly by plugin... I've thought of proposing such a change for Kopernicus but haven't had a chance to put together the request. (I'd want to be able to suggest a precise course of action)

So, TL;DR it's totally doable and a player could probably even do it on their own but in the absence of an official solution (which is doable) would have to deal with performance issues on their own as well.

Hmm that does sound a bit outside my ability range (although if anyone is familiar with any tutorials, I'd love to hear it!). I assume that this is the reason Kerbnet scans don't work either?

Share this post


Link to post
Share on other sites
1 hour ago, GP_LeChuck said:

Hmm that does sound a bit outside my ability range (although if anyone is familiar with any tutorials, I'd love to hear it!). I assume that this is the reason Kerbnet scans don't work either?

No idea about that. I didn’t know something was wrong with kerbnet that was rss specific 

Share this post


Link to post
Share on other sites

Hello. I am literally dying to get this running but I must be missing a step.  I followed all of the downloads on the first post of this thread and did the first 3 steps against a fresh KSP1.61 install.  

It made no visible change to my game.  Are there more steps to get it running besides unzipping the files into my KSP folder?

Much thanks for any help.

Share this post


Link to post
Share on other sites
Posted (edited)
On 8/2/2019 at 9:51 PM, RocketBlam said:

I'm having a problem with RSS. I have gotten it working, mostly, in 1.7.3. However, all of the engines have ISPs that are too high. They all seem to be about 30% better than usual. For example, a Terrier has a vac ISP of 586.The improved ISPs are across the board. Every engine is more efficient. I don't like this, it takes the challenge out. It's basically like playing stock, but with a different solar system. The challenge is gone.

Does anyone know what setting can be changed to get the original ISP values back?

FYI, I cleared out all my other mods and reinstalled RSS from CKAN, and installed the texture pack manually. It all works, amazingly. I'm running RSS on 1.7.3. And the engine ISP values are normal again.

I did not, FYI, install any "recommended" mods.

Edited by RocketBlam

Share this post


Link to post
Share on other sites
5 minutes ago, Memelord69420 said:

I cant as the planets dont load in

Did you install dependencies?

Share this post


Link to post
Share on other sites

For me it only worked after I deleted Mercury, Neptune and Uranus from the RSSKopernicus folder. Running on 64bit Linux. With those planets left in it will lock up while loading.

Not a big deal for now since I'm not planning to visit them for quite a while yet.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.