Theysen

[1.7.3] Real Solar System v16.4 [26 Nov 2019]

Recommended Posts

So I'm coming back after a bit of a break and upgrading everything to 1.8.1, and I am happy to say that RSS has installed with the new version of Kopernicus just fine (and a big thanks to both sets of devs, too). I've given up on RSSVE as it seems to be defunct (but thanks to Phineas Freak for all the effort he has put into keeping it going as long as he has -- and for having a username that always harkens me back to a different time).

My question is is there anything that people are using to add clouds to the sky or water effects that works well with RSS? EVE and or scatterer? I've used RSSVE for so long I am out of touch with everything else.

Share this post


Link to post
Share on other sites

Can anyone help?

Started with vanilla KSP 1.8.1 (no DLCs), installed Kopernicus, RSS, 2048 Tex, KSCSwitcher and RSSDateTime.

Get stuck in loading screen, so I checked the log:

[LOG 08:39:58.840] Loading Systems: Elapsed time is 29.41279s
[LOG 08:40:01.435] [AddonLoader]: Instantiating addon 'Injector' from assembly 'Kopernicus'
[LOG 08:40:01.436] [Kopernicus] Running Kopernicus 1.8.1-1 on KSP 1.8.1
[LOG 08:40:01.447] [Kopernicus] Default logger initialized as Kopernicus
[LOG 08:40:01.452] [Kopernicus] ShaderLoader: Loading asset bundle at path C:/Program Files (x86)/Steam/steamapps/common/Kerbal Space Program/KSP_x64_Data/../GameData/Kopernicus/Shaders\kopernicusshaders-windows.unity3d
[LOG 08:40:01.454] [Kopernicus] ShaderLoader: adding Kopernicus/Rings
[LOG 08:40:01.615] [Kopernicus]: texture does not exist! C:/Program Files (x86)/Steam/steamapps/common/Kerbal Space Program/KSP_x64_Data/../GameData/RSS-Textures/PluginData/CeresBiomes.DDS
[LOG 08:40:01.634] [Kopernicus] CalculateArrayLengthOffset using offset of -8
[LOG 08:40:01.634] [Kopernicus] LoadRestOfReader reallocating buffer to 4194304
[WRN 08:40:01.651] DontDestroyOnLoad only works for root GameObjects or components on root GameObjects.
[LOG 08:40:01.688] [OD] Adding for body Ceres map named CeresColor (G) for Ceres of path = RSS-Textures/PluginData/CeresColor.dds
[LOG 08:40:02.088] [OD] --> OnDemandStorage.EnableBody loading Ceres
[LOG 08:40:02.143] [OD] ---> Map CeresColor (G) for Ceres enabling self. Path = RSS-Textures/PluginData/CeresColor.dds
[WRN 08:40:02.155] Cannot find preset 'High' for pqs 'Ceres(Clone)'
[LOG 08:40:02.157] lcScatterList
[WRN 08:40:02.157] CelestialBodyTransform: Cannot find CelestialBody.
[EXC 08:40:02.170] Exception: Failed to load Body: Ceres
	Kopernicus.Configuration.Loader.Kopernicus.ConfigParser.Interfaces.IParserEventSubscriber.PostApply (ConfigNode node) (at <0882401b48d84227ad9c2bbcf4ce8401>:0)
	Kopernicus.ConfigParser.Parser.LoadObjectFromConfigurationNode (System.Object o, ConfigNode node, System.String configName, System.Boolean getChildren) (at <698cce273aaa41f09ce80d0801f868a2>:0)
	Kopernicus.ConfigParser.Parser.CreateObjectFromConfigNode[T] (ConfigNode node, System.String configName, System.Boolean getChildren) (at <698cce273aaa41f09ce80d0801f868a2>:0)
	Kopernicus.Injector.Awake () (at <0882401b48d84227ad9c2bbcf4ce8401>:0)
	UnityEngine.DebugLogHandler:LogException(Exception, Object)
	ModuleManager.UnityLogHandle.InterceptLogHandler:LogException(Exception, Object)
	UnityEngine.Debug:LogException(Exception)
	Kopernicus.Injector:Awake()
	UnityEngine.GameObject:AddComponent(Type)
	AddonLoader:StartAddon(LoadedAssembly, Type, KSPAddon, Startup)
	AddonLoader:StartAddons(Startup)
	AddonLoader:OnLevelLoaded(GameScenes)
	AddonLoader:OnSceneLoaded(Scene, LoadSceneMode)
	UnityEngine.SceneManagement.SceneManager:Internal_SceneLoaded(Scene, LoadSceneMode)

So Ceres seems to be the first planet body to be loaded and there is no Biomes.dds (I checked the Texture .zip, there are only .pngs for all the bodies). I think that triggers the exception 10 lines later?

I saw another warning, that the game cannot find the preset 'high', so I removed kopernicus, started KSP and set texture from high to default, but to no avail.

I tried with the other res textures, same problem. Even though the release notes of the textures say:

Quote

Convert all png textures to DXT5

Any suggestion how to fix that?

Edited by ULLMOD

Share this post


Link to post
Share on other sites

CKAN does the trick.

I started from scratch, this time installing RSS via CKAN—biomes.dds are there, game runs fine.

Hope that helps my fellow Kerbonauts!

Share this post


Link to post
Share on other sites
2 hours ago, ULLMOD said:

Can anyone help?

Started with vanilla KSP 1.8.1 (no DLCs), installed Kopernicus, RSS, 2048 Tex, KSCSwitcher and RSSDateTime.

Get stuck in loading screen, so I checked the log:


[LOG 08:39:58.840] Loading Systems: Elapsed time is 29.41279s
[LOG 08:40:01.435] [AddonLoader]: Instantiating addon 'Injector' from assembly 'Kopernicus'
[LOG 08:40:01.436] [Kopernicus] Running Kopernicus 1.8.1-1 on KSP 1.8.1
[LOG 08:40:01.447] [Kopernicus] Default logger initialized as Kopernicus
[LOG 08:40:01.452] [Kopernicus] ShaderLoader: Loading asset bundle at path C:/Program Files (x86)/Steam/steamapps/common/Kerbal Space Program/KSP_x64_Data/../GameData/Kopernicus/Shaders\kopernicusshaders-windows.unity3d
[LOG 08:40:01.454] [Kopernicus] ShaderLoader: adding Kopernicus/Rings
[LOG 08:40:01.615] [Kopernicus]: texture does not exist! C:/Program Files (x86)/Steam/steamapps/common/Kerbal Space Program/KSP_x64_Data/../GameData/RSS-Textures/PluginData/CeresBiomes.DDS
[LOG 08:40:01.634] [Kopernicus] CalculateArrayLengthOffset using offset of -8
[LOG 08:40:01.634] [Kopernicus] LoadRestOfReader reallocating buffer to 4194304
[WRN 08:40:01.651] DontDestroyOnLoad only works for root GameObjects or components on root GameObjects.
[LOG 08:40:01.688] [OD] Adding for body Ceres map named CeresColor (G) for Ceres of path = RSS-Textures/PluginData/CeresColor.dds
[LOG 08:40:02.088] [OD] --> OnDemandStorage.EnableBody loading Ceres
[LOG 08:40:02.143] [OD] ---> Map CeresColor (G) for Ceres enabling self. Path = RSS-Textures/PluginData/CeresColor.dds
[WRN 08:40:02.155] Cannot find preset 'High' for pqs 'Ceres(Clone)'
[LOG 08:40:02.157] lcScatterList
[WRN 08:40:02.157] CelestialBodyTransform: Cannot find CelestialBody.
[EXC 08:40:02.170] Exception: Failed to load Body: Ceres
	Kopernicus.Configuration.Loader.Kopernicus.ConfigParser.Interfaces.IParserEventSubscriber.PostApply (ConfigNode node) (at <0882401b48d84227ad9c2bbcf4ce8401>:0)
	Kopernicus.ConfigParser.Parser.LoadObjectFromConfigurationNode (System.Object o, ConfigNode node, System.String configName, System.Boolean getChildren) (at <698cce273aaa41f09ce80d0801f868a2>:0)
	Kopernicus.ConfigParser.Parser.CreateObjectFromConfigNode[T] (ConfigNode node, System.String configName, System.Boolean getChildren) (at <698cce273aaa41f09ce80d0801f868a2>:0)
	Kopernicus.Injector.Awake () (at <0882401b48d84227ad9c2bbcf4ce8401>:0)
	UnityEngine.DebugLogHandler:LogException(Exception, Object)
	ModuleManager.UnityLogHandle.InterceptLogHandler:LogException(Exception, Object)
	UnityEngine.Debug:LogException(Exception)
	Kopernicus.Injector:Awake()
	UnityEngine.GameObject:AddComponent(Type)
	AddonLoader:StartAddon(LoadedAssembly, Type, KSPAddon, Startup)
	AddonLoader:StartAddons(Startup)
	AddonLoader:OnLevelLoaded(GameScenes)
	AddonLoader:OnSceneLoaded(Scene, LoadSceneMode)
	UnityEngine.SceneManagement.SceneManager:Internal_SceneLoaded(Scene, LoadSceneMode)

So Ceres seems to be the first planet body to be loaded and there is no Biomes.dds (I checked the Texture .zip, there are only .pngs for all the bodies). I think that triggers the exception 10 lines later?

I saw another warning, that the game cannot find the preset 'high', so I removed kopernicus, started KSP and set texture from high to default, but to no avail.

I tried with the other res textures, same problem. Even though the release notes of the textures say:

Any suggestion how to fix that?

Hello, all the old DDS images need to be converted.

the changes in 1.8.1, can be seen here (https://wiki.kerbalspaceprogram.com/wiki/1.8)

"DXT3 DDS formatted textures are not supported by Unity or KSP any more. You must convert to DXT5. "

for 1.8.1 Convert Textures:
Donloaded: https://github.com/microsoft/DirectXTex/releases
sample: K:\SteamLibrary\steamapps\common\Kerbal Space Program\GameData\RSS-Textures>texconv.exe -f DXT5 *.dds -y

sample: K:\SteamLibrary\steamapps\common\Kerbal Space Program\GameData\RSS-Textures\PluginData>texconv.exe -f DXT5 *.dds -y

With that Real Solar System run very well in 1.8.1!

 

But yes installing via CKAN all is fine because new version is already pointing to the new version of the images v18

 

 

 

Edited by pmborg

Share this post


Link to post
Share on other sites
14 hours ago, Mandella said:

So I'm coming back after a bit of a break and upgrading everything to 1.8.1, and I am happy to say that RSS has installed with the new version of Kopernicus just fine (and a big thanks to both sets of devs, too). I've given up on RSSVE as it seems to be defunct (but thanks to Phineas Freak for all the effort he has put into keeping it going as long as he has -- and for having a username that always harkens me back to a different time).

My question is is there anything that people are using to add clouds to the sky or water effects that works well with RSS? EVE and or scatterer? I've used RSSVE for so long I am out of touch with everything else.

In 1.8.1, I just use Scatterer, EVE, Planetshine, DistantObjectEnhancement, and RVE64k. They all seem to run fine together but only with RSS version 16.2. Also, ANY mod that is not just parts from 1.7.x or previous will break kopernicus 1.8.1 so be mindful of that. RVE 64k is currently only retextured Earth. 

Share this post


Link to post
Share on other sites
2 hours ago, Alvi said:

In 1.8.1, I just use Scatterer, EVE, Planetshine, DistantObjectEnhancement, and RVE64k. They all seem to run fine together but only with RSS version 16.2. Also, ANY mod that is not just parts from 1.7.x or previous will break kopernicus 1.8.1 so be mindful of that. RVE 64k is currently only retextured Earth. 

Thanks Alvi. Do you use any updated Scatter configs? I note the suggested changes at the start of the Scatterer thread are listed as "outdated."

 

Edit to add: Looks like EVE is the one I'm going to have to hack together some custom configs for.

Another Edit: Annnd I didn't see you said 16.2, and I've got 16.4 RSS installed. I'll look into rolling back a version, if necessary.

Edited by Mandella

Share this post


Link to post
Share on other sites

 

10 hours ago, Mandella said:

Thanks Alvi. Do you use any updated Scatter configs? I note the suggested changes at the start of the Scatterer thread are listed as "outdated."

 

Edit to add: Looks like EVE is the one I'm going to have to hack together some custom configs for.

Another Edit: Annnd I didn't see you said 16.2, and I've got 16.4 RSS installed. I'll look into rolling back a version, if necessary.

The only change I believe between 16.2 and 16.4 RSS is that annoying bump in the runway, but its practically a non-issue (for me at least, depends on how much you like aviation) Also i didn't require any custom configs, i just installed all of the 1.8.1 versions of everything besides RSS and RVE 64k. I would also highly recommend KS3P, theres a beta for 1.8 on Github for it. When complete it should look great. Here's some Images from my WIP Mir station, docked with Space Shuttle Atlantis.c17wI2T.png

1zEcWjC.png

Edited by Alvi

Share this post


Link to post
Share on other sites

I'm looking for a suggestion for any mods OTHER than Realism Overhaul which change the stock engines to real world specs compatible with Real Solar System but without all the other stuff that RO does... Plus right now RO does not work with 8.1 and all the rest of my mods are standardized on 8.1.

 

Worst case I guess I can write scripts manually to update each engine, but I'm hoping someone has already done something like this.

Share this post


Link to post
Share on other sites
5 minutes ago, Atlas Gaming said:

I'm looking for a suggestion for any mods OTHER than Realism Overhaul which change the stock engines to real world specs compatible with Real Solar System but without all the other stuff that RO does... Plus right now RO does not work with 8.1 and all the rest of my mods are standardized on 8.1.

 

Worst case I guess I can write scripts manually to update each engine, but I'm hoping someone has already done something like this.

You might be looking for SMURFF. It's what I use.

 

 

Share this post


Link to post
Share on other sites
On 2/10/2020 at 6:37 AM, Alvi said:

 

1zEcWjC.png

@Alvi can I please ask what textures you are running? Thank you in advance!

Share this post


Link to post
Share on other sites
3 hours ago, Atlas Gaming said:

I'm looking for a suggestion for any mods OTHER than Realism Overhaul which change the stock engines to real world specs compatible with Real Solar System but without all the other stuff that RO does... Plus right now RO does not work with 8.1 and all the rest of my mods are standardized on 8.1.

 

Worst case I guess I can write scripts manually to update each engine, but I'm hoping someone has already done something like this.

Just as a FYI RO does work with 1.8.1. See RaiderNick's post here:

 

Share this post


Link to post
Share on other sites
20 hours ago, Dafni said:

@Alvi can I please ask what textures you are running? Thank you in advance!

Hey, sorry for replying late just saw your quote now. I'm running RVE64k on KSP 1.8.1 with all of its recommended mods (Scatterer, EVE, KS3P, Planetshine, Distant Object Enhancement) along with the usual RSS 8k textures as a a base. Be notified that RVE 64k may not work on 1.8 with RSS 16.4, but your mileage may vary. It works 100% fine in 1.8 with RSS 16.2, however. Currently it only re-textures Earth, so if you want other planets i'd consider messing with Vanadins 16k textures and adjusting the configs so it doesn't mess with RVE64k, as they're not designed to work together. RVE 64k is also in Beta currently, and sometimes the city lights textures glitch out. If this happens i'd recommend time-warping a bit or quick-loading. Any other issues can be chalked up to it being Beta. 

Another thing you may consider if you plan on running these textures, particularly the 64k ones, is that if your vessel is above 150-200 parts, your FPS will almost certainly be closer to 30 than 60. If that doesn't bother you, go all in. I run with a GTX 980 TI and my FPS is usually in the 70-110 range during normal rocket launches and Space Shuttle launches (75 parts), but my International Space Station (110+ parts) gets around 50-70 FPS, less when the Space Shuttle is docked. Here's some links;

 

Share this post


Link to post
Share on other sites
2 hours ago, Alvi said:

Hey, sorry for replying late just saw your quote now.

 

Hey! No need to apologize at all! Many thanks for the extensive reply, I appreciate it.

I was considering giving those 16k textures a try but the talk about the modified RSSVE configs scared me away. Still debating my 1.8.1 RSS build. Again many thanks for the input.

Share this post


Link to post
Share on other sites

Good day,

I installed this pack with relative dependences (Kopernicus and Module Manager for 1.8.1.,  KSCSwitcher and RSSDate last update). The only problem I have is that sunlight is really weak, even on Mercury brightness is really low. I've tried to install RSSVE but problem remain. If I delete RSS folder sunlight come back to normality so I tried te redownload and reinstall RSS but nothing, that sunlight still remain low. There is a way to fix it?

Thank you

Share this post


Link to post
Share on other sites
8 hours ago, Preliator said:

Good day,

I installed this pack with relative dependences (Kopernicus and Module Manager for 1.8.1.,  KSCSwitcher and RSSDate last update). The only problem I have is that sunlight is really weak, even on Mercury brightness is really low. I've tried to install RSSVE but problem remain. If I delete RSS folder sunlight come back to normality so I tried te redownload and reinstall RSS but nothing, that sunlight still remain low. There is a way to fix it?

Thank you

I have the same issue. I finally gave up on trying to get EVE working and uninstalled it, but the sunlight issue is with just RSS I agree.

Share this post


Link to post
Share on other sites
16 hours ago, Preliator said:

Good day,

I installed this pack with relative dependences (Kopernicus and Module Manager for 1.8.1.,  KSCSwitcher and RSSDate last update). The only problem I have is that sunlight is really weak, even on Mercury brightness is really low. I've tried to install RSSVE but problem remain. If I delete RSS folder sunlight come back to normality so I tried te redownload and reinstall RSS but nothing, that sunlight still remain low. There is a way to fix it?

Thank you

Noted the same thing, but just cranked up the ambient light setting until it looked okay again.

Share this post


Link to post
Share on other sites

Are there any Scatterer configs for RSS? I am aware that RSSVE exists but I would like only the Scatterer part for performance reasons. I tried searching several topics but only found a config for Earth only.

Share this post


Link to post
Share on other sites
1 hour ago, viktor19 said:

Are there any Scatterer configs for RSS? I am aware that RSSVE exists but I would like only the Scatterer part for performance reasons. I tried searching several topics but only found a config for Earth only.

Delete everything from the RSSVE Folder except the scatterer configs.

Edited by ValiZockt
Hit enter to fast ;)

Share this post


Link to post
Share on other sites
On 2/11/2020 at 1:22 AM, Atlas Gaming said:

Just installed... that looks like it is exactly what I was hoping for! Thanks

You can also try https://spacedock.info/mod/1446/Jimbodiah's Simple RSS patch

Trouble wit SMURFF is that BDB (and possibly other mods) which I also play with, specifically disables SMURFF compatibility, so you end up with Saturn/Gemini/etc replicas that are still not capable of reaching orbit

 

 

Edited by nasaholic

Share this post


Link to post
Share on other sites
On 2/10/2020 at 9:59 PM, Atlas Gaming said:

I'm looking for a suggestion for any mods OTHER than Realism Overhaul which change the stock engines to real world specs compatible with Real Solar System but without all the other stuff that RO does... Plus right now RO does not work with 8.1 and all the rest of my mods are standardized on 8.1.

 

Worst case I guess I can write scripts manually to update each engine, but I'm hoping someone has already done something like this.

I built an RSS mod called Less Real Than Real(ism), which is basically a simplified fork of RP-1 for stock and stock-alike parts.

 

 

Share this post


Link to post
Share on other sites

I found a minor bug. It's nothing game breaking, but I assume its not intended behavior. There's a region of the Atlantic Ocean where the biome reads as "Mountains" for science collection. I found this at Latitude 26 degrees, 33 minutes North and Longitude 67 degrees, 16 minutes West.

I installed RSS through CKAN earlier today, and am running KSP version 1.8.1

Share this post


Link to post
Share on other sites

Hello @Theysen,

First of all congratulations about the work done in Real Solar System! :)

 

I developed something that the community desired a possibility to have "Real Solar System" with the Stock System as well at the same time, where Kerbol orbit Sun.

In order to publish the "Real Solar System with Stock", I need to push 2 changes in "Real Solar System" in order to allow it in a compatible way, with or without "Real Solar System with Stock".

- Basically what this add-on does, it's to move all planets from Kerbol System from center, and add them after Pluto, instead of remove all System like in "Real Solar System" Mod.

 

About dependencies:

"Real Solar System with Stock" depends on "Real Solar System"

 

What do think about this Idea?

Fix to Support "Real Solar System with Stock": https://www.dropbox.com/s/wizizeqd2xim8oi/fix-RealSolarSystem.zip?dl=0

"Real Solar System with Stock": https://www.dropbox.com/s/gsb41bj3rwhudkm/RealSolarSystemWithStock.zip?dl=0 (allow the installation of RSS without delete Kerbol System)

Edited by pmborg

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.