Booots

[1.9.x] Kerbal Wind Tunnel 1.2.4

Recommended Posts

Feature Request -

This mod is very helpful in showiing the optimum altitude for busting mach 1, whether your design is in fact capable of mach 1, and the best altitude for hitting max speed on air breathers.

But can you update it to take into account the "lift" you get from orbital freefall effect, which is quite significant by mach 4+,    and also have a checkbox to enable the thrust from rocket engines to be taken into account.

For example, you can toggle on the thrust from your NERVs to enable you to break through the sound barrier so long as you're not right down in the weeds.

Most important of all, if you're building a liquid fuel only spaceplane,  does it have excess thrust when operating on NERV power alone after the jets quit?  If the mod took account of orbital freefall and had an option to take into account the thrust from the NERVs,  it could help you with this

Share this post


Link to post
Share on other sites

Hey everyone!

I'm back working on this after a busy summer with work and RL fun times. @neistridlar: stay tuned - I've solved the math for determining near-optimal ascent profiles for fuel or time. I've got a working prototype and now just need to add GUI options for it and make it robust enough for users at large (you guys do tend to break things in new and exciting ways :P ).

Speaking of such...

On 9/18/2018 at 2:23 PM, Apaseall said:

I am unsure why an engine from a mod should cause an issue. I am under the belief that this mod parses the .craft and pulls in stuff like enginemodule or enginefxmodule, those should contain the data you need to crunch for this mod? Sorry if I have the module names wrong. You are picking up stuff like isp curves for velocity and altitude etc?

That's exactly what I'm doing. I'm seeing a NullRef in the logs, which implies I'm looking for a value the mod engine doesn't provide. It also narrows down which item it is in that it has to be a reference-type rather than a value-type, which should help me find why my mod isn't handling it gracefully. I'm too interested in the ascent profile solver right now to sit down and bug find, but I promise I'll get to it soon.

On 10/5/2018 at 5:43 AM, AeroGav said:

Feature Request -

This mod is very helpful in showiing the optimum altitude for busting mach 1, whether your design is in fact capable of mach 1, and the best altitude for hitting max speed on air breathers.

But can you update it to take into account the "lift" you get from orbital freefall effect, which is quite significant by mach 4+,    and also have a checkbox to enable the thrust from rocket engines to be taken into account.

For example, you can toggle on the thrust from your NERVs to enable you to break through the sound barrier so long as you're not right down in the weeds.

Most important of all, if you're building a liquid fuel only spaceplane,  does it have excess thrust when operating on NERV power alone after the jets quit?  If the mod took account of orbital freefall and had an option to take into account the thrust from the NERVs,  it could help you with this

Oh right, I keep forgetting to add the centripetal force. It's a super easy fix. I'll get to that right away too.

To get it to take your rocket engines into account, just move them into the first stage and it'll recognize them. It calculates as if all engine in the first stage are on full throttle the whole time. I might have to add some more complicated options for the ascent profile calculator to model the post-flight ballistic portion of the flight, but I like to keep things simple when I can.

That's it for tonight! Despite my long absence from the forums, I'm back developing this so stay tuned.

Share this post


Link to post
Share on other sites

Maybe I've set up something wrong, but some of the graphs I'm getting for my planes don't make sense... I've gotten 3 different flight envelopes from one plane! The zigzag and chopped off pyramid don't make sense, and then one graph tells me I have excess thrust with Juno jets above 18km (that's impossible! flight ceiling is very low on this craft). Somehow, graphs for other planes work just fine.

https://imgur.com/a/aHZx3rY

I've tested this plane... It's ceiling is about 6-7 km on jets, has a wet takeoff speed of around 60-80 m/s and can almost touch the sound barrier. I tried disabling the rocket engine and making sure the jets are on the first stage, but the flight envelope calculation still makes no sense...

Edit 2: Here's the output.log file: https://drive.google.com/file/d/15FwzV2wEbECT6Fl_9o4LMUVliQExNXWo/view?usp=sharing

I have modded parts installed on vessel, (a life support canister + kerbal engineer jammed inside the payload bay) but I tried those parts on other planes and updating the wind tunnel, yet their flight envelopes still look fine. I have a lot of quality of life mods installed but none of them change stock aerodynamics and only two add parts (kerbal engie and usi life support).

I installed this mod using CKAN but I think I was having issues like this before I switched to CKAN. I reinstalling the mod to no avail.

Edited by It'snorocketscience
updated info, mroe clarity

Share this post


Link to post
Share on other sites

I might have missed something, but how do you install this. I installed the zip with only the 4.0mb windtunnel folder. I stuck it in Gamedata/Sqaud. Was this the correct thing to do. I'm getting errors and it's not working from what I can tell.

Share this post


Link to post
Share on other sites

No, just put it in GameData

8 minutes ago, Arugela said:

I might have missed something, but how do you install this. I installed the zip with only the 4.0mb windtunnel folder. I stuck it in Gamedata/Sqaud. Was this the correct thing to do. I'm getting errors and it's not working from what I can tell.

See above 

Share this post


Link to post
Share on other sites

Newest release is out! Version 1.2!

New Features!

  • New fuel economy and fuel burn rate graphs!
  • New lines for time-optimal and fuel-optimal graphs! (Possibly inaccurate, occasionally buggy)
  • GUI improvements to hold all these new graphs
  • Ability to select multiple graphs at once
  • Remove frame stuttering while calculating (makes it a tiny bit slower though)

Also bug fixes, but those are old news.

Some of you have had strong opinions about the GUI, so please check it out and let me know what you think!

Also, if I'm missing any graphs that you would like to see, let me know because it's versatile enough at this point to graph basically any parameter.

Share this post


Link to post
Share on other sites
6 hours ago, Booots said:

Some of you have had strong opinions about the GUI, so please check it out and let me know what you think!

I like it. There are a few details I don't like though. The drop down menu for selecting which flight envelope graph to show is transparent, and does not block the cursor from behaving as normal when you hover over the menu. That makes things more confusing than they need to be. Also after clicking apply for the optimal fuel/time graphs there is no indication that anything is going on, until suddenly the new graphs appear, it would be nice if there was at least an icon indicating that something is going on, or better still some kind of progress indicator.

I'm traveling at the moment, so not really able to test the accuracy of the calculations, due to a lack in computation power, but I will take a look at in about a weeks time.

Share this post


Link to post
Share on other sites

I put it in the gamedata folder and got a bunch of errors and the program never appeared to do anything? Is there a place the errors go? And does anyone know what causes this?

I looked at the KSP.log and I'm getting a character encode error...(neither utf-8 nor ISO-... will allow it to display the text.) Might be part of the problem. Never had that before. Might be a linux thing or from an update. I'm on fedora 28 btw. Not sure how many might be in a situation to run into a similar issue.

The errors were saying they can't read something. Not sure when or how this became a problem on my computer. Or is there something more general I'm missing?!

rant:

I really wish game companies would start putting all their files back into their main single game folders. It's really hard to remember where they choose to put things when dealing with too many different companies. If they want to preserve folders all they have to do is make a prompt on delete asking if you want to leave files for potential reinstall. They used to do that along time ago. Then you just preserve the game folder with important sub folders and not ones scattered around the system...

One shining example is making software in an environment made by others... You can assume a static environment. But you sadly shouldn't. 8) (hurray for lazy desktop environment development!) You would think they could manage to maintain something as simple as a default alphabetical order without it not being in alphabetical order. Let alone saving changes and setting as you do things. Can't find the folder that saves other log file for ksp now. I always remember it by it's position and not it's name. 8\ (BTW, this is the closest desktop environment to working correctly that doesn't break important stuff for me(powersaving, crashing when using the basic functions, desktop actually showing icons, etc.) and isn't gnome.)

I think fedora my have just wiped out everyones .local folder or something.... Or it's missing stuff.

Edited by Arugela

Share this post


Link to post
Share on other sites
2 hours ago, Arugela said:

I put it in the gamedata folder and got a bunch of errors and the program never appeared to do anything? Is there a place the errors go? And does anyone know what causes this?

Ok, just to make sure there are no stupid mistakes, let me explain how it is supposed to be installed. Extract the Zip-file. Inside that there is a folder called WindTunnel. That folder needs to go inside GamdData, so you get GameData/WindTunnel, and inside that a bunch of .dlls as well as two folders. I'm unfamiliar with running KSP on linux, but might it be that the mod needs to be compiled specifically for linux?

Errors go in the KSP.log file in the root directory of your install. On windows at least it seems to be UTF-8 with CR LF.

If the mod is working correctly you should get an additional icon in the lower right corner in the VAB and SPH, which you can click to open the window for the mod.

Share this post


Link to post
Share on other sites

Hi, thanks for the update, I look forward to being able to use the mod.

Quick note, I see you have added a PluginData folder. I see from other mods that the usual thing to do is have a folder called Plugins, then Plugins/PluginData. .dll files go in the Plugins folder and user or game settings go in the PluginData folder.
Obviously how you organize the folders for your mod is up to you, but if you are trying to conform to some sort of best practice it might be worth confirming if my observations are accurate.

Once again, thank you for your update.

Share this post


Link to post
Share on other sites

I noticed I am getting some error messages when I boot the game, which seem to be related to Kerbal Wind Tunel. Not sure it is a problem, as the mod seems to be working mostly fine.

[LOG 16:53:41.887] ******* Log Initiated for Kerbal Space Program - 1.4.4.2215 (WindowsPlayer x64) en-us *******
Kerbal Space Program - 1.4.4.2215 (WindowsPlayer x64) en-us


OS: Windows 10  (10.0.0) 64bit
CPU: Intel(R) Core(TM) i5-4210U CPU @ 1.70GHz (4)
RAM: 8108
GPU: Intel(R) HD Graphics Family (1136MB)
SM: 30 (Direct3D 9.0c [igdumdim64.dll 20.19.15.4835])
RT Formats: ARGB32, Depth, ARGBHalf, Shadowmap, RGB565, ARGB4444, ARGB1555, Default, ARGB2101010, DefaultHDR, ARGB64, ARGBFloat, RGFloat, RGHalf, RFloat, RHalf, R8, RG32


Log started: Sat, Oct 20, 2018 16:53:41


[LOG 16:53:42.011] ActionCanvas MASK: 3458764513820540928
[LOG 16:53:42.011] MainCanvas MASK: 3458764513820540928
[LOG 16:53:42.026] PhysicsGlobals: Loading database
[LOG 16:53:42.037] AppCanvas MASK: 3458764513820540928
[LOG 16:53:43.730] Load(Assembly): WindTunnel/Accord
[LOG 16:53:43.731] AssemblyLoader: Loading assembly at C:\Users\neistridlar\Documents\Kerbal Space Program\GameData\WindTunnel\Accord.dll
[LOG 16:53:43.761] Load(Assembly): WindTunnel/Accord.Math.Core
[LOG 16:53:43.761] AssemblyLoader: Loading assembly at C:\Users\neistridlar\Documents\Kerbal Space Program\GameData\WindTunnel\Accord.Math.Core.dll
[LOG 16:53:43.771] Load(Assembly): WindTunnel/Accord.Math
[LOG 16:53:43.771] AssemblyLoader: Loading assembly at C:\Users\neistridlar\Documents\Kerbal Space Program\GameData\WindTunnel\Accord.Math.dll
[LOG 16:53:43.783] Load(Assembly): WindTunnel/Wind Tunnel
[LOG 16:53:43.784] AssemblyLoader: Loading assembly at C:\Users\neistridlar\Documents\Kerbal Space Program\GameData\WindTunnel\Wind Tunnel.dll
[LOG 16:53:43.787] AssemblyLoader: Loading assemblies
[ERR 16:53:43.838] ADDON BINDER: Cannot resolve assembly: System.ComponentModel.DataAnnotations, Culture=neutral, PublicKeyToken=31bf3856ad364e35

[ERR 16:53:43.867] ADDON BINDER: Cannot resolve assembly: System.ComponentModel.DataAnnotations, Culture=neutral, PublicKeyToken=31bf3856ad364e35

[ERR 16:53:43.900] AssemblyLoader: Exception loading 'Accord': System.Reflection.ReflectionTypeLoadException: The classes in the module cannot be loaded.
  at (wrapper managed-to-native) System.Reflection.Assembly:GetTypes (bool)
  at System.Reflection.Assembly.GetTypes () [0x00000] in <filename unknown>:0 
  at AssemblyLoader.LoadAssemblies () [0x00000] in <filename unknown>:0 

Additional information about this exception:

 System.IO.FileNotFoundException: Could not load file or assembly 'System.ComponentModel.DataAnnotations, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies.
File name: 'System.ComponentModel.DataAnnotations, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35'

 System.TypeLoadException: Could not load type 'Accord.RealAttribute' from assembly 'Accord, Version=3.8.0.0, Culture=neutral, PublicKeyToken=fa1a88e29555ccf7'.

 System.TypeLoadException: Could not load type 'Accord.RealAttribute' from assembly 'Accord, Version=3.8.0.0, Culture=neutral, PublicKeyToken=fa1a88e29555ccf7'.

 System.IO.FileNotFoundException: Could not load file or assembly 'System.ComponentModel.DataAnnotations, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies.
File name: 'System.ComponentModel.DataAnnotations, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35'

 System.TypeLoadException: Could not load type 'Accord.RealAttribute' from assembly 'Accord, Version=3.8.0.0, Culture=neutral, PublicKeyToken=fa1a88e29555ccf7'.

 System.IO.FileNotFoundException: Could not load file or assembly 'System.ComponentModel.DataAnnotations, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies.
File name: 'System.ComponentModel.DataAnnotations, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35'

 System.IO.FileNotFoundException: Could not load file or assembly 'System.ComponentModel.DataAnnotations, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies.
File name: 'System.ComponentModel.DataAnnotations, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35'

 System.TypeLoadException: Could not load type 'Accord.IntegerAttribute' from assembly 'Accord, Version=3.8.0.0, Culture=neutral, PublicKeyToken=fa1a88e29555ccf7'.

 System.TypeLoadException: Could not load type 'Accord.IntegerAttribute' from assembly 'Accord, Version=3.8.0.0, Culture=neutral, PublicKeyToken=fa1a88e29555ccf7'.

 System.TypeLoadException: Could not load type 'Accord.IntegerAttribute' from assembly 'Accord, Version=3.8.0.0, Culture=neutral, PublicKeyToken=fa1a88e29555ccf7'.

 System.TypeLoadException: Could not load type 'Accord.IntegerAttribute' from assembly 'Accord, Version=3.8.0.0, Culture=neutral, PublicKeyToken=fa1a88e29555ccf7'.

 

Share this post


Link to post
Share on other sites

Really a fantastic mod! And works perfectly in 1.5.1 as far as I can tell.

My only complaint is the inability to change the axes of the flight envelope: it's currently great for a fighter but I'd like the altitude to go a bit higher for some shuttles, or the speed range to be reduced for slower planes; similarly for AoA: the gradient is linear from 0 to 35° but in flight the 0-5° range is what you are looking at for better cruise performance and it's all pretty much the same shade of blue.
I've seen that mentioned earlier in the thread and apparently you are already on it.

Edited by Gaarst

Share this post


Link to post
Share on other sites

Ok maybe this isn't the best place to post this but I have no idea where to post it, so I'm going to put it here

Whenever I open it on the toolbar it says "Calculating... (0.0%)" and doesn't go any further. Can't find a single thing about it through google, nothing even close. Any solution?

Share this post


Link to post
Share on other sites
6 hours ago, Raiden60 said:

Ok maybe this isn't the best place to post this but I have no idea where to post it, so I'm going to put it here

Whenever I open it on the toolbar it says "Calculating... (0.0%)" and doesn't go any further. Can't find a single thing about it through google, nothing even close. Any solution?

This is exactly the best place to post about this! :D It sounds like something is going wrong when the mod tries to set up the calculations - I've seen situations like that before. Can you recreate that situation in game and then upload your KSP.log file to DropBox or someplace and post a link? Can you also include a list of mods that you're using?

I'll try to fix your bug once I have that info.

Share this post


Link to post
Share on other sites
21 hours ago, Raiden60 said:

Ok maybe this isn't the best place to post this but I have no idea where to post it, so I'm going to put it here

Whenever I open it on the toolbar it says "Calculating... (0.0%)" and doesn't go any further. Can't find a single thing about it through google, nothing even close. Any solution?

 

15 hours ago, Booots said:

This is exactly the best place to post about this! :D It sounds like something is going wrong when the mod tries to set up the calculations - I've seen situations like that before. Can you recreate that situation in game and then upload your KSP.log file to DropBox or someplace and post a link? Can you also include a list of mods that you're using?

I'll try to fix your bug once I have that info.

I'm having this exact same issue as well as two others:
1) Same thing, but stuck at 100% instead of 0%.
2) Sometimes when I open the flight envelope tab the entire GUI is blank (one giant gray box) and my frame rate drops from ~160 FPS down to ~4 FPS until I minimize or close the window. I've waited on the screen for a good 15 minutes just to make sure it's not some slower calculation.

All three of these issues require me to quit KSP, delete the mod, re-install the mod, and relaunch KSP. I can't find what triggers the issue as so far it seems to happen arbitrarily with the same plane, and with or without other mods installed. They're very common occurrences and I can generally expect about a 50/50 chance between either the mod functioning or running into one of those issues. Either tonight or tomorrow (depending on free time) I'll try to create a few examples and send the logs/crafts. 

I'm excited to get this stable though, it'll be extremely helpful.

Edit: This is in 1.4.5, btw :P

Edited by Ilandria

Share this post


Link to post
Share on other sites

I'm trying to reproduce it now but for some reason it's working perfectly fine now. Haven't changed any mods or anything but when it stops working I'll let you know and give you the log

Share this post


Link to post
Share on other sites
6 hours ago, Ilandria said:

 

I'm having this exact same issue as well as two others:
1) Same thing, but stuck at 100% instead of 0%.
2) Sometimes when I open the flight envelope tab the entire GUI is blank (one giant gray box) and my frame rate drops from ~160 FPS down to ~4 FPS until I minimize or close the window. I've waited on the screen for a good 15 minutes just to make sure it's not some slower calculation.

All three of these issues require me to quit KSP, delete the mod, re-install the mod, and relaunch KSP. I can't find what triggers the issue as so far it seems to happen arbitrarily with the same plane, and with or without other mods installed. They're very common occurrences and I can generally expect about a 50/50 chance between either the mod functioning or running into one of those issues. Either tonight or tomorrow (depending on free time) I'll try to create a few examples and send the logs/crafts. 

I'm excited to get this stable though, it'll be extremely helpful.

Edit: This is in 1.4.5, btw :P

I'm also having the 100% issue now, this is also in 1.4.5. I reckon this is due to an updated version and it probably worked fine in previous versions of the mod, but we're only seeing it now

Share this post


Link to post
Share on other sites

I get the 0% loading issue, it works when I boot the game but after a few uses it is just stuck at 0% loading.

Share this post


Link to post
Share on other sites
On 10/11/2018 at 4:25 AM, Booots said:

Oh right, I keep forgetting to add the centripetal force. It's a super easy fix. I'll get to that right away too.

Is it in the latest build yet? I really would love to see this feature,  sounds less complicated to implement than a "best ascent profile planner" thing.

I built this two stage career space plane with droppable Panthers 

https://kerbalx.com/AeroGav/KrankerSpoiler  = picture of the "booster" stage 

Spoiler


1olh9cL.jpg

 

)

Here are the reported flight envelopes  -  to the left is Panther stage,  middle pic is NERVs and Panthers,  right pic is with NERVs running after separation of the Panther nacelles.

2WyUGE5.png
That appears to be without centripetal force,   MECO occurs at about 38-40km with 2100 m/s and the AP going above 70km,  when you fly the thing by just setting Prograde hold (the wings are angled up at 5 degrees to the fuselage) .   Judging by this pic, the service ceiling is probably Eeloo.

Spoiler

 

KXxgvi6.png

 

 

 

As regards optimum ascent profiles, I use this mod to help me to it manually,  by breaking the flight down into 3 stages

1.  Airbreathing climb - follow the yellow stuff, try to be at whichever altitude gives max excess thrust for your velocity

2,  Speedrun - level off at the altitude that gives the best combo of top speed speed combined with height, with speed being more valuable than altitude.     In the example of the above aircraft,  the very highest speed occurs at 8km,  but it achieves a top speed about a dozen or so less than that at just under 14km,  so that's what i do.  Above 14km Vmax falls off rapidly , not worth losing 70 m/s velocity in order to get up to 15km.    Once in the speedrun,  when do you accept the airbreathers have given you all they reasonably can ?  Let's say  your jet engines are Whiplash, with 4000 ISP, and your rocket engines are NERVs, with 800.   The air breathers are 5x as fuel efficient as the rockets,  so stay air breathing until drag is at 80% of your thrust - at that point, their fuel efficiency advantage has gone, even if you're still accelerating, so it's time to stage.

3. Once in rocket mode,  I just follow the yellow/red as per 1.   In practice,  this means holding the wings at 5 degree angle of attack with the body hopefully at zero

It's not perfect,  but "close enough for government work", as they say.

Edited by AeroGav

Share this post


Link to post
Share on other sites
On 11/2/2018 at 9:47 AM, AeroGav said:

Is it in the latest build yet? I really would love to see this feature,  sounds less complicated to implement than a "best ascent profile planner" thing.

Yep! I made sure to include that fix in the latest release. If you think it's still inaccurate, feel free to double check my math here: https://github.com/DBooots/KerbalWindTunnel/blob/1.2/Wind Tunnel/Wind Tunnel/DataGenerators/EnvelopeSurf.cs#L345

Also, @AeroGav, I love seeing what you're doing with this mod! Thanks, and keep it up!

On 10/30/2018 at 6:53 PM, Raiden60 said:

I'm also having the 100% issue now, this is also in 1.4.5. I reckon this is due to an updated version and it probably worked fine in previous versions of the mod, but we're only seeing it now

 

On 10/31/2018 at 5:29 AM, nsgallup said:

I get the 0% loading issue, it works when I boot the game but after a few uses it is just stuck at 0% loading.

Can you guys post logs when that happens? I couldn't see anything suspicious in the first log @Raiden60 posted, so the more info the better. Because it sounds like it might be related to my threading system, what sort of CPU are you guys running on?

Share this post


Link to post
Share on other sites

I've been trying to learn about the relationships between Center of Pressure and Center of Lift.  Is there a way to visualize CoP, in a similar fashion to the Stock CoM and CoL indicators?

I've also been spending time on re-entry vehicle force balancing to create high L/D orientations, first with blunt cones (Apollo-style), and progressing to biconics and spaceplanes.  Can there be an option to adjust the limits of the AoA scale, potentially all the way to +/-90 deg (at least out to 45 deg), or do the calculations deliberately get curtailed at +/-20 deg?

FYI, I love the mod so far, but I've also seen the occasional stall at 0% and 100% calculation.  I'm running a 4 Core i7-4710MQ 2.5 GHz on Win 7 Pro with 16 GB of system RAM. 

Share this post


Link to post
Share on other sites
6 hours ago, Booots said:

Yep! I made sure to include that fix in the latest release. If you think it's still inaccurate, feel free to double check my math here: https://github.com/DBooots/KerbalWindTunnel/blob/1.2/Wind Tunnel/Wind Tunnel/DataGenerators/EnvelopeSurf.cs#L345

Also, @AeroGav, I love seeing what you're doing with this mod! Thanks, and keep it up!

Ah yes,   it's making a difference -  1.1 output

2WyUGE5.png

1.2 shows this 

Tzrkg2B.jpg

Share this post


Link to post
Share on other sites
On 11/4/2018 at 8:59 PM, KSPrynk said:

I've been trying to learn about the relationships between Center of Pressure and Center of Lift.  Is there a way to visualize CoP, in a similar fashion to the Stock CoM and CoL indicators?

I've also been spending time on re-entry vehicle force balancing to create high L/D orientations, first with blunt cones (Apollo-style), and progressing to biconics and spaceplanes.  Can there be an option to adjust the limits of the AoA scale, potentially all the way to +/-90 deg (at least out to 45 deg), or do the calculations deliberately get curtailed at +/-20 deg?

FYI, I love the mod so far, but I've also seen the occasional stall at 0% and 100% calculation.  I'm running a 4 Core i7-4710MQ 2.5 GHz on Win 7 Pro with 16 GB of system RAM. 

Oh, good question. I think KSP only shows lifting forces and doesn't have an indicator for drag. Maybe CorrectCoL takes it into account? Or has an option to? Those indicators are out of scope for this mod, though, sorry.

I'm working on a feature right now to adjust axes limits to anything you want. I've got it almost working, with just a few things to iron out. If anyone's watching the GitHub page, they'll have noticed the batches of commits that usually precede an update. :)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.