Paul Kingtiger

Universal Storage II [1.3.1 and 1.4.5 - 1.7.0]

Recommended Posts

I just built a ship with one of the decoupler/SAS modules in a position where it was visible while still coupled, and want to say that I'm seriously impressed that you animated a part that will almost never be seen.

Share this post


Link to post
Share on other sites

Shrouds without the bottom cap?

Short Gemini service module?

Edited by Gapone

Share this post


Link to post
Share on other sites

I'm experiencing a strange glitch whenever I place the 4 bay core between other parts. When under thrust, the core is compressed like a spring, and oscillates non-stop when thrust is cut-off. The whole ship is tore apart by the oscillations.

KSP 1.5.1, US2 1.6.0.9

Share this post


Link to post
Share on other sites
5 hours ago, lodestar said:

I'm experiencing a strange glitch whenever I place the 4 bay core between other parts. When under thrust, the core is compressed like a spring, and oscillates non-stop when thrust is cut-off. The whole ship is tore apart by the oscillations.

KSP 1.5.1, US2 1.6.0.9

Use auto strut it will fix the problem.

I think it was written fixed in  the last version

Share this post


Link to post
Share on other sites
On 2/25/2019 at 4:54 AM, danielboro said:

Use auto strut it will fix the problem.

I think it was written fixed in  the last version

YEs it is fixed in the next release, which should be too far away (currently balancing the new science parts).

In the meantime you can head over to https://1drv.ms/f/s!AvmqbLkW8UIH2PsfIYBmSwhNfYG-pw and download patch 1.6.0.9a which fixes the issue (drop the gamedata folder into you KSP install as normal.

 

Share this post


Link to post
Share on other sites
On 2/25/2019 at 1:40 AM, lodestar said:

I'm experiencing a strange glitch whenever I place the 4 bay core between other parts. When under thrust, the core is compressed like a spring, and oscillates non-stop when thrust is cut-off. The whole ship is tore apart by the oscillations.

KSP 1.5.1, US2 1.6.0.9

 

45 minutes ago, Paul Kingtiger said:

YEs it is fixed in the next release, which should be too far away (currently balancing the new science parts).

In the meantime you can head over to https://1drv.ms/f/s!AvmqbLkW8UIH2PsfIYBmSwhNfYG-pw and download patch 1.6.0.9a which fixes the issue (drop the gamedata folder into you KSP install as normal.

 

Lodestar , see paul response

:)

Share this post


Link to post
Share on other sites
On 2/24/2019 at 4:31 PM, DStaal said:

I just built a ship with one of the decoupler/SAS modules in a position where it was visible while still coupled, and want to say that I'm seriously impressed that you animated a part that will almost never be seen.

I'm a little crazy like that

On 2/24/2019 at 9:19 PM, Gapone said:

Shrouds without the bottom cap?

Short Gemini service module?

Soo.. fairing shells like you'd get in the stock game? How do you mean? How short is short? 

On 2/11/2019 at 7:31 AM, Giraffe said:

Hello! I like this mod! Maybe i can localize him?

Sure! What language could you provide? :)

On 2/17/2019 at 1:50 PM, Capt. Hunt said:

Hey, @Paul Kingtiger, I was playing around with the conical US fairings, and I had an idea.

What do you think of a parachute wedge?  That would slot nicely into the size 1 to size 0 conical fairing.  I know you could just attach a radial parachute, but it's not as clean looking, and besides, you could make that argument about all of the wedge parts.  I think a wedge version of the Mk 16 parachute would be really handy.

Hm, might work. We'll have a think about it! 

On 2/19/2019 at 3:15 AM, Zorg said:

Back at KSP after a bit of break, at that time US-II was still in development and I'm delighted to see the full release as I started a new GPP game. I usually play with USI life support but all the US-II parts for TAC LS made me try that out instead.

Just want to say thank you for the fantastic work to the devs!

You're very welcome! 

On 2/20/2019 at 10:07 AM, Eugene Moreau said:

What happened the wedges for the 2hot/presmat and gravmax/seismic sensors?  I can't find them for the life of me.  will they be coming back?

Maybe ;) 

On 2/22/2019 at 8:41 AM, Zorg said:

One more post from me on US2 and BDB synergy...

Amazing craft, wow. Makes me want to play the game again :P

Share this post


Link to post
Share on other sites

I'm experiencing a glitch where module manager is telling me I have an old version, but the installed version from ckan says it's 1.6.0.9, but the module manager says its 1.5.1.9

Share this post


Link to post
Share on other sites
4 hours ago, Trulight said:

I'm experiencing a glitch where module manager is telling me I have an old version, but the installed version from ckan says it's 1.6.0.9, but the module manager says its 1.5.1.9

Look back through the posts on this forum. It's a known issue, you can ignore it and it will be fixed in the next release.

It has no impact on the mod.

Share this post


Link to post
Share on other sites
6 hours ago, Daishi said:

fairing shells like you'd get in the stock game? How do you mean? How short is short?

1) No, just those things you already have thiere just without the bottom, as MH structural tubes, to allow mounting engines.

2) BDB short. The one you already have there is exactly the same height as BDB Gemini service module, but nothing to be as long as the short BDB Gemini service module.

p.s the gemini service module you have here has debug lines not disabled

p.p.s the wedged fuel tank is not 9lf/11ox

Edited by Gapone

Share this post


Link to post
Share on other sites
On 2/23/2019 at 5:45 PM, webward said:

If anyone using USI LS has noticed that the Universal Storage: Recycling Module part doesn't appear to be working, I've put up a gist with a modified config that appears to resolve the issue, the file that you want to modify is "KSPRoot\GameData\UniversalStorage2\Parts\Processors\WaterPurifier.cfg": https://gist.github.com/w3bward/30f281b50234b747dc5d3bdabef82bdc

Tried to replace that file with yours. But the purifier still does nothing :(

 

Ideas?

Share this post


Link to post
Share on other sites

There aren't localization tags in the USACD1500 config

Edited by flart

Share this post


Link to post
Share on other sites

AVC tells me there is a new version even after updating. I think there is a mistake in the version numbler file, can you check it please ? =)
(tested CKAN and manually installs)

Share this post


Link to post
Share on other sites

The last mention of this is not 10 posts up. It is known. It doesn't keep the mod from functioning in any way. It only tells you the mod isn't current when it actually is. If it really bothers you, just edit the .version file to the correct current version.

Share this post


Link to post
Share on other sites
On 2/26/2019 at 1:04 PM, Daishi said:

I'm a little crazy like that

Soo.. fairing shells like you'd get in the stock game? How do you mean? How short is short? 

Sure! What language could you provide? :)

Hm, might work. We'll have a think about it! 

You're very welcome! 

Maybe ;) 

Amazing craft, wow. Makes me want to play the game again :P

@DaishiIt's great! Russian. So, i get to work. What do you prefer: receive the file through it on Google.Disk or in GitHab (but i don't find link)?

Share this post


Link to post
Share on other sites
12 hours ago, Giraffe said:

@DaishiIt's great! Russian. So, i get to work. What do you prefer: receive the file through it on Google.Disk or in GitHab (but i don't find link)?

Awesome! Pop @Paul Kingtiger a private message on here, he'll be able to tell you what's needed :)

Share this post


Link to post
Share on other sites

Any chance of a variant of the 1.875-1.5m Gemini service module that doesn't have all the struts on the inside and is open at the top? I'd love to be able to have a solid retro pack nestled in the top of the SM (similar to the real Gemini) but at the moment it just gets caught when you decouple the SM.

Even better would be a two-piece Gemini SM, so you can decouple the bottom parts to reveal the retros.

Share this post


Link to post
Share on other sites

@Paul Kingtiger hello

are you sure the Elektron is working?

i just found way its not working

not working

                 INPUT_RESOURCE
                 {
                    ResourceName = water
                    Ratio = 0.003856
                    FlowMode = STAGE_PRIORITY_FLOW
                 }

 

after correcting to 

                 INPUT_RESOURCE
                 {
                    ResourceName = Water
                    Ratio = 0.003856
                    FlowMode = STAGE_PRIORITY_FLOW
                 }

it is working

Share this post


Link to post
Share on other sites
On 3/4/2019 at 3:13 AM, Daedalus451 said:

Any chance of a variant of the 1.875-1.5m Gemini service module that doesn't have all the struts on the inside and is open at the top? I'd love to be able to have a solid retro pack nestled in the top of the SM (similar to the real Gemini) but at the moment it just gets caught when you decouple the SM.

Even better would be a two-piece Gemini SM, so you can decouple the bottom parts to reveal the retros.

I'll see what i can throw together, the second option might work with a part variant. 

4 hours ago, danielboro said:

@Paul Kingtiger hello

are you sure the Elektron is working?

i just found way its not working

not working

                 INPUT_RESOURCE
                 {
                    ResourceName = water
                    Ratio = 0.003856
                    FlowMode = STAGE_PRIORITY_FLOW
                 }

 

after correcting to 

                 INPUT_RESOURCE
                 {
                    ResourceName = Water
                    Ratio = 0.003856
                    FlowMode = STAGE_PRIORITY_FLOW
                 }

it is working

I'm sure that got fixed... hrm

Share this post


Link to post
Share on other sites
On 3/6/2019 at 7:36 AM, Daishi said:

I'm sure that got fixed... hrm

it was

i had a look at the version i have installed in KSP 1.4.1 and it is the fixed version

and 

old version

                 OUTPUT_RESOURCE
                 {
                    ResourceName = Hydrogen
                    Ratio = 4.7936
                    DumpExcess = false
                    FlowMode = STAGE_PRIORITY_FLOW
                 }

new version for 1.6.1

                 OUTPUT_RESOURCE
                 {
                    ResourceName = Hydrogen
                    Ratio = 4.7936
                    DumpExcess = false
                 }

missing FlowMode?

Edited by danielboro

Share this post


Link to post
Share on other sites

Beta version release Universal Storage II Mk.10

We have a beta version avalable in the OneDrive folder https://1drv.ms/f/s!AvmqbLkW8UIH2PsfIYBmSwhNfYG-pw

  • 1.6.0.10.zip for KSP 1.4 and later
  • 1.3.1.10.zip for KSP 1.3.1

 

New features

New Science parts

  • Universal Storage: Atmospheric Science Unit
  • Universal Storage: Advanced Material Bay
  • Universal Storage: Advanced Goo Unit
  • Universal Storage: Atmospheric Fluid Spectro Variometer
  • Universal Storage: Physical Science Unit

Bug fixes

  • 16: Bug: Part jittering caused by PEM fuel cell when attached to to a Quad core.
  • 14: Bug: Broken localization for #autoLOC_US_Toggle Primary Bays in Tapered fairing 1.5m to 1.875m
  • 18: Bug: Out of date VERSION field in KSP-AVC file
  • Added FlowMode to all ModuleResourceConverter outputs
  • Added localization for Universal Storage: ACD (1.5m)

 

I plan to push this out to SpaceDock and general release in a couple of weeks, in the meantime feedback and bug reports are very much appreciated. 

 

Edited by Paul Kingtiger

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.