Paul Kingtiger

Universal Storage II [1.3.1 and 1.4.5 - 1.7.0]

Recommended Posts

46 minutes ago, Arcurador said:

I'm having an issue with the Universal Storage science experiments. They no longer seem to exist. I can only find the original game versions of the experiments. I downloaded US2 from Ckan but not the original US. It looks as though it isn't compatible anymore. Did I miss something or forget to do something? I'm kinda new to this lol. 

The stock science parts got remade recently, so they're almost ready to be released in the next update and aren't in CKAN yet. They have a bit more functionality than stock, so naturally we're still working out a few bugs :) If you're happy to help us test them there are Beta releases a few posts above this in Paul's Onedrive.

9 hours ago, infinite_monkey said:

I'm having trouble with a contract that demands having a Magnetometer Boom and a RPWS Antenna on board. The contract doesn't seem to recognize the parts from Universal Storage II.

We'll have a look :)

Share this post


Link to post
Share on other sites

 

15 hours ago, infinite_monkey said:

I'm having trouble with a contract that demands having a Magnetometer Boom and a RPWS Antenna on board. The contract doesn't seem to recognize the parts from Universal Storage II.

It happend to me yesterday, that the whole part and the wedge part are not the same for the contract system.

Share this post


Link to post
Share on other sites
3 hours ago, Tacombel said:

 

It happend to me yesterday, that the whole part and the wedge part are not the same for the contract system.

Should have a fix for that tonight.

Share this post


Link to post
Share on other sites

A note for people waiting for the fix:

Parts needed for the contract are written to the save file at contract acceptance.  So any fix will only affect *future* contracts, not ones you've already accepted.   (Unless you edit the save file.)  I've seen this catch a few people out in the past.  ;)

Share this post


Link to post
Share on other sites

Thx, Kingtiger. It wasn't a request, but thank you all the same.

21 hours ago, infinite_monkey said:

I'm having trouble with a contract that demands having a Magnetometer Boom and a RPWS Antenna on board. The contract doesn't seem to recognize the parts from Universal Storage II.

It happend to me yesterday, that the whole part and the wedge part are not the same for the contract system.

Share this post


Link to post
Share on other sites
13 hours ago, Daishi said:

The stock science parts got remade recently, so they're almost ready to be released in the next update and aren't in CKAN yet. They have a bit more functionality than stock, so naturally we're still working out a few bugs :) If you're happy to help us test them there are Beta releases a few posts above this in Paul's Onedrive.

We'll have a look :)

Thank you for the quick response. I would LOVE to help you test them out, unfortunately I'm about to head to an area of the world where internet is very limited. All the US parts will probably be released and bug free by the time I am able to connect again. :)  And I have to say, you guys are doing some AMAZING work with these parts. You guys took your great concept of the first Universal Storage parts and are continuously going above and beyond with your new creations. Thank you guy for doing such an awesome job!

Share this post


Link to post
Share on other sites

The H

1 hour ago, Arcurador said:

I would LOVE to help you test them out, unfortunately I'm about to head to an area of the world where internet is very limited. All the US parts will probably be released and bug free by the time I am able to connect again.

We could always send you the updates on a USB stick via carrier pigeon or hot air balloon...  is there at least electricity where you're going?

Share this post


Link to post
Share on other sites

lol yes there is. But I'll be moving around in Africa so I have no idea when I'll find some internet. 

Share this post


Link to post
Share on other sites

Pushed an update to the Beta release.

  • Science contracts should now work (please let me know if they don't)
  • Removed the solar panel function in the 2.5m fairing (this will be saved for a later release).
  • Fixed some localization issues

The beta is now in a feature freeze.  We won't be adding any new parts or functions to this update (now called, Universal Storage II - Science Pack)

We will continue to work on bug fixes in preperation for releasing on Space dock and CKAN as Universal Storage II 1.6.0.10

Share this post


Link to post
Share on other sites

Found a possible bug in the Elecktron module.  It appears to have the Hydrogen and Oxygen levels reversed.   The PEM and Alkaline cell modules seem to have the correct ratios.

3LdLbfm.png

Share this post


Link to post
Share on other sites
3 hours ago, Chilkoot said:

Found a possible bug in the Elecktron module.  It appears to have the Hydrogen and Oxygen levels reversed.   The PEM and Alkaline cell modules seem to have the correct ratios.

Thank you, fix pushed to beta.

Share this post


Link to post
Share on other sites
On 3/17/2019 at 3:44 AM, Paul Kingtiger said:

It was designed to be compatable with exsisting craft so that's a bug, we'll look into it.

In the meantime, the original part is in the download under GameData\UniversalStorage2\Parts\Shrouds\CylindricalShroud250.zip so you can swap them out to fix the issue while we work on it.

The four bay core is physicsless in the current beta so it can't compress and cause this issue.  In GameData\UniversalStorage2\Parts\Structural check US_Quad.cfg in notepad and check it has the following line:
If it doesn't then you're not on the latest beta version (you can manually enter the line in your install to fix the issue.  If you do have the line and it's compressing then another mod must be conflicting with the build or I don't know what's going on.

himage.png

I'll check this later and inform.

Share this post


Link to post
Share on other sites
Posted (edited)

Thanks @Paul Kingtiger, the parts on new vessels are now accepted by the contracts.

On 3/18/2019 at 3:03 PM, DStaal said:

A note for people waiting for the fix:

Parts needed for the contract are written to the save file at contract acceptance.  So any fix will only affect *future* contracts, not ones you've already accepted.   (Unless you edit the save file.)  I've seen this catch a few people out in the past.  ;)

Does someone happen to know what I need to change in the save file? Nevermind, I found it out. I changed it for one of the 2 contracts (added the new names), and somehow the other one worked as well.

Edited by infinite_monkey

Share this post


Link to post
Share on other sites
On 3/19/2019 at 7:22 AM, FellipeC said:

I'll check this later and inform.

Worked! Thanks!

Share this post


Link to post
Share on other sites
Posted (edited)

Not sure if mentioned, but the solar panels in the hatches don’t seem to work. Messed with it, but I can’t figure it out. Am I missing something?  Thanks.

 

Edit:  Never mind. Saw above post saying it was saved for later release.

(Guess reading the posts helps...) ;)

Edited by Fr8monkey

Share this post


Link to post
Share on other sites

A thought that occured to me on an EVA.  I love that the new EVA-X has an antenna, but how do I use it?  The backpack doesn't appear to have a battery, so a kerbonaut using the pack can't actually transmit anything with it.

Share this post


Link to post
Share on other sites

Another thing I’ve noticed is even with a scientist on your craft, the science experiments aren’t resetting themselves. 

Share this post


Link to post
Share on other sites
3 hours ago, Capt. Hunt said:

A thought that occured to me on an EVA.  I love that the new EVA-X has an antenna, but how do I use it?  The backpack doesn't appear to have a battery, so a kerbonaut using the pack can't actually transmit anything with it.

Looks like an oversight on our part - we had set the pack to have more EC when lifesupport mods were installed, but never set a baseline amount for a standalone install with KIS. We'll patch that asap :)

3 hours ago, Fr8monkey said:

Another thing I’ve noticed is even with a scientist on your craft, the science experiments aren’t resetting themselves. 

We'll take a look. 

Share this post


Link to post
Share on other sites
Posted (edited)

Pushed a small update to the Beta, just the evaX has been changed.

It now has Electric Charge without a life support mod having to be installed.

eva-X-Rebalance.png

Edited by Paul Kingtiger

Share this post


Link to post
Share on other sites

@Paul Kingtiger, not sure if its been mentioned yet or not but the version file hosted on the AVC site references the latest version as v1.6.0.9 http://ksp-avc.cybutek.net/version.php?id=591 but the .version file bundled in the latest downloadable release states the mod as v1.5.1.9.

Not an issue as so far as KSP-AVC pops up the dialog box every start telling you that there's a new version of the mod when in fact there is not.

Share this post


Link to post
Share on other sites
Posted (edited)
26 minutes ago, Poodmund said:

@Paul Kingtiger, not sure if its been mentioned yet...

Fixed in the current beta release (see the first post for details).

For a full list of issues and their status (what's fixed and what's being worked on) you can check out Bitbucket issue tracker:
https://bitbucket.org/uvs2/universalstorage2/issues?&sort=-id

Edited by Paul Kingtiger

Share this post


Link to post
Share on other sites

Resource-containing parts like battery, tanks, etc, don't show resource amount/capacity in description in VAB. Also, after attachment their actual mass is different from part description (example: H2 tank, mass in description 0.165 t, mass in part info (dry) - 0.33 t).

Share this post


Link to post
Share on other sites
13 minutes ago, Mystique said:

Resource-containing parts like battery, tanks, etc, don't show resource amount/capacity in description in VAB. Also, after attachment their actual mass is different from part description (example: H2 tank, mass in description 0.165 t, mass in part info (dry) - 0.33 t).

What version of KSP and Universal Storage are you using?

Share this post


Link to post
Share on other sites
Posted (edited)
1 hour ago, Paul Kingtiger said:

What version of KSP and Universal Storage are you using?

US II 1.6.0.9 from CKAN, KSP 1.6.1.2401.

BTW, seems like version file both in space dock and in CKAN is not updated with "1.6.0.9" version number.

Edited by Mystique

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.