Paul Kingtiger

Universal Storage II [1.3.1 and 1.4.5 - 1.7.0]

Recommended Posts

1 minute ago, EasyAce said:

Yes, I've passed advanced construction and do find the US2 minituized material bay under miniturization. I also have the first US2 fairings. But they are useless without the core.

I would suggest a bad installation.  Have you tried uninstalling and reinstalling the appropriate version?  What KSP and USII versions are you running?

Share this post


Link to post
Share on other sites
1 minute ago, Brigadier said:

I would suggest a bad installation.  Have you tried uninstalling and reinstalling the appropriate version?  What KSP and USII versions are you running?

1.7.0.2483 for KSP

1.7.0.10 for USII.

 

I'll try a fresh install. Guess there are some other mods messing things up. Thanks anyway.

Share this post


Link to post
Share on other sites
Posted (edited)
2 minutes ago, EasyAce said:

1.7.0.2483 for KSP

1.7.0.10 for USII.

 

I'll try a fresh install. Guess there are some other mods messing things up. Thanks anyway.

If that doesn't work out, try replicating the missing parts with just KSP and USII (+ dependencies).  Add your other mods until the problem reappears.

Edited by Brigadier

Share this post


Link to post
Share on other sites
On ‎5‎/‎6‎/‎2019 at 8:06 AM, lordcirth said:

What I am doing wrong here? The Cylindrical Fairing does not clear the Advanced Material Bay wedge's door when open. Or is it normal to just not use a fairing for these parts?o6deCeE.png

In that situation, you'd want to toggle the door off in the right click menu. There wasn't really any other way I could see to get the Mat bay to fit in the smaller diameter fairing :) 

Share this post


Link to post
Share on other sites
5 hours ago, Daishi said:

In that situation, you'd want to toggle the door off in the right click menu. There wasn't really any other way I could see to get the Mat bay to fit in the smaller diameter fairing :) 

Ah, I see! Currently the Kerbalism Alpha is breaking the animations, so I didn't have that button. That makes sense, though. Thanks!

Share this post


Link to post
Share on other sites
Posted (edited)
On 5/4/2019 at 10:53 AM, DMagic said:

Anyone have more details on this problem? Is the problem collecting data from the part? Or resetting the part after collecting data? Or collecting data after resetting the part? All of the above?

Do the options for collecting or resetting the part appear in the right click menu? Do any screen messages appear related to this?

I thought I was the only one running into this issue, but looks like several others are experiencing similar.

For me, I can run the experiment, open/close the doors, and the experiment will be collected (at least, I think so) when the vessel is recovered. But with a Scientist in front of it, there's no option to collect the data and Reset the experiment from the right click menu. I also don't believe it's allowing for a Transfer function, or being collected from command pods or science storage (which, I think that's intended functionality).

If you try to run the experiment when it's "full", the only messages on screen are orange saying it can't run. Let me get in game and I'll try troubleshooting more specifically.

Edited by scottadges

Share this post


Link to post
Share on other sites

@scottadges Are you, or anyone else with this problem, using any of the science helper mods, like XScience, For Science, etc...? Or Kerbalism?

All of these functions work fine for me, so it's a little hard to figure out what's going on.

Share this post


Link to post
Share on other sites
Posted (edited)
1 hour ago, DMagic said:

using any of the science helper mods, like XScience,

Yes, I'm using [X] Science but neither of the others you mentioned.

I'm still working on getting my science probe back to the Mun (where I need science for my Career game) so I'll test later tonight and send along a log as well.

In the meantime, here's my modlist from CKAN:

Spoiler

Flight Manager for Reusable Stages (FMRS) Continued (FMRSContinued 1.2.7.4)
[x] Science! Continued (xScienceContinued 5.21)
Action Groups Extended (AGExt 1:2.3.4)
Airplane Plus (AirplanePlus 26.1)
Astronomer's Visual Pack (AstronomersVisualPack 1:3.7.4.0)
Astronomer's Visual Pack-2k Textures (AVP-2kTextures v1.7)
Automated Screenshots & Saves (AutomatedScreenshots 0.8.4.3)
B9 Part Switch (B9PartSwitch v2.7.1)
BetterCrewAssignment (BetterCrewAssignment 1.3.2)
BetterTimeWarpContinued (BetterTimeWarpCont 2.3.11.3)
ClickThrough Blocker (ClickThroughBlocker 0.1.7.1)
CollisionFX-Updated (CollisionFXUpdated 0.8.3.1.1)
CommNet Constellation (CommNetConstellation 1.3.2)
Community Category Kit (CommunityCategoryKit 4.1.0.0)
Community Resource Pack (CommunityResourcePack 1.1.0.0)
Community Tech Tree (CommunityTechTree 1:3.3.7)
Community Terrain Texture Pack (CommunityTerrainTexturePack 1:1.0.4)
Community Trait Icons (CommunityTraitIcons v1.1.1)
Contract Configurator (ContractConfigurator 1.27.1)
Contract Pack: Bases and Stations Reborn (ContractConfigurator-KerbinSpaceStation 2:3.7.1.4)
Contract Pack: Tourism Plus (ContractConfigurator-Tourism 1.5.2)
Contract Parser (ContractParser 8.0)
Contracts Window + (ContractsWindowPlus 9.2)
Craft Manager (CraftManager 1.1.5)
Decoupler Shroud (DecouplerShroud 0.6.1)
Deployable Engines Plugin (DeployableEngines 1.0.1)
Distant Object Enhancement (DistantObject v1.9.1.1)
Distant Object Enhancement default config (DistantObject-default v1.9.1.1)
DMagic Orbital Science (DMagicOrbitalScience 1.4.2)
Docking Port Alignment Indicator (DockingPortAlignmentIndicator 6.8.3)
Draggable Altimeter (DraggableAltimeter v1.0.1)
Draggable Navball (DraggableNavball v1.0.1)
Dynamic Battery Storage (DynamicBatteryStorage 2:1.4.2.0)
Easy Vessel Switch (EVS) (EasyVesselSwitch 1.11)
Editor Extensions Redux (EditorExtensionsRedux 3.3.20)
Environmental Visual Enhancements (EnvironmentalVisualEnhancements 2:EVE-1.4.2-2)
Feline Utility Rovers (FelineUtilityRovers 1.2.10)
Firespitter Core (FirespitterCore v7.12.0)
Firespitter Resources config (FirespitterResourcesConfig v7.12.0)
Hangar Extender (HangerExtenderExtended 3.5.3.5)
Heat Control (HeatControl 0.4.11)
Hide Empty Tech Tree Nodes (HideEmptyTechNodes 1.1.1)
HyperEdit (HyperEdit 1.5.8.0)
Interstellar Fuel Switch (InterstellarFuelSwitch 3.8.2.4)
Interstellar Fuel Switch Core (InterstellarFuelSwitch-Core 3.8.2.4)
Keep It Straight (KeepItStraight 1.0.6)
Kerbal Alarm Clock (KerbalAlarmClock v3.10.0.0)
Kerbal Engineer Redux (KerbalEngineerRedux 1.1.6.0)
Kerbal Improved Save System (KerbalImprovedSaveSystem v2.4.0)
Kerbal Planetary Base Systems (KerbalPlanetaryBaseSystems v1.6.9)
Konstruction (Konstruction 1.1.0.0)
Kopernicus Planetary System Modifier (Kopernicus 2:release-1.7.0-1)
KS3P (KS3P V5.0)
KSP AVC (KSP-AVC 1.3.0.3)
KXAPI (KXAPI 1.1.0)
Making Less History (MakingLessHistory 1.0)
MechJeb 2 (MechJeb2 2.8.3.0)
MechJeb and Engineer for all! (MechJebForAll 1.3.0.5)
MemGraph (MemGraph 1:1.1.1.7)
Mini Airbrakes (MiniAirbrakes 1.1)
Mk2 Stockalike Expansion (Mk2Expansion 2:1.8.4.1)
Mk3 Stockalike Expansion (Mk3Expansion 1.4.8)
ModularFlightIntegrator (ModularFlightIntegrator 1.2.6.0)
Module Manager (ModuleManager 4.0.2)
MSP-3000 Material Science Pod (MSP3000 v1.1)
NavHud (NavHudRenewed 1.3.6.2)
Near Future Construction (NearFutureConstruction 1.0.6)
Near Future Electrical (NearFutureElectrical 1.0.1)
Near Future Electrical Core (NearFutureElectrical-Core 1.0.1)
Near Future IVA Props (NearFutureProps 1:0.5.1)
Near Future Launch Vehicles (NearFutureLaunchVehicles 1.1.11)
Near Future Propulsion (NearFuturePropulsion 1.1.1)
Near Future Solar (NearFutureSolar 0.8.15)
Near Future Solar Core (NearFutureSolar-Core 0.8.15)
Near Future Spacecraft (NearFutureSpacecraft 1.2.3)
Outer Planets Mod (OuterPlanetsMod 2:2.2.2)
Patch Manager (PatchManager 0.0.16.4)
PersistentRotation (PersistentRotation 1.8.5)
PlanetShine (PlanetShine 0.2.6.1)
PlanetShine - Default configuration (PlanetShine-Config-Default 0.2.6.1)
Portrait Stats (PortraitStats 17.0)
Precise Node (PreciseNode 1.2.10.2)
Progress Parser (ProgressParser 10.0)
RasterPropMonitor (RasterPropMonitor 1:v0.30.6)
RasterPropMonitor Core (RasterPropMonitor-Core 1:v0.30.6)
RCS Build Aid Continued (RCSBuildAidCont 1:0.9.7.6)
Realistic Atmospheres (RealisticAtmospheres 1.3.1)
RecoveryController (RecoveryController 0.0.3.7)
Reentry Particle Effect (ReentryParticleEffect 1.4)
ReStock (ReStock 0.1.3)
ReStock+ (ReStockPlus 0.1.3)
scatterer (Scatterer 2:v0.0540)
scatterer - default config (Scatterer-config 2:v0.0540)
scatterer - sunflare (Scatterer-sunflare 2:v0.0540)
SpaceY Expanded (SpaceY-Expanded 1.4)
SpaceY Heavy Lifters (SpaceY-Lifters 1.17.2)
Stockalike Mining Extension (StockalikeMiningExtension 0.99.3)
Stockalike Station Parts Expansion Redux (StationPartsExpansionRedux 1.2.0)
TAC Fuel Balancer (TacFuelBalancer v2.20)
TextureReplacer (TextureReplacer v3.7)
The Janitor's Closet (JanitorsCloset 0.3.5.1)
Toolbar (Toolbar 1.7.18)
Toolbar Controller (ToolbarController 1:0.1.6.20)
Tracking Station Evolved (TrackingStationEvolved 4.1)
Transfer Window Planner (TransferWindowPlanner v1.6.3.0)
TriggerAu Flags (TriggerAu-Flags v2.9.3.0)
TRP-Hire (TRPHire 0.6.9.1)
TweakScale - Rescale Everything! (TweakScale v2.4.2.0)
Tweakscale Configs for Making History (TweakscaleMakingHistoryConfigs 1.0e)
Universal Storage II (UniversalStorage2 1.7.0.10)
USI Tools (USITools 1.1.0.0)
WorldStabilizer (WorldStabilizer 0.9.4-ksp-1.6.1)

 

Edited by scottadges

Share this post


Link to post
Share on other sites
Posted (edited)
4 hours ago, DMagic said:

All of these functions work fine for me, so it's a little hard to figure out what's going on.

So I've tested this pretty well, I think, with my little Mun science lander. It's designed to specifically capture multiple Material Science using the US2 Advanced bay, which is overall a super-awesome part. Just thought I'd say that to start.

Anyway, I actually think it's working fine. I don't know if I was confused, or if maybe something was weird earlier, but after screencapping each step... it all worked smoothly. (I am in fact wondering if my issue wasn't somewhere Between the Chair and the Keyboard)

In any case, I was able to reset the experiment module with a Scientist after docking it to my Mun research station. And then re-run it after it had been restored and take the data from it, etc.

Here are the highlights (put in spoiler to avoid thread-spamming)

Spoiler

1. Running the experiment module landed on the Mun. No problems and was able to run this twice before getting "module full" notification.

0t15kg8.jpg

2. After docking the probe back to my station, the scientist is able to Collect the experiment.

UpxKstV.jpg

3. After collection, the scientist is able to Restore the bay and you see the notification on screen.

jEhmNBE.jpg

4. For testing, I ran it twice again and then restored it again.

So, as far as I can tell... all is well (at least with my setup). Sorry for any headaches!

Edited by scottadges

Share this post


Link to post
Share on other sites

Hi.

I m using USII with X sciences.

For my experience when i get sciences from x sciences for mystery goo and material, all seems ok but when coming back to kerbin, i never have science collected.

But if i do myself the experience directly with righlt click, i can collect goo/material sciences when coming back home.

Great mod ! tx for all your work.

Share this post


Link to post
Share on other sites
Posted (edited)

@Paul Kingtiger, just dropping by to say that this is an immense improvement. Your mod was a part of almost every one of my flights before I dropped out almost two years ago, and I’m happy to see my complaints reached your ears without me saying a word.

Just one minor question - is the lone wedge in the 1.25-to-0.625 fairing deliberately set off-axis? It’s pretty noticeable for single; I haven’t yet checked with the RCS Build Aid to see if the CoM is also off-center.

Edited by DDE

Share this post


Link to post
Share on other sites
12 hours ago, LTQ90 said:

Hi.

I m using USII with X sciences.

For my experience when i get sciences from x sciences for mystery goo and material, all seems ok but when coming back to kerbin, i never have science collected.

But if i do myself the experience directly with righlt click, i can collect goo/material sciences when coming back home.

Great mod ! tx for all your work.

We'll have a look, there seems to be a bit of cross-mod conflicts with these science parts.

4 hours ago, DDE said:

@Paul Kingtiger, just dropping by to say that this is an immense improvement. Your mod was a part of almost every one of my flights before I dropped out almost two years ago, and I’m happy to see my complaints reached your ears without me saying a word.

Just one minor question - is the lone wedge in the 1.25-to-0.625 fairing deliberately set off-axis? It’s pretty noticeable for single; I haven’t yet checked with the RCS Build Aid to see if the CoM is also off-center.

Only way it could fit within that profile was to mount it slightly off center, so most likely :)

Share this post


Link to post
Share on other sites
4 hours ago, Daishi said:

Only way it could fit within that profile was to mount it slightly off center, so most likely :)

If you're having trouble with COM issues, you can fit water wedges and adjust the payload to move the COM to where it's needed.
I guess you could do the same with fuel wedges and have a useful resource as well as a balanced rocket.

Share this post


Link to post
Share on other sites

Hi! I have a fixed English localization fixed (there were minor errors in the file "en-us.cfg). And as did the Russian localization of the mod. How can I get them to you?

Share this post


Link to post
Share on other sites
6 hours ago, Sooll3 said:

Hi! I have a fixed English localization fixed (there were minor errors in the file "en-us.cfg). And as did the Russian localization of the mod. How can I get them to you?

That's great, thank you, there is a link in my sig which will show you how to submit localization updates.

Share this post


Link to post
Share on other sites

I'm having trouble getting the doors on the 2.5m cylindrical fairing to line up the wedges on the 6 bay core. Any ideas?

Share this post


Link to post
Share on other sites
Posted (edited)
2 hours ago, dlrk said:

I'm having trouble getting the doors on the 2.5m cylindrical fairing to line up the wedges on the 6 bay core. Any ideas?

I wouldn't expect it to? The 2.5 meter fairing is intended for the 8 bay core. 

The 6 bay core fits the tapered 1.875 to 2.5m Gemini style fairing and presumably a 1.875m cylindrical bay that might come in a future update. 

Edited by Zorg

Share this post


Link to post
Share on other sites
23 minutes ago, Zorg said:

... presumably a 1.875m cylindrical bay that might come in a future update. 

I think I'm legitimately more excited about this appearing in the future than the Breaking Ground DLC... and I am looking forward to that.

Share this post


Link to post
Share on other sites
Posted (edited)
On 5/8/2019 at 9:55 PM, Daishi said:

We'll have a look, there seems to be a bit of cross-mod conflicts with these science parts.

Hey there, I'm back with maybe another version of this issue where you can't collect the science from the Advanced bay. If you remember, I did a bunch of testing the other day and all worked well. But now, while on my Minmus expedition, I can't collect the science from the Advanced Materials bay.

So I think there's something else going on here. Have any ideas?

Here's the copy of the log: KSP Log 051119 T1444.log

I did find (presumably) where I ran the DM/US2 science modules via [X] Science the first time in this location:

[LOG 14:15:50.371] [5/11/2019 2:15:50 PM [x] Science!]: <Trace> (StatusWindow) - Finding Module for Science Report: dmImagingPlatform
[LOG 14:15:50.439] [5/11/2019 2:15:50 PM [x] Science!]: <Trace> (StatusWindow) - Running DMModuleScienceAnimates Experiment dmImagingPlatform on part dmUS2ImagingPlatform
[LOG 14:15:58.040] [5/11/2019 2:15:58 PM [x] Science!]: <Trace> (StatusWindow) - Finding Module for Science Report: mysteryGoo
[LOG 14:15:58.041] [5/11/2019 2:15:58 PM [x] Science!]: <Trace> (StatusWindow) - Running Experiment mysteryGoo on part USGooBayWedge
[LOG 14:15:58.042] [Experiments]: Setting FX Modules to 1...
[LOG 14:15:58.042] [Experiments]: FX Modules set: 1
[LOG 14:16:04.756] [5/11/2019 2:16:04 PM [x] Science!]: <Trace> (StatusWindow) - Finding Module for Science Report: dmSolarParticles
[LOG 14:16:04.756] [5/11/2019 2:16:04 PM [x] Science!]: <Trace> (StatusWindow) - Running DMModuleScienceAnimates Experiment dmSolarParticles on part dmUS2SolarParticles
[LOG 14:16:12.534] [5/11/2019 2:16:12 PM [x] Science!]: <Trace> (StatusWindow) - Finding Module for Science Report: mobileMaterialsLab
[LOG 14:16:12.534] [5/11/2019 2:16:12 PM [x] Science!]: <Trace> (StatusWindow) - Running Experiment mobileMaterialsLab on part USMatBayWedge

Starts at Line 116847 through 116859 of the log (a couple extraneous Kopernicus entries removed).

Here are some screenshots to illustrate what this looked like when I couldn't collect the data. Notice that I don't have the option to Collect from the right-click menu.

When I did my testing before and WAS able to see Collect as an option, I think I maybe was running it manually instead of [X] Science? I also WAS able to collect the Solar Particles and other wedge science which was run via [X] Science.

1. Here's Bob getting out to collect the Advanced Materials science, because it wasn't collecting into the Science Storage, so he go out to check if it needed restoring.

trZq7z5.jpg

2. Tried running it again manually from Observe Materials Bay, and you can see it shows one more available (since after this it would be inoperable)

hnpoHYO.jpg

You can also see that [X] Science is showing at least one Materials Study captured. But the dialog box shown is from running it manually. Also there was no Materials Science in the science storage box when using the Collect All button on the box.

 

Edited by scottadges

Share this post


Link to post
Share on other sites
Posted (edited)

UPDATE 19:34 CST - Ignore what I wrote below in this post, as far as surface attached being a theory, although maybe that's an interesting aside. :confused:

Doing some more thorough and specific testing in a clean KSP 1.7 install with only Universal Storage 2 (v1.1.7.10) and then having [X] Science installed/not installed using a basic "testbed".

Here's what I ended up with:

  1. With [X] Science installed, and you run the AMB experiment via the mod, you then can't Collect the data or Restore the bay
  2. With [X] Science installed, if you run the experiment manually, you can Collect and Restore normally
  3. With [X Science NOT installed, of course everything runs normally

The reason why there are three setups is I was seeing if there were differences with A. Surface Attached, B. Fairing Attached with Door, and C. Fairing Attached No Door.

Findings:

With [X] Science installed, there are no options to Collect or Restore after all AMBs in this scenario were run using [X] Science. In this case, the scientist is on board the testbed, but the same applies when on EVA. Also notice that there is no option on the science storage box to Collect All data. 

ze1tZgr.jpg

2. Without [X] Science installed, everything works normally. The scientist can Collect, Restore, The AMBs can Transfer Data to a container and the container itself shows the Collect All. Same applies to EVA, the scientist can Collect, Restore, and then re-run any of the AMBs.
JfdOvcW.jpg

 

I have more screenshots of these steps which I can provide if necessary, but rather than spam this thread any longer, I can provide those if you feel you need extra info.

Previous comments RE: surface attachment...

Spoiler

==============

After my Orbiter/Science lander got to Minmus, I realized I could test another scenario: The Advanced Materials bay attached to a craft OUTSIDE of the fairing/bay. Maybe that has something to do with it? (you tell me, I dunno if that's even a possibility)

As you can see from the images, Bob on EVA was able to Run, Collect, and Restore from the Advanced Materials bay that is surface attached to the lander. The other AMB (in that fairing docked to the orbiter above), I'm not able to do any of these actions.

I should also mention, I was activating this AMB manually. I don't believe this one was run by [X] Science, since I did NOT see the lines below in my T1658 log vs. the T1444 log which did have these lines:


[x] Science!]: <Trace> (StatusWindow) - Finding Module for Science Report: mobileMaterialsLab
[x] Science!]: <Trace> (StatusWindow) - Running Experiment mobileMaterialsLab on part USMatBayWedge

1BVDIMg.jpg

1UXQaHv.jpg

I should also mention, I was activating this AMB manually. I don't believe this one was run by [X] Science, since I did NOT see the lines below in my T1658 log vs. the T1444 log which did have these lines:


[x] Science!]: <Trace> (StatusWindow) - Finding Module for Science Report: mobileMaterialsLab
[x] Science!]: <Trace> (StatusWindow) - Running Experiment mobileMaterialsLab on part USMatBayWedge

Finally, if it helps, I've also attached the latest log: KSP Log 051119 T1658.log

So maybe the surface attachment outside of a fairing/bay is or isn't related? Or maybe the [X] Science compatibility is the real culprit? Good luck troubleshooting and thanks as always for all your hard work!

 

Edited by scottadges

Share this post


Link to post
Share on other sites

@scottadges Thanks for looking into that. I'm fairly certain the problem is XScience (I think Automated Science something something and For Science would also have the same problem).

It's also telling that I've never heard any reports of issues with the other US science parts, the thermometer, barometer, etc... Those also use a custom science module, but not one that would have this particular problem when used in conjunction with science management mods.

You'll notice those "Running DMScienceAnimate" lines in the log, referring to DMagic Orbital Science experiments, both XScience and Automated whatever have explicit support for running DMagic Orbital Science and DMScienceAnimateGeneric (which is used by a lot of other mods) experiments (For Science does not have this support, which is why it is marked as incompatible with DMOS). But they don't have that kind of support for any random experiment that changes the science behavior like these do (they mostly have custom behavior in managing multiple samples for the same part).

I'm pretty sure that Science Alert would handle this correctly, as it does this the right way: https://github.com/linuxgurugamer/ScienceAlert/blob/master/Source/ScienceAlert.Experiments/ExperimentObserver.cs#L284-L288

So the simplest solution would be do these experiments manually and bug whoever is maintaining XScience to change its behavior when it deploys the experiment. It should, theoretically, be a simple thing to change, and I think it's something I've brought up before, but all of those science mods tend to pass through multiple different maintainers and developers.

Share this post


Link to post
Share on other sites
Posted (edited)
10 minutes ago, DMagic said:

the simplest solution would be do these experiments manually

Thanks @DMagic, I appreciate your comments. You replied just as I was re-editing my earlier post to clarify my further testing (see the previous post for further reference.

But yes, it looks like [X] Science is what's going on here. I notice that @Flupster has taken over the dev on that, so I'll post a comment in that thread as well and reference this conversation.

Also, it doesn't seem to be causing any problems with the other wedge experiments (or at least, I haven't tested them as specifically). And I haven't had problems with your other amazing science parts when running [X] Science. Although... I should probably do a more thorough testing of the standard Dmagic parts for all the [X] Science folks!  :0.0:

Edited by scottadges

Share this post


Link to post
Share on other sites

[X] Science has historically had a problematic relationship with DMagic ScienceAnimate experiments. There are several in ProbesPlus that exhibit this behavior as well. If run from [X] Science, they bork and stay that way. If run manually, they work.

Share this post


Link to post
Share on other sites

I've had a look but can't find it in the FAQ o othe notes - if I 'lock' a fairing in the VAB does that mean it cannot be opened at all in orbit? 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.