Paul Kingtiger

Universal Storage II [1.3.1 and 1.4.5 - 1.7.0]

Recommended Posts

2 hours ago, meeware said:

I've had a look but can't find it in the FAQ o othe notes - if I 'lock' a fairing in the VAB does that mean it cannot be opened at all in orbit? 

Yep, the button to open/close the shroud won't be there in flight.

Share this post


Link to post
Share on other sites

Ah ok, feared as much.... time for a roll back to earlier save (shame, it was such a lovely space station too). Did I miss something in the documentation?

Share this post


Link to post
Share on other sites
2 hours ago, meeware said:

Did I miss something in the documentation?

It seems self-explanatory. What else would a "lock doors" function do but prevent them from being opened?

Share this post


Link to post
Share on other sites
Posted (edited)
On 5/17/2019 at 6:25 AM, DMagic said:

It seems self-explanatory. What else would a "lock doors" function do but prevent them from being opened?

I'd say the problem is less about "why can't I open a locked door?" and more "why can't I unlock a locked door?". I learned what locking the bay doors does the hard way too. 

And yes, I do get that having the "lock/unlock" options accessible in flight would be redundant. I frankly had no idea what those options were there for, and ended up doing a bit of science to try and find out. 

FWIW, it might be useful to allow for a Kerbal on EVA to lock and unlock the payload doors in flight, depending mainly if it's as easy to do on your guys' end as I'm hoping it is.

Edited by TBenz

Share this post


Link to post
Share on other sites

If anyone cares for my two cents on this, I'd prefer that it stay how it is.  I intentionally lock bays occasionally if they don't have anything that I need to access in flight, like batteries.  I like the aesthetic and it's nice to only have the correct bays available to open.

Share this post


Link to post
Share on other sites
Posted (edited)

I'm sure this is an often asked question but does anyone know what is causing this graphical issue? It seems to be the merging of all variants into one image, thus it flickers as well 

 

Spoiler

QV8HICA.png

Perhaps something to do with b9 part switch? I've had the bug consistently over 3 modded installs

 

Also I had an idea: US2 compatible solar panels could be cool.

Edited by Boamere

Share this post


Link to post
Share on other sites
7 hours ago, Boamere said:

I'm sure this is an often asked question but does anyone know what is causing this graphical issue? It seems to be the merging of all variants into one image, thus it flickers as well 

Perhaps something to do with b9 part switch? I've had the bug consistently over 3 modded installs

Also I had an idea: US2 compatible solar panels could be cool.

Are you on the latest version of Universal Storage?  I had the same issue with the previous version (and didn't have B9 part switch) but it should be fixed now

Solar panels are currently in development!

Share this post


Link to post
Share on other sites
Posted (edited)
On 5/22/2019 at 12:00 PM, Paul Kingtiger said:

Are you on the latest version of Universal Storage?  I had the same issue with the previous version (and didn't have B9 part switch) but it should be fixed now

Solar panels are currently in development!

I have reinstalled the most recent version and reapplied the patch from the onedrive, and it is still occurring. 

I'm going to copy my KSP root and delete every other mod and see if it still happens.

Edit: It isn't happening, even with part switch installed. I'm going to try some mod combinations

Edit 2: It appears to be "Filter Extensions" causing the issue. Should I post this there?

 

(also that's sick, maybe a US2 RTG as well? Although that could be OP)

Edited by Boamere

Share this post


Link to post
Share on other sites
Posted (edited)

I found some encoding issue again, in GameData\UniversalStorage2\TexturesUnlimited.cfg

Log says:

ERROR: Could not locate model: UniversalStorage2/Parts/Control/ACDMedium while applying KSP_MODEL_SHADER with name of: UNKNOWN

So I deleted the invisible *nix character and saved the file, here you go:
https://www.dropbox.com/s/341rysagf2zicrq/UniversalStorage2.zip?dl=1

@Electrocutor

Edited by Gordon Dry

Share this post


Link to post
Share on other sites

If you're taking requests, any chance to get a piece (or function added to an existing piece) for science collection and storage?  I currently edited the control pod to do this and I think it works great.  The regular stock science box also wedges nicely into the thing without too much fuss, but the clipping issues can prevent you from changing out other modules.

Also, can we disable detection of the "blockages" on the covers?  Sometimes it makes sense, but other times it doesn't - such as when I have primary doors locked (and something else stuck to them or nearby) but the secondary doors still refuse to function.

Share this post


Link to post
Share on other sites
1 hour ago, PolecatEZ said:

If you're taking requests, any chance to get a piece (or function added to an existing piece) for science collection and storage?  I currently edited the control pod to do this and I think it works great.  The regular stock science box also wedges nicely into the thing without too much fuss, but the clipping issues can prevent you from changing out other modules.

Also, can we disable detection of the "blockages" on the covers?  Sometimes it makes sense, but other times it doesn't - such as when I have primary doors locked (and something else stuck to them or nearby) but the secondary doors still refuse to function.

so - add a SSD (Science Storage Device) like from Tarsier Space Technology?

that's an easy +PART MM patch. :) Just tell me which part you want the patch for.

Share this post


Link to post
Share on other sites
Posted (edited)
8 hours ago, Gordon Dry said:

I found some encoding issue again, in GameData\UniversalStorage2\TexturesUnlimited.cfg

No such file in the 1.7.0.10 or 1.3.0.10 archive available on Spacedock, as linked in the OP.

Edited by Corax

Share this post


Link to post
Share on other sites
2 hours ago, zer0Kerbal said:

so - add a SSD (Science Storage Device) like from Tarsier Space Technology?

that's an easy +PART MM patch. :) Just tell me which part you want the patch for.

Or you could re-purposed the Universal Storage MechJeb computer, which is redundant now that MechJeb is enabled for all cores by default.

Share this post


Link to post
Share on other sites
Posted (edited)
29 minutes ago, Friznit said:

Or you could re-purposed the Universal Storage MechJeb computer, which is redundant now that MechJeb is enabled for all cores by default.

@Friznit easy enough to write patch to add science - so something like this: (haven't tried it yet)

Spoiler

@PART[USGuidanceComputer]:NEEDS[UniversalStorage2]:FINAL
{
	MODULE:NEEDS[!TarsierSpaceTech]
	{
		name = ModuleScienceContainer
		reviewActionName = Review Stored Data // #autoLOC_502201 //#autoLOC_502201 = Review Stored Data
		storeActionName = Store Experiments  //#autoLOC_502202 //#autoLOC_502202 = Store Experiments
		evaOnlyStorage = True
		storageRange = 1.3
		canBeTransferredToInVessel = True
		canTransferInVessel = True
		showStatus = True
	}
	
	MODULE:NEEDS[TarsierSpaceTech]
	{
		name = TSTScienceHardDrive
		Capacity = 480
		corruption = 0.1
		powerUsage = 1.0
		fillFromEVA = true
		EVARange = 1.2
	}
	
}

// .--- ..- ... - / .- / ... ..- --. --. . ... - .. --- -. /
// --.. . .-. ----- -.- . .-. -... .- .-..
// zer0Kerbal

might also want to adjust @TechRequired = basicScience

Edited by zer0Kerbal

Share this post


Link to post
Share on other sites
3 hours ago, Corax said:

No such file in the 1.7.0.10 or 1.3.0.10 archive available on Spacedock, as linked in the OP.

File comes from:

 

Share this post


Link to post
Share on other sites
Posted (edited)
3 hours ago, zer0Kerbal said:

@Friznit easy enough to write patch to add science - so something like this: (haven't tried it yet)

  Hide contents


@PART[USGuidanceComputer]:NEEDS[UniversalStorage2]:FINAL
{
	MODULE:NEEDS[!TarsierSpaceTech]
	{
		name = ModuleScienceContainer
		reviewActionName = Review Stored Data // #autoLOC_502201 //#autoLOC_502201 = Review Stored Data
		storeActionName = Store Experiments  //#autoLOC_502202 //#autoLOC_502202 = Store Experiments
		evaOnlyStorage = True
		storageRange = 1.3
		canBeTransferredToInVessel = True
		canTransferInVessel = True
		showStatus = True
	}
	
	MODULE:NEEDS[TarsierSpaceTech]
	{
		name = TSTScienceHardDrive
		Capacity = 480
		corruption = 0.1
		powerUsage = 1.0
		fillFromEVA = true
		EVARange = 1.2
	}
	
}

// .--- ..- ... - / .- / ... ..- --. --. . ... - .. --- -. /
// --.. . .-. ----- -.- . .-. -... .- .-..
// zer0Kerbal

might also want to adjust @TechRequired = basicScience

Just the ModuleScienceContainer would be good enough, yes, that's what I edited onto the wedge.  I guess if you had TarsierSpaceTech you could also add the TSTScienceHardDrive part.

Its shows up in my game because of MJ, but that's a bit redundant because the new MJ release has a patch to add it to all command modules.  Giving that cool computery part a new (and useful..and sciency) purpose was the idea.
 

 

Edited by PolecatEZ

Share this post


Link to post
Share on other sites
1 hour ago, PolecatEZ said:

Just the ModuleScienceContainer would be good enough, yes, that's what I edited onto the wedge.  I guess if you had TarsierSpaceTech you could also add the TSTScienceHardDrive part.

Its shows up in my game because of MJ, but that's a bit redundant because the new MJ release has a patch to add it to all command modules.  Giving that cool computery part a new (and useful..and sciency) purpose was the idea.
 

 

Yep - that patch puts a stock science container in that part if TST isn't installed, and if TST is installed, then it puts a TST SSD.

Happy flying!

Share this post


Link to post
Share on other sites
2 hours ago, Paul Kingtiger said:

We already have a RTG!

I am a fool, shows how far I get with my KSP career installs before I forget and go play something else...

 

Also another question (sorry for being a pain ): How are you meant to balance the mass of the advanced material bay? Is there something that has the exact mass that I could place on the opposite side? I might just be being a goon

Share this post


Link to post
Share on other sites
On 5/1/2019 at 8:32 PM, Paul Kingtiger said:

I've pushed a fix to the Beta folder (link in my sig).  1.7.0.11  let me know how you get on.

I've witnessed some weird debug looking lines appearing on the Gemini textured 2.5m fairing with the solar panels inside.  I'm also getting the same issue with the Remote Operating System- no control is showing in the top left of the UI.  I've just double checked I'm on the latest version.  Will post logs later unless this is a know issue?

 

screenshot5.png

Share this post


Link to post
Share on other sites
1 hour ago, Boamere said:

I am a fool, shows how far I get with my KSP career installs before I forget and go play something else...

 

Also another question (sorry for being a pain ): How are you meant to balance the mass of the advanced material bay? Is there something that has the exact mass that I could place on the opposite side? I might just be being a goon

From what I can tell, the center of mass for the wedges are at the snap point node, so there's not much need to balance them as the COM is mostly center mass anyways when you link it to one of the wedge holder thingamajiggers.

Share this post


Link to post
Share on other sites
10 hours ago, Friznit said:

I've witnessed some weird debug looking lines appearing on the Gemini textured 2.5m fairing with the solar panels inside.  I'm also getting the same issue with the Remote Operating System- no control is showing in the top left of the UI.  I've just double checked I'm on the latest version.  Will post logs later unless this is a know issue?

 

screenshot5.png

Do you have the latest version installed?  The solar panels (with debug stuff) were in some of the beta builds but should not be in the current release (on Space Dock)

11 hours ago, Boamere said:

I am a fool, shows how far I get with my KSP career installs before I forget and go play something else...

 

Also another question (sorry for being a pain ): How are you meant to balance the mass of the advanced material bay? Is there something that has the exact mass that I could place on the opposite side? I might just be being a goon

If you have balance issues you can use water wedges and adjust the contents until it balances.  Generally I don't find it too much of a problem as long as the space out the heavier wedges.

Share this post


Link to post
Share on other sites
14 hours ago, Paul Kingtiger said:

Do you have the latest version installed?  The solar panels (with debug stuff) were in some of the beta builds but should not be in the current release (on Space Dock)

If you have balance issues you can use water wedges and adjust the contents until it balances.  Generally I don't find it too much of a problem as long as the space out the heavier wedges.

 

On 5/27/2019 at 11:23 PM, PolecatEZ said:

From what I can tell, the center of mass for the wedges are at the snap point node, so there's not much need to balance them as the COM is mostly center mass anyways when you link it to one of the wedge holder thingamajiggers.

Thanks guys

Share this post


Link to post
Share on other sites

Hey everyone,

Now that the expansion is out I'm working on making wedges compatible with the stock storage system.  

Getting the storage wedge to act as a cargo container should be easy, but I'm not sure if we'll be able to get wedges stored inside the storage wedge, I'll play around with it and see.

Otherwise everything should still be working with the new expansion / patch, let me know if it isn't!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.