Paul Kingtiger

Universal Storage II [1.3.1 and 1.4.5 - 1.7.0]

Recommended Posts

Another bug - if the control unit from this mod is the only probe core/control unit on a spacecraft, it a) shows up as junk on the map/tracking centre, b) on the ksp stock stage display, none of the d/vs show correctly (they all show as 0), and c) none of the manoeuvre nodes show up correctly in the flight window- they all show something like 12000 d/v requires and 1h 20m until burn time.  

None of this is actually *gamebreaking* for me, since I use MechJeb to fly my ships anyways and both Mechjeb's manoeuvre planner auto-execute and RemoteTech flight computers execute everything *correctly*, but it's still a bit of a pain and I could see it being gamebreaking for those who prefer to fly manually.  

Share this post


Link to post
Share on other sites

Hi,  

Firstly, thanks for this amazing mod, its great to be able to build more realistic command vehicles using it.  

I'm not sure if this is a bug, or deliberate behaviour, but if it is deliberate I would like to know the way around it.  

I have built a 2 stage launch stage, and have a service bay at the top of the second stage with batteries, plus a control core & RCS. The intention is to launch to LKO, and then dock the 2nd stage to a fuel depot to unload and then deorbit back using RCS.  

The problem is that when testing I don't appear to get control of the probe. I can have full throttle or zero throttle, and I can follow prograde, retrograde. The connection to the commnet in the top left hand corner is totally blank. I have checked that I have electric charge (in any case, it doesn't work from the launchpad)  I have other probes launched with the probe core on board with a different vehicle that work fine (full control, access to commnet).  

Is this expected behaviour? I have tried with a regular hecs probe attached on top of the stack and things work fine.  I'm not sure what further information if any is useful - this is my first post on this forum.  Thanks again

 

On 9/11/2019 at 2:08 PM, AstroPawian said:

Work in 1.7.3 ???

apart from my comment just above everything else seems to work fine.

Share this post


Link to post
Share on other sites
1 hour ago, Andrew Jolly said:

Hi,  

Firstly, thanks for this amazing mod, its great to be able to build more realistic command vehicles using it.  

I'm not sure if this is a bug, or deliberate behaviour, but if it is deliberate I would like to know the way around it.  

I have built a 2 stage launch stage, and have a service bay at the top of the second stage with batteries, plus a control core & RCS. The intention is to launch to LKO, and then dock the 2nd stage to a fuel depot to unload and then deorbit back using RCS.  

The problem is that when testing I don't appear to get control of the probe. I can have full throttle or zero throttle, and I can follow prograde, retrograde. The connection to the commnet in the top left hand corner is totally blank. I have checked that I have electric charge (in any case, it doesn't work from the launchpad)  I have other probes launched with the probe core on board with a different vehicle that work fine (full control, access to commnet).  

Is this expected behaviour? I have tried with a regular hecs probe attached on top of the stack and things work fine.  I'm not sure what further information if any is useful - this is my first post on this forum.  Thanks again

 

apart from my comment just above everything else seems to work fine.

 

Check to make sure the probecore (which one is it?) is set as a probe and not debris. 

If you can’t change it in the probecore PAW you should be able to change it in the Tracking Station. 

Share this post


Link to post
Share on other sites

I thinks we need an ISRU wedge set. Not being able to do ISRU with these is a missed oppurtunity. 

For all I know it could be in the works but I thought Id put it out there. 

Share this post


Link to post
Share on other sites
14 hours ago, G'th said:

I thinks we need an ISRU wedge set. Not being able to do ISRU with these is a missed oppurtunity. 

For all I know it could be in the works but I thought Id put it out there. 

It's already on the list!  Good to know there is support for it.

Share this post


Link to post
Share on other sites
2 hours ago, Paul Kingtiger said:

It's already on the list!  Good to know there is support for it.

I would love that! Since there already is a Sabatier reactor (when using Rational Resources, will that produce methane instead of liquid fuel?), it would be nice to have a part for electrolysis so we would also get hydrogen and oxygen/oxidizer.

Share this post


Link to post
Share on other sites
4 hours ago, Paul Kingtiger said:

It's already on the list!  Good to know there is support for it.

Get's my vote! &)

Share this post


Link to post
Share on other sites

My target is to be able to do Mars Direct style ISRU to collect water from the regolith and CO2 from the atmosphere to run your electrolysis and sabatier.  But once we've got the parts we can ISRU anything!

Share this post


Link to post
Share on other sites
On 8/7/2019 at 3:12 PM, Tourman said:

One thing I've noticed is the mystery goo wedge animation doesn't work. The vase that holds the goo is always extended, even if you start/stop the experiment. All other wedges work fine.

I have the same problem. Have you been able to solve it?

Edited by infinite_monkey

Share this post


Link to post
Share on other sites

Any chance decouple-able wedge probe cores are planned? The US shroud and cores would make perfect satellite buses. 

Edited by subyng

Share this post


Link to post
Share on other sites
10 hours ago, subyng said:

Any chance decouple-able wedge probe cores are planned? The US shroud and cores would make perfect satellite buses. 

Nothing planned but I'll add it to the feature request list.

Share this post


Link to post
Share on other sites
On 9/24/2019 at 6:44 PM, subyng said:

Any chance decouple-able wedge probe cores are planned? The US shroud and cores would make perfect satellite buses. 

@Paul Kingtiger I second this.  Never thought of it but it sounds fantastic!  Only issue I can think of is what all you could fit in there besides a probe core.  Not sure the satellite would be capable of much.

Share this post


Link to post
Share on other sites

First I need to say a big thank you for this essential mod for me since many years :)

I don't know if this has been notified before or not but it seems that the cylindrical shrouds in size 1,5m and 1,875m are missing.

And if I can make a suggestion, it would be nice if we could also choose Electric and Liquid fuel as central payload for the core parts. 

Share this post


Link to post
Share on other sites
Posted (edited)

A suggestion, greatly enjoying the mod (after a loooong hiatus from the game).  It has come a long way.

It would be terrific if we found a way to incorporate in the USII system some of the antennas in some way. <3

Same goes for solar cells, but then I'm asking for too much!

Edited by Dante80

Share this post


Link to post
Share on other sites

Hey @Paul Kingtiger!

First, thank you for your amazing contributions to the KSP community. US II (and US before it) have been must-have mods in my careers since I had careers, and I owe your team many snacks. I do have a request, and it's (I hope) a small one. Stock KSP refers to decouplers that only separate from one side of a stack as "decouplers" and ones that separate both sides as "separators". I was using an ACD for the first time and, because of the part description, thought that it would separate from both sides of the stack. My Munar Lander was still unfortunately stuck underneath it. I'd like to request that the descriptive text be changed from "...combines a stack separator..." to "... combines a stack decoupler...", as to be in line with the general stock descriptions. Obviously, this is low-low-low priority, if you even agree. :)

Again, thank you! 

Share this post


Link to post
Share on other sites
30 minutes ago, eightiesboi said:

Obviously, this is low-low-low priority, if you even agree.

Because if he doesn't agree, it's a low-low-low-low priority :P

Share this post


Link to post
Share on other sites
7 hours ago, eightiesboi said:

...I'd like to request that the descriptive text be changed from "...combines a stack separator..." to "... combines a stack decoupler...", as to be in line with the general stock descriptions. Obviously, this is low-low-low priority, if you even agree. :)

Again, thank you! 

That's a good point, and easy to implement.  I'll make sure it's included in the next release.

Share this post


Link to post
Share on other sites

Hi guys, had a bit of a lul in my motivation but trying to get back into it now. This next update is going to be a bit larger than I envisioned, but we're getting there!

On 10/4/2019 at 8:32 AM, Dante80 said:

A suggestion, greatly enjoying the mod (after a loooong hiatus from the game).  It has come a long way.

It would be terrific if we found a way to incorporate in the USII system some of the antennas in some way. <3

Same goes for solar cells, but then I'm asking for too much!

Solar is coming in a big way, we're adding panels to mostly all of the petal shrouds and a few of the larger cylindrical bays, as well as a few wedge-mounted parts. 

On 9/27/2019 at 2:58 AM, HaArLiNsH said:

First I need to say a big thank you for this essential mod for me since many years :)

I don't know if this has been notified before or not but it seems that the cylindrical shrouds in size 1,5m and 1,875m are missing.

And if I can make a suggestion, it would be nice if we could also choose Electric and Liquid fuel as central payload for the core parts. 

Those profiles are coming! I wasn't too sure about the 1.5m profile but i can always downscale the 1.875m set without too much grumbling, i assume ;)

On 9/25/2019 at 10:44 AM, subyng said:

Any chance decouple-able wedge probe cores are planned? The US shroud and cores would make perfect satellite buses. 

We are adding a few extra sizes to the probecore parts, but i've always thought they were a bit too small to act as true satellites. Would a dedicated decoupler work between the wedge and the bay? 

But thanks again for all the nice feedback guys, it's heartening to check the forums to see everyone enjoying our work. Helps to keep things going, so to speak :)

Feature list for the next update!
* Russian skins for nearly every existing shroud, with a few colour variants of each. Main skins will be set to Tantares olive, alongside a few unique white versions
* New Russian inspired parts - namely a early tech tree Vostok\Voskhod shroud with internal monoprop, an extendable four high Soyuz\Progress shroud with internal fuel, and a 1.5m and 1.875m cylindrical bay.
* A new mini-Gemini shroud that is skinned to match with the Restock MK1 capsule.
* Solar panel integration on the inside of mostly all of the petal shrouds, plus a large (Gigantor XL) and small (OX-4L) wedge mounted versions
* Core trusses! These will act as cores that you can attach wedges to, but shaped to act as convenient bodywork for lander designs. 
* Smaller combo lifesupport parts, to make the early game a little more forgiving. 
* A smaller probe core variant for the late game
* Ore and Xenon wedges
* Wedge mounted ore drills
* ISRU parts (maaaybe?) 

Share this post


Link to post
Share on other sites

Am I more excited for the next US2 update or KSP2... I am not too sure. :D

Share this post


Link to post
Share on other sites
Posted (edited)

Looking good!

Any news on bug fixes? The 2.5m core ‘north west west’ node induced torque and the LFO tank amounts come to mind in particular. 
 

edit: And the ‘attachment ID is lost after saving/loading a craft with a us2 core’ thing. Might be KSP itself, but it loses this value only for us2 cores when I tested it :/

Edited by Jognt

Share this post


Link to post
Share on other sites

Nice - looking forward to the update.  Am I the only one that uses TAC LS a lot for the sole reason that I get to use US2 parts with it?

Still having that random problem that many have reported with the Probe Core acting weird.  I'm guessing it's a mod conflict but I there's nothing evident in the logs.  Seems to happen when you detach a US2 Probe Core from another parent probe core (e.g. satellite off a Centaur)

Share this post


Link to post
Share on other sites
55 minutes ago, Friznit said:

Nice - looking forward to the update.  Am I the only one that uses TAC LS a lot for the sole reason that I get to use US2 parts with it?

Still having that random problem that many have reported with the Probe Core acting weird.  I'm guessing it's a mod conflict but I there's nothing evident in the logs.  Seems to happen when you detach a US2 Probe Core from another parent probe core (e.g. satellite off a Centaur)

I can't say I *haven't* had problems. I can remember a time where I couldn't control my 2nd stage for it's return because it got marked as debris, but it's entirely possible that I'd set that _myself._

I don't think I've seen it happen after I started manually setting up each probecore on my pre-built launchers though.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.