Paul Kingtiger

Universal Storage II [1.3.1 and 1.4.5 - 1.7.0]

Recommended Posts

15 hours ago, Poodmund said:

Am I more excited for the next US2 update or KSP2... I am not too sure. :D

Yes.:D

Share this post


Link to post
Share on other sites
On 10/7/2019 at 10:48 PM, Daishi said:

Hi guys, had a bit of a lul in my motivation but trying to get back into it now. This next update is going to be a bit larger than I envisioned, but we're getting there!

Feature list for the next update!
* Russian skins for nearly every existing shroud, with a few colour variants of each. Main skins will be set to Tantares olive, alongside a few unique white versions
* New Russian inspired parts - namely a early tech tree Vostok\Voskhod shroud with internal monoprop, an extendable four high Soyuz\Progress shroud with internal fuel, and a 1.5m and 1.875m cylindrical bay.
* A new mini-Gemini shroud that is skinned to match with the Restock MK1 capsule.
* Solar panel integration on the inside of mostly all of the petal shrouds, plus a large (Gigantor XL) and small (OX-4L) wedge mounted versions
* Core trusses! These will act as cores that you can attach wedges to, but shaped to act as convenient bodywork for lander designs. 
* Smaller combo lifesupport parts, to make the early game a little more forgiving. 
* A smaller probe core variant for the late game
* Ore and Xenon wedges
* Wedge mounted ore drills
* ISRU parts (maaaybe?) 

Super-awesome, and thanks so much for continuing to support and develop this mod - this is always one of the first two mods I (re)install in any copy of KSP. (the other is Restock)

Any chance of a generic tank? Meaning it would be great to have something that can hold Methane or Nitrogen to support waste/supply products in other mods that have them.

Share this post


Link to post
Share on other sites
On 10/10/2019 at 10:38 AM, panarchist said:

Super-awesome, and thanks so much for continuing to support and develop this mod - this is always one of the first two mods I (re)install in any copy of KSP. (the other is Restock)

Any chance of a generic tank? Meaning it would be great to have something that can hold Methane or Nitrogen to support waste/supply products in other mods that have them.

I think we were gonna make those specific resource tanks anyway, but sure :)

Thanks for being a fan :D 

Share this post


Link to post
Share on other sites
3 hours ago, Daishi said:

I think we were gonna make those specific resource tanks anyway, but sure :)

Thanks for being a fan :D 

Honestly, I'd rather have specific tanks for those two, and I probably requested that in this thread previously - if that was the plan, then I'm excited about it.

Share this post


Link to post
Share on other sites

Hey guys, i assume silence is golden, and the mod still works in 1.8? :)

Share this post


Link to post
Share on other sites
1 hour ago, Daishi said:

Hey guys, i assume silence is golden, and the mod still works in 1.8? :)

I haven't seen any issues yet, appears to be a-ok.

Share this post


Link to post
Share on other sites
15 hours ago, Daishi said:

Hey guys, i assume silence is golden, and the mod still works in 1.8? :)

Not sure...still testing.

I was wondering why this craft could not connect even though it has an antenna and a guidance unit.  Yes, there are problems in the log involving MechJeb (plus a 10k m/s circularization burn at 250 km above Kerbin; what's with that?). I'm going to remove MechJeb and try again.

Craft file

Log

CriSjrH.png

Edit 1 - Removing MechJeb didn't solve the problem. 

Edit 2 - Is there any way to force the craft, on revert to VAB, to keep the saved container states?  I've saved this craft several times in the VAB with 0 water in the tank.  On revert, the tank reverts to full.

Edit 3 - Weird.  The 10k dV to circularize and lack of a connection appear in KSP 1.7.3.  Could this be a US 2 issue?? (or more likely my not understanding something)

Edited by Brigadier
Added Edit 3

Share this post


Link to post
Share on other sites
9 hours ago, Brigadier said:

Not sure...still testing.

I was wondering why this craft could not connect even though it has an antenna and a guidance unit.  Yes, there are problems in the log involving MechJeb (plus a 10k m/s circularization burn at 250 km above Kerbin; what's with that?). I'm going to remove MechJeb and try again.

Craft file

Log

CriSjrH.png

Edit 1 - Removing MechJeb didn't solve the problem. 

Edit 2 - Is there any way to force the craft, on revert to VAB, to keep the saved container states?  I've saved this craft several times in the VAB with 0 water in the tank.  On revert, the tank reverts to full.

Edit 3 - Weird.  The 10k dV to circularize and lack of a connection appear in KSP 1.7.3.  Could this be a US 2 issue?? (or more likely my not understanding something)

I think there is something wrong with that probe core, we'll have another look at it. I'm sure the tank reset bug only happened with the KIS wedges but apparently not. 

Share this post


Link to post
Share on other sites

I had some time to test it, It seemingly works fine in 1.8 - things I noticed is that I could not get the right click menu on some US2 items in the VAB once, it worked again after a game restart. I have no idea what broke, it might be something elses fault. It has not happened since either. I could also not tell if only truly the US2 parts were affected, because I obv. did not test every other part in the game, but I only saw it with them.

One of the parts in conjunction with TacLS - I think it was the water purifier - gave no reaction to right click at all, not even a tooltip in the part list.

But right now (in a new start without TacLS, switched to Snacks! + Air) everything seems to work just fine.

Edited by DaniDE

Share this post


Link to post
Share on other sites
11 minutes ago, DaniDE said:

I had some time to test it, It seemingly works fine in 1.8 - things I noticed is that I could not get the right click menu on some US2 items in the VAB once, it worked again after a game restart. I have no idea what broke, it might be something elses fault. It has not happened since either. I could also not tell if only truly the US2 parts were affected, because I obv. did not test every other part in the game, but I only saw it with them.

Something similar is happening to me in 1.7.3, when a right click doesn't work sometimes. It repairs itself when I switch scenes (and clear input locks for a good measure). It's general problem, not US2 one.

Share this post


Link to post
Share on other sites

I've also had problems with the water tank resetting to full every time.

@Brigadier do you mean the US2 probe wedge that keeps getting no probe control? Part of the problem is it gets flagged as debris and stops connecting. I don't know if you can rename a vessel without probe control. Also, sometimes it'll get flagged as debris and become nonfunctional after decoupling. 

So, safest option: use a different probe core. Second safest, always use separators versus decouplers (I think separators preserve both parts being a real vessel). And triple check in the VAB that the vessel type is probe not debris

 

Also, stoked for the lander frames! I imagine it like the Boeing Mars Lander concept or Altair

Share this post


Link to post
Share on other sites

I *did* have one issue under 1.8.0 where all the parts showed in the VAB editor as their 4x (quad) versions, not the 1x default ones. It was before updating MM to the latest, so I expect it wasn't a US2 issue. So if anyone sees that behavior, check if you're on the old 4.0.3 MM instead of the latest (4.1.0 at this writing) MM.

Share this post


Link to post
Share on other sites
41 minutes ago, panarchist said:

I *did* have one issue under 1.8.0 where all the parts showed in the VAB editor as their 4x (quad) versions, not the 1x default ones. It was before updating MM to the latest, so I expect it wasn't a US2 issue. So if anyone sees that behavior, check if you're on the old 4.0.3 MM instead of the latest (4.1.0 at this writing) MM.

I'm still on 1.7.3 and using MM 4.0.3, and have seen this behavior as well.

Share this post


Link to post
Share on other sites
3 hours ago, panarchist said:

I *did* have one issue under 1.8.0 where all the parts showed in the VAB editor as their 4x (quad) versions, not the 1x default ones. It was before updating MM to the latest, so I expect it wasn't a US2 issue. So if anyone sees that behavior, check if you're on the old 4.0.3 MM instead of the latest (4.1.0 at this writing) MM.

I've recently seen this under KSP 1.7.3 and don't know how long it's been like that and I haven't noticed until I started testing.  For me, it's purely cosmetic.

Share this post


Link to post
Share on other sites
9 hours ago, maja said:

Something similar is happening to me in 1.7.3, when a right click doesn't work sometimes. It repairs itself when I switch scenes (and clear input locks for a good measure). It's general problem, not US2 one.

sometimes pressing the <ESC> key frees things up for me in similar situations.

Share this post


Link to post
Share on other sites
8 hours ago, t6jesse said:

@Brigadier you mean the US2 probe wedge that keeps getting no probe control? Part of the problem is it gets flagged as debris and stops connecting. I don't know if you can rename a vessel without probe control. Also, sometimes it'll get flagged as debris and become nonfunctional after decoupling. 

So, safest option: use a different probe core. Second safest, always use separators versus decouplers (I think separators preserve both parts being a real vessel). And triple check in the VAB that the vessel type is probe not debris

KSP v1.7.3, US 2 v1.7.1.10

Yeah, it the Remote Operations System, which in the VAB says it has an antenna.  This test craft is a 5-bay core with centre fuel, a 48-7S Spark engine, a ROS, a TEG and a recycler, all cheated into orbit.  The only way I have to control it is MechJeb.  Note the line in OneWindow that says the "Control Locked" when I try to create a maneuver node.

fQtSgyR.png

Edited by Brigadier
Added more info

Share this post


Link to post
Share on other sites
18 minutes ago, Brigadier said:

KSP v1.7.3, US 2 v1.7.1.10

Yeah, it the Remote Operations System, which in the VAB says it has an antenna.  This test craft is a 5-bay core with centre fuel, a 48-7S Spark engine, a ROS, a TEG and a recycler, all cheated into orbit.  The only way I have to control it is MechJeb.  Note the line in OneWindow that says the "Control Locked" when I try to create a maneuver node.

fQtSgyR.png

Try going into the Tracking Station and changing its type to Probe instead of Debris. I’m 100% sure I can do that, but that feature may have been added by Tracking Station Evolved (dmagic). 

Share this post


Link to post
Share on other sites
12 minutes ago, Jognt said:

Try going into the Tracking Station and changing its type to Probe instead of Debris. I’m 100% sure I can do that, but that feature may have been added by Tracking Station Evolved (dmagic). 

That worked.  The functionality is, indeed, added by Tracking Station Evolved but then it should also be possible to rename and change the vessel type from the flight view.  In my first test, changing in the flight view didn't work but in the Tracking Station did.

Sigh, more investigation required.

Share this post


Link to post
Share on other sites

I might have to get Tracking Station Evolved too then. That probe core is super useful, but I can't rely on it right now. I think it might have been on the fix list for the next release though, I know many others have had the same problem and the devs are tracking it

Edited by t6jesse

Share this post


Link to post
Share on other sites

For peeps who have been having trouble with the probe core, this module manager patch should fix it until the next release

@PART[USDoubleProbeCore]:AFTER[UniversalStorage2]
{
  %vesselType = Probe
}

Just save this into a text file with the extension .cfg (example, US2ProbeFix.cfg ) and put it anywhere inside your gamedata folder. 

Share this post


Link to post
Share on other sites
1 minute ago, Zorg said:

For peeps who have been having trouble with the probe core, this module manager patch should fix it until the next release

@PART[USDoubleProbeCore]:AFTER[UniversalStorage2]
{
  %vesselType = Probe
}

Just save this into a text file with the extension .cfg (example, US2ProbeFix.cfg ) and put it anywhere inside your gamedata folder. 

Good eye! Thanks man :D

Share this post


Link to post
Share on other sites

Hi,

First of all, thank you for a great mod. Secondly, would it be possible to have cargo container wedges for surface experiments? Maybe reusing the water tank model? 

Share this post


Link to post
Share on other sites
Just now, Lathari said:

Secondly, would it be possible to have cargo container wedges for surface experiments? Maybe reusing the water tank model? 

In the meantime, the SEQ-3 small container fits nicely on the 2.5m core, just like the experiment storage container

Share this post


Link to post
Share on other sites
11 minutes ago, Lathari said:

Hi,

First of all, thank you for a great mod. Secondly, would it be possible to have cargo container wedges for surface experiments? Maybe reusing the water tank model? 

If you also have KIS installed, this will dupe the KIS wedges:

+PART[USKASRadial]:AFTER[KIS]
{
    @name=USKASRadial_BREAKINGGROUND

    !MODULE[ModuleKISInventory] {}

    MODULE
	{
		name = ModuleInventoryPart
		InventorySlots = 2
	}
}

+PART[USKASWedge]:AFTER[KIS]
{
    @name=USKASWedge_BREAKINGGROUND

    !MODULE[ModuleKISInventory] {}

    MODULE
	{
		name = ModuleInventoryPart
		InventorySlots = 2
	}
}

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.