Jump to content

Universal Storage II [1.3.1 and 1.4.5 - 1.7.0]


Paul Kingtiger
 Share

Recommended Posts

On 12/18/2021 at 3:54 AM, Poodmund said:

And not once did I ever ask about it. :P 

(yeah right, did I?!) :D 

It would be amazing to see US2 get a last stretch 'hurrah!' and good for KSP 1.12. Its one of those pinnacle KSP mods, a cornerstone of the modding scene.

H5uyc.jpg

I thought this would be fun. Take a look at this. I don't know what the exact date on it is (I could find out with a bit of work, because it's drawn on hotel stationary, and I remember where I was), but Imgur says I uploaded it 9 years ago. I think KSP was under version 0.16. It was my original concept for an idea that someone eventually made and called 'Universal Storage', hah!

What I'm saying is, @Daishi owes me royalties on all the stacks of money he's made from this mod.

Edited by Frostiken
Link to comment
Share on other sites

On 1/4/2022 at 8:41 PM, linuxgurugamer said:

I've fixed that by adjusting ALL the sizes of the parts down by about 2%, everything now fits very nicely

New release, 4.0.0.1

  • Added :LAST to the NerteaCryoMassRebalance.cfg
  • Changed :FINAL to LAST[UniversalStorage2] in the MassResourceRebalance.cfg
  • Fixed GuidanceComputer to only be available when kOs is installed
  • Added resize patch to reduce size of parts very slightly by about 2.25%, to better fix stock parts
  • Changed MassResourceRebalance.cfg to change FINAL to LAST[UniversalStorage2]
  • Following changes/additions to support IFILS, currently under development:
    • Fixed OxygenWedge for IFILS, to only hold liquid O2
    • Updated ComboLivesupportWedge to support IFILS
    • Updated FoodWedge with correct names for IFILS
    • Updated Elektron to not be available when IFILS is installed
  • Updated version file
     

https://github.com/linuxgurugamer/universal-storage-2/releases/tag/4.0.0.1

 

Hi @linuxgurugamer. Thanks for all the work you do. Found a small error.

NerteaCryo.cfg exists in both Parts -> Fuels as well as Patches folders.

It's causing MouduleCryoTank to be applied to the US fuel tank twice. That caused @Nertea's DynamicBatteryStorage to flip out and throw exceptions. I removed the NerteaCryo.cfg file from the part folder leaving the one in the patches folder. Reloaded my game and everything behaving normally. Looked at my persistence file and MM had removed the offending duplicate ModuleCryoTank from ships using that tank.

If anyone else is getting this issue removing the duplicate .cfg file should fix the problem until a new release alleviates the issue.

Link to comment
Share on other sites

3 hours ago, daveisadp said:

Hi @linuxgurugamer. Thanks for all the work you do. Found a small error.

NerteaCryo.cfg exists in both Parts -> Fuels as well as Patches folders.

It's causing MouduleCryoTank to be applied to the US fuel tank twice. That caused @Nertea's DynamicBatteryStorage to flip out and throw exceptions. I removed the NerteaCryo.cfg file from the part folder leaving the one in the patches folder. Reloaded my game and everything behaving normally. Looked at my persistence file and MM had removed the offending duplicate ModuleCryoTank from ships using that tank.

If anyone else is getting this issue removing the duplicate .cfg file should fix the problem until a new release alleviates the issue.

Thank you, will be removed in next beta

Link to comment
Share on other sites

On 1/14/2022 at 7:47 PM, SilverlightPony said:

Any idea why the Universal Storage Mystery Goo and Materials Study parts complain about being shielded even though they're inside an open Universal Storage 1.25m-to-1.875m fairing?

f4N4Sip.png

Same issue cropping up with the cylindrical 2.5m fairing and an 8-wedge center bit.  Some experiments worked, some complained about being shielded.  Very annoying.

Edited by SilverlightPony
Link to comment
Share on other sites

On 1/14/2022 at 7:47 PM, SilverlightPony said:

Any idea why the Universal Storage Mystery Goo and Materials Study parts complain about being shielded even though they're inside an open Universal Storage 1.25m-to-1.875m fairing?

 

On 1/21/2022 at 6:27 AM, SilverlightPony said:

Same issue cropping up with the cylindrical 2.5m fairing and an 8-wedge center bit.  Some experiments worked, some complained about being shielded.  Very annoying.

 

You do realize this is a BETA, and rather than complaining about it, a proper bug report in a respectful manner would get a better response than totally annoying me (which these two posts did).

It's a BETA for a reason, and I need decent reports rather than complaints. 

For example,  the picture from the first one  is too dark to see anything, and the second one doesn't have a picture at all.

An example craft file would be very useful in diagnosis.

 

That being said, I was going to be releasing a new beta this weekend, I'll see if I have some time to look at this

Link to comment
Share on other sites

7 minutes ago, linuxgurugamer said:

 

 

You do realize this is a BETA, and rather than complaining about it, a proper bug report in a respectful manner would get a better response than totally annoying me (which these two posts did).

It's a BETA for a reason, and I need decent reports rather than complaints. 

For example,  the picture from the first one  is too dark to see anything, and the second one doesn't have a picture at all.

An example craft file would be very useful in diagnosis.

 

That being said, I was going to be releasing a new beta this weekend, I'll see if I have some time to look at this

Sorry, I got a solution (or at least a workaround) from Reddit but forgot to post it here.  Turns out, the problem wasn't the fairing/payload-bay.

I was trying to run the experiments via ScienceAlert without realizing that the experiments in question need to be manually deployed via the parts' right-click menu first.  The last time I was doing a career or science playthrough, triggering a deployable experiment by any method would automatically deploy it if needed.  This still works for some experiments (even US ones, like the Magnetometer Boom), but the US Atmospheric Science Unit (the 2Hot/PresMat thing) and US Materials Bay needed to be deployed manually.  Once deployed, running the experiment via ScienceAlert worked fine.

Link to comment
Share on other sites

1 hour ago, SilverlightPony said:

Sorry, I got a solution (or at least a workaround) from Reddit but forgot to post it here.  Turns out, the problem wasn't the fairing/payload-bay.

I was trying to run the experiments via ScienceAlert without realizing that the experiments in question need to be manually deployed via the parts' right-click menu first.  The last time I was doing a career or science playthrough, triggering a deployable experiment by any method would automatically deploy it if needed.  This still works for some experiments (even US ones, like the Magnetometer Boom), but the US Atmospheric Science Unit (the 2Hot/PresMat thing) and US Materials Bay needed to be deployed manually.  Once deployed, running the experiment via ScienceAlert worked fine.

Glad you got it figured out

20 minutes ago, SilverlightPony said:

Unrelated to the above, with Filter Extensions and Moar Filter Extension Configs installed, the 0.65m, 1.25m, and 1.875m Wheel-O-Decoutron ACDs all show up under the 2.5m size filter rather than the filters for their respective sizes.

What about just Filter Extensions by itself?

If it is the  Moar Filter Extension Configs  which is causing the problem you need to post in that thread.  That's @leatherneck6017's mod

 

Edit:  I took a look at a few of the parts, most of them are set to a size2 instead of  a wedge, I'll have to get that fixed

Please, when reporting a problem, try to isolate it to the minimal mod set needed to replicate.  This actually has nothing to do with Filter Extensions

Edited by linuxgurugamer
Link to comment
Share on other sites

A release (finally!!!)

4.0.0.2

  • Changes from last beta:
  • Fixed bulkheadProfiles for many parts
  • Added three new parts:
  • Basic Sub-satellite
    • Contains two small science experiments, temperature and pressure
  • Advanced Sub-Satellite
    • Contains the following experiments
      • Magnometer
      • Camera, for low altitude photos
      • Solar panels, fixed
      • Radiators, deployable
      • Xenon gas tank
    • Antenna, deployable
  • Micro-Dawn Electric Drive
    • Designed to attach to the bottom of the Advanced Sub-Satellite.  Combined with the satellite, it has a bit more than 700 dV available

Please report any issues that you see.  

Edited by linuxgurugamer
Link to comment
Share on other sites

Congrats for the release @linuxgurugamer ! I'd like to ask (I didn't see any info in last thread pages) if there are compatibility issues with previous US2 release (1.9.1.2).

Given the major version bump, I suppose this is not retrocompatible, but I'd like to know if you (or someone else) experimented and there are any suggestions on how to handle the switch between the two versions in an existing save game.

Edited by leonardfactory
Link to comment
Share on other sites

Yes, thanks so much Linux for getting my parts functional and out in the world :) Hope everybody has fun with them! 

There is also a Lunar Mapping Cam and a Science Storage box, aka the Data Input Terminal. 

Ro4ZwZE.png

 

Edited by Daishi
Link to comment
Share on other sites

17 hours ago, leonardfactory said:

Congrats for the release @linuxgurugamer ! I'd like to ask (I didn't see any info in last thread pages) if there are compatibility issues with previous US2 release (1.9.1.2).

Given the major version bump, I suppose this is not retrocompatible, but I'd like to know if you (or someone else) experimented and there are any suggestions on how to handle the switch between the two versions in an existing save game.

There shouldn't be any incompatibility.  I only fixed a few issues (see the notes in the beta releases) and implemented the new models

Link to comment
Share on other sites

14 minutes ago, linuxgurugamer said:

There shouldn't be any incompatibility.  I only fixed a few issues (see the notes in the beta releases) and implemented the new models

Thanks for clarifying that, will test and file a report/PR if I find something. Kudos!

Link to comment
Share on other sites

22 minutes ago, linuxgurugamer said:

If anyone knows of any other issues, let me know, I might be able to get any fixes in if I have time

The 1.875m shroud doesn't show up in my parts list.  /s  :D 

Absolutely loving these modules!

Link to comment
Share on other sites

32 minutes ago, Poodmund said:

The 1.875m shroud doesn't show up in my parts list.  /s  :D 

Absolutely loving these modules!

Which one, there are two?  And are you in career or sandbox mode?  For both of them , the techRequired is advConstruction

LtVp3MF.png

Link to comment
Share on other sites

hi

there seems a little issue with the science definitions

using x-science it shows a bunch of science which is new e.g "simple temperature scan", "simple pressure..." etc but i  wasn't abnle to find the device to do the science

so i searched for those definitions and found the following =>    experimentID = UStemperatureScan => which is part of the microsat => BasicMicroSatWedge.cfg

MODULE
    {
        name = ModuleScienceExperiment
        experimentID = UStemperatureScan
        experimentActionName = #autoLOC_502067 //#autoLOC_502067 = Log Temperature
        resetActionName = #autoLOC_502064 //#autoLOC_502064 = Delete Data
        useStaging = False
        useActionGroups = True
        hideUIwhenUnavailable = False
        xmitDataScalar = 0.5
        dataIsCollectable = False
        collectActionName = #autoLOC_238018 //#autoLOC_238018 = Take Data
        interactionRange = 1.5
        rerunnable = True
        usageReqMaskInternal = 1
        usageReqMaskExternal = -1

 

which refers to

EXPERIMENT_DEFINITION
{    
    id = UStemperatureScan
    title = Simple Temperature Scan // #autoLOC_501014 //#autoLOC_501014 = Temperature Scan
    baseValue = 4
    scienceCap = 4
    dataScale = 1
    
    requireAtmosphere = False
    situationMask = 31
    biomeMask = 7

ingame if hovering over the item with  the mod so called "extended information about Science experiments" it shows only the #loc   entries insted  of the science experiment

 

but going inflight with the aboce device doesn't provide the expected science experiment. it still counts as a normal temperature scan.

if you need more information  let me know

greets

Link to comment
Share on other sites

1 hour ago, GoAHead said:

ingame if hovering over the item with  the mod so called "extended information about Science experiments" it shows only the #loc   entries insted  of the science experiment

So this is a problem with the Extended Information mod, not this, right?

 

1 hour ago, GoAHead said:

but going inflight with the aboce device doesn't provide the expected science experiment. it still counts as a normal temperature scan.

Well, it _is_ a normal temperature scan, with less science than the stock one

 

I've been able to duplicate the problem, not sure what's going on yet.  It actually has nothing to do with the Extended Information mod

Edited by linuxgurugamer
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...