Jump to content

[1.4.x] BDArmory Continued v1.2.2.2a [8/8/2018] + Vessel Mover, Camera Tools, BDMk22, Destruction Effects, Burn Together


Papa_Joe
 Share

Recommended Posts

17 minutes ago, SpannerMonkey(smce) said:

It also looks from your video at 0:53 , as if some of the launch tubes are obscured by that 2x2 structure, if any of the tubes that contain missiles are obscured it will trigger the clearance check, and that will be applied to the whole launcher, clearance check prevents you shooting your own craft.

I'll try to raise it higher.

Link to comment
Share on other sites

21 hours ago, SpannerMonkey(smce) said:

It also looks from your video at 0:53 , as if some of the launch tubes are obscured by that 2x2 structure, if any of the tubes that contain missiles are obscured it will trigger the clearance check, and that will be applied to the whole launcher, clearance check prevents you shooting your own craft.

 

I changed the patriot's design, but I didn't get any changes. Gun all also stupidly follows the target, but does not shoot !

Link to comment
Share on other sites

1 hour ago, Briso said:

I changed the patriot's design, but I didn't get any changes

Except your craft is still inverted!!  Which as mentioned previously will have a detrimental effect.  

Also be aware that we are only able to provide bug fix support for current BDA release versions, which right now means BDA v1.2.4, and any issues arising from v1.2.4 will be dealt with during the next update cycle (ongoing)  rather than being retroactively applied .

  I have tested these parts (as shown previously) in both the publicly available BDA v1.2.4 release and Pre release test versions of BDA and am unable to discern any problem, apart from the previously known issues with launchers.

Not sure if the lag, very evident on your video is as a result of recording or signs of deeper problems in your game resulting in excessive logging.  Should your problems persist I'd like to suggest a complete fresh install of the latest BDA and a careful examination of the KSP.log to ensure that there are no other mod related issues, BDA runs best in a clean (No excessive logging of null refs etc )  game environment

Link to comment
Share on other sites

On 2/14/2019 at 8:06 PM, SpannerMonkey(smce) said:

Except your craft is still inverted!!  Which as mentioned previously will have a detrimental effect.  

Also be aware that we are only able to provide bug fix support for current BDA release versions, which right now means BDA v1.2.4, and any issues arising from v1.2.4 will be dealt with during the next update cycle (ongoing)  rather than being retroactively applied .

  I have tested these parts (as shown previously) in both the publicly available BDA v1.2.4 release and Pre release test versions of BDA and am unable to discern any problem, apart from the previously known issues with launchers.

Not sure if the lag, very evident on your video is as a result of recording or signs of deeper problems in your game resulting in excessive logging.  Should your problems persist I'd like to suggest a complete fresh install of the latest BDA and a careful examination of the KSP.log to ensure that there are no other mod related issues, BDA runs best in a clean (No excessive logging of null refs etc )  game environment

 

16 hours ago, Xd the great said:

Here try this:

https://kerbalx.com/Xdthegreat/pac-3-missile-vehicle

and next time you record a video you may consider opening the Alt+F12 menu.

Thanks to your patriot work. Thank you for your help as well as for SpannerMonkey's help. I also use your mods with joy. My favorite submarine.

Link to comment
Share on other sites

9 hours ago, Project Cygnus said:

I'm curious, has anybody had any issue with the Water AI? Everytime I've tried to use it on two specific craft it just locks into either yawing left or right. Logs are normal, nothing should be causing it as far as I can tell

Hi. no problems noted in my recent scenario runs. Water craft are quite fussy in Ai set up, I've not found a suitable setting that would work for everything , each craft has to be set up individually. There are also issues that only water craft suffer,  such as control surface/rudder runaway that shows itself if  the  ctrl surface is scaled, this starts to show in a turn, the vessel will start to gather speed , regardless or throttle position and the ai will not have a clue how to stop  it ( its a result of some deep internal KSP code that was introduced with the aero package in ksp1.0)   ,  purely scaling parts can also have a horrible affect on a crafts behavior,  excessive deck weight can also induce a turning moment that the ai will be unable to control as it usually combines with the aforementioned runaway syndrome

Link to comment
Share on other sites

11 hours ago, SpannerMonkey(smce) said:

Hi. no problems noted in my recent scenario runs. Water craft are quite fussy in Ai set up, I've not found a suitable setting that would work for everything , each craft has to be set up individually. There are also issues that only water craft suffer,  such as control surface/rudder runaway that shows itself if  the  ctrl surface is scaled, this starts to show in a turn, the vessel will start to gather speed , regardless or throttle position and the ai will not have a clue how to stop  it ( its a result of some deep internal KSP code that was introduced with the aero package in ksp1.0)   ,  purely scaling parts can also have a horrible affect on a crafts behavior,  excessive deck weight can also induce a turning moment that the ai will be unable to control as it usually combines with the aforementioned runaway syndrome

I had actually figured out the issue, when running with multiple craft ships for independent targeting AA the patrol mode was freaking out as two craft were on the same spot. It's an interesting issue I've never experienced beforehand.

4 hours ago, MjrLeeObvious said:

Is there a current status on an updated version of this? Current version at the time of writing is 1.6.2.

The current version of BD works with 1.6.2

Link to comment
Share on other sites

On 2/22/2019 at 10:18 PM, gag09 said:

I'm trying to make a rail-gun that uses both ore and electricity as resources but for some reason using two resources borks it. Is there a way that i'm missing?

We will need the .cfg of your part to see what is wrong. 

I usually do it by making the part generate bullets from ore and electricity. like the Convert-o-tron

And customize the bullet as you wish.

refer to the bdac files for self-learning.

Link to comment
Share on other sites

Hey there! Please could you help me with the location of some pieces of the mod. The thing is that I don't want to install any parts or effects that accompany them, but I would like to extract the camera tools for the cinematics and the squadron menu thing. However I cannot find them and I need your help. Thank you!

Link to comment
Share on other sites

On 2/24/2019 at 8:50 PM, Rover 6428 said:

Hey there! Please could you help me with the location of some pieces of the mod. The thing is that I don't want to install any parts or effects that accompany them, but I would like to extract the camera tools for the cinematics and the squadron menu thing. However I cannot find them and I need your help. Thank you!

Try 

and camera tools.

 

Well, the squadron menu thing is bdac.

On 2/24/2019 at 9:13 PM, ElonsMusk said:

Man I seriously appreciate people who clearly state this type of thing. Big ups, friendo.

@Papa_Joe?

Link to comment
Share on other sites

I'm having a problem in my save.

I have a set up where the target is sitting in the KSC and I have a radar post on the hills above. I have 2 artillery guns using the 105mm Howitzer behind it, over the horizon and about 5 km from the target. I've made sure all AIs units ranges are set to 10km and the radar post is streaming it's signal to my guns. they receive it, and lock onto target, but they won't fire.

Any suggestions for how to fix? I want my guns to fire over the hills, and the bullet drop should be sufficient to arc the shot properly.

Link to comment
Share on other sites

4 hours ago, Chris Bolland said:

I'm having a problem in my save.

I have a set up where the target is sitting in the KSC and I have a radar post on the hills above. I have 2 artillery guns using the 105mm Howitzer behind it, over the horizon and about 5 km from the target. I've made sure all AIs units ranges are set to 10km and the radar post is streaming it's signal to my guns. they receive it, and lock onto target, but they won't fire.

Any suggestions for how to fix? I want my guns to fire over the hills, and the bullet drop should be sufficient to arc the shot properly.

I'm not completely sure but I think guns will not fire unless there is a clean line of sight to the target. Maybe @SpannerMonkey(smce) can correct me if I'm wrong.

Link to comment
Share on other sites

I've ran into a problem with modular missiles in KSP 1.6.1 with BDA version 1.2.4.0

I built a a basic two stage missile to fire from surface to surface targets and configured guidance settings to STS/AGM with GPS targeting. Fallowing testing the missile till it's accurate I tried to re-root the missile to create a sub-assembly like how it's described in the MM wiki. Once the missile is saved as a sub assembly it no longer works properly when loaded into another craft and fired. On launch it seems to lose guidance, goes off on a path away from the target it or doesn't attempt at all to change the missiles course.

Tried this over many times with different builds and I can't find out what's causing this.

Link to comment
Share on other sites

45 minutes ago, OmegaForce said:

I've ran into a problem with modular missiles in KSP 1.6.1 with BDA version 1.2.4.0

I built a a basic two stage missile to fire from surface to surface targets and configured guidance settings to STS/AGM with GPS targeting. Fallowing testing the missile till it's accurate I tried to re-root the missile to create a sub-assembly like how it's described in the MM wiki. Once the missile is saved as a sub assembly it no longer works properly when loaded into another craft and fired. On launch it seems to lose guidance, goes off on a path away from the target it or doesn't attempt at all to change the missiles course.

Tried this over many times with different builds and I can't find out what's causing this.

Could you record a video showing how you build the missile and how you fire it? I will help you with it

Link to comment
Share on other sites

20 hours ago, jrodriguez said:

I'm not completely sure but I think guns will not fire unless there is a clean line of sight to the target. Maybe @SpannerMonkey(smce) can correct me if I'm wrong.

Is there any way I can target guns like the howitzers using GPS chords?

My goal is to make artillery that can auto bombard from distance. If it won't work, then that's alright, I just hope spanner can update the mod to do that some time.

Thanks!

(PS won't it be awesome if this became a stand alone game?!?!)

Link to comment
Share on other sites

5 hours ago, Chris Bolland said:

Is there any way I can target guns like the howitzers using GPS chords?

My goal is to make artillery that can auto bombard from distance. If it won't work, then that's alright, I just hope spanner can update the mod to do that some time.

Thanks!

(PS won't it be awesome if this became a stand alone game?!?!)

It seriously would. However I'd like to retain the ability to build and tweak vehicles and aircraft 

Link to comment
Share on other sites

observation: feature requesting is trending.  action: *jumps on wagon*

suggestion: I'd like to see the team system expanded into a custom faction system with adjustable relations.  Perhaps, >.> on top of a little bit of collaboration with the dmp team?  maybe even some airspace "biomes" with random encounters (of low count assets).

reality: i want a lot of things :blush: that i cannot have.

farewell: farewell.

 

post script: lol

Link to comment
Share on other sites

On 2/26/2019 at 8:23 AM, jrodriguez said:

guns will not fire unless there is a clean line of sight to the target

Not wrong, there are ways around some of  the issues, but non of them will work with guard mode, part of the problem is there's no high angle trajectory for shells,  and no way to aim even if there was. Shell trajectory is mainly a product of velocity and mass,  you can manipulate the shell trajectory by increasing shell mass or lowering shell velocity, but in doing so you encounter all kinds of undesirable and peculiar side effects. Conducted a good many experiments with high angle artillery but nothing useful has come from any of it.

Link to comment
Share on other sites

I think I found an error in the gun deviation code. Sorry, no GitHub account to raise an issue.

BDArmory/Misc/VectorUtils.cs

public static float Gaussian()
//...
return Mathf.Sqrt(-2 * Mathf.Log(UnityEngine.Random.value)) * Mathf.Cos(Mathf.PI * UnityEngine.Random.value);
//...

Per the reference in the code comments: https://en.wikipedia.org/wiki/Box–Muller_transform

That should be TWO*pi.

The probability distribution as written is messed up. I set up a matrix of "random" numbers from 0.01 to 1.0 in Excel, stepped every 0.05, and it turns out an Average of 0.46, and a Median of 0.69. Correctly written, the Average is -0.02, the Median is 0.00. The maximum values obviously remain the same.

Just for giggles, I ran the linear spread for a GAU-8 (maxDeviation = 0.45°, which then gets divided by 2 for stdDeviation=0.225°). At 2500m range, the current distribution is Average 4.49m, Median 6.46m.

For a Hidden Vulcan @ 2500m (maxDeviation=0.125°): Average: 1.25m, Median: 1.79m

IIRC the guns start firing when within 2° of target, but the messed up probability is likely a contributing factor to dogfights taking so dang long.

Statistics in spoiler:

Spoiler

piVgsYVt1.png

pi*25zenkWW.png

 

Link to comment
Share on other sites

This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...