Question

Hi, As you can tell from the title My Ksp has lost all sound. This happened all of a sudden, along with most of my other steam games, but has anyone experienced this before? Thanks!

Share this post


Link to post
Share on other sites

7 answers to this question

Recommended Posts

  • 0

I just tried some old wireless headphones I got for christmas a year ago, and they work with the steam games that had no sound but no ksp. They don't have error logs either anymore, so they are fixed. Hope this helps anyone who is experiencing this glitch on multiple games other than ksp.

-just looked in the ksp log, there is nothing about audio anymore. Will try to investigate more

-Nevermind, it does work

 

 

Edited by Vinhero100

Share this post


Link to post
Share on other sites
  • 0
Just now, Vinhero100 said:

along with most of my other steam games

If its happening with other games on steam it might be a steam issiue.

Try veryfing file integrety

Share this post


Link to post
Share on other sites
  • 0
1 hour ago, KerbolExplorer said:

If its happening with other games on steam it might be a steam issiue.

Try veryfing file integrety

oh sorry I forgot to mention I don't own a copy of the game from steam, I bought it off the website

-sorry I didn't make that clear, forgot you can by ksp off steam

Edited by Vinhero100

Share this post


Link to post
Share on other sites
  • 0

Well since it's not solely a KSP issue, check your audio drivers, etc etc.  

But a KSP.log would let us know if KSP has been able to initialize the sound or not. 

Share this post


Link to post
Share on other sites
  • 0

I did update literally everything on my pc, but nothing worked. I found the log, and it said "No device found" right after it tried to load "editor loop01"

 

 

 

Share this post


Link to post
Share on other sites
  • 0
10 hours ago, Vinhero100 said:

I did update literally everything on my pc, but nothing worked. I found the log, and it said "No device found" right after it tried to load "editor loop01"

 

 

 

Could you post the log to a outside site, or just post about twenty lines or so of the log here in spoiler tags?

 

Digging through my skull, I can recall device conflicts being an issue for sound, so check your device manager and see if something has become disabled.  I mean, without more info to narrow down the issue, we're kinda shooting in the dark.  Do you have sound outside of games?   So when you loaded up the forums, did you get a notification *ding*? 

Share this post


Link to post
Share on other sites
  • 0
Spoiler

[LOG 19:28:25.681] Load(Audio): Squad/Sounds/editorLoop01
[LOG 19:28:25.734] [SpaceNavigatorWindows]: No device found.
[LOG 19:28:26.017] Opt-out preferences successfully retrieved, applied and saved:
{"optOut":false,"analyticsEnabled":true,"deviceStatsEnabled":true,"limitUserTracking":false,"performanceReportingEnabled":true}

this is a part that stuck out to me, even though I have no experience in any of this. The rest was just the list of parts and audio that it loaded in, but the audio obviously didn't work so that was useless. A few steam games work and fortnite is not affected by any of this :) (lol) anything that's not a game though works normally on my pc. And everything seems fine in device manager. As for device conflicts, I only have headphones (not even wireless!) hooked up to my laptop for sound. 

- oh, and I forgot to add that my pc needs a bios upgrade, even though I bought it in august, would that have to do something with the sound?

Edited by Vinhero100

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.