Jump to content

[1.3.0] Kerbal Engineer Redux 1.1.3.0 (2017-05-28)


Recommended Posts

I'm trying to use RCS thrusters as primary engines on a craft. They're not showing up in the KER staging or DV readouts though. I have the RCS thrusters set to "Fore by Throttle".

Is there a way to get them to show up?

Link to post
Share on other sites
3 hours ago, Tyko said:

I'm trying to use RCS thrusters as primary engines on a craft. They're not showing up in the KER staging or DV readouts though. I have the RCS thrusters set to "Fore by Throttle".

Is there a way to get them to show up?

In the VAB click the RCS button.

In flight RCS has a separate display to normal engines - it should be under the vessel tab (I think), or you can add it from the edit panels.

Link to post
Share on other sites
26 minutes ago, Gordon Dry said:

@Jognt worth an issue report

I only do issue reports when I'm damned sure I checked to see if I could reproduce a problem. Nobody wakes up thinking "Gee, I wish I could research an unconfirmed issue about something 'sometimes' not working 'maybe'!".

Feel free to narrow it down, but I'm not going to point a finger here. I don't have the time to make sure I can do a proper report atm.

Edited by Jognt
Link to post
Share on other sites
  • 3 weeks later...
5 hours ago, Krzysztof z Bagien said:

Deleting a section should require confirmation - I accidentaly clicked "delete" button and had to create "Randezvous" from scratch :(

Also, changing size via GUI size selector buttons resets colour of all entries to default green.

Yeah I can see how that would be a surprise! I'd have just reinstalled the whole mod, I admire your dedication to recreating it manually!

Link to post
Share on other sites

Anyone have an issue with the text going wonky? It was working fine under 1.7.3 and then all of a sudden the window in the editor cannot be resized/moved and it is about half the size it needs to be so it becomes unreadable. At the same time, the in-flight HUDs are about half the right width and are four times taller. Makes it super hard to read.

xBeNvU7BuTnjucohR9xXSWl1DkP2oGGRq_6Atkdr

HFXkUtMgK9PSCXLef9W55depAmx31OqBvnp_h2YV

Homer

Link to post
Share on other sites
On 7/24/2019 at 4:20 PM, Jognt said:

Yeah I can see how that would be a surprise! I'd have just reinstalled the whole mod, I admire your dedication to recreating it manually!

Well, I have a lot of other things customised, so it was faster that way :D

 

On 7/24/2019 at 2:13 PM, Gordon Dry said:

@Krzysztof z Bagien ofc you're right, but you could have created backups of the files inside GameData\KerbalEngineer\Settings\ as well :wink:

Yeah, I know. I guess it's true that there are two types of people - those who backup, and those who will backup :D

Link to post
Share on other sites
  • 3 weeks later...

Hello cybutek,

Congratulations for your excellent mod, but I found a problem on this function:

FILE: BuildAdvanced.cs #line 415

        private void DrawBurnTime()
        {
            GUILayout.BeginVertical(GUILayout.Width(75.0f * GuiDisplaySize.Offset));
            GUILayout.Label("BURN", titleStyle);
            for (int i = 0; i < stagesLength; ++i)
            {
                stage = stages;
                if (showAllStages || stage.deltaV > 0.0)
                {
                    GUILayout.Label(TimeFormatter.ConvertToString(stage.time), infoStyle);
                }
            }
            GUILayout.EndVertical();
        }

If the burn time is bigger than 24h, the value will be zero, can you please fix it? or just print on console log the stage.time

 

Many thanks in advance!

 

Edited by pmborg
Link to post
Share on other sites
  • 2 weeks later...

Hey folks, I decided to get back into KSP after a long hiatus, and I'm having a problem with the latest version of KER (i.e. the one on jrbudda's github). It is active and works in the Tracking Station, but the button is greyed out in the VAB and while in flight so I can't use it. KSP with both DLCs. Any ideas what's going on?

Link to post
Share on other sites
9 hours ago, stratvox said:

Hey folks, I decided to get back into KSP after a long hiatus, and I'm having a problem with the latest version of KER (i.e. the one on jrbudda's github). It is active and works in the Tracking Station, but the button is greyed out in the VAB and while in flight so I can't use it. KSP with both DLCs. Any ideas what's going on?

It works fine on my 1.7.3 install :/, other than that I don’t know how to troubleshoot further than ‘reinstall’, sorry. 

Link to post
Share on other sites
On 8/25/2019 at 10:16 AM, stratvox said:

Hey folks, I decided to get back into KSP after a long hiatus, and I'm having a problem with the latest version of KER (i.e. the one on jrbudda's github). It is active and works in the Tracking Station, but the button is greyed out in the VAB and while in flight so I can't use it. KSP with both DLCs. Any ideas what's going on?

I second this issue, it started today and is related to this mod. The only thing I have done today was to install some USI mods that were updated to the current version of the game. Uninstalled everything and did a fresh install of the game and mods, same issue.

 

When I click the rendevouz button the mod bug and the grey bar shows up along other graphical glitches, the game gets slow, really slow and get stuck on the loading screen once i leave the ship. The planets move on the loading button, but it do not get anywhere.

 

Maybe is some change on the module manager or other support mod that got incompatible with this one?

Edit: Tried an older version the mod from github, same issue.

 

Edit 2: Dont ask me why, BUT I FOUND THE ISSUE. There is an incompatibility between this mod and Transfer Window Planner that got updated today. I removed it and it is solved.

Edited by Kadrush
found the issue
Link to post
Share on other sites
  • 2 weeks later...
  • 1 month later...

I'm getting something weird, the Hud 1 and 2 don't keep their transparency when I set it. Sometimes one works but the other one doesn't. If I set them that way and put each hud in its own area on the screen, if I leave game and come back in they will be jointly together and not transparent anymore.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...