cybutek

[1.3.0] Kerbal Engineer Redux 1.1.3.0 (2017-05-28)

Recommended Posts

On 8/26/2012 at 10:42 AM, cybutek said:

Note that by default KER runs using a career unlock system. This means that when in career mode it will require either an Engineer skilled Kerbal, an Engineer Chip/ER7500 part placed on the vessel or a level 3 tracking station to work in flight. Unless one of these three conditions is present, the KER icon will be disabled and greyed out in flight. This mode is completely optional though, and by clicking on "Settings" on the Kerbal Engineer Redux window in the editor, you may change its mode from "Career" to "Partless".

@PeaceFighter

Share this post


Link to post
Share on other sites

There is a problem in KER: when you mix engines with different fuels at the same stage, ISP calculates incorrectly. A mix of liquid and solid fuels in stock produces small difference: 238 instead of 231:

iv3fPLB.jpg

But differense can be significantly greater when you mix LF and LH2, 410 instead of 344 as an example. It's a common problem with different fuels at one stage, both in stock and mods. Error in ISP leads to error in dV.

Share this post


Link to post
Share on other sites
40 minutes ago, Marschig said:

There is a problem in KER: when you mix engines with different fuels at the same stage, ISP calculates incorrectly. A mix of liquid and solid fuels in stock produces small difference: 238 instead of 231:

iv3fPLB.jpg

But differense can be significantly greater when you mix LF and LH2, 410 instead of 344 as an example. It's a common problem with different fuels at one stage, both in stock and mods. Error in ISP leads to error in dV.

What makes you think it is KSP that is right? How did you do the math?

Share this post


Link to post
Share on other sites

. Been using this mod since almost the start of my KSP gaming, tis great. Appears there is a bug with HUD2 coordinates when using high resolution.

Yesterday, I upgraded to 4k = 2560 x 1440

After upgrading the Hud2 gets displayed over the top of the compass in middle of screen. Any chance of fixing this? I can test any fix if you don't have 4k.

 

Please see here hud2 issue here: https://steamcommunity.com/sharedfiles/filedetails/?id=2021195933

Share this post


Link to post
Share on other sites

@fragtzack have you tried to use the "edit" button next to the "HUD2" button to move the window? These HUD elements don't have a fixed position, you can place them everywhere you want.

 

PS: 2560x1440 is the "2k" resolution (WQHD), 4k would be 3840 x 2160 ;)

Share this post


Link to post
Share on other sites
1 hour ago, 4x4cheesecake said:

@fragtzack have you tried to use the "edit" button next to the "HUD2" button to move the window? These HUD elements don't have a fixed position, you can place them everywhere you want.

 

PS: 2560x1440 is the "2k" resolution (WQHD), 4k would be 3840 x 2160 ;)

Much thanks!

Share this post


Link to post
Share on other sites

Perhaps I'm being stupid but very related to moving the HUDS- how can I expand them, so the text doesn't overlap lines? Many thanks in advance!

 

4P1MHph.png

Share this post


Link to post
Share on other sites
On 3/17/2020 at 12:47 PM, Aurochs said:

Perhaps I'm being stupid but very related to moving the HUDS- how can I expand them, so the text doesn't overlap lines? Many thanks in advance!

 

There is a larger control panel that should be either on your screen, or accessible by clicking on the engineer buttons on the side of the screen. In addition to having options to change what's displayed on the HUD and the font size, there should also be a button that allows you to move their position.

Share this post


Link to post
Share on other sites
On 3/20/2020 at 10:04 PM, proteasome said:

There is a larger control panel that should be either on your screen, or accessible by clicking on the engineer buttons on the side of the screen. In addition to having options to change what's displayed on the HUD and the font size, there should also be a button that allows you to move their position.

Thanks- I had no luck whatsover, so ultimately deleted the "GuiDisplaySize" file from the KerbalEngineer Settings folder. When I restarted the game the HUDs were back to normal. Thanks for the help.

Share this post


Link to post
Share on other sites

Is it just me, or do the KER presets have some readouts that are not listed in the KER view editor?

For example, the default LAND view has the Impact marker readout enabled, but the impact marker readout doesn't seem to be listed under any of the categories in the KER view editor. There are other similarly missing readouts too, but I haven't compiled a list yet.

This currently makes it impossible to add those readouts to custom views, or to get them back if (accidentally) removed, short of resetting to a default configuration.

I tried searching this forum thread, but couldn't find anything on this.

I have KSP 1.9.1 on Linux, with KER 1.1.7.1... and a couple dozen other mods. If this is not a known issue, I could make a clean install with just KER, and post the logs.

Share this post


Link to post
Share on other sites

This may be a silly question...

Is there an Air Speed readout?  I mean, the speed (velocity?  It's early please don't judge) that is on the navball readout when you launch is a combination of both the horizontal and the vertical speeds, effectively early at launch as being the speed vs the still atmospheric air?

So is there a readout that tells me my speed?

Thanks.

Share this post


Link to post
Share on other sites
44 minutes ago, theJesuit said:

This may be a silly question...

Is there an Air Speed readout?  I mean, the speed (velocity?  It's early please don't judge) that is on the navball readout when you launch is a combination of both the horizontal and the vertical speeds, effectively early at launch as being the speed vs the still atmospheric air?

So is there a readout that tells me my speed?

Thanks.

I'm not too sure what you mean by this - you can see the vertical and horizontal speeds separately in the HUD on the right by default. Is this what you were looking for?

Share this post


Link to post
Share on other sites
1 hour ago, pt1243 said:

I'm not too sure what you mean by this - you can see the vertical and horizontal speeds separately in the HUD on the right by default. Is this what you were looking for?

I'm looking for the same number that displays on the navball.  Surface speed which is the combination of horizontal and vertical speed?  I guess the velocity relative to the surface.

Share this post


Link to post
Share on other sites
8 hours ago, theJesuit said:

I'm looking for the same number that displays on the navball.  Surface speed which is the combination of horizontal and vertical speed?  I guess the velocity relative to the surface.

Ah - that makes sense. As far as I can see, I don't think there is a readout for this, unfortunately.

Share this post


Link to post
Share on other sites
18 hours ago, peteletroll said:

@Technologicat, the impact marker is definitely there, I always use it.

I tried again last night, and... lo and behold, Impact marker was there, in the Surface category, where it belongs. Got it, now I have it in HUD2. Problem solved. (Having it in the HUD allows easily disabling the bullseye marker during EVA. Having the marker is useful when flying long distances with the jetpack, but it's mostly a distraction when you're just trying to jump into your lander's cargo hold to retrieve some equipment.)

So it may have been just me. Thanks for the reply.

Another readout I couldn't find in any of the categories of the editor the other night is the compact combined stage/total dV, which is displayed in HUD1 by default. Other dV readouts are listed, though. I'll look again when I get the chance and report back.

Share this post


Link to post
Share on other sites
On 3/1/2020 at 2:55 PM, Marschig said:

There is a problem in KER: when you mix engines with different fuels at the same stage, ISP calculates incorrectly. A mix of liquid and solid fuels in stock produces small difference: 238 instead of 231:

iv3fPLB.jpg

But differense can be significantly greater when you mix LF and LH2, 410 instead of 344 as an example. It's a common problem with different fuels at one stage, both in stock and mods. Error in ISP leads to error in dV.

I too seem to be experiencing this problem, the first stage of my rocket dV seems way off, mixing rocket types (solid & liquid) doesn't seem to display the dV for that stage correctly, for some reason the stage that has the attached decoupler seems to display some dV even though the boosters that are attached to them are in the previous stage?

Share this post


Link to post
Share on other sites
2 hours ago, Ham Hock said:

for some reason the stage that has the attached decoupler seems to display some dV even though the boosters that are attached to them are in the previous stage?

Your center stage has a longer burn time then your boosters, so the dV displayed in Stage 0 is the dV of your center stage after decoupling the boosters ;)

Share this post


Link to post
Share on other sites

Hello, thanks for any ideas about this ...

I'm using KSRSS (a 2.5x RSS) and trying to use KER to get a proper launch window to the moon. I've set the Moon as my target. However, the "Relative Inclination" readout on the Rendezvous HUD displays some static value while you're still on the launchpad, and doesn't start updating until you lift off.

My (limited) understanding is that I should wait until the relative inclination of the Moon is close to 0 before launch ... but if that value never updates, I don't know how to do that. Am I doing something dumb?

Share this post


Link to post
Share on other sites

Getting continuous log spam from KER in the VAB and during flight. Using 1.8.1 and JNSQ. Any ideas what could be causing this? I can provide the full log if needed.

 

Spoiler

[LOG 23:23:36.813] VesselSimulator -> SimManager.StartSimulation() // routine is null
[LOG 23:23:36.813] VesselSimulator ->   at UnityEngine.MonoBehaviour.StartCoroutine (System.Collections.IEnumerator routine) [0x00007] in <5aeafee3fea24f37abd1315553f2cfa6>:0 
  at KerbalEngineer.VesselSimulator.SimManager.StartSimulation () [0x000f1] in <979676d180724d169128060aa6bde65d>:0 
[LOG 23:23:36.982] VesselSimulator -> SimManager.StartSimulation() // routine is null
[LOG 23:23:36.982] VesselSimulator ->   at UnityEngine.MonoBehaviour.StartCoroutine (System.Collections.IEnumerator routine) [0x00007] in <5aeafee3fea24f37abd1315553f2cfa6>:0 
  at KerbalEngineer.VesselSimulator.SimManager.StartSimulation () [0x000f1] in <979676d180724d169128060aa6bde65d>:0 
[LOG 23:23:37.148] VesselSimulator -> SimManager.StartSimulation() // routine is null
[LOG 23:23:37.148] VesselSimulator ->   at UnityEngine.MonoBehaviour.StartCoroutine (System.Collections.IEnumerator routine) [0x00007] in <5aeafee3fea24f37abd1315553f2cfa6>:0 
  at KerbalEngineer.VesselSimulator.SimManager.StartSimulation () [0x000f1] in <979676d180724d169128060aa6bde65d>:0 
[LOG 23:23:37.314] VesselSimulator -> SimManager.StartSimulation() // routine is null
[LOG 23:23:37.314] VesselSimulator ->   at UnityEngine.MonoBehaviour.StartCoroutine (System.Collections.IEnumerator routine) [0x00007] in <5aeafee3fea24f37abd1315553f2cfa6>:0 
  at KerbalEngineer.VesselSimulator.SimManager.StartSimulation () [0x000f1] in <979676d180724d169128060aa6bde65d>:0 
[LOG 23:23:37.484] VesselSimulator -> SimManager.StartSimulation() // routine is null
[LOG 23:23:37.484] VesselSimulator ->   at UnityEngine.MonoBehaviour.StartCoroutine (System.Collections.IEnumerator routine) [0x00007] in <5aeafee3fea24f37abd1315553f2cfa6>:0 
  at KerbalEngineer.VesselSimulator.SimManager.StartSimulation () [0x000f1] in <979676d180724d169128060aa6bde65d>:0 
[LOG 23:23:37.651] VesselSimulator -> SimManager.StartSimulation() // routine is null
[LOG 23:23:37.651] VesselSimulator ->   at UnityEngine.MonoBehaviour.StartCoroutine (System.Collections.IEnumerator routine) [0x00007] in <5aeafee3fea24f37abd1315553f2cfa6>:0 
  at KerbalEngineer.VesselSimulator.SimManager.StartSimulation () [0x000f1] in <979676d180724d169128060aa6bde65d>:0 
[LOG 23:23:37.821] VesselSimulator -> SimManager.StartSimulation() // routine is null
[LOG 23:23:37.821] VesselSimulator ->   at UnityEngine.MonoBehaviour.StartCoroutine (System.Collections.IEnumerator routine) [0x00007] in <5aeafee3fea24f37abd1315553f2cfa6>:0 
  at KerbalEngineer.VesselSimulator.SimManager.StartSimulation () [0x000f1] in <979676d180724d169128060aa6bde65d>:0 
[LOG 23:23:37.986] VesselSimulator -> SimManager.StartSimulation() // routine is null
[LOG 23:23:37.986] VesselSimulator ->   at UnityEngine.MonoBehaviour.StartCoroutine (System.Collections.IEnumerator routine) [0x00007] in <5aeafee3fea24f37abd1315553f2cfa6>:0 
  at KerbalEngineer.VesselSimulator.SimManager.StartSimulation () [0x000f1] in <979676d180724d169128060aa6bde65d>:0 
[LOG 23:23:38.151] VesselSimulator -> SimManager.StartSimulation() // routine is null
[LOG 23:23:38.152] VesselSimulator ->   at UnityEngine.MonoBehaviour.StartCoroutine (System.Collections.IEnumerator routine) [0x00007] in <5aeafee3fea24f37abd1315553f2cfa6>:0 
  at KerbalEngineer.VesselSimulator.SimManager.StartSimulation () [0x000f1] in <979676d180724d169128060aa6bde65d>:0 

 

Share this post


Link to post
Share on other sites

Hello, I apparently found a bug. Running  KER 1.1.7.1 on Win10

In the VAB, several parts do not display mass property in mouse wheel click pop-up information. More importantly, these parts also are not calculated in the torque values in the KER stage data table. Placing these off the engine thrust line should obviously cause non-zero torque and it does for other parts. There are lighter parts down to 5 kg that do have mass in the pop-up information and also affect torque values, so there isn't some general lower mass limit for parts to be included.

communotron 88-88

communotron 16

communotron 16-S

RV-105 RCS thruster

Vernor thruster

barometer

thermometer

Gravmax

Double-C seismic

BZ-52 radial attachment point

Kelus-LV ladder

EAS-4 strut connector

I didn't check every part, may be more. Oddly, the total ship mass seems correct. It changes as the listed parts are added and also matches the total KSP gives at the lower right. 

Share this post


Link to post
Share on other sites

For whatever reason, those parts are programmed to add their mass to the parent part rather than the part that is actually attached.  Due to this they won't affect the CoM by much unless their parent part is offset.

Share this post


Link to post
Share on other sites

Wow. That's so random. Why some parts and not the others? The stock game doesn't even tell you the torque, so how would anybody know this and get a ship balanced? Especially a small xenon science probe.

Thanks for the info. I'll chalk it up to another KSP annoyance. It would be nice for a workaround if KER displayed "mass: parent" or "mass: self".  It also would be nice if it displayed the parts' temperature ratings, BTW. 

 

Share this post


Link to post
Share on other sites
Posted (edited)
Why some parts and not the others?


The corresponding property is PhysicsSignificance.
If not present in a part's configuration, it defaults to zero, so deleting it or explicitly setting it to zero reverts the behaviour, with all consequences: the part's mass is treated as you might expect it, as are forces acting upon the part.
This increases the amount of calculations necessary, and that's the main reason why it was introduced–to simplify physics calculations for parts deemed too insignificant to require accurate physical simulation, and in turn speed up the game.
It's trivial to edit directly or (preferably) modify with a ModuleManager patch. Just don't be surprised when you experience FPS drops ;)
Edited by Corax
FPS caution

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.