cybutek

[1.3.0] Kerbal Engineer Redux 1.1.3.0 (2017-05-28)

Recommended Posts

Version 0.6.2.0 is now available!

Integration with Blizzy78's Toolbar Plugin and multi-mode engine support (e.g. R.A.P.I.E.R.) are the two big changes.

Have fun! :)

Share this post


Link to post
Share on other sites
Version 0.6.2.0 is now available!

Integration with Blizzy78's Toolbar Plugin and multi-mode engine support (e.g. R.A.P.I.E.R.) are the two big changes.

Have fun! :)

Any word on the ^V going wonky with KW Rocketry getting fixed?

Share this post


Link to post
Share on other sites
Any word on the ^V going wonky with KW Rocketry getting fixed?

Simple answer is that if KW Rocketry is adhering to the stock system then it will work perfectly fine just like any other engine. KW Rocketry has not yet been updated for 0.23, that's more than likely where the problem lies.

Share this post


Link to post
Share on other sites

Hey, great to see toolbar support implemented :)

I just found a minor thing that triggered a bug in the toolbar: While the pause menu is open, KER would remove its button from the toolbar. This will make the toolbar disappear from the screen completely if it is currently being positioned at the right or bottom screen edge, and if it is also currently in auto-hidden mode.

While that bug is completely on my end, there is no real need to remove the button while the pause menu is open. Instead, I think I will modify the toolbar implementation so that all buttons will be disabled while the pause menu is open.

Share this post


Link to post
Share on other sites
Hey, great to see toolbar support implemented :)

I just found a minor thing that triggered a bug in the toolbar: While the pause menu is open, KER would remove its button from the toolbar. This will make the toolbar disappear from the screen completely if it is currently being positioned at the right or bottom screen edge, and if it is also currently in auto-hidden mode.

While that bug is completely on my end, there is no real need to remove the button while the pause menu is open. Instead, I think I will modify the toolbar implementation so that all buttons will be disabled while the pause menu is open.

Thanks for the info. Helped track down a small issue in KER as well. OnUpdate isn't called when the pause menu is up, changed it to use Unity's base Update method and it now works as intended on my end :)

By the way, KER was not removing the button. It's just that while the pause menu was up the isActive flag was not being set. This is because the OnUpdate method was not being called. The visibility of the button is being set using isActive, which basically is set to whether there is an engineer system on the current vessel or not. As there's no need to show a KER button if there's not one attached to the vessel. So to narrow down your search, the bug in the toolbar is not with the removal of buttons, but the visibility of them. This bug should still be re-producible by switching between crafts with and without engineer, if that is the case. Hopefully this short blurb on how the system is working my end helps with your bug tracking.

If you need any more info, just ask away.

Share this post


Link to post
Share on other sites
the bug in the toolbar is not with the removal of buttons, but the visibility of them.

Right, that's what I actually meant :)

Just another thing: Would it be possible to not require one of the parts be attached to the vessel if the toolbar is available? I think the parts look really great, but personally I always just attach them to get the KER window, then remove them before actual flight. I don't really have a use for them. I'd rather just click the toolbar button and get the window when I need it.

Share this post


Link to post
Share on other sites
Right, that's what I actually meant :)

Just another thing: Would it be possible to not require one of the parts be attached to the vessel if the toolbar is available?

A part less build engineer is already a feature in the 1.0 dev build, although I've not had time to update it to 0.23 yet. Feature improvements are very low priority for v0.6 unless it's something that can be ported over to 1.0 (hence why the integration with your mod is via a separate dll). When I do work on KER, it's usually v1.0. :)

Share this post


Link to post
Share on other sites

Digging deeper, I find there are more issues with the way KER uses the Toolbar Plugin:

- It uses [KSPAddon] in a way that does not work. You cannot add enum values like that. The result here is that while the value of Startup.EditorAny is -3, and Startup.Flight is 7, OR-ing them together like that results in -1, which is the same as simply stating Startup.EveryScene. This isn't bad in itself, but it is probably not what you meant.

- So the button is added to the toolbar in every scene, but it will only have a texture (icon) if the current game scene is either an editor or the flight scene. The end result is that the toolbar gets a new button right at the main menu, but without an icon.

My suggestion would be this:

- Change the [KSPAddon] line to explicitly use Startup.EveryScene.

- Use IButton.Visibility with GameScenesVisibility to restrict the display of the button to the scenes you want (EDITOR, SPH, and FLIGHT.) You may ignore IButton.Visible when you use IButton.Visibility instead.

- Always set a texture for the button, regardless of game scene.

- Always add a (single) click handler to the button, regardless of game scene.

Share this post


Link to post
Share on other sites

I noticed this today: more than 360 degrees when looking at my surface display. I'm not sure if anyone else has seen this, or if it's even specific to Engineer or a gamewide bug. Just thought I'd post it here.

cSNdjMG.png

Share this post


Link to post
Share on other sites
My guess is wrap-around.. Just modulo with 360

but this is just a guess. ksp is messy with numbers like this.

It's not a huge issue; more of an annoyance for planning precision injections and landings.

Share this post


Link to post
Share on other sites
Simple answer is that if KW Rocketry is adhering to the stock system then it will work perfectly fine just like any other engine. KW Rocketry has not yet been updated for 0.23, that's more than likely where the problem lies.

Awesome, I had a feeling it was on KW's end but wasn't sure! Thanks for the reply :) At least it calculates correctly on the launch pad which will do as a workaround I suppose.

EDIT: The toolbar integration is awesome by the way, thanks for doing that. And thanks to Blizzy for making it. Such a good idea.

Share this post


Link to post
Share on other sites
Right, that's what I actually meant :)

Just another thing: Would it be possible to not require one of the parts be attached to the vessel if the toolbar is available? I think the parts look really great, but personally I always just attach them to get the KER window, then remove them before actual flight. I don't really have a use for them. I'd rather just click the toolbar button and get the window when I need it.

There is also a mod to add Engineer 6 to every command pod without the need for parts here: Spaceport

Share this post


Link to post
Share on other sites
There is also a mod to add Engineer 6 to every command pod without the need for parts here: Spaceport

With your mod to add KER 0.6 to all command pods coupled with the toolbar, it essentially makes KER completely part less whilst giving you the option of having it on or not. It's nice when things just come together and compliment nicely :)

Share this post


Link to post
Share on other sites

Will we ever get KER with a "closest approach to target" table like Protractor has? Trying to adjust that while using the system map is a nightmare and often inaccurate for me. It's a huge pain when I already have a peridune and I'm trying to get it lower; they overlap and I'm often unable to view the new estimated peridune. It would just be easier to incorporate the functionality of that mod with KER than to have two separate ones.

Share this post


Link to post
Share on other sites

I'm having an issue with the toolbar integration. If KER is disabled through the toolbar in the VAB, the area that KER uses in the VAB isn't 'freed'. As in it behaves as if it wasn't disabled, not letting parts move through that area and dimming the function buttons (Parts, AG, Crew, New Craft, Load Craft, Save and Launch) when mousing over the area. Is there a workaround for this?

Edited by Hetsin

Share this post


Link to post
Share on other sites
I'm having an issue with the toolbar integration. If KER is disabled through the toolbar, the area that KER uses in the VAB isn't 'freed'. As in it behaves as if it wasn't disabled, not letting parts move through that area and dimming the function buttons (Parts, AG, Crew, New Craft, Load Craft, Save and Launch) when mousing over the area. Is there a workaround for this?

Sounds like a bit of a strange bug... I'll look into it. Not sure of any workarounds if it's working as you say it is.

Share this post


Link to post
Share on other sites
There is also a mod to add Engineer 6 to every command pod without the need for parts here:

Personally I don't see the need to have KER be a PartModule at all.

Share this post


Link to post
Share on other sites

I'm experiencing alot of lag spikes whenever KER re-calculates it's values. It's not keeping up real time anymore and when it catches up it's about 5 seconds of waiting. I also have Editor extensions, KAS, Kethane, Navyfish (docking assistant) and RCS Build Aid installed. Any ideas?

Share this post


Link to post
Share on other sites
I'm experiencing alot of lag spikes whenever KER re-calculates it's values. It's not keeping up real time anymore and when it catches up it's about 5 seconds of waiting. I also have Editor extensions, KAS, Kethane, Navyfish (docking assistant) and RCS Build Aid installed. Any ideas?

I've got those mods (and more) installed and haven't seen any lag of the magnitude you're describing. The only bug I seem to be hitting is that sometimes the delta-v calculator just stops calculating. (This is with Realism Overhaul and Modular Fuels if that helps.) It's not a game-breaker for me since I use MechJeb now for delta-v calculations -- I need that sea-level-thrust indicator when building my launch stage. I still use KER during orbital flight.

Share this post


Link to post
Share on other sites

I was building a rocket with some RAPIERS as boosters when the readouts went blank, reloading the game didn't help.

6slROFU.jpg

Other mods installed:

KSP Interstellar .9.1.1

Procedural Fairing 2.4.3

Novapunch 2.03a

Kerbal Joint Reinforcements 1.5

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.