cybutek

[1.3.0] Kerbal Engineer Redux 1.1.3.0 (2017-05-28)

Recommended Posts

Can you tell me how do disable or at least make toggle-able the mouse over part data showing up in the VAB? I can't seem to make it go away even if I switch engineer to require the module while not having the module on the ship. If I missed it somewhere, sorry but I promise i did look. If I didn't a toggle in the settings menu would be wonderful. I love the new 1.0+ engineer, but this little thing is just making me nuts. :P

Thanks.

Share this post


Link to post
Share on other sites
Can you tell me how do disable or at least make toggle-able the mouse over part data showing up in the VAB? I can't seem to make it go away even if I switch engineer to require the module while not having the module on the ship. If I missed it somewhere, sorry but I promise i did look. If I didn't a toggle in the settings menu would be wonderful. I love the new 1.0+ engineer, but this little thing is just making me nuts. :P

Thanks.

For the time being you can edit the BuildOverlay.xml settings file and set the visibility to false.

Also for people with flickering issues... The fix for this bug is fairly straight forward and will be implemented next update.

Share this post


Link to post
Share on other sites

Ohh, it's KER adding the part stats? I saw them, thought they were really pretty cool. It's great that it shows the stats in the staging list as well. I just like it in general, really :)

Share this post


Link to post
Share on other sites

I am seeing a terminal velocity on the surface tab with FAR installed on 1.0.2. I figured it was because of the new FARAPI that was added to far. The problem is that it has no relation to the numbers in FAR and also seems unrelated to stock. The listed terminal is huge and rapidly gets huger. I think around 5km above the surface the terminal is approaching 10kps.

Share this post


Link to post
Share on other sites

The new v1.0 version is fantastic and thanks ever so much for the built-in partless functionality!

Share this post


Link to post
Share on other sites

I'm pretty new to KSP and mods in general, and I haven't been able to find an answer via search, so I apologize in advance if this is a silly question or has already been answered previously.

When I install this mod, it makes my UI vanish in the VAB and Spaceplane hangar; only the miniature 3D model icons float in mid air, with no transparent blue background or boxes around them, or scroll bar, tabs, etc. My frames per second also plummets, and the game crashes within seconds (if it hasn't already crashed when attempting to load the VAB or Spaceplane area).

Has anyone encountered similar problems in the past and know what may cause this issue?

Share this post


Link to post
Share on other sites

While i totally like the new release (thanks for your continued work on this, it just keeps getting better!), the missing backwards might be a problem.

For those who are struggling: HERE is a download with the old "EngineerFlightChip" part model (i have removed all modules from the part, so its really just a small part that does nothing - but it allows you to load those old saves with flights containing the Flight Engineer part. Just dump the folder into the "Parts" subfolder of KerbalEngineer.

@cybutek: Maybe consider putting that part up as a seperate "backwards compatibility download"?

Share this post


Link to post
Share on other sites
I'm pretty new to KSP and mods in general, and I haven't been able to find an answer via search, so I apologize in advance if this is a silly question or has already been answered previously.

When I install this mod, it makes my UI vanish in the VAB and Spaceplane hangar; only the miniature 3D model icons float in mid air, with no transparent blue background or boxes around them, or scroll bar, tabs, etc. My frames per second also plummets, and the game crashes within seconds (if it hasn't already crashed when attempting to load the VAB or Spaceplane area).

Has anyone encountered similar problems in the past and know what may cause this issue?

I've not seen this before but your description would indicate there should be errors in your output_log.txt (in KSP_Data or KSP_x64_Data). Can you find this file and, after one of these crashing runs of KSP, upload the file somewhere and post a link? Also, let us know which version of "this mod" you installed, what version of KSP you are running, what you actually did to install it and what other mods you have installed (if any).

Share this post


Link to post
Share on other sites

DeltaV varies with atmospheric pressure (because most engines have a lower Isp in atmosphere than in vacuum). The VAB is currently showing you the stats for in-vacuum. If you click the "Atmospheric" button the values will be much closer (though the "flight" ones will still be very slightly higher as the VAB uses 0m altitude and your craft on the pad is slightly higher so the atmospheric pressure is slightly less.

Edited by Padishar

Share this post


Link to post
Share on other sites

When I look at my "Delta-V" Column I see two different Delta-V's, divided by a slash.

What does each number mean?

Thank you for your time! Great plugin!

Edited by herman
Improved my question

Share this post


Link to post
Share on other sites

The new version 1.x looks great. Love the new options. But I am missing a few things, most important the "time to ascending / descending node" in the rendevousz-window and the burn time of each stage in the vessel-window. Or maybe I am just blind and cant find it in the new menus. :D

Anyway, keep up the great work. And many thanks! :)

Share this post


Link to post
Share on other sites

I miss time left on stage at current thrust next to delta V. I used it all the time to judge when I was going to need to stage and also how worried I should be when landing.

Share this post


Link to post
Share on other sites
I miss time left on stage at current thrust next to delta V. I used it all the time to judge when I was going to need to stage and also how worried I should be when landing.

I miss this as well!

Share this post


Link to post
Share on other sites
I miss time left on stage at current thrust next to delta V. I used it all the time to judge when I was going to need to stage and also how worried I should be when landing.

I miss that too

Share this post


Link to post
Share on other sites
DeltaV varies with atmospheric pressure (because most engines have a lower Isp in atmosphere than in vacuum). The VAB is currently showing you the stats for in-vacuum. If you click the "Atmospheric" button the values will be much closer (though the "flight" ones will still be very slightly higher as the VAB uses 0m altitude and your craft on the pad is slightly higher so the atmospheric pressure is slightly less.

Thank you, this seems to be more accurate.. miss the old setting

Share this post


Link to post
Share on other sites
Thank you, this seems to be more accurate.. miss the old setting

Errr, what old setting? This works exactly as it did in 0.6.x.x...

Share this post


Link to post
Share on other sites

Please please please. Add the ability to add custom rendevouz point by entering coordinates so they show up on the nav ball!

This gives me the ability to go into SCANsat to get coordinates for a certain point on a planet and then use KER to be able to locate it!

Thanks for a great mod otherwise.

Share this post


Link to post
Share on other sites
For some strange reason, Kerbal Engineer isn't showing up in the toolbar. And ideas?

You will, at the very least, have to tell us which version of this mod you have tried to install, which version of KSP you have installed it in, which toolbar you are talking about and upload your output_log.txt somewhere and post a link... This is really the absolute minimum of information you should submit with any bug report. Obviously a description of what isn't working (with screenshots where helpful) is also required and a description of any particular sequence of actions that are required for it to go wrong would be very helpful.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.