cybutek

[1.3.0] Kerbal Engineer Redux 1.1.3.0 (2017-05-28)

Recommended Posts

Is it just me, or is KER not working? I downloaded, unzipped it, and threw the folder on to the game data file on ksp. But for some reason, I have the parts to put on my ship, but they have no effect. I don't get the pop up menu with all the information on it....

Anyone have a fix?

What version are you running? Do you have any log files?

Share this post


Link to post
Share on other sites
What version are you running? Do you have any log files?

I am running the latest version ( downloaded literally 3 days ago) and I have no other mods running....

Share this post


Link to post
Share on other sites

Skylid,

There are two current versions, both of which were updated today. Since you have the parts, but the plugin isn't working, my best guess is that you installed whatever version you have incorrectly. Exactly what the installation looks like depends on which version you're using.

If the installation wasn't the problem, then you'll need to supply some information to get any help:

  • Your KSP version
  • Your KER version
  • Your Operating System and version
  • Steps to cause the problem
  • Cause the problem, then quit KSP and find your output log:
    • Windows (32 bit): KSP_win\KSP_Data\output_log.txt
    • Windows (64 bit): KSP_win64\KSP_x64_DATA\output_log.txt
    • Mac OS X: Open Console, find Unity on the left side, and click on Player.log. It's also located at ~/Library/Logs/Unity/Player.log.
    • Linux: ~/.config/unity3d/Squad/Kerbal\ Space\ Program/Player.log

Share this post


Link to post
Share on other sites

ninja'd by Master Tao

His post is also a lot more verbose and informative than mine was, so look ^^^ up :D

Edited by cybutek

Share this post


Link to post
Share on other sites

cybutek, thanks for the update, and I assume you're on top of it, but I felt I should mention that the OP is still showing 1.0.3 =)

Share this post


Link to post
Share on other sites
cybutek, thanks for the update, and I assume you're on top of it, but I felt I should mention that the OP is still showing 1.0.3 =)

Hahaha, thanks for letting me know... With so many things to sort out on each update, something's bound to go amiss at some point. It probably would of stayed like that until the next update without your keen eyes :D

Share this post


Link to post
Share on other sites

Ha! I think you can credit NathanKell with that ninja. I lifted the form response idea from his posts.

Share this post


Link to post
Share on other sites
"Time to ascending / descending node" in target-mode not going to come back in 1.XX? :(

Don't fret... They will be coming back, along with a load of others. :)

Share this post


Link to post
Share on other sites

Version 1.0.5 is now available!

Added: Acceleration readout to the Vessel category (current / maximum).

Added: Category library system for the Flight Engineer readouts.

Added: Drop-down category selection to better support the new system.

Changed: Misc category now called Miscellaneous (this will cause previously added readouts from this category to vanish).

Fixed: Bug with the Build Engineer toolbar button.

Fixed: Some buggyness when trying to close the bodies drop-down in the Build Engineer via the button.

Fixed: Flight Engineer toolbar menu now hides when hiding the GUI with F2.

Fixed: Flight Engineer toolbar button now disables when in module mode and no engineer is running.

Note the change in name of the Misc catagory to Miscellaneous.. This means that all your separators and gui size adjusters that have been installed will vanish and require putting in again, sorry.

The category library system has now been fully implemented. This is going to make it much easier to create packs of readouts. So they will not have to be shoved in the Orbital, Surface... categories. Think readout pack devoted to just information for FAR :wink:

Share this post


Link to post
Share on other sites
Hey, were can you get Version 1.0.5? I just tried to install 0.6.2.9 and I got the same problem the guy two pages back was having

All the links for it are on the first post.

Share this post


Link to post
Share on other sites
Hey, were can you get Version 1.0.5? I just tried to install 0.6.2.9 and I got the same problem the guy two pages back was having

You can get 1.0.5 from the links in the first post. If you want to use 0.6.2.9 (e.g. you have old saves with vessels that have the old parts on) then you should probably get my experimental patch too (especially if you're having the same issue as Immashift was).

Edit: If you mean the problem that Skylid was having then I suggest you follow the advice he was given and upload your output_log.txt.

Edited by Padishar

Share this post


Link to post
Share on other sites

Just started using Real Fuels and noticed the TWR was off. A quick search shows this is a known problem. Was a fix ever released? Thanks for any help.

Share this post


Link to post
Share on other sites
Just started using Real Fuels and noticed the TWR was off. A quick search shows this is a known problem. Was a fix ever released? Thanks for any help.

The latest versions of KER should work fine with Real Fuels. What version of KER are you using? Can you provide screenshots that show the incorrect values (e.g. that show the KER window and the engine tweakable panels that show the engine thrust)?

Share this post


Link to post
Share on other sites

Kerbal Engineer 1.0.5.0. I think it might be user error. Looking for problems after loading 40 mods. I'm going to keep playing and see if I can't figure out my issue. I fly by the TWR and feel like I'm not getting the lift I should be.

Share this post


Link to post
Share on other sites
Kerbal Engineer 1.0.5.0. I think it might be user error. Looking for problems after loading 40 mods. I'm going to keep playing and see if I can't figure out my issue. I fly by the TWR and feel like I'm not getting the lift I should be.

If you're using RO, your thrust will reduce with atmospheric pressure. Are you accounting for that? KER will, if you click the atmospheric button in the VAB.

Share this post


Link to post
Share on other sites

Upgrading from Engineer 1.0.4 to 1.0.5 gives me a crash either during asset loading, or crash when loading the spacecenter from 'load game'

Crash always seems to occur at Load(Model): KerbalEngineer/Parts/EngineerChip/EngineerChip

[offending output_log of type-1 crash]

Rolled back to 1.0.4 and no crashes (so far)

Share this post


Link to post
Share on other sites
Upgrading from Engineer 1.0.4 to 1.0.5 gives me a crash either during asset loading, or crash when loading the spacecenter from 'load game'

Crash always seems to occur at Load(Model): KerbalEngineer/Parts/EngineerChip/EngineerChip

[offending output_log of type-1 crash]

Rolled back to 1.0.4 and no crashes (so far)

I confirm this issue.

Share this post


Link to post
Share on other sites

Did you completely delete version 1.0.4 before installing 1.0.5 or did you copy it over the top? It works perfectly fine for me after deleting 1.0.4 first...

Share this post


Link to post
Share on other sites

This is, without a doubt, the number one most important mod ever created for this game. It enables me to do maneuvers without relying on mechjeb. I have no idea how I was able to play KSP before because without it, the game is really terrible and is devoid of it's technicality. Why squad hasn't contacted and paid you to adopt it in the game is beyond me. So I just want to say thank you

Share this post


Link to post
Share on other sites
Did you completely delete version 1.0.4 before installing 1.0.5 or did you copy it over the top? It works perfectly fine for me after deleting 1.0.4 first...

Tried both (overwrite-existing-1.0.4 and delete 1.0.4 then install 1.0.5 clean), both give the same crash

Will try just updating the .dll's from 1.0.5 into 1.0.4 [Edit] Nope, this doesn't work either.

Edited by NoMrBond

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.