cybutek

[1.3.0] Kerbal Engineer Redux 1.1.3.0 (2017-05-28)

Recommended Posts

I also have noticed that sometimes entries are too long (deltav with burn time usually) and continue on next line but there is not enough space and they clip into next line making stuff unreadable. Is there a way to manually resize the window? I couldn't drag the corner etc :(

I've noticed this, too. Occurs whenever burn time exceeds one hour and dV is four digits or more. It looks like there's enough room for the readout but it still spills over. Not a big deal as the display can still be read, but it looks a bit unpolished.

Share this post


Link to post
Share on other sites
I also have noticed that sometimes entries are too long (deltav with burn time usually) and continue on next line but there is not enough space and they clip into next line making stuff unreadable. Is there a way to manually resize the window? I couldn't drag the corner etc :(

That problem is something that I have been pondering over for a while, but just not got around to doing anything about it. Resizing the windows is a no-go as it would just cascade down a whole new set of bigger problems, so that's out of the question, at least for now. The easiest solution would be to just have the burn time always show on a new line. Also because of how the readouts work, it could possibly be fixed by just making the space flexible. This'll be a little bit trial and error with finding the best solution that's aesthetically pleasing and functional. If anyone has some suggestions feel free to chuck them in the pot, as I'll more than likely fix this in the next update :D

I've noticed this, too. Occurs whenever burn time exceeds one hour and dV is four digits or more. It looks like there's enough room for the readout but it still spills over. Not a big deal as the display can still be read, but it looks a bit unpolished.

That probably is because it is unpolished :P

KER 1.0 is a public test after all... Not representative of the final product :D

Anyone who opts to download and use KER 1.0 should be buckled in to experience the development process, where updates are regular and new features are being constantly added. It also helps to have feedback such as above, as it lets me know what people are noticing and where the priorities should be.

Edited by cybutek

Share this post


Link to post
Share on other sites

I was checking phase angles on some satellites In my remote tech network and it seems like the phase angle readouts on the latest version (1.0.6) seem to be wrong. I also was checking the phase angles for setting up future launch windows and the phase angles didn't agree with what kerbal alarm clock was giving. Here are some of the phase angles that KER was giving me for the same reference satellite in my network. Also note that the distance parameter isn't returning a distance value either.

8sxpQCA.jpg

Share this post


Link to post
Share on other sites
I was checking phase angles on some satellites In my remote tech network and it seems like the phase angle readouts on the latest version (1.0.6) seem to be wrong. I also was checking the phase angles for setting up future launch windows and the phase angles didn't agree with what kerbal alarm clock was giving. Here are some of the phase angles that KER was giving me for the same reference satellite in my network. Also note that the distance parameter isn't returning a distance value either.

http://i.imgur.com/8sxpQCA.jpg

Thanks for the report, I'll take a look into what's actually causing this bug in a bit. Seems odd that the Distance is also 0, it is probably related and hopefully an easy fix.

Share this post


Link to post
Share on other sites

Is there any chance of having IntakeAir supply/demand added to the Vessel tab? This is a highly useful readout for jet powered craft that MJ can provide, but I'd rather get it from KER as the performance overhead seems less.

Share this post


Link to post
Share on other sites
Is there any chance of having IntakeAir supply/demand added to the Vessel tab? This is a highly useful readout for jet powered craft that MJ can provide, but I'd rather get it from KER as the performance overhead seems less.

I can definitely see about trying to sort out a readout which shows this :)

Share this post


Link to post
Share on other sites

In the VAB the Build Engineer Overlay shows the most important facts about the rocket: Delta-V and TWR.

I want to request that an additional info is displayed: the partcount.

Currenty I have three alternatives to get an info about the partcount that are all a bit bothersome: using mechjeb or saving and looking at the Load-Screen or counting.

Share this post


Link to post
Share on other sites

There's a simple question that's been bugging me for some time, and forum/google/reddit searches have yielded no results. What's the difference between the Build&Flight chip and the ER-7500 computer? I've noticed that the ER-7500 is significantly more expensive, is there anything to justify the cost other than the funky retro look? Thanks.

Share this post


Link to post
Share on other sites
I want to request that an additional info is displayed: the partcount.

That feature is already implemented for the GUI, just not turned on yet due to it not being a part of the simulation code. Considering that the simulation code is now going to be maintained on 1.0 and not 0.6, expect it to be implemented very soon :)

There's a simple question that's been bugging me for some time, and forum/google/reddit searches have yielded no results. What's the difference between the Build&Flight chip and the ER-7500 computer? I've noticed that the ER-7500 is significantly more expensive, is there anything to justify the cost other than the funky retro look? Thanks.

Absolutely no difference apart from the awesome looks :D

There's nothing stopping you from changing the cost in the part's config files.

Share this post


Link to post
Share on other sites
Absolutely no difference apart from the awesome looks :D

There's nothing stopping you from changing the cost in the part's config files.

Got it, thanks! There's no need to change the cost... in my mind ER-7500 is kerbalkind's Apple Inc.: you're paying for the brand, not the hardware ;)

Share this post


Link to post
Share on other sites
That feature is already implemented for the GUI, just not turned on yet due to it not being a part of the simulation code. Considering that the simulation code is now going to be maintained on 1.0 and not 0.6, expect it to be implemented very soon :)

That is great to hear - thanks. Perhaps include also an option to display it during flight.

Share this post


Link to post
Share on other sites
After installing 1.0.6 I now have 2 ker icons in the stock toolbar. One of them works and the other does nothing when I click it. I did completely remove the old version launch and save the game without it before installing this new one. None of my ships using the old one had the KER parts on them anyway since I use module manager to add the ker module, so I don't know why it's doing this.

Which old version did you remove? Was it a 0.6 series or a 1.0?

Does the same thing happen if you just start KSP and start a new sandbox game, go to the VAB and build a simple rocket (pod, fuel, engine)?

Could you upload your output_log.txt (preferably of doing the above with it going wrong) somewhere or, if you are willing, have a look at it yourself and look for any mention of anything engineer related. You shouldn't find any references to anything called engineer other than in the new KerbalEngineer folder in GameData. (You can also keep an eye out for "Exception" messages or anything else that looks like an error).

Share this post


Link to post
Share on other sites

Can we have times in kerbin days rather than earth days? Or at least some option to toggle between the two? 1.0.6 is showing orbital period etc. in earth days, confusing me every time :(

Share this post


Link to post
Share on other sites
I removed 0.6 to install 1.0. I know they aren't compatible but that is just because the part names changed. I wasn't using any of the parts, just a module manager config so it shouldn't be causing any problems. There are no KER related messages in the logs.

You've answered one of the questions I asked but ignored the other for some reason and appear to have either looked at the wrong log or not understood what you were looking for.

Have you removed the MM config (or suitably edited it to work correctly with 1.0, in which case can you post it)? It wasn't that the part names changed, it is more about the PartModule names changing. Your existing craft will have BuildEngineer and FlightEngineer modules in their command pods and neither of these modules exists anymore (or should if you have correctly removed the old version). In 1.0 the build engineer no longer requires a part module at all and the name of the flight engineer one has changed (and you can configure it to appear with no module present on the craft).

By "anything engineer related" I meant absolutely anything, e.g. the messages that get output when each of the mod plugins is initially loaded.

Share this post


Link to post
Share on other sites

Well, this is new. Anyone ever see this? It just randomly started happening today. I tried removing and reinstalling but to no avail. This tells me that perhaps another mod is causing it. However, before I go through the arduous process of eliminating the culprit, I'm wondering if A) Anyone else has seen this before and what steps, if any, you took to fix it, and/or B) is this a problem with a cfg file that's easily fixed, or am I hosed? Thanks!

zWGqbQH.png

EDIT-- Well, I don't know how I got the problem originally, but if anyone else is experiencing it, here's how I fixed it. Before, when I removed and replaced it, I just deleted the Kerbal Engineer folder in Game Data, then copied over the fresh version. When I restarted KSP, the problem was still there. This time, I deleted Kerbal Engineer, started the game, and started a new sandbox game. My thinking was that I would "flush the system", so to speak, and let the game reorient itself without Engineer present at all. I then exited, reinstalled the mod, and reloaded. Everything is back to normal.

Can't say why it worked, unless there was something to my flushing theory, but it did.

Edited by jonrd463
Fixed problem

Share this post


Link to post
Share on other sites

I guess someone has already pointed this out, but KER 1.0.6 can be made retrocompatible with 0.6 by including the EngineerChipFlight part in KER 1.0.6 even if I guess the part doesn't do anything with 1.0.6 installed

OTOH, is it possible to make it use the toolbar added by a mod whose author's name I'm forgetting instead of the stock toolbar?

Share this post


Link to post
Share on other sites

I have a slightly weird issue with Time to Apo/Periapsis and Time to AN/DN. The numbers are not accurate:

X4Y9Ail.png?1

It seems to only happen around Jool. It's KER 0.6.2.10. The particular ship involved has one of the little tape-recorder parts on the main craft. Since launching it, I have started using a Module Manager script to add KER to all control parts, and there are three OKTO modules on the ship.

I've tinkered with a few things, but can't figure out what I'm doing wrong.

Share this post


Link to post
Share on other sites

@JWag: This is because KER is using 24h days and KSP is using 6h days. It should be an easy fix, for now you can enable 24h days in option if you want it to match :)

Share this post


Link to post
Share on other sites

Oh for pete's sake, I should've been able to figure that out. :confused: Thanks, dzikakulka!

Share this post


Link to post
Share on other sites
BTW, what's the "Sim Delay" thing does?

Isn't there a run sim option on the .6 parts? I've never figured out what that does.

Share this post


Link to post
Share on other sites
BTW, what's the "Sim Delay" thing does?

The sim delay controls the time between one run of the vessel simulation code and the next one. This allows you to adjust how much work it does if it is affecting performance too much.

Isn't there a run sim option on the .6 parts? I've never figured out what that does.

The "Log Sim" button causes the next run of the vessel simulation to output lots of debugging info into output_log.txt. The "Dump Tree" option causes the next run of the code to output the part tree of the vessel into output_log.txt.

Share this post


Link to post
Share on other sites

Version 1.0.7 is now available!

It's quite a big one with an initial implementation of a presets system. This is to manage the increasingly overwhelming number of readouts that are now available. There is a simple stock preset for each of the primary sections, and can be used if you do not fancy editing the sections yourself. The presets are saved within the 'Presets' directory, and feel free to create your own and distribute them.

Added: Part count information to the Build Engineer.

Added: Reset button to the G-Force readout.

Added: Preset system to the Flight Engineer.

Added: New stock presets:

- Orbital

- Surface

- Vessel

- Rendezvous

Added: New readouts to the orbital category:

- True Anomaly

- Eccentric Anomaly

- Mean Anomaly

- Argument of Periapsis

- Angle to Prograde

- Angle to Retrograde

Added: New readouts to the vessel category:

- Intake Air (Demand)

- Intake Air (Supply)

- Intake Air (Supply/Demand)

Added: New readouts to the rendezvous category.

- Semi-major Axis

- Semi-minor Axis

Added: Time formatter which can show time as referenced by any celestial body.

Added: New readouts to the miscellaneous category:

- Time Reference Adjuster

Changed: Moved Sim Delay readout into the Miscellaneous category.

Changed: Updated MiniAVC to v1.0.2.3.

Fixed: Issues with large value wrap around in the Flight Engineer.

Fixed: Bug in the phase angle calculation.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.