Ray Gott

new linux user, need help with Add-on making history

Recommended Posts

I"m in need of some help installing making history add-on. I"m running Linux mint on a Quad core Asus motherboard I built.

the basic program runs great, so i decided to buy the Making history Add-on. I"ve  unzipped the files to a folder on my desktop.

But the instructions tell me to run a script called dlc-mhe-[lang]. command. I"ve got no clue how to run this in the Command terminal.

after i open the terminal I get this:(  ray@ray-quadcore:~$   ) can anyone with some linux experience help me out?

Thanks for any help

Ray Gott

Share this post


Link to post
Share on other sites

Welcome to the forum. :)

But I don't use Linux. Someone who does should be along shortly. 

Share this post


Link to post
Share on other sites
6 hours ago, Ray Gott said:

I"m in need of some help installing making history add-on. I"m running Linux mint on a Quad core Asus motherboard I built.

the basic program runs great, so i decided to buy the Making history Add-on. I"ve  unzipped the files to a folder on my desktop.

But the instructions tell me to run a script called dlc-mhe-[lang]. command. I"ve got no clue how to run this in the Command terminal.

after i open the terminal I get this:(  ray@ray-quadcore:~$   ) can anyone with some linux experience help me out?

Thanks for any help

Ray Gott

Hi :-)

First, i don't have the Making History expansion and have never installed it, so i can only comment on the linux stuff.

Short version:

You don't necessarily need the terminal to execute a script. Double click on the folder on your desktop. Search the file dlc-mhe-[lang] and double click it to execute it.

-----------

Long version in the terminal:

From the prompt you mentioned on, change into the folder you have unzipped the dlc pack to. This is done by typing cd Desktop/[folder on your desktop] and press enter.

Your prompt should change to ray@ray-quadcore:~/Desktop/[folder on your desktop]$. If not and you get an error message "File or directory not found" or so then you either mistyped something or the folder isn't named as expected. There is a shortcut: once you have typed enough letters for the terminal to find a match, you can simply type [tab] and it'll fill out automatically. Handy for long winded directory names :-). If you ever get lost cd-ing through your directory tree, simply type cd and you'll land in the root of your home directory, denoted as ~ in ray@ray-quadcore:~$

You can check the contents of a directory with the ls command by typing ls -l. If the list is too long to fit an a screen, type ls -l | less, which lets you scroll up and down. The vertical dash is the pipe sign you'll find somewhere on your keyboard.

As always, man [command] will invoke the help, like man cd or man ls.

Once you have found the file you are looking for, execute it by typing ./dlc-mhe-[lang] and enter. If you get an error, just ask :-)

Edited by Green Baron

Share this post


Link to post
Share on other sites

Did you get the game and the DLC from the same place?  Given that you're unsure how to install the DLC, but were able to install the game, I have a feeling you may have gotten the game from Steam and the DLC from the KSP store?  If you got them from different places, this will get a bit more complicated.

Also, you may be having issues running the command by clicking on it because it's not set as executable.  You can change this by simply right clicking on file, Properties, Permissions, and checking "Allow executing file as a program".  At least in MATE, the other Desktop Environments might be worded a bit different, but should be about the same.

You can also change it at the command line.  Basically just follow @Green Baron's directions above.  But before doing this:

2 hours ago, Green Baron said:

execute it by typing ./dlc-mhe-[lang]

Type:

sudo chmod +x dlc-mhe-[lang]

Assuming [lang] needs to be replaced with your language, so it may be dlc-mhe-en if you have the English version.

Share this post


Link to post
Share on other sites
46 minutes ago, Geonovast said:

... because it's not set as executable ...

Oh, i didn't know that. Thanks for the hint !

Someone should tell @SQUAD if that wasn't already done, because it is a bug.

Edited by Green Baron

Share this post


Link to post
Share on other sites

Trimmed a post or two. Could we at least wait until people are out of the Welcome sub before we hit them with the Squad bashing? 

Share this post


Link to post
Share on other sites

Thanks for all the help Green Baron, I"ve forgotten all that DOS stuff i learned back in the 80's. Terminal seams to be structured the same.

After i got into the correct file on my desk top i executed it. the addons  where in my start up page when i opened the program.

thanks again to all that responded,

Game on....

Ray Gott

Share this post


Link to post
Share on other sites

You're welcome. Happy landings !

It sounds like you did not have to change the file's executable flag and everything was fine with the installation process ?

Edited by Green Baron

Share this post


Link to post
Share on other sites

I may be mistaken, but i THINK the expansion is entirely contained within it's mod folder, so it should be a drag and drop into Gamedata.
Although it sounds like you've already got the issue fixed. Also, welcome to the forum.

Edited by SpaceMouse

Share this post


Link to post
Share on other sites
On 9/20/2018 at 8:06 AM, SpaceMouse said:

I may be mistaken, but i THINK the expansion is entirely contained within it's mod folder, so it should be a drag and drop into Gamedata.
Although it sounds like you've already got the issue fixed. Also, welcome to the forum.

You are entirely correct; the expansion is a mod folder in a zip in a zip. You can just uncompress those and drop it into place. You even get a .DS_Store file in there!

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.