Radar

[1.7.x] Space Shuttle release 23.06.2019

Recommended Posts

1 minute ago, Briso said:

I have to say this perfectly as always, but tomorrow I will start a series of hard tests (I want to test whether the Shuttle will be able to output the maximum load without deviation from the trajectory). And Yes finally I got pleasure from landing because with the old configs (1.2.2) it was impossible !

And of course I want to thank you (super cool configs, which gave the opportunity to work with RSS) and Radar for the continuation of the mod and for the opportunity to land the Shuttle. Yes, and the radar configurations are also great because they bring me joy when I go to the KSC strip and plant this bird. Thank you for being there ) Now I'm just waiting for the new Canadarm2 and also new updates of this mod and configs !

Im glad to hear it :). Any feedback is greatly appreciated, for both my configs, but also radar's im sure.

Currently im working on a TACLS>Mechjeb>RemoteTech patch, if it would peek your interrest. (For those who wants to use Lifesupport mods) 

So u dont have to put extra pieces on the shuttle, instead have it all aboard in the cabin.

Share this post


Link to post
Share on other sites
58 minutes ago, Trickzie said:

Im glad to hear it :). Any feedback is greatly appreciated, for both my configs, but also radar's im sure.

Currently im working on a TACLS>Mechjeb>RemoteTech patch, if it would peek your interrest. (For those who wants to use Lifesupport mods) 

So u dont have to put extra pieces on the shuttle, instead have it all aboard in the cabin.

 

Glad to hear

Edited by Briso

Share this post


Link to post
Share on other sites
11 hours ago, Briso said:

I have to say this perfectly as always, but tomorrow I will start a series of hard tests (I want to test whether the Shuttle will be able to output the maximum load without deviation from the trajectory). And Yes finally I got pleasure from landing because with the old configs (1.2.2) it was impossible !

And of course I want to thank you (super cool configs, which gave the opportunity to work with RSS) and Radar for the continuation of the mod and for the opportunity to land the Shuttle. Yes, and the radar configurations are also great because they bring me joy when I go to the KSC strip and plant this bird. Thank you for being there ) Now I'm just waiting for the new Canadarm2 and also new updates of this mod and configs !

It's exactly what I wanted to achieve, the enjoyment but also the reward at the end when you do land the glider :)

Canadarm was for the Shuttle, I have this working with my version at the moment and I'm able to launch ISS parts without major problems. I did have on one occasion the arm doing funny things so I'm just needing to do more testing of this.

The Canadarm2 is for the ISS, I have this almost complete also. The Mobile Base System which can assist with the Canadarm2 needs someone to texture it as it's boring white doesn't look good, but also when using DX11 it has lines running through the model when zoomed out.

Basically needs a UV Unwrap and textured, save model and it's done.

@Briso Happy for you to help out with the weights and fuel. I have some values I want to try on the weekend with the fuel and weights, so maybe after this if no luck in the balance I'll be more than happy to take onboard your findings. Just need to allow for weighted cargo, nothing worse than only making it half way up :)

 

Share this post


Link to post
Share on other sites
10 hours ago, Radar said:

Just need to allow for weighted cargo, nothing worse than only making it half way up :)

No your absolutely right. I did a series of payload test's, yesterday afternoon and most of the evening on my configs. Taking the actually numbers from wiki :

Payload to LEO 27,500 kg (60,600 lb)
Payload to ISS 16,050 kg (35,380 lb)
Payload to GTO 3,810 kg (8,400 lb)
Payload to Polar orbit 12,700 kg (28,000 lb)

It preformed very well within the  acceptable margin of errors.

So the base design you've done with the shuttle is good.

Edited by Trickzie

Share this post


Link to post
Share on other sites

Any idea on how to improve this thing's stability and maneuverability? Its almost impossible to follow a stable path manually....

Share this post


Link to post
Share on other sites
On 10/11/2018 at 12:12 AM, DanielBR401 said:

Any idea on how to improve this thing's stability and maneuverability? Its almost impossible to follow a stable path manually....

If you're meaning the RSS patch, i am well aware of the error, but have yet to find out why and where it occurs.

It's still in early release, so im still tweaking it to get it where i want it to be.

 

 

Share this post


Link to post
Share on other sites

Just an update for all..

Been speaking with Trickzie with finding a balance both for him with RSS, and everyone else with Stock. I have applied a quick change to my CFG files for the External Tank and the Side Rocket Boosters and so far so good, it's still balanced well but just need a little more testing before I release (including Trickzie testing).

It will include an updated cockpit that will require the MAS mod, the ISS with working Canadarm/s and references to the additional mods / versions used for the arms to work under 1.4.5.

To avoid an excess number of mods used the Canadarms will use the Klaw from Stock, the CFG files will resize this to fit nicely. I thought about using magnetic ends but it was hit and miss. Keeping it simple :)

Share this post


Link to post
Share on other sites

Now with 1.5 out I'll be doing some overall testing and tweaks no doubt. So far people are reporting that the drag model is not right, so I won't make drastic changes until a patch has been released for 1.5.

Share this post


Link to post
Share on other sites

Seeing this thread made my day. Ever since I got back into KSP in July I had to backdate to 1.2.2 to continue using the Shuttle! Any news on getting the texture changes to work?

Share this post


Link to post
Share on other sites

I'm buggered if I can get this work work with my fresh 1.3.1 RSS-RO install.  Am I missing some mod or a version or something?
Is there a one-stop RO config shop?  Github perhaps?

Currently the front of the orbiter (nose/cockpit) registers as non-RO.  As I've dropped the configs in the proper place (an overwrite, I believe) this shouldn't be. 
The gear doesn't retract, I get a Rasterpropmon error just loading the cockpit.
Something's certainly screwbied.
The only mods I have installed apart from what comes with RSS-RO are this, the RO configs for this, and ASET.

Help?

Edited by slaintemaith

Share this post


Link to post
Share on other sites
9 hours ago, slaintemaith said:

I'm buggered if I can get this work work with my fresh 1.3.1 RSS-RO install.  Am I missing some mod or a version or something?
Is there a one-stop RO config shop?  Github perhaps?

Currently the front of the orbiter (nose/cockpit) registers as non-RO.  As I've dropped the configs in the proper place (an overwrite, I believe) this shouldn't be. 
The gear doesn't retract, I get a Rasterpropmon error just loading the cockpit.
Something's certainly screwbied.
The only mods I have installed apart from what comes with RSS-RO are this, the RO configs for this, and ASET.

Help?

Seems like you didnt install it right, for the wheels to work you need KSPWheel (in the download) and for the cockpit you will need JSI(also in the download).

The RSS-configs dont make the parts RO-"confirm", for that you need to add:  '%RSSROConfig = True' without the ' to every cfg file.

Share this post


Link to post
Share on other sites

Oh, I installed it right if by "install it right," you mean "put the folders in the proper folders when extracting."
I should think that by the nature of configging something for RO that it would indeed RO-confirm them.  
I'm probably being silly.
But no.  I'm clearly missing something.  Either the install file or the patching file have changed and I don't know where they are (apart from the links found in the first post of this thread) or the versions for KSPWheel and JSI have changed in the file given and don't work with 1.3.1.

Share this post


Link to post
Share on other sites
2 hours ago, slaintemaith said:

Oh, I installed it right if by "install it right," you mean "put the folders in the proper folders when extracting."
I should think that by the nature of configging something for RO that it would indeed RO-confirm them.  
I'm probably being silly.
But no.  I'm clearly missing something.  Either the install file or the patching file have changed and I don't know where they are (apart from the links found in the first post of this thread) or the versions for KSPWheel and JSI have changed in the file given and don't work with 1.3.1.

Sorry my Mistake, the versions of KSPWheel and JSi dont work in 1.3.1, you need to download the version for 1.3.1

https://github.com/JPLRepo/JSIAdvTransparentPods/releases/tag/V0.1.15.0

and

https://github.com/shadowmage45/KSPWheel/releases/tag/0.10.5.21

or the sstu version for 1.3.1, there it is also included

Share this post


Link to post
Share on other sites
2 hours ago, slaintemaith said:

I should think that by the nature of configging something for RO that it would indeed RO-confirm them.

For RSS-RO , you will need the original files for RO, to put into RO folder. I've included the files i have on storage.

https://www.dropbox.com/s/by5h1qdc0p75kdl/Space_Shuttle_System_RO configs.rar?dl=0

 

The patch on mainpage is RSS (RO alike) it would not contain '%RSSROConfig = True' since RealismOverhaul mod is not updated to 1.4.5.

Edited by Trickzie

Share this post


Link to post
Share on other sites

Oh good.  So I'm not as stupid as I was originally made out to be?  =)

 

That said, and not meaning to be a berk, but, would it be possible to make different .zips with the proper versions of things for the proper versions?
 

 

Edited by slaintemaith

Share this post


Link to post
Share on other sites
Quote

The patch on mainpage is RSS (RO alike) it would not contain '%RSSROConfig = True' since RealismOverhaul mod is not updated to 1.4.5.

Yes.  I'm not using 1.4.5.  Never expected a RSS-RO patch to work with 1.4.5, since RSS-RO is only now working with 1.3.1.
I'd like to think that's not as stupid as I'm making it sound.

Edited by slaintemaith

Share this post


Link to post
Share on other sites
5 hours ago, slaintemaith said:

Oh good.  So I'm not as stupid as I was originally made out to be?  =)

 

That said, and not meaning to be a berk, but, would it be possible to make different .zips with the proper versions of things for the proper versions?
 

 

Why should he, its easy to download the correct versions and replace the wrong ones and its also possible to add some lines to a cfg. Lets keep the authors focus on development of the mod :D

Share this post


Link to post
Share on other sites

So let's say I hauled off and made all those changes and packaged the proper 1.3.1 versions of KSPWheel and JSI with the RO-happy looking parts.
Let's say I put them all into a .zip.

Would you, the maintainers of this craft, be interested in putting that someplace for the general population?

 

Edited by slaintemaith

Share this post


Link to post
Share on other sites
11 hours ago, slaintemaith said:

So let's say I hauled off and made all those changes and packaged the proper 1.3.1 versions of KSPWheel and JSI with the RO-happy looking parts.
Let's say I put them all into a .zip.

Would you, the maintainers of this craft, be interested in putting that someplace for the general population?

 

I cant really speak for Rader, since im only the maintainer of RSS patch.

But if u were able to make a 1.3.1 .zip with the necessary files required for it, im sure Rader could put it somewhere on the mainpage, for both our versions of it. (however, u would be the maintainer of it then).

Share this post


Link to post
Share on other sites
On 10/8/2018 at 4:51 AM, Radar said:

 

 

Not sure why yourself and one other are having issues with Nosecone. By not work what do you mean, not show up or doesn't function?

As you can see in the video of the original post, it's working fine for user KottabosGames. The only problem I found in his video was the extendable docking port not working for him, and the cockpit not displaying parts which would be as a result of not having the ASET & JSI mod installed.

 

When I tried to attach it, it would not show an attachment point. 

Share this post


Link to post
Share on other sites
On 10/19/2018 at 4:15 AM, slaintemaith said:

So let's say I hauled off and made all those changes and packaged the proper 1.3.1 versions of KSPWheel and JSI with the RO-happy looking parts.
Let's say I put them all into a .zip.

Would you, the maintainers of this craft, be interested in putting that someplace for the general population?

 

More than happy to add your 1.3.1 version in the original post. Gives people options depending on what they prefer to play.

17 hours ago, luc.c_24 said:

When I tried to attach it, it would not show an attachment point. 

Hold down ALT on the keyboard, see if that makes any difference. It shouldn't but curious why you don't see the attachment node when it's visible in my stock version.

Share this post


Link to post
Share on other sites
On 10/20/2018 at 6:11 AM, Radar said:

More than happy to add your 1.3.1 version in the original post. Gives people options depending on what they prefer to play.

Hold down ALT on the keyboard, see if that makes any difference. It shouldn't but curious why you don't see the attachment node when it's visible in my stock version.

thanks, always helps

 

Share this post


Link to post
Share on other sites
6 hours ago, Radar said:

I've added the 1.3.1 RSS-RO friendly link version provided to me by @slaintemaith

I know with those files the Shuttle can make it to orbit and can do orbital ops.  Basically the only things I modded were the versions of the included add-ons, and a line in each part to make it RO-compatible.

I've yet to succeed in developing a repeatable procedure to have it re-enter and land at <insert base of choice here> without shorting it, overshooting it, or unplanned rapid disassembly.

Hopefully sharper minds than mine can come up with something reliable.  I know this guy is working on a script using KoS, but he's not yet released it.  (and he might not--it's his, after all.  I'm not going to bug him)  It's also quite possible that the masses for the parts need to be altered to better reflect reality.  I -do- know that dumping propellants is something the real Shuttle did, and something you should do before entry interface using this spacecraft.  You WILL want to keep some, however, for RCS before the flight control surfaces become effective enough to hold attitude.

Edited by slaintemaith

Share this post


Link to post
Share on other sites

I did notice that your Side Rockets had a LOT of mass weight compared to the External Tank. As for re-entry, I used MechJeb to get an idea what it would do, now can do re-entry without and easy land without troubles.

I'm currently looking at your files and of Trickzie to better gauge where the fuel and weights should be for the next release. Now that I've stopped traveling for work I can put a bit more time into testing a few options, plus fix the cockpit using the MAS mod. Similar to what G'th did with his version Ultimate Shuttle IVA.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.