Jump to content

[x.x.x] Space Shuttle in development


Radar
 Share

Recommended Posts

On 7/9/2021 at 1:28, Brainpop14 said:

I wanna know about 1.12.2 please?

It should work, since they are only parts, (and some textures), I doubt there is an Inventory system.
Let me try it, and I'll see.

https://github.com/DylanSemrau/Space-Shuttle-System/tree/master/GameData/SPACE_SHUTTLE_SYSTEM

Edited by luisitoISS
Link to comment
Share on other sites

  • 3 weeks later...

@Brainpop14I'm sorry for the delay, but I already have the answer to your question.
Let's say it works 8/10, mainly because it is designed to be used in RO, and not in Stock.
There is no VAT in the cabin, and what I just mentioned to you.

https://imgur.com/IKKkUbi
https://imgur.com/ulo3Y6j
https://imgur.com/lmAumJH
https://imgur.com/ryHrFcH

Link to comment
Share on other sites

To change the textures download firespitter from GitHub, go to the SpaceShuttle folder, and you will see a folder called textures, and if you open it, you will see all of the textures for this, copy those, and make a new folder called SPACE_SHUTTLE_SYSTEM and place the copied textures, open up ksp and enjoy!

Link to comment
Share on other sites

  • 3 weeks later...
  • 1 month later...
Also I have a problem is that when I put the capsule of the Shuttle, the wheel comes off by itself And I can't save the wheel I think I'm installing the wrong mod, can someone tell me how I can install the mod correctly?
 
 
volume_up
 
 
content_copy
 
 
 
 
share
 
 
 
 
 
Link to comment
Share on other sites

  • 1 month later...
  • 1 month later...
On 1/24/2022 at 2:13 PM, Drehverschluss said:

What is "your" version?

2 pages back: https://forum.kerbalspaceprogram.com/index.php?/topic/178381-xxx-space-shuttle-in-development/&do=findComment&comment=3979440

Specifically, here: https://github.com/SpaceODY/Space-Shuttle-System-Expanded

Edited by panarchist
Link to comment
Share on other sites

Having some issues.

I downloaded the @SpaceODYversion of the mod and everything works well except the engine mount. Whenever I grab the engine mount and attach it to the rest of the shuttle everything is fine. However when I switch editors or load the craft in so that I can launch it the mount just disappears. Everything else seems to be interacting with it yet it's just invisible and unable to be interacted with (clicking on it does nothing).  I have the mod running on version 1.12 so maybe that's the issue but I am honestly lost. I have tried every version of the mod and have been encountering the same issue every time.

If anyone could give any tips on how I can fix this it would be greatly appreciated,

Thank you

Link to comment
Share on other sites

  • 3 weeks later...

Using the Space OYD version, Parts are all loading in however I am unable to change the subtype or texture, Using KSP version 1.12.3. Any help would be apricated here is a player log hope this helps. Also @SpaceODY A friend of mine known as Kingzlo, found that RO engines is why some parts don't show up like the RS-25 or AJ190. Going into RO engines-Patch Manager-ActveMMPatches and then delete the RS-25 and AJ190 configs allows the Shuttle mods to show up. This works for any other engine also I found and any other part mod that adds them in and has configs for them already. Also found that using Tufx with the shuttle mod also makes some things see through depending on the angle.  https://www.dropbox.com/s/rxyo1xalbt82ykh/Player.zip?dl=0

Link to comment
Share on other sites

  • 2 weeks later...
On 4/4/2022 at 9:00 PM, Jim123 said:

Using the Space OYD version, Parts are all loading in however I am unable to change the subtype or texture, Using KSP version 1.12.3. Any help would be apricated here is a player log hope this helps. Also @SpaceODY A friend of mine known as Kingzlo, found that RO engines is why some parts don't show up like the RS-25 or AJ190. Going into RO engines-Patch Manager-ActveMMPatches and then delete the RS-25 and AJ190 configs allows the Shuttle mods to show up. This works for any other engine also I found and any other part mod that adds them in and has configs for them already. Also found that using Tufx with the shuttle mod also makes some things see through depending on the angle.  https://www.dropbox.com/s/rxyo1xalbt82ykh/Player.zip?dl=0

1. For the subtypes not working make sure you have B9PartSwitch installed

2. Parts like the SSME and AJ-10 will disappear with the ROEngine patch. But for some reason people have issues with non-engine components like the Engine mount or body flap to disappear as well.

3. When TUFX has HDR enabled it will cause issues on the shuttle. If you turn it off when in game and it still shows the odd clipping you mention you may need to restart ksp for it to work.

Link to comment
Share on other sites

  • 2 months later...
Posted (edited)
4 hours ago, ExMachina said:

Any tips on how to land this thing with FAR?

I mean, there's this.
It's for RSS/RO, which includes FAR
I don't think it'll work in a stock sized environment, though.

 

 

Edited by slaintemaith
Link to comment
Share on other sites

  • 1 month later...
On 10/2/2021 at 4:47 PM, SpaceODY said:

If you use my version of it yes.

First, is there any chance of your version getting its own page?

 

Second, would it be possible to create a kanadarm 1 for this, .

3rd, could we get a better way to mount payloads into the payload bay, rather than users creating ingredients their own methods?

Link to comment
Share on other sites

On 8/4/2022 at 10:33 PM, Sampa said:

First, is there any chance of your version getting its own page?

 

Second, would it be possible to create a kanadarm 1 for this, .

3rd, could we get a better way to mount payloads into the payload bay, rather than users creating ingredients their own methods?

Also, I made an arm using infernal robotics, for now...but, wanted to report an interesting issue.  The node for attaching an arm is on the wrong side of the orbiter payload bay

Link to comment
Share on other sites

So, I have an old shuttle component from when Mike-NZ was still around on the forum...  was wondering if anyone would be interested in me updating it to make it available for SpaceODY's updated shuttle?  It's a tail cone for the shuttle!

Link to comment
Share on other sites

This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...