Jump to content
  • 0

#autoLOC and freeze in loading screen


BerthNerd
 Share

Question

After running a modded KSP install for a while, I decided to reinstall everything. I completely deleted the installation folder and also uninstalled it from steam to do a clean fresh install to start modding again.

However, I can't even get the base game running anymore. I'm trying to run v1.3.1, but other versions don't work either.

What I am getting is, that in the loading screen, I don't get the loading screen hints, but instead a #autoLOC with some number behind it. The game is then stuck in loading screen and doesn't get to the menu.

Revalidating the files through steam just lead to 400 files being redownloaded, but the same issue persists.

output_log: https://www.dropbox.com/s/nosx86mvzxkhxd4/output_log.txt?dl=0

I don't really have any experience in reading those, so any help would be appreciated.

Link to comment
Share on other sites

Recommended Posts

  • 0

Apparently the Localization-file is still being deleted. I sequentially made three exceptions: The KSP directory, the Localization-directory and finally the .cfg itself.

I doublechecked if i did the exclusions right and tried launching the game through steam or just with a restart of the machine, as the Localization-file seems to be deleted upon starting the game through steam and when Windows finishes startup (...or when shutting down, for all I know)

 

I think thats wild. i specifically excluded a file not to be tampered with, but Windows deletes it anyway?

 

Edit: Interesting. I didnt really think about it yet, but just now I realized the Career games I deleted twice now keep reappearing whenever I verify KSPs local files. This is probably steams doing?
Normally I wouls expect Steam to understand I want these saves gone - maybe this has something to say?

The Career I actively play it saves flights and all correctly, though.

Edited by Audiopulse
Link to comment
Share on other sites

  • 0
7 hours ago, Audiopulse said:

Edit: Interesting. I didnt really think about it yet, but just now I realized the Career games I deleted twice now keep reappearing whenever I verify KSPs local files. This is probably steams doing?
Normally I wouls expect Steam to understand I want these saves gone - maybe this has something to say?

The Career I actively play it saves flights and all correctly, though.

Did you delete the savegames ingame or in the explorer? This sounds steam doesn't recognize the savegames beeing deleted and restores them from the cloud.

I kinda doubt that the cloud also messes around with other files like the dictionary but who knows? The easiest way  to find out would be to deactivate the cloud for KSP (right click on KSP in your steam library -> properties -> updates). Not the first time I've read about the cloud messing around but the last time, it was related to the stock crafts and a mod which added some crafts to the same folder....these crafts were restored on each game launch but shouldn't be in the cloud at all, so I guess it's worth a try ;)

Link to comment
Share on other sites

  • 0

Well yes - fixing the reappearing careers should not be a problem. Them even reappearing is not much of a problem, actually.

But I guess regarding the mysterious deletion of KSPs localization we are at the end of our line? Should I report this issue to Microsoft kind of as a bug maybe?

 

Link to comment
Share on other sites

  • 0

This is certainly not a new thread, but it is the top search result on Google for this problem so I thought I would chime in with what solved this for me. After trying so many things and even having the same problem on a completely new PC and OS install:

Check the KSP-folder, make sure nothing is set to read-only (check the top-level folder).  The game launches fine from Steam after removing read-only, at least for me. Hopefully this helps someone!

Link to comment
Share on other sites

  • 0
1 hour ago, Coto said:

This is certainly not a new thread, but it is the top search result on Google for this problem so I thought I would chime in with what solved this for me. After trying so many things and even having the same problem on a completely new PC and OS install:

Check the KSP-folder, make sure nothing is set to read-only (check the top-level folder).  The game launches fine from Steam after removing read-only, at least for me. Hopefully this helps someone!

Does this not prevent you from saving the game and ships? If not, it's a neat workaround :)

Link to comment
Share on other sites

  • 0
22 hours ago, 4x4cheesecake said:

Does this not prevent you from saving the game and ships? If not, it's a neat workaround :)

Notice that I turned off read-only, I didn't turn it on :) Many people were having these problems after a re-install, I guess some files are created as read-only during install. I believe that under certain (maybe localization related?) circumstances Steam bugs out when it cannot access these files, and this causes the problem.

Link to comment
Share on other sites

  • 0
5 hours ago, Coto said:

Notice that I turned off read-only, I didn't turn it on :) Many people were having these problems after a re-install, I guess some files are created as read-only during install. I believe that under certain (maybe localization related?) circumstances Steam bugs out when it cannot access these files, and this causes the problem.

OOHH, I misread that :confused:

I thought you're suggesting to set the KSP directoy to read only so it's not possible to remove any files and once the game is installed, everything stays in place.  Though, it would most likely prevent you from saving anything...

Your thought process makes a bit more sense^^

Link to comment
Share on other sites

This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...