severedsolo

[1.7.x] ScrapYard - The Common Part Inventory 1.1.3 (16/06/2019)

Recommended Posts

On 4/24/2019 at 11:52 AM, vardicd said:

<THIS IS NOT A BUG REPORT, ONLY A PUBLIC SERVICE ANNOUNCEMENT>

Public Service announcement for anyone using scrapyard, Earlier today I spent close to 4 hours tracking down what I thought was a Kerbal Construction Time bug, only to find I wasn't hunting what I thought I was hunting. After a conversation I had with Gap back on the 7th~ish when I updated my KSP to 1.7 today and started a new save, I turned on this feature of scrapyard: 

(WIP) Funds can be overridden so that using parts from the inventory do not contribute to the cost of the vessel. You do still need to have the full amount of funds (for now).

I've never used it before and began playing. I shortly noticed I was getting a massive frame-rate drop and performance hit. I was also getting a endlessly scrolling error message from KCT. {hence why I spent 4 hours tearing apart my install to try and find what mod was causing my KCT error. I still haven't found it.} Turns out the performance hit and frame-rate chug was all from enabling that WIP feature of scrapyard. I was able to repro this on a clean install with only scrapyard installed. Video of my test below:

 

 

Perhaps, if @severedsolo would be so kind, a warning could be added to the first page that enabling the WIP feature of scrapyard, may provide a performance hit, and stuttering in the build editors. {Other user's performance may not be as negatively impacted. performance may vary by user system specs.}

@gap I'm tagging you in this because of our conversation about the WIP feature of scrapyard, and I seem to remember some running conversations over on the KCT thread about stuttering in the VAB/SPH. Thought I'd give you a heads up here so you can investigate on your own and see if this helps you alleviate some of your symptoms.

Thank you for your time.

Hi @vardicd, thank you for tagging me in your notice, and sorry for the late reply... I don't know how, I had missed your post until today.

So far I only tested ScrapYard in career mode, and since I was mostly busy testing mods rather than actually playing, I never made much progress in game. That is to say that, with only a few parts available in VAB/SPH, I never noticed any significant slow down or stuttering while there, whether the WIP fund override option was enabled or not.

Things might change in the near future, as I am starting to enjoy the game balance of my current mods. As I progress in my career, I will let you know if I find anything that can confirm or disconfirm your report.

Hopefully one day @severedsolo will support and optimize the WIP feature we are discussing, because I think it provides a much more realistic gameplay than the 'regular' SY mode :)

Share this post


Link to post
Share on other sites
Posted (edited)

Hi,

my recovered parts don't appear in the inventory.  Mod and inventory is enabled.
What could be the reason?
I used this mod in prev. KSP versions without any problems.

Installed Mods:

 

Spoiler

Kerbal Construction Time

Monthly Budget

Kerbal KRASH System

Oh Scrap

KIS/KAS

EVS

Magicore

 

Edited by eldorim
listed mods

Share this post


Link to post
Share on other sites
1 hour ago, eldorim said:

Hi,

my recovered parts don't appear in the inventory.  Mod and inventory is enabled.
What could be the reason?
I used this mod in prev. KSP versions without any problems.

Installed Mods:

 

  Hide contents

Kerbal Construction Time

Monthly Budget

Kerbal KRASH System

Oh Scrap

KIS/KAS

EVS

Magicore

 

Other than the usual, double check you've properly installed the mod, make sure you've got all the correct, and up to date versions of the mods. I'm not sure what might be going on in your install, as you haven't provided screenshots of your install, so I can't see it. I'm using all of those mods you listed, with maybe the exception of EVS, I'm not sure what that mod is from that abbreviation,  and I'm using way more mods, and I'm not seeing any problems. If it's not one of those issues being a problem for you, I'm sure Severedsolo would appreciate your KSP output logs, if he's going to give you any help with your issue.

Share this post


Link to post
Share on other sites
15 hours ago, eldorim said:

Hi,

my recovered parts don't appear in the inventory.  Mod and inventory is enabled.
What could be the reason?
I used this mod in prev. KSP versions without any problems.

Installed Mods:

 

  Reveal hidden contents

Kerbal Construction Time

Monthly Budget

Kerbal KRASH System

Oh Scrap

KIS/KAS

EVS

Magicore

 

Not seeing Module Manager in that list - although I'll admit that I wouldn't list it either, as I'd assume everyone has that.

Other than that, yes log please

Share this post


Link to post
Share on other sites

This is probably one of the hardest decisions I’ve had to make, but it’s time to face the truth.

Regular followers will probably have noticed that I’ve been a bit less communicative recently, and when I do reply, the replies can be a bit curt.

I mod for myself, and the truth is that I really haven’t played KSP since 1.4.x came out (even then it was becoming less and less). This means that I just don’t have the motivation to bring stuff up to date, or address issues, and quite frankly it’s showing.

Every time I load up the forums, or get an email on one of my threads with a bug, I groan to myself. This is not a reflection on you guys, you are all almost exclusively a very nice bunch of people who are very helpful in helping me track down issues, and the rare one or two who haven’t been have usually been put off by my generally grumpy attitude to those kind of requests, so don’t tend to stick around. The problem is with me, I just don’t want to do this any more, and that’s not fair on you guys, who need someone who will actually dedicate themselves to it.

With that, it’s time for me to announce my retirement from modding. I don’t plan to just disappear, I’ll still be around, and I plan to get all the mods to a point where someone else could take them over easily (at the very least they will be getting a 1.7 update), and I’ll try and resolve any outstanding issues on Github before I call it a day. I still want to be a part of the community, I just don’t want to mod.

I believe everything is licensed MIT, but for anything that isn’t, it will be changed over to make any handover as smooth as possible. If anyone is interested in adopting any of my mods, please let me know.

I’d like to thank every one of you for your support and encouragement over the years, I’d like to thank the amazing modding community for all their help, especially the guys on Discord (you know who you are) and just generally everyone on this forum for being awesome.

The fact that somebody like me, who started with literally zero programming experience can become one of the big names in modding (well, I like to think I am anyway) simply by teaching myself and following other modders examples, is testament to how helpful this entire community can be.

If your just interested in my retirement, you can stop reading here. If you’d like to know what I’ll be doing next, check the spoiler (it's in no way KSP related just FYI).

Spoiler

I’ve mentioned several times that I have an autistic daughter. One of the things that REALLY bugs me, is that there are very few apps that allow you to use PECS* in a helpful way, especially when children are first learning it. To start with, children don’t understand symbols, you use photographs instead, but the apps almost exclusively have symbols and nothing else.

 

So, what I want to do, is use the programming skills that I have learnt here, to develop an app that will allow parents of autistic children to take pictures of objects, record their parents voice saying what that object is, and then when the child pushes the photo on the app, it will say the word.

 

*For those who don’t know, PECS stands for “Picture Exchange Communication System” - basically for non-verbal autistic people it gives them a voice, they can communicate what they want / how they are feeling by handing you a picture/symbol of that thing/emotion etc.

Share this post


Link to post
Share on other sites

I think you are making a praiseworthy decision with respect to your your spare time, and I wish you all good in those endeavors.

Share this post


Link to post
Share on other sites

Thank you for sharing your thoughts and future plans.  Very sorry to see you go, but very glad to hear of your new project; thank you for all your time in making KSP a better experience, and I wish you all the luck in developing the app.

A couple of questions if you have the time:  from what I gather, there is a bug in the current SY 1.1.2 that has to do with KRASH, and you recommend using 1.1.1 until a fix is out.  Is 1.1.2 ok to use if I don't use KRASH, or will the issues still arise?  If I do go back to 1.1.1, will that be compatible with the current version of Oh Scrap?

Share this post


Link to post
Share on other sites
2 hours ago, ble210 said:

Thank you for sharing your thoughts and future plans.  Very sorry to see you go, but very glad to hear of your new project; thank you for all your time in making KSP a better experience, and I wish you all the luck in developing the app.

A couple of questions if you have the time:  from what I gather, there is a bug in the current SY 1.1.2 that has to do with KRASH, and you recommend using 1.1.1 until a fix is out.  Is 1.1.2 ok to use if I don't use KRASH, or will the issues still arise?  If I do go back to 1.1.1, will that be compatible with the current version of Oh Scrap?

I'd go back to 1.1.1 anyway, at the moment i haven't had time to look into it, but I seriously broke something, and I don't know what it is right now.

1.1.1 will work fine with Oh Scrap! - Oh Scrap! actually needed a compatibility patch to bring it up to date to work fully with 1.1.2 anyway, and was built using SY 1.1.1

In fact - I've just pulled SY 1.1.2, until I get time to look into it.

Share this post


Link to post
Share on other sites
Posted (edited)

I'm sorry to see you go. Your mod is a great idea, thanks for make it come true.
I wish I could adopt it. I would have the programming skills (my job)  but absolutely no time :-(

I put a single capsule on the launch pad and recovered it after.
Why is it blacklisted?

[LOG 22:16:37.689] Capsule loaded!
[LOG 22:16:37.702] 5/9/2019 10:16:37 PM,KerbalConstructionTime-KACWrapper,Attempting to Grab KAC Types...
[LOG 22:16:37.725] [OhScrap]: Attempting to refresh part 173947152
[LOG 22:16:37.725] [OhScrap]: Refreshed. New ID is 2629794411
[LOG 22:16:37.729] [ScrapYard] Blacklisted 1 parts.
[LOG 22:16:37.729] [ScrapYard] Loaded 4 module templates and 1 forbidden templates.
[LOG 22:16:37.730] [ScrapYard] Automatically refurbishing 1 modules.

Edit: I think I found it:

MagiCore 1.3.1.5 is needed, but CKAN only provides 1.3.1.4

[EXC 22:25:40.343] FileNotFoundException: Could not load file or assembly 'MagiCore, Version=1.3.1.5, Culture=neutral, PublicKeyToken=null' or one of its dependencies.

 

 

Edit: I found a zip of MagiCore 1.3.1.5 and installed it manually.

ScrapYard works fine now!

Thanks for helping!

Edited by eldorim

Share this post


Link to post
Share on other sites
21 hours ago, eldorim said:

IMagiCore 1.3.1.5 is needed, but CKAN only provides 1.3.1.4

[EXC 22:25:40.343] FileNotFoundException: Could not load file or assembly 'MagiCore, Version=1.3.1.5, Culture=neutral, PublicKeyToken=null' or one of its dependencies.

 

 

Edit: I found a zip of MagiCore 1.3.1.5 and installed it manually.

ScrapYard works fine now!

What version of CKAN are you running? Apparently MagiCore has not had updates for a long time, and its latest release (1.3.1.5) IS available through CKAN :)

 

Share this post


Link to post
Share on other sites
Posted (edited)

CKAN v1.26.2 with the repo: github.com/KSP-CKAN/CKAN-meta/archive/master.tar.gz

Edit: Found the reason. 1.3.1.5 is only released  for ksp up to1.6.0, but i installed 1.7.0.
Put the version into the compatibility list and did the update

Thanks for the hint!

Edited by eldorim

Share this post


Link to post
Share on other sites
Posted (edited)
On 5/8/2019 at 11:49 PM, severedsolo said:

I'd go back to 1.1.1 anyway, at the moment i haven't had time to look into it, but I seriously broke something, and I don't know what it is right now.

1.1.1 will work fine with Oh Scrap! - Oh Scrap! actually needed a compatibility patch to bring it up to date to work fully with 1.1.2 anyway, and was built using SY 1.1.1

In fact - I've just pulled SY 1.1.2, until I get time to look into it.

@severedsolo  Does SY 1.1.2 still have problems? CKAN is still set to update Scrapyard to v1.1.2. If the only issue is using the (WIP) Funds override, I don't use that feature, so is it safe for me to use v1.1.2?

If v1.1.2 is not ready yet, you might want to update Scrapyard's CKAN profile to reflect v1.1.1 as the latest released version. Just a suggestion.

Thanks for your efforts with this mod and Oh Scrap! are much appreciated. I love using both mods.

Edited by GJNelson

Share this post


Link to post
Share on other sites
3 hours ago, GJNelson said:

@severedsolo  Does SY 1.1.2 still have problems? CKAN is still set to update Scrapyard to v1.1.2. If the only issue is using the (WIP) Funds override, I don't use that feature, so is it safe for me to use v1.1.2?

If v1.1.2 is not ready yet, you might want to update Scrapyard's CKAN profile to reflect v1.1.1 as the latest released version. Just a suggestion.

Thanks for your efforts with this mod and Oh Scrap! are much appreciated. I love using both mods.

No, the build counts are broken, which makes the mod functionally useless, I've pulled the release from github. 

I'm just waiting for BG to hit, as I assume we'll be getting 1.8 then, and I'll do a release

Share this post


Link to post
Share on other sites
Posted (edited)
On 5/22/2019 at 1:51 AM, severedsolo said:

No, the build counts are broken, which makes the mod functionally useless, I've pulled the release from github. 

I'm just waiting for BG to hit, as I assume we'll be getting 1.8 then, and I'll do a release

Ok, thanks for the info.  Waiting for the release of KSP Breaking Ground sounds like a good idea. I imagine a lot of mods will be needing updating when KSP 1.8 is available.

Update: Oops! Make that when KSP V1.7.1 is available, and available it now is. I'm eager to start exploring it new things!

Edited by GJNelson

Share this post


Link to post
Share on other sites

ScrapYard 1.1.3 Released

  • Recompile against KSP 1.7.2
  • Using KRASH, KCT and ScrapYard together will no longer cause the universe to explode.

 

Share this post


Link to post
Share on other sites
1 hour ago, severedsolo said:

ScrapYard 1.1.3 Released

  • Recompile against KSP 1.7.2
  • Using KRASH, KCT and ScrapYard together will no longer cause the universe to explode.

 

Thank youvery much, I have been waiting for this release for a long time now!
Until some mods aren't updated I wont upgrade to the latest KSP version. Can  we safely install this new ScrapYard release on top of KSP v1.7.1?

Share this post


Link to post
Share on other sites
Just now, gap said:

Thank youvery much, I have been waiting for this release for a long time now!
Until some mods aren't updated I wont upgrade to the latest KSP version. Can  we safely install this new ScrapYard release on top of KSP v1.7.1? 

Yeah, I actually tested on 1.7.1, (stupidly forgot to re-copy my ModDev environment after updating) - so it definitely works on 1.7.1

Share this post


Link to post
Share on other sites
Just now, severedsolo said:

Yeah, I actually tested on 1.7.1, (stupidly forgot to re-copy my ModDev environment after updating) - so it definitely works on 1.7.1

Perfect thanks! I will install it right away and I will let you know in case I notice anything wrong :wink:

Share this post


Link to post
Share on other sites
4 hours ago, severedsolo said:

ScrapYard 1.1.3 Released

  • Recompile against KSP 1.7.2
  • Using KRASH, KCT and ScrapYard together will no longer cause the universe to explode.

 

And there was much rejoicing!

 

Share this post


Link to post
Share on other sites
Posted (edited)

@gap - the issue with ScrapYard refusing to apply the inventory to the MK1 pod is not a bug in ScrapYard. It's with DeadlyReentry.

ScrapYard is trying to reload the modules currently on the part from the parts cfg, but the MODULE node for ModuleAeroReentry is missing for the Mk1 pod which is causing ScrapYard to catch a NRE.

Copying the Mk1-3's configuration to the Mk1 pod's MM patch in DeadlyReentry.cfg seems to fix the issue:

    MODULE
    {
        name = ModuleAeroReentry
        skinMaxOperationalTemp = 3400
        leaveTemp = true
    }

HOWEVER - I don't know why this module is even being loaded onto the part with no config, or why it is missing. It may just be a config error, or it may have been omitted for a reason.

Pinging @Starwaster as he'll be the best person to answer that question.

Edited by severedsolo

Share this post


Link to post
Share on other sites
40 minutes ago, severedsolo said:

@gap - the issue with ScrapYard refusing to apply the inventory to the MK1 pod is not a bug in ScrapYard. It's with DeadlyReentry.

ScrapYard is trying to reload the modules currently on the part from the parts cfg, but the MODULE node for ModuleAeroReentry is missing for the Mk1 pod which is causing ScrapYard to catch a NRE.

Copying the Mk1-3's configuration to the Mk1 pod's MM patch in DeadlyReentry.cfg seems to fix the issue:


    MODULE
    {
        name = ModuleAeroReentry
        skinMaxOperationalTemp = 3400
        leaveTemp = true
    }

HOWEVER - I don't know why this module is even being loaded onto the part with no config, or why it is missing. It may just be a config error, or it may have been omitted for a reason.

Pinging @Starwaster as he'll be the best person to answer that question.

Thank you very much severedsolo, I would have never tracked down DeadlyReentry as the cause of this problem. Hopefully Starwaster will be able to answer all the the questions you have posed above and to devise a proper fix :)

Share this post


Link to post
Share on other sites

@gap @severedsolo Deadly Reentry adds that module to a part's prefab at runtime for any part lacking one. It's always done that for the years it has been in existence so I'm not understanding why it's a problem now.

Just loaded up KSP, launched and recovered a Mk1 Pod several times and this is what I get.

SY Inventory shows a Mk1pod. SY window shows 3 previous uses. I click 'Quick Apply' . Entry in SY window goes away. The Mk1 Pod's PAW now indicates that this part has three previous uses.

Imgur album linked below. (still not able to do imgur albums properly on the forums?)

https://imgur.com/a/CbizhEm

So, is something DIFFERENT supposed to be happening here than what I'm getting? 

 

Share this post


Link to post
Share on other sites
Posted (edited)
24 minutes ago, Starwaster said:

@gap @severedsolo Deadly Reentry adds that module to a part's prefab at runtime for any part lacking one. It's always done that for the years it has been in existence so I'm not understanding why it's a problem now.

Just loaded up KSP, launched and recovered a Mk1 Pod several times and this is what I get.

SY Inventory shows a Mk1pod. SY window shows 3 previous uses. I click 'Quick Apply' . Entry in SY window goes away. The Mk1 Pod's PAW now indicates that this part has three previous uses.

Imgur album linked below. (still not able to do imgur albums properly on the forums?)

https://imgur.com/a/CbizhEm

So, is something DIFFERENT supposed to be happening here than what I'm getting? 

 

No what you are seeing is the correct behaviour.

What I was seeing though, was that Module causing an exception when SY tried to save the copy it pulled from the prefab.

I'm gonna guess there's something else going on here, probably incompatibility with some unknown third mod (there were several mods installed in that test as that's the only way I could actually reproduce the issue).

Sorry for the false alarm, and thanks for your input. In my defense, the exception was being thrown when SY tried to save that particular module, and the patch I put above did fix it (or at least worked around whatever the actual problem is).

Would there by any problems with adding ModuleAeroReentry through a patch on that pod anyway? Just so I can point people in the right direction if it comes up again. (There are far too many mods involved here for either of us to really do anything about it, and I'm loathe to include patches for DRE with SY, when they don't really interact)

Edited by severedsolo

Share this post


Link to post
Share on other sites
2 minutes ago, severedsolo said:

Thanks for your input. Would there by any problems with adding ModuleAeroReentry through a patch on that pod anyway? Just so I can point people in the right direction if it comes up again. 

If they want to they can but are you sure that's really the problem? There are going to be a lot more parts not having that module explicitly patched in. 

Looking at one of my most used installations, only 329 parts with MAR patched in. There are a total of 1567 parts listed in the MM cache. Installations with parts from newer mods will have a greater proportion of unpatched vs patched parts (because the module adds itself in at runtime, I usually only create a patch for a part if it requires special handling such as space plane parts)

So how is it that @gap is only having trouble with the Mk1Pod? That just doesn't make sense to me. He should be having the same problem with lot more parts than just that pod.

Share this post


Link to post
Share on other sites

@Starwaster @severedsolo 

Maybe I can add something. First off, the problem is not exactly ScrapYard refusing to appy the inventory to the Mk1 pod, but the inventory not getting applied automatically to the said part when the 'auto apply' function is checked, and the pod resetting to new whenever a change is made to the vessel it belongs to. That means that I am forced to apply the inventory to it manually, at the very end of the assembling process.

Secondly, I must admit that I have started using DeadlyReentries after starting my current career, and probably after building the pod that now I want to be applied automatically. Might that be the cause of my problem?
 

It is true, besides SY and DR, I have several other mods, but none that I can think of that would interfere with SY.
Starwaster, If you want to have a look into my mod list or you need more details on the issue I described above (including save game and logs), you can find them in the OhScrap thread starting from this post:
 

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.