• 0
spearsp

Cannot map throttle and rudder

Question

Hi

Sorry if this is a repeat, but all I've been able to find is the joystick not mapping at all, instead of just missing two axes.

My problem: I cannot map throttle and rudder in the settings. It is only seeing pitch and roll inputs. If I select the Yaw input and then activate the rudder, it doesn't respond. If I move the stick left/right or forward/backward, it does pick it up, but just not on yaw or throttle. I know that they're working on the joystick, because I can see the results in the game controller test, and the stick works fine with FlightGear.

My environment: The stick is a Saitek Cyborg Force. It is calibrated in Windows. I'm on Windows 10 (64), running the latest release of KSP (downloaded and reinstalled yesterday, in an attempt to fix the problem), unmodded. I installed using the Windows installer.

Any help would be appreciated.

 

Thanks

Share this post


Link to post
Share on other sites

4 answers to this question

Recommended Posts

  • 0

Twy using the Advanced Fly By Wire mod, it does a better job of interfacing with joysticks

Share this post


Link to post
Share on other sites
  • 0

Thanks for the quick response. This didn't work for me: I get an access violation as soon as I try to open the controller dialog. I picked up something from the forums about copying a DLL from the System32 directory to the plugins folder in KSP, but that didn't make any difference. Any idea how to move forward with this?

Share this post


Link to post
Share on other sites
  • 0
45 minutes ago, spearsp said:

Thanks for the quick response. This didn't work for me: I get an access violation as soon as I try to open the controller dialog. I picked up something from the forums about copying a DLL from the System32 directory to the plugins folder in KSP, but that didn't make any difference. Any idea how to move forward with this?

Move this over to the AFBW forum, but would need a log file, please

Share this post


Link to post
Share on other sites
  • 0

Thank you. I've moved the issue to the AFBW forum and shared the crash dump on dropbox.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now