Jump to content

[1.12.x] Dang It! Continued


linuxgurugamer
 Share

Recommended Posts

  • 3 weeks later...

I'm looking for a little help from the Dang It! community. First I want to say that this mod is tons of fun. I'm using it in a hard mode + kOS + RemoteTech + life support + KCT career. Losing an engine in the middle of a mission to land a probe on the Mun, tweaking the landing software to compensate, and then limping to the finish line is one of the most fun things I've done in KSP so far. Thanks LGG for maintaining this mod (along with 1/6 of the total mods I am using in my game now). 

Anyway. I'm to the point in my career where I need large liquid fuel tanks for my Nerv tugs. Usually I use some sort of modular tank/container mod for this. I tried using Configurable Containers, but then the tanks don't seem to leak/fail (the MBTF, etc. doesn't show up in the part description in the VAB). Does anyone have any advice on how to get a mod like this working with Dang It!? More generally, if there is a repository of Dang It! configs/advice for other mods to help solve problems like this, I would love to hear about it.

Sorry if this is a basic question that has been answered many times in the thread already. 

Link to comment
Share on other sites

EDIT: the take spare part button is still there, but only for the Dangit Repair Bay, and only if you're standing 6 inches in front of it. Like... literally 6 inches. Take Spare Part still isn't an option for either the truck cab or the aircraft cockpit, both of which have 10 spare parts available, no matter how close I stand. I *was* able to get the repair option for the aileron to show, but only if I'm physically standing on top of the aileron. The other issues still stand.

 

So I'm having a two-part issue that I'm hoping I can possibly get some resolution for:

1) My "take spare part" button has disappeared, so... kind of critical to the function of this mod.

2) I have an aircraft (the one pictured) that I launched using Kerbal Construction Time. It experienced an aileron failure in flight, at which point i successfully landed it. I then recovered it via KCT (with Scrapyard enabled, on the chance that matters). I then launched the aircraft again at a different runway at a later date. The aileron failure immediately shows back up (no problem there... kinda cool that it was persistant), so I dispatched a repair truck with a Dangit Repair Bay to fix it. Well, I get there and... right-clicking the part doesn't show any "drown in WD40" option like it normally does. You can see in the pic that there's no Dangit-related buttons at all... What's weird is that there aren't any Dangit buttons for *any* part... except for the airplane's cockpit, which still shows a lone "Perform Maintainance" button. All inspects, Take Parts, etc, are all gone. Any help would be greatly appreciated.

Output Log found here: https://drive.google.com/open?id=1svsgw9e8B4kv4sZKZpDVSabItfiLsqxK

Screenshot here:

7eXeNca.jpg

Edited by Kardea
Link to comment
Share on other sites

Currently using KSP 1.4.4 and i'm building a craft in the SPH. When i try to build the craft however, after it exceeds 20 parts+ my FPS drops significantly. The craft uses the mod Space Station Parts Expansion Redux.as a majority. After deleting various mods and tweaking numerous settings, i've found out that this is the mod causing the issue. 

I'm using the lastest release of this mod, but i'm not sure if their are any incompatabilites with this and SSPER (Space Station Parts Expansion Redux)?

Any help would be appreciated.

KSP Log file: https://www.dropbox.com/s/lwy4dtcrbinn1ji/KSP.log?dl=0

Link to comment
Share on other sites

10 hours ago, AncientHoplite said:

Currently using KSP 1.4.4 and i'm building a craft in the SPH. When i try to build the craft however, after it exceeds 20 parts+ my FPS drops significantly. The craft uses the mod Space Station Parts Expansion Redux.as a majority. After deleting various mods and tweaking numerous settings, i've found out that this is the mod causing the issue. 

I'm using the lastest release of this mod, but i'm not sure if their are any incompatabilites with this and SSPER (Space Station Parts Expansion Redux)?

Any help would be appreciated.

KSP Log file: https://www.dropbox.com/s/lwy4dtcrbinn1ji/KSP.log?dl=0

I prefer the output_log.txt

and this is going to have to wait a bit, busy with some other mods

 

Link to comment
Share on other sites

  • 1 month later...

I have had the same issue as KBluey and others, but I can provide more info.

The bug triggers if I switch away from the vessel with a failure before repairing it.

If I immediately go EVA, I can repair failures, but if I switch away and back, I can not.

 

Also: are failures more likely to happen together? I just had four, on two different crafts, in a very short times pan. That was a very frustrating, but fun experience. Sadly, two of the failures are now not repairable due to the aforementioned bug...

Link to comment
Share on other sites

@linuxgurugamer I think this is one of the  best mods around. I will pitch in a suggestion, forgive me if it has been suggested before, or if you are not up for suggestions at all.

So the thing is: not all craft are designed with parts 'showing'. imagine, for instance, if you use an empty structural fuselage and fill it with tanks, batteries etc, in a manner that when your craft is finished, the parts are 'buried' inside and not visible after you launch. If you place a part inside other, and it fails, you get the sound alarm but there is no way to know where the flaw is. Could the GUI perhaps have a little tab showing what part has presented the failure? Perhaps also the 'mute alarm' button could be replicated there, for convenience. 

I am also in doubt on what to type in the 'modifier' slot of the GUI. I am imagining that typing, say, 1.5 will make flaws happen 50% faster, and 0.5 would cut the frequency of flaws in half. Is that how it works? 

Edited by Daniel Prates
Link to comment
Share on other sites

55 minutes ago, gamerscircle said:

Hi there @linuxgurugamer , would it be possible that is Dangit goes off, to take the craft outta warp.. or have an option for that?

 Absolutely. But, I'm a little busy with some other stuff, so can you put in a issue at git hub so I don't lose this 

Link to comment
Share on other sites

  • 3 weeks later...

This mod does quite literally NOTHING for me.

I completely wiped out all my gamedata files, verified installation, and installed nothing but Toolbar Control, ClickThroughBlocker, and DangIt and it STILL does absolutely nothing.

There's no button on the toolbar. No parts have MTBF lists or anything of the sort.

Output_Log: https://drive.google.com/open?id=1A-EHKU8Ks64DXNJX3xPyKYktxzHQO9Yq

 

 

Edited by Frostiken
Link to comment
Share on other sites

28 minutes ago, Frostiken said:

There's no button on the toolbar. No parts have MTBF lists or anything of the sort.

Did you install Module Manager?  It's also mentioned in the original post as a dependency.

Edited by Jacke
Link to comment
Share on other sites

It works now, but I think it was a combination of two things.

 

1) I somehow managed to get a copy of DangIt that contained NO plugin .dlls. Pretty sure I downloaded it from SpacePort and it was half blank.

2) The Interstellar mod is a bloated hog and contains a lot of other mods bundled in with it and I think it overwrote a bunch of crap. For example, the little wrench for the toolbar that lets you pick what shows up on which was totally missing, Haystack never showed up with its icon.

 

I deleted everything and reinstalled everything using CKAN this time and it came back to life. I promise you it wasn't me being stupid though. I'm like 99% certain it was KSPIE 

Link to comment
Share on other sites

7 hours ago, Frostiken said:

1) I somehow managed to get a copy of DangIt that contained NO plugin .dlls. Pretty sure I downloaded it from SpacePort and it was half blank.

LOL Spaceport hasn't been around for many years.  Are you referring to SpaceDock?

8 hours ago, Frostiken said:

) The Interstellar mod is a bloated hog and contains a lot of other mods bundled in with it and I think it overwrote a bunch of crap. For example, the little wrench for the toolbar that lets you pick what shows up on which was totally missing, Haystack never showed up with its icon.

 

I deleted everything and reinstalled everything using CKAN this time and it came back to life. I promise you it wasn't me being stupid though. I'm like 99% certain it was KSPIE 

Good, glad you figured it out.   If the wrench is missing, then that means the Toolbarcontroller wasn't installed.  Probably KSPIE doesn't include it

Link to comment
Share on other sites

10 hours ago, Fnhatic said:

Yeah I just checked KSPIE and it's got a ton of obsolete, old mods bundled. I have no idea what the logic there is but it's potentially catastrophic.

I contact him, he is going to update my mods, but it's not something I support (KSPIE).  There was big to-do in the past year about  modpacks, and how at the very least a modpack (I hesitate to call him an author) editor should at least get permission before bundling mods.  The KSPIE has at least three of my mods bundled, and he never asked me permission.  To say that I'm annoyed is being kind.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...