Lisias

[>= 1.4] TweakScale - Under Lisias' Management - 2.4.3.4 - 2019-0903

Recommended Posts

Just now, Machine Maker said:

Ok, will do.

Nah. Nailed already. You use Munar Industries and MarkIV system. It's the same problem that hit @Critter79606. Do what follows:

  1. Replace the following TweakScale files:
    1. GameData/TweakScale/patches/B9_HX.cfg with this file. Click in "Raw" then download the artifact and replace the offending file with it.
    2. GameData/TweakScale/patches/MarkIVSystem_TweakScale.cfg with this one. Same thing.
  2. Replace the following Munar Industries file:
    1. GameData/MunarIndustries/MFTX_TweakScale.cfg with this one. Ditto.

TweakScale 2.4.3.1 will be released this week, and it will have the B9 and MarkIV fixes implemented.

Keep an eye on the Munar Industries for the next release. I had applied a pull request with the fix.

But keep using S.A.V.E . Just in case. :)

Share this post


Link to post
Share on other sites
On 7/22/2019 at 10:36 PM, Lisias said:

Replace the following TweakScale files... GameData/TweakScale/patches/MarkIVSystem_TweakScale.cfg with this one. Same thing.

I was about to report an issue and fix for that file, but I see you're on it already. :confused:

Share this post


Link to post
Share on other sites
Posted (edited)

ANNOUNCE

Release 2.4.3.1 is available for downloading, with the following changes:

  • This is an emergencial Release due a Emergencial Release. :P
  • Adding KSPe Light facilites:
    • Logging
  • Closing or reworking the following issues:
    • #31 Preventing being ran over by other mods
      • A misbehaviour on detecting the misbehaviour :) was fixed.
    • #47 Count failed Sanity Checks as a potential problem. Warn user.
    • #48 Backport the Heterodox Logging system into Orthodox (using KSPe.Light)
    • #49 Check the Default patches for problems due wildcard!
    • #50 Check the patches for currently supported Add'Ons
      • ModuleGeneratorExtended Behaviour
    • #51 Implement a Cancel button when Actions are given to MessageBox
      • Yeah. Doing it right this time.
    • #54 [ERR ***FATAL*** link provided in KSP.log links to 404
      • Typo maldito, typo maldito - tralálálálálálá
    • #56 Breaking Parts patches
    • #57 Implement Warning Dialogs
      • Warnings about Overrules, parts that couldn’t be checked and parts with TweakScale support withdrawn.
      • Doing it right this time!
    • #58 Mk4 System Patch (addendum)

See OP for the links.

Highlights

A new TWEAKSCALEBEHAVIOUR, ModuleGeneratorExtended , is available for parts using ModuleGenerator that wants to scale the INPUT_RESOURCES too. This feature wasn’t introduced directly into the ModuleGenerator’s TWEAKSCALEEXPONENTS to prevent damage on Add'Ons (and savegames) that rely on the current behaviour (scaling only the output), as suddenly the resource consumption would increase on already stablished bases and crafts.

Just add the lines as the example below (the output resources scaling is still inherited from the default patch!).

@PART[my_resource_converter]:NEEDS[TweakScale]
{
    #@TWEAKSCALEBEHAVIOR[ModuleGeneratorExtended]/MODULE[TweakScale] { }
    %MODULE[TweakScale]
    {
        type = free
    }
}

WARNINGS

The last detected Unholy interaction between modules (Kraken Food), when rogue patches apply twice the same property on a part, are still detected on the Sanity Checks and a (now) proper (scaring) warning is being shown. Unfortunately, this issue is a serious Show Stopper, potentially (and silently) ruining your savegames. This is not TweakScale fault, but yet it’s up to it to detect the problem and warn you about it. If this happens with you, call for help. Now a Cancel button is available for the brave Kerbonauts willing to fly unsafe.

TweakScale strongly recommends using S.A.V.E..

Special procedures for recovering mangled installments once the TweakScale is installed (triggering the MM cache rebuilding) are possible, but keep your savegames backed up. And DON`T SAVE your crafts once you detect the problem. Reach me on Forum for help.

TweakScale stills mangles further affected crafts and savegames with some badly (but recoverable) patched parts so when things are fixed, your crafts preserve the TweakScale settings without harm. THIS DOES NOT FIX THE PROBLEM, as this is beyond the reach of TweakScale - but it at least prevents you from losing your crafts and savegames once the problem happens and then is later fixed.

As usual, this version still drops support in runtime for some problematic parts. Any savegame with such problematic parts scaled will have them descaled. This is not a really big problem as your game was going to crash sooner or later anyway - but if you plan to return to such savegame later when TweakScale will fully support that parts again, it’s better to backup your savegames!

Keep an eye on the Known Issues file.

— — — — —

This Release will be published using the following Schedule:

  • GitHub (reaching first manual installers and users of KSP-AVC): Right now.
  • CurseForge: Right now.
  • SpaceDock (and CKAN users): Right now.

The reasoning is to gradually distribute the Release to easily monitor the deployment and cope with eventual mishaps.

Edited by Lisias
SpaceDock updated.

Share this post


Link to post
Share on other sites

Note that the Nerta_Tweakscale.cfg (sic) will need updating with Nertea's new cryogenic engine names at some point.  If I don't get too distracted tomorrow I'll drop a PR in - it's not a big job.

Share this post


Link to post
Share on other sites

I've updated to the latest version (v2.4.3.1 of tweakscale), during the game loading process, I received numerous MM errors.  When I started my game, some of my crafts, the tweakscale properties defaulted back to default size and it appears that when I am in the VAB, I don't have the option to change the scale on any parts.  I've uploaded my ksp.log file:

https://www.dropbox.com/s/0jmm9gc9jpuwhae/KSP.log?dl=0

Did I do something wrong and am I missing something?

Any help would be appreciated.  I am using KSP 1.7.3.

Share this post


Link to post
Share on other sites
16 minutes ago, HawkEngineer said:

I've updated to the latest version (v2.4.3.1 of tweakscale), during the game loading process, I received numerous MM errors.  When I started my game, some of my crafts, the tweakscale properties defaulted back to default size and it appears that when I am in the VAB, I don't have the option to change the scale on any parts.  I've uploaded my ksp.log file:

https://www.dropbox.com/s/0jmm9gc9jpuwhae/KSP.log?dl=0

Did I do something wrong and am I missing something?

Any help would be appreciated.  I am using KSP 1.7.3.

Wow…. TweakScale is not working at all on your installment. By your log, the "Scale.dll" is missing!

Download TweakScale again from one of the links on the OP, delete the whole TweakScale folder on your GameData and install it again. I just checked the 3 links and eye balled the contents and the packages are fine. So something happened on your side of the cable-modem.

After giving a second look on the KSP.log, I ask your permission do additionally advise you to:

  • Install and use S.A.V.E. I'm doing my best to avoid breaking things, but there're a lot of Add'Ons "out there" and it's unfeasible I can check all of them for incompatibilities or mishaps with TweakScale. With S.A.V.E. we can be assured that such events, if happening, would be nuisances and not problems.
  • I found some log entries about problems with "WildBlueIndustries.ModuleBreakableFuelTank.onFlowStateChanged" and "InterstellarFuelSwitch.InterstellarFuelSwitch" . I don't have a clue about what's happening neither if this is serious or not - but on the recent past, when TweakScale was caught on such exceptions, bad things happened to the game. Better safe than sorry, I would ask about directions to the Add'Ons maintainers. It can be something simple as an outdated or missing dependency.
  • There's something broken on Kopernicus ("Could not load type 'System.Runtime.CompilerServices.ExtensionAttribute' from assembly 'KatLib"). Perhaps a missing dependency?
  • Since you are using KSP-AVC, consider using ZeroMiniAVC. The more recent package I found is here. There's a lot of useless MiniAVC dlls on your installment. Not a problem at all, but I find them annoying. :) 

On a side note, there's a really awful ammount of log messages saying "-INFO- System.Boolean[0][1636.83]: LoadFromStock" .  Tens of logs each Millisecond, thousands of logs each seacond. This thing is being a drag on your game, this awful amount of logging affects performance. If I manage to find the source, I'll let you know.

 

Share this post


Link to post
Share on other sites

I am also getting similar issues with tweakscale as Hawk but I am not getting any MM errors.

Share this post


Link to post
Share on other sites
Posted (edited)

The problem seems to be the CKAN release of tweakscale v2.4.3.1 , it is unfortunately missing a lot of files.

Reverting to v2.4.2.0 on CKAN fixed my game for now.

Edited by Marut
Extra info

Share this post


Link to post
Share on other sites
21 minutes ago, Marut said:

The problem seems to be the CKAN release of tweakscale v2.4.3.1 , it is unfortunately missing a lot of files.

Reverting to v2.4.2.0 on CKAN fixed my game for now.

Same experience. Seems all the recent bug reports are from that, it's missing most files. I used to be a "never CKAN" user, and I'm probably going back to that. Half my installed mods I've had to take over from CKAN anyway. Another complaint about the already broken CKAN version: it included all of the BreakingParts patches with no warning.

Share this post


Link to post
Share on other sites
Posted (edited)

Same problem here.
Tweakscale stopped working at all after updating via CKAN

After manual installation form github, everything seems to work fine, but im getting this:

Spoiler

sZIycw4.png

 

Edited by falcoon

Share this post


Link to post
Share on other sites
Posted (edited)

Yeah. And the fun begins. ;)

— — — 

@HawkEngineer, @Marut, @falcoon, @farnayway

CKAN problems: that caught me with my pants down. I don't have the slightest idea about what's happening. Since I didn't changed anything on the CKAN configuration file, added one DLL on the Plugins folder, some .CFG files on the TweakScale folder, and a new folder called __LOCAL/TweakScale - so it's hardly something I can revert or control.

I think this is most likely to be something wrong on CKAN itself. Did you guys reached the Maintainer?

— — — 

5 hours ago, whitespacekilla said:

Another complaint about the already broken CKAN version: it included all of the BreakingParts patches with no warning.

That folder is being shipped (on Github, CurseForge and SpaceDock) empty with only a README.md. This is the place where I recommend placing eventual patches needed to "break things again" in a controlled way to keep current savegames ongoing if the need arises.

Check if there's anything besides a README.md on that folder. It's meant to be populated by the user with custom patches made specially to that installation (since the __LOCAL thingy)

— — — 

@Rafael acevedo your log file is truncated, it doesn't goes to the point in which I can help.  With the full log I can say what the problems are, and if I can help or if we need to escalate it to someone else.

— — — 

1 hour ago, falcoon said:

 

  Hide contents

sZIycw4.png

 

This is happening to some parts that lack proper support and I had to withdraw support for these parts because they were crashing KSP.  TweakScale is doing it from some time already, this is the first time I'm displaying a message about.

There's no other alternative but to support the parts or bluntly withdraw support for them.

Some of these parts lacking support are Stock ones - they use ModulePartVariant with mass, and this is not implemented yet on TweakScale due the amount of issues I had to cope first. The TweakScale 2.4.4 series will be dedicated to implement support for these parts as also to add support to any other Stock part not supported yet.

But some other parts are not Stock and are not under my control, since the need of the message. Such parts need to have this tacked down by the maintainer in way or another.

— — —

@whitespacekilla . I will review the pull request ASAP.

Edited by Lisias
Hit "save" too soon.

Share this post


Link to post
Share on other sites
1 hour ago, Lisias said:

 

@Rafael acevedo your log file is truncated, it doesn't goes to the point in which I can help.  With the full log I can say what the problems are, and if I can help or if we need to escalate it to someone else.

 

Lisias, the problem was that the Tweakscale.DLL was missing.  This is caused by the CKAN install. I notice that the DLL was missing, removed the mod using ckan and reinstalled using Ckan. DLL wasn't installed. did a uninstall again with CKAN, followed by a full manual verification of the uninstall. Then I did a manual install using GITHUB file.  Errors were gone. I have an advisory on some 18 parts were tweakscale support was removed, but no fatal errors.

Thanks

Rafael

Share this post


Link to post
Share on other sites

I ran into the error messages after updating via CKAN to v2.4.3.1 and when I checked the Tweakscale folder in Gamedata, I also found that it was missing Scale.dll. Like @Rafael acevedo I installed from the Github release and now everything is A-Ok.

If I have time, I will try to replicate the problem with the CKAN update of Tweakscale and report it to the CKAN dev, but someone will probably beat me to it.

Share this post


Link to post
Share on other sites
13 hours ago, Lisias said:

Wow…. TweakScale is not working at all on your installment. By your log, the "Scale.dll" is missing!

Download TweakScale again from one of the links on the OP, delete the whole TweakScale folder on your GameData and install it again. I just checked the 3 links and eye balled the contents and the packages are fine. So something happened on your side of the cable-modem.

After giving a second look on the KSP.log, I ask your permission do additionally advise you to:

  • Install and use S.A.V.E. I'm doing my best to avoid breaking things, but there're a lot of Add'Ons "out there" and it's unfeasible I can check all of them for incompatibilities or mishaps with TweakScale. With S.A.V.E. we can be assured that such events, if happening, would be nuisances and not problems.
  • I found some log entries about problems with "WildBlueIndustries.ModuleBreakableFuelTank.onFlowStateChanged" and "InterstellarFuelSwitch.InterstellarFuelSwitch" . I don't have a clue about what's happening neither if this is serious or not - but on the recent past, when TweakScale was caught on such exceptions, bad things happened to the game. Better safe than sorry, I would ask about directions to the Add'Ons maintainers. It can be something simple as an outdated or missing dependency.
  • There's something broken on Kopernicus ("Could not load type 'System.Runtime.CompilerServices.ExtensionAttribute' from assembly 'KatLib"). Perhaps a missing dependency?
  • Since you are using KSP-AVC, consider using ZeroMiniAVC. The more recent package I found is here. There's a lot of useless MiniAVC dlls on your installment. Not a problem at all, but I find them annoying. :) 

On a side note, there's a really awful ammount of log messages saying "-INFO- System.Boolean[0][1636.83]: LoadFromStock" .  Tens of logs each Millisecond, thousands of logs each seacond. This thing is being a drag on your game, this awful amount of logging affects performance. If I manage to find the source, I'll let you know.

 

@Lisias,

I've followed your recommendations, I deleted my tweakscale install from CKAN and manually installed from the github download.  The install seems to be working, but I get the following messages after the game loads.  I searched the log file and can't seem to locate the messages and identify which parts are the issue.  Any help would be appreciated.

https://www.dropbox.com/s/awvclaezvmv3vq7/screenshot (1).png?dl=0

 

https://www.dropbox.com/s/255l8d07zq2ee5m/ksp.log?dl=0

Again, thanks for all your work on this mod and the quick response. 

 

Share this post


Link to post
Share on other sites
Posted (edited)
31 minutes ago, HawkEngineer said:

@Lisias,

I've followed your recommendations, I deleted my tweakscale install from CKAN and manually installed from the github download.  The install seems to be working, but I get the following messages after the game loads.  I searched the log file and can't seem to locate the messages and identify which parts are the issue.  Any help would be appreciated.

https://www.dropbox.com/s/awvclaezvmv3vq7/screenshot (1).png?dl=0

https://www.dropbox.com/s/255l8d07zq2ee5m/ksp.log?dl=0

Again, thanks for all your work on this mod and the quick response. 

 

Let's see:

The "Failed check" one is this:

[LOG 10:49:36.945] [TweakScale] ERROR: part=wingShuttleStrake (Big-S Wing Strake) Exception on Sanity Checks: System.NullReferenceException: Object
  at ConfigNode.CopyToRecursive (.ConfigNode node, Boolean overwrite) [0x00000] in <filename unknown>:0
  at ConfigNode.CopyToRecursive (.ConfigNode node, Boolean overwrite) [0x00000] in <filename unknown>:0
  at ConfigNode.CopyToRecursive (.ConfigNode node, Boolean overwrite) [0x00000] in <filename unknown>:0
  at ConfigNode.CreateCopy () [0x00000] in <filename unknown>:0
  at GameDatabase.GetConfigNode (System.String url) [0x00000] in <filename unknown>:0
  at TweakScale.PrefabDryCostWriter.GetMeThatConfigNode (.Part p) [0x00000] in <filename unknown>:0
  at TweakScale.PrefabDryCostWriter.checkForOverules (.Part p) [0x00000] in <filename unknown>:0
  at TweakScale.PrefabDryCostWriter+<WriteDryCost>d__3.MoveNext () [0x00000] in <filename unknown>:0

I will try to reproduce it in the next days, I ask for patience, it's working days for me. Be informed that besides that part is being mentioned, it may not be the "culprit', but what I call 'Screaming Victim". Don't bother the Maintainer yet, let me check it carefully to understand what's really happening. You can send me the ModuleManager cache files (so I can eye ball them)  if you know how - otherwise, please wait some days. And don't use that part for now, just in case (it may be fine, or it may bork - it's not knowing the problem).

The "support withdraw" thingy is:

[LOG 10:49:36.985] [TweakScale] WARNING: Removing TweakScale support for EnginePlate1p5 (EP-18 Engine Plate).
[LOG 10:49:36.985] [TweakScale] ERROR: Part EnginePlate1p5 (EP-18 Engine Plate) didn't passed the sanity check due EP-18 Engine Plate.
[LOG 10:49:36.985] [TweakScale] WARNING: Removing TweakScale support for EnginePlate2 (EP-25 Engine Plate).
[LOG 10:49:36.985] [TweakScale] ERROR: Part EnginePlate2 (EP-25 Engine Plate) didn't passed the sanity check due EP-25 Engine Plate.
[LOG 10:49:36.986] [TweakScale] WARNING: Removing TweakScale support for EnginePlate3 (EP-37 Engine Plate).
[LOG 10:49:36.986] [TweakScale] ERROR: Part EnginePlate3 (EP-37 Engine Plate) didn't passed the sanity check due EP-37 Engine Plate.
[LOG 10:49:36.986] [TweakScale] WARNING: Removing TweakScale support for EnginePlate4 (EP-50 Engine Plate).
[LOG 10:49:36.986] [TweakScale] ERROR: Part EnginePlate4 (EP-50 Engine Plate) didn't passed the sanity check due EP-50 Engine Plate.
[LOG 10:49:36.995] [TweakScale] WARNING: Removing TweakScale support for Tube1 (T-12 Structural Tube).
[LOG 10:49:36.995] [TweakScale] ERROR: Part Tube1 (T-12 Structural Tube) didn't passed the sanity check due T-12 Structural Tube.
[LOG 10:49:36.995] [TweakScale] WARNING: Removing TweakScale support for Tube1p5 (T-18 Structural Tube).
[LOG 10:49:36.995] [TweakScale] ERROR: Part Tube1p5 (T-18 Structural Tube) didn't passed the sanity check due T-18 Structural Tube.
[LOG 10:49:36.995] [TweakScale] WARNING: Removing TweakScale support for Tube2 (T-25 Structural Tube).
[LOG 10:49:36.995] [TweakScale] ERROR: Part Tube2 (T-25 Structural Tube) didn't passed the sanity check due T-25 Structural Tube.
[LOG 10:49:36.995] [TweakScale] WARNING: Removing TweakScale support for Tube3 (T-37 Structural Tube).
[LOG 10:49:36.995] [TweakScale] ERROR: Part Tube3 (T-37 Structural Tube) didn't passed the sanity check due T-37 Structural Tube.
[LOG 10:49:36.995] [TweakScale] WARNING: Removing TweakScale support for Tube4 (T-50 Structural Tube).
[LOG 10:49:36.995] [TweakScale] ERROR: Part Tube4 (T-50 Structural Tube) didn't passed the sanity check due T-50 Structural Tube.

These 9 ones is on me. These parts use a thing called MODULEPARTVARIANT that happens to change the mass of the variant, something that I will implement now on the 2.4.4.x series (that I'll start working on this WeekEnd). This is not a problem, as the parts will not use TweakScale for now, you can use them normally (the just can't be scaled by now) - but once I publish a DLL that does the job, everything will just works. And without breaking anything in use. :)

There're other reasons to have TweakScale support withdrawn, but these 9 ones you listed are just what I said.

My apologies for the nuisance, but I need to know what parts on the Wild need some care from TweakScale - and I don't have the time to check it myself. You can safely keep going on the game, the Message disappears by clicking on the button, by waiting the timeout or by starting a game - what happens first.

— — — — 

@HawkEngineer, @MaeharaProjekt, @Rafael acevedo, @falcoon, @whitespacekilla

@farnayway

Whoever manages to report this, please include me in the loop. I have some ideas about what can be happening, and there's a chance CKAN is just part of a collective bork (you need a lot of help to screw up some things!) instead of being the problem. In a way or another, I want to confirm my hypothesis before trying random thing and making things worse.

— — — — 

@Marut - try installing it from SpaceDock, CurseForce or Github if you are in a rush. It worked for the guys.

Edited by Lisias
Uh.. some bad grammars.

Share this post


Link to post
Share on other sites

This is a mess, I am afraid to update. I restored my old install from the recycling bin without even launching the game to see if this update works or not, even though I manually backed up my save folder with the intent to. I am glad and thankful you posted all the warnings and whatnot and I was able to catch it. I would be extremely furious if this had broken my most recent save, which is actually a restart/salvage from a previous save that managed to survive 4+ years of squad updates, mod updates and numerous numerous hours of enjoyable gameplay.

I don't have the patience to deal with yet another mod who has broken everything because of update. I guess this means I will be forever stuck with the version that I currently have. I realize this is not helpful in the least posting this, but I feel that I am not the only one who is frustrated, afraid and disappointed at how such a long-standing useful and straight forward mod has now because this mess of broken saves, forum complaints and what seems to be the mismanagement by the newly appointed management. 

I guess my question at this point is, will there ever be an update from this point forward that doesn't break or even risk breaking my current save? I refuse to start yet another new save just because of 1 mod with a broken update. 

Share this post


Link to post
Share on other sites
Posted (edited)

I got it to work.

I wasn't able to simply delete the old tweakscale using CKAN because it's required by KSP Interstellar Extended.  So I simply downloaded the newest version of tweak from curseforge and copied over the existing files.

This is one of my most favorite and useful mods, I totally appreciate the continued development !

Edited by enewmen

Share this post


Link to post
Share on other sites
Posted (edited)

I used CKAN to install version 2.4.2.0 again.

 

No errors.

Maybe someone can tell when the new version on CKAN "is save" again.

 

Till then, best luck building your rockets!!

Edited by PeaceFighter

Share this post


Link to post
Share on other sites
37 minutes ago, Haze-Zero said:

This is a mess, I am afraid to update.

I agree. This is a very unfortunate state of affairs.

Keep in mind, however, that people installing it manually are reporting success.

Whatever had happened, happened outside the scope of TweakScale, and it can happen again to anyone, on any Add-On. By any means this is something related to the Add-On itself.

That said, yes. This need to be identified and corrected or at least mitigated. Mainly because you are susceptible to this every time you update any Add-On.

Share this post


Link to post
Share on other sites
1 hour ago, Lisias said:

The "support withdraw" thingy is:


[LOG 10:49:36.985] [TweakScale] WARNING: Removing TweakScale support for EnginePlate1p5 (EP-18 Engine Plate).
[LOG 10:49:36.985] [TweakScale] ERROR: Part EnginePlate1p5 (EP-18 Engine Plate) didn't passed the sanity check due EP-18 Engine Plate.
[LOG 10:49:36.985] [TweakScale] WARNING: Removing TweakScale support for EnginePlate2 (EP-25 Engine Plate).
[LOG 10:49:36.985] [TweakScale] ERROR: Part EnginePlate2 (EP-25 Engine Plate) didn't passed the sanity check due EP-25 Engine Plate.
[LOG 10:49:36.986] [TweakScale] WARNING: Removing TweakScale support for EnginePlate3 (EP-37 Engine Plate).
[LOG 10:49:36.986] [TweakScale] ERROR: Part EnginePlate3 (EP-37 Engine Plate) didn't passed the sanity check due EP-37 Engine Plate.
[LOG 10:49:36.986] [TweakScale] WARNING: Removing TweakScale support for EnginePlate4 (EP-50 Engine Plate).
[LOG 10:49:36.986] [TweakScale] ERROR: Part EnginePlate4 (EP-50 Engine Plate) didn't passed the sanity check due EP-50 Engine Plate.
[LOG 10:49:36.995] [TweakScale] WARNING: Removing TweakScale support for Tube1 (T-12 Structural Tube).
[LOG 10:49:36.995] [TweakScale] ERROR: Part Tube1 (T-12 Structural Tube) didn't passed the sanity check due T-12 Structural Tube.
[LOG 10:49:36.995] [TweakScale] WARNING: Removing TweakScale support for Tube1p5 (T-18 Structural Tube).
[LOG 10:49:36.995] [TweakScale] ERROR: Part Tube1p5 (T-18 Structural Tube) didn't passed the sanity check due T-18 Structural Tube.
[LOG 10:49:36.995] [TweakScale] WARNING: Removing TweakScale support for Tube2 (T-25 Structural Tube).
[LOG 10:49:36.995] [TweakScale] ERROR: Part Tube2 (T-25 Structural Tube) didn't passed the sanity check due T-25 Structural Tube.
[LOG 10:49:36.995] [TweakScale] WARNING: Removing TweakScale support for Tube3 (T-37 Structural Tube).
[LOG 10:49:36.995] [TweakScale] ERROR: Part Tube3 (T-37 Structural Tube) didn't passed the sanity check due T-37 Structural Tube.
[LOG 10:49:36.995] [TweakScale] WARNING: Removing TweakScale support for Tube4 (T-50 Structural Tube).
[LOG 10:49:36.995] [TweakScale] ERROR: Part Tube4 (T-50 Structural Tube) didn't passed the sanity check due T-50 Structural Tube.

These 9 ones is on me. These parts use a thing called MODULEPARTVARIANT that happens to change the mass of the variant, something that I will implement now on the 2.4.4.x series (that I'll start working on this WeekEnd). This is not a problem, as the parts will not use TweakScale for now, you can use them normally (the just can't be scaled by now) - but once I publish a DLL that does the job, everything will just works. And without breaking anything in use. :)

There're other reasons to have TweakScale support withdrawn, but these 9 ones you listed are just what I said.

My apologies for the nuisance, but I need to know what parts on the Wild need some care from TweakScale - and I don't have the time to check it myself. You can safely keep going on the game, the Message disappears by clicking on the button, by waiting the timeout or by starting a game - what happens first.

 

 

Those are the same parts i have issues with. Happy to know you are working on them. Thanks for making this game great

Share this post


Link to post
Share on other sites
Posted (edited)

I made a quick research (ab)using a bit of the free time between tasks at job. This is what I got:

The download file from Github file, https://github.com/net-lisias-ksp/TweakScale/releases , is ok. I just downloaded (again) and checked it. It's all there. There's currently 95 downloads registered for this release on Github.

The download file from CurseForge, https://www.curseforge.com/kerbal/ksp-mods/tweakscale/files , is ok. I download it too and checked. There's currently 625 downloads registered for this release on CurseForge.

The download file from SpaceDock, https://spacedock.info/mod/127/TweakScale/download/2.4.3.1, is also ok. Yeah, I downloaded it and checked. There's about 800 downloads registered for this release on SpaceDock.

CKAN makes a beautiful job on archiving every Add'On they are allowed on the Archive.org. I don't care too much about the installer (I don't use it), but this is the reason I make a point on supporting CKAN how I can: they are preserving the Add'Ons to be available in the future, no matter what. :) The link is https://archive.org/download/TweakScale-v2.4.3.1 and yeah, it's fine too. I just checked.

And this is the reason why we need to work together and identify this problem. It's not a trivial one, it's not something that I made wrongly, or a bug on the CKAN installer, or something like that. It's something on the process as a whole. And it can happen again! :( 

— — — — 

Problem identified here. And no, this will not happen again. you can bet your SAS on it. :/ 

Edited by Lisias
problem identified.

Share this post


Link to post
Share on other sites
20 minutes ago, Rafael acevedo said:

 Thanks for making this game great

Greater. About 400% greater! :sticktongue:

(The maximum upsize scale allowed)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.