Lisias

[>= 1.4] TweakScale - Under Lisias' Management - 2.4.3.7 - 2019-1011

Recommended Posts

Fatal Error

[WRN 00:07:18.493] [TweakScale] **FATAL** Found a showstopper problem on TT.19.IRI.BODY.
[ERR 00:07:18.493] [TweakScale] **FATAL** Part TT.19.IRI.BODY has a fatal problem due having duplicated properties - see issue #34 -

Share this post


Link to post
Share on other sites
Posted (edited)
22 hours ago, Xt007 said:

Fatal Error

[WRN 00:07:18.493] [TweakScale] **FATAL** Found a showstopper problem on TT.19.IRI.BODY.
[ERR 00:07:18.493] [TweakScale] **FATAL** Part TT.19.IRI.BODY has a fatal problem due having duplicated properties - see issue #34 -

Yep. Sorry for that. 

I need your full KSP.log to be able to diagnose this. Post it on pastebin or similar, please. 

Backup your savegames. Any craft using this part is going to cause you trouble when we fix the problem. 

------- POST EDIT ----

I think I managed to locate the mishap. If I'm right, you are lucky: you found the only situation where this misbehavior is not destructive. :)

I will confirm my thesis in the morning and get back to you.

— — — POST POST EDIT — — — 

@Xt007, I confirmed the problem and fixed it unofficially.

Replace the file GameData/TundraTechnologies/Patches/Tweakscale.cfg with this content:

@PART[TT_19*RCS*]:NEEDS[TweakScale]
{
	%MODULE[TweakScale]
	{
		type = free_square
	}
}

@PART[TT_19_IRI_BODY,TT_19_NH_BODY]:NEEDS[TweakScale]
{
	%MODULE[TweakScale]
	{
		type = free_square
	}
}

@PART[TT_19_NH_SOLAR]:NEEDS[TweakScale]
{
	%MODULE[TweakScale]
	{
		type = free_square
	}
}

@PART[TT_19_NH_Generator]:NEEDS[TweakScale]
{
	%MODULE[TweakScale]
	{
		type = free_square
	}
}

This will fix your issue. I'm issuing a pull request to the Add'On maintainer with this fix.

— — — POST POST POST EDIT — — — 

Pull request made: https://github.com/damonvv/TundraExploration/pull/16

Now it's up to the Maintainer. Ping @damonvv!

Edited by Lisias
I think I found the problem.

Share this post


Link to post
Share on other sites
Posted (edited)

Get this weird bug (craft built in 1.4.3)

ksp 1.7.1 both expansion

tweakscale 2.4.2.0 and 2.4.3.0 (tested both same result)

I added a new precooler in the middle to show the difference.

9YzLKYy.png

Edited by Mathrilord

Share this post


Link to post
Share on other sites
Posted (edited)
8 hours ago, Mathrilord said:

Get this weird bug (craft built in 1.4.3)

ksp 1.7.1 both expansion

tweakscale 2.4.2.0 and 2.4.3.0 (tested both same result)

Two instances of the same tweakable is a patch issue - sometimes, it's intentional, sometimes it's not. Since the duplicated tweak is not a TweakScale Tweakable, this is not TweakScale related. TweakScale 2.4.3 don't check for duplicates outside TweakScale module node - there're legit uses for such twins tweakables - they are a problem only for TweakScale.

I need your KSP.log and your Module Manager's cache files in order to further help you if you want, but it's not TweakScale related.

Edited by Lisias
Krakens count the tyops!!!

Share this post


Link to post
Share on other sites

Here's part of my log file, pastebin size limit lol 

<script src="https://pastebin.com/embed_js/ed7cJueZ"></script>

Thank you for your hard work and remember "All work and no play makes Jeb a dull boy" Go blow something up!

Share this post


Link to post
Share on other sites
9 minutes ago, Mathrilord said:

I take that back. There's something… "Interesting" on your installment. TweakScale is getting Exceptions from everywhere!

[ERR 11:53:09.294] [TweakScale] part=s1p5booma (Size 1.5 Tail Connector A) Exception on Sanity Checks: System.NullReferenceException: Object ref
  at TweakScale.PrefabDryCostWriter.checkForShowStoppers (.Part p) [0x00000] in <filename unknown>:0
  at TweakScale.PrefabDryCostWriter+<WriteDryCost>d__3.MoveNext () [0x00000] in <filename unknown>:0
    
====
    
[WRN 11:55:04.822] ...no SyncModuleControlSurface module found on part definition. Skipping...
[WRN 11:55:04.823] [Part]: PartModule indexing mismatch at wingShuttleElevon1, index 0.
Node 'TweakScale' found in loaded data, but 'ModuleControlSurface' is defined in prefab.
Looking for TweakScale in other indices...
[WRN 11:55:04.823] ...TweakScale module found at index 1.
[WRN 11:55:04.827] [Part]: PartModule indexing mismatch at pointyNoseConeB, index 1.
Node 'TweakScale' found in loaded data, but 'ModulePartVariants' is defined in prefab.
Looking for TweakScale in other indices...
[WRN 11:55:04.827] ...TweakScale module found at index 2.
[WRN 11:55:04.830] [Part]: PartModule indexing mismatch at pointyNoseConeB, index 1.
Node 'TweakScale' found in loaded data, but 'ModulePartVariants' is defined in prefab.
Looking for TweakScale in other indices...
[WRN 11:55:04.830] ...TweakScale module found at index 2.
[WRN 11:55:04.835] [TweakScale Warning] No valid member found for surfaceArea in ModuleAeroSurface
TweakScale.Tools:LogWf(String, Object[])
    
====
    
[LOG 11:56:27.262] [FlightGlobals]: Part persistentId changed from 433306481 to 157418842. Vessel PersistentId 0
[WRN 11:56:27.267] [TweakScale Warning] No valid member found for surfaceArea in ModuleAeroSurface
TweakScale.Tools:LogWf(String, Object[])

I don't like the smell on this Kraken Poo. I'm on it.

Share this post


Link to post
Share on other sites
Posted (edited)

SyncModuleControlSurface is from AtmosphereAutopilot but should not cause problem. All the exceptions comes from AirplanePlus, no mention of rapier or precooler. Craft file must be corrupted.

edit:

TMasterson5 airplaneplus tweakscale patch probably not updated for aiplaneplus/ksp lastest version

Edited by Mathrilord

Share this post


Link to post
Share on other sites
36 minutes ago, Mathrilord said:

SyncModuleControlSurface is from AtmosphereAutopilot but should not cause problem. All the exceptions comes from AirplanePlus, no mention of rapier or precooler. Craft file must be corrupted.

Agreed. But yet the next logged line complains about ModuleControlSurface so perhaps we have a link somehow.

About the TMasterson5 , it's a lot of damage for only a faulty patched part. It's still interesting...

Share this post


Link to post
Share on other sites
Posted (edited)

Just installed sxt, on mainmenu tweakscale say 6 fatal error but I found only 5 in log

Spoiler

[WRN 13:04:41.363] [TweakScale] **FATAL** Found a showstopper problem on SXTInlineAirIntake.
[ERR 13:04:41.363] [TweakScale] **FATAL** Part SXTInlineAirIntake has a fatal problem due having duplicated properties - see issue #34 - https://github.com/net-lisias-ksp/TweakScale/issues/34.

[WRN 13:04:41.364] [TweakScale] **FATAL** Found a showstopper problem on SXTWingSmall.
[ERR 13:04:41.364] [TweakScale] **FATAL** Part SXTWingSmall has a fatal problem due having duplicated properties - see issue #34 - https://github.com/net-lisias-ksp/TweakScale/issues/34.

[WRN 13:04:41.364] [TweakScale] **FATAL** Found a showstopper problem on SXTWingLarge.
[ERR 13:04:41.364] [TweakScale] **FATAL** Part SXTWingLarge has a fatal problem due having duplicated properties - see issue #34 - https://github.com/net-lisias-ksp/TweakScale/issues/34.

[WRN 13:04:41.365] [TweakScale] **FATAL** Found a showstopper problem on SXTOsaulNoseCockpitAn225.
[ERR 13:04:41.365] [TweakScale] **FATAL** Part SXTOsaulNoseCockpitAn225 has a fatal problem due having duplicated properties - see issue #34 - https://github.com/net-lisias-ksp/TweakScale/issues/34.

[WRN 13:04:41.366] [TweakScale] **FATAL** Found a showstopper problem on SXTOsualRadCockpit.
[ERR 13:04:41.366] [TweakScale] **FATAL** Part SXTOsualRadCockpit has a fatal problem due having duplicated properties - see issue #34 - https://github.com/net-lisias-ksp/TweakScale/issues/34.

Edit: my bad, found the sixth. Wondering why research tool wasn't able to see it with fatal as key word.

Spoiler

[WRN 13:04:41.370] [TweakScale] **FATAL** Found a showstopper problem on SXTtruckbox.
[ERR 13:04:41.370] [TweakScale] **FATAL** Part SXTtruckbox has a fatal problem due having duplicated properties - see issue #34 - https://github.com/net-lisias-ksp/TweakScale/issues/34.

 

Edited by Mathrilord

Share this post


Link to post
Share on other sites
Posted (edited)

AtmosphereAutopilot use its own module(SyncModuleControlSurface) to control aero part, engine(custom gimbal module) and maybe reaction wheel(not sure). It disable stock Module(ModuleControlSurface) when installed. When uninstalled the game switch back to stock module. (That's from what I understand)

With clean install + MH + BG + AirplanePlus(needed to load the craft) + Tweakcale + MM (no patch) problem still there as tweakscale is the only thing affecting stock part (Shock cone intake, Engine Pre-cooler and Rapier). If you look closely on the picture whe can see that the precooler scale is a bit off(LF too)(weirdly, Shock cone intake infront of pre-cooler has the same off scale). The only thing that could have affect the pre-cooler part in previous install is tweakable everything and a ressource switcher but I'm sure I had none install when I built this craft.

PS: If I delete .cfg of the part with fatal error I should be able to play with sxt without worry?

PS2: English not first language, am I doing great?

PS5: sorry still waiting after Sony (not that I care about it)

edit: does Showstopper thing can corrupt more than the save file you've loaded? Because I create a new save to see which part they are.

Edited by Mathrilord

Share this post


Link to post
Share on other sites
Posted (edited)
4 hours ago, Mathrilord said:

PS: If I delete .cfg of the part with fatal error I should be able to play with sxt without worry?

PS2: English not first language, am I doing great?

PS5: sorry still waiting after Sony (not that I care about it)

edit: does Showstopper thing can corrupt more than the save file you've loaded? Because I create a new save to see which part they are.

PS: Yes. It's kinda killing the victim to avoid the crime, but it works. :) 

PS2: As good as mine. What's not exactly a compliment. :sticktongue:

edit: Yes. It will corrupt every single savegames you load that uses one of the problematic parts. Worst - as you create new crafts, they appears to work fine (because the game "adapts" to the corruption). But then when you delete or install some other Add'On and MM rebuilds the cache, things can change (more corruption, or corruption being fixed) and then all your crafts and savegames are ruined.

— — 

About the remaining reports, I'm working on it. :)

If it serves of something, my main game got 182 Fatalities (I will rename it to "Mortal Kombat!!"").

Chances are that  by fixing my rig, a lot of your problems will be fixed too. This game is being ran for months, I have a huge amount of crafts to salvage… Oh joy… :D 

59162363-0d21fe00-8ac6-11e9-969a-e779b79

(and, of course, I found a tyop :P on the Message Box! KRAKENS….)

Edited by Lisias
YEAP. found a tyop!

Share this post


Link to post
Share on other sites
Posted (edited)
11 hours ago, Mathrilord said:

edit:

TMasterson5 airplaneplus tweakscale patch probably not updated for aiplaneplus/ksp lastest version

TMasterson5's patches are not using :NEEDS,, meaning that the patches are being injected no matter TweakScale is installed or not. It's also adding the value name "type" no matter there's already one or not.

All the patches are essentially what follows:

        @PART[<partname>]
        {
                %MODULE[TweakScale]
                {
                        type = free
                }
        }

On the bright side, TMasterson5 carefully patched the parts by name, using no Wildcards.

It worths to mention that without the :NEEDS, TMasterson5's patches are applied before TweakScale ones, due the Alphabetical order used to apply patches in MM's LEGACY mode. My advice is to ask TMasterson5 to add ":NEEDS[TweakScale]" on every patch to prevent problems in the future - since he adopted a very restrictive license (CC BY-NC-ND), I'm afraid I can't help further.

However, this is not the root cause of your problem. I deinstalled the TMasterson5's patches and the SXT fatalities are still there. I can confirm that the source of the problem is, indeed, the SXT patches as I testing it on a test bed with minimal Add'On installed. I'm still looking on the matter, but I can tell in advance that SXT uses a License that allows me to help, and the Maintainer is very helpful on handling bugs. Once I confirm the problem and cook a fix, you can take for granted it will be fixed on the next release (being SXT or TweakScale, depending of the source of the mishap).

— — — Post Edit — — — 

These problems on the SXT are the serious one:

                MODULE
                {
                        name = TweakScale
                        type = surface
                        defaultScale = 1.25
                        type = free
                }

You see the double "type" value? This is the thing that will corrupt your savegames. Currently,  you should be using the "free" value but in the exact instant we fix your installment, the other value will be used instead (probably surface, as usually the problematic patch are the one being applied later and so is the one that vanishes). And then TweakScale will get confused as it was scaling things on the "free" premises and now it is being told to use "surface".

— — — POST POST EDIT — — — 

The Pull Request was applied.

https://github.com/linuxgurugamer/SXTContinued/pull/71

In the mean time, you can download this file and replace the old in GameData/SXT/Patches/ModCompatibility . Be advised that until the SXT Maintainer accepts the pull request (if ever), this is not a official fix. :)

Ping @linuxgurugamer !

Edited by Lisias
Port edit!

Share this post


Link to post
Share on other sites
Posted (edited)

If part variant is incompatible with tweakscale does it mean that Restock make Vector engine not resizable since it get variant

Thanks for your time :D very appreciated

Edited by Mathrilord

Share this post


Link to post
Share on other sites
3 minutes ago, Mathrilord said:

If part variant is incompatible with tweakscale does it mean that Restock make Vector engine not resizable since it get variant

Only when MASS is applied on the Variants. When there's no mass on the MODULEPARTVARIANT, scaling happens properly (or if something is wrong, I wasn't notified yet!)

https://github.com/net-lisias-ksp/TweakScale/issues/13 

In time, I just fixed SXT. I'm applying a PULL REQUEST soon. will notify on the original post.

Share this post


Link to post
Share on other sites
Posted (edited)
8 hours ago, Vaga said:

Don't know if this helps but I am also getting some errors from Tweakscale.  That bad ones are from mk4cockpit-shoulder-1  to -3 Part of near future space planes.

https://drive.google.com/file/d/16Vrk0htq-o5QKgDHs8KO0SOOjEf6_fqP/view?usp=sharing

The KSP.log would make things easier. But since you had nailed the part names for me, I could check for myself - I'm using Mark IV System (the Add'On where these parts lives), so I known them. :) 

And yeah, I confirm the problem:

[WRN 00:54:33.323] [TweakScale] **FATAL** Found a showstopper problem on mk4cockpit-shoulder-1.
[ERR 00:54:33.323] [TweakScale] **FATAL** Part mk4cockpit-shoulder-1 has a fatal problem due having duplicated properties - see issue #34 - https://github.com/net-lisias-ksp/TweakScale/issues/34.

[WRN 00:54:33.323] [TweakScale] **FATAL** Found a showstopper problem on mk4cockpit-shoulder-2.
[ERR 00:54:33.323] [TweakScale] **FATAL** Part mk4cockpit-shoulder-2 has a fatal problem due having duplicated properties - see issue #34 - https://github.com/net-lisias-ksp/TweakScale/issues/34.

[WRN 00:54:33.323] [TweakScale] **FATAL** Found a showstopper problem on mk4cockpit-shoulder-3.
[ERR 00:54:33.323] [TweakScale] **FATAL** Part mk4cockpit-shoulder-3 has a fatal problem due having duplicated properties - see issue #34 - https://github.com/net-lisias-ksp/TweakScale/issues/34.

And yeah. They are also of the nasty type (from the MM cache)

                MODULE
                {
                        name = TweakScale
                        type = stack
                        defaultScale = 5.0
                        type = surface
                }

However… This is on me:blush: The default TweakScale patches for the Mark IV System is to be blamed on this one. My apologies, I should had checked my own patches for wildcards earlier, I completely missed that.:blush:

Since this is the nasty kind of problem, I suggest you to bluntly delete "MarkIVSystem_TweakScale.cfg" from GameData/TweakScale/patches folder. As long you are not scaling any Mark IV parts, you will be fine - but, as always, backup your savegames. It's easier to salvage things before they are broken. The Mark IV parts will be the first I will fix and I will post the corrected file here.

You can overlook the issue here: https://github.com/net-lisias-ksp/TweakScale/issues/49

A new release will be issued as soon as possible with this problem fixed, as well any other I find in the mean time: https://github.com/net-lisias-ksp/TweakScale/milestone/7

 

Edited by Lisias
Issue and milestone

Share this post


Link to post
Share on other sites
Posted (edited)
9 hours ago, Lisias said:

 

— — — Post Edit — — — 

These problems on the SXT are the serious one:


                MODULE
                {
                        name = TweakScale
                        type = surface
                        defaultScale = 1.25
                        type = free
                }

You see the double "type" value? This is the thing that will corrupt your savegames. Currently,  you should be using the "free" value but in the exact instant we fix your installment, the other value will be used instead (probably surface, as usually the problematic patch are the one being applied later and so is the one that vanishes). And then TweakScale will get confused as it was scaling things on the "free" premises and now it is being told to use "surface".

— — — POST POST EDIT — — — 

The Pull Request was applied.

https://github.com/linuxgurugamer/SXTContinued/pull/71

In the mean time, you can download this file and replace the old in GameData/SXT/Patches/ModCompatibility . Be advised that until the SXT Maintainer accepts the pull request (if ever), this is not a official fix. :)

Ping @linuxgurugamer !

First time Ive heard of SXT being used with TW.  Will review and apply patch later today

Edited by linuxgurugamer

Share this post


Link to post
Share on other sites
Posted (edited)
On 6/9/2019 at 8:12 AM, Lisias said:

Yep. Sorry for that. 

I need your full KSP.log to be able to diagnose this. Post it on pastebin or similar, please. 

Backup your savegames. Any craft using this part is going to cause you trouble when we fix the problem. 

------- POST EDIT ----

I think I managed to locate the mishap. If I'm right, you are lucky: you found the only situation where this misbehavior is not destructive. :)

I will confirm my thesis in the morning and get back to you.

— — — POST POST EDIT — — — 

@Xt007, I confirmed the problem and fixed it unofficially.

Replace the file GameData/TundraTechnologies/Patches/Tweakscale.cfg with this content:


@PART[TT_19*RCS*]:NEEDS[TweakScale]
{
	%MODULE[TweakScale]
	{
		type = free_square
	}
}

@PART[TT_19_IRI_BODY,TT_19_NH_BODY]:NEEDS[TweakScale]
{
	%MODULE[TweakScale]
	{
		type = free_square
	}
}

@PART[TT_19_NH_SOLAR]:NEEDS[TweakScale]
{
	%MODULE[TweakScale]
	{
		type = free_square
	}
}

@PART[TT_19_NH_Generator]:NEEDS[TweakScale]
{
	%MODULE[TweakScale]
	{
		type = free_square
	}
}

This will fix your issue. I'm issuing a pull request to the Add'On maintainer with this fix.

— — — POST POST POST EDIT — — — 

Pull request made: https://github.com/damonvv/TundraExploration/pull/16

Now it's up to the Maintainer. Ping @damonvv!

Fixed on the github. Will take some time to be in the actual release. Thanks for noticing! Now I need to find myself a hammer and invite @JadeOfMaar for a drink :sticktongue:

Edited by damonvv

Share this post


Link to post
Share on other sites
1 hour ago, damonvv said:

Thanks for noticing! Now I need to find myself a hammer and invite @JadeOfMaar for a drink :sticktongue:

Could you borrow me the hammer? I think my own has a **FATAL** due a patching problem. :D 

Share this post


Link to post
Share on other sites
Posted (edited)
12 hours ago, Lisias said:

The KSP.log would make things easier. But since you had nailed the part names for me, I could check for myself - I'm using Mark IV System (the Add'On where these parts lives), so I known them. :) 

And yeah, I confirm the problem:


[WRN 00:54:33.323] [TweakScale] **FATAL** Found a showstopper problem on mk4cockpit-shoulder-1.
[ERR 00:54:33.323] [TweakScale] **FATAL** Part mk4cockpit-shoulder-1 has a fatal problem due having duplicated properties - see issue #34 - https://github.com/net-lisias-ksp/TweakScale/issues/34.

[WRN 00:54:33.323] [TweakScale] **FATAL** Found a showstopper problem on mk4cockpit-shoulder-2.
[ERR 00:54:33.323] [TweakScale] **FATAL** Part mk4cockpit-shoulder-2 has a fatal problem due having duplicated properties - see issue #34 - https://github.com/net-lisias-ksp/TweakScale/issues/34.

[WRN 00:54:33.323] [TweakScale] **FATAL** Found a showstopper problem on mk4cockpit-shoulder-3.
[ERR 00:54:33.323] [TweakScale] **FATAL** Part mk4cockpit-shoulder-3 has a fatal problem due having duplicated properties - see issue #34 - https://github.com/net-lisias-ksp/TweakScale/issues/34.

And yeah. They are also of the nasty type (from the MM cache)


                MODULE
                {
                        name = TweakScale
                        type = stack
                        defaultScale = 5.0
                        type = surface
                }

However… This is on me:blush: The default TweakScale patches for the Mark IV System is to be blamed on this one. My apologies, I should had checked my own patches for wildcards earlier, I completely missed that.:blush:

Since this is the nasty kind of problem, I suggest you to bluntly delete "MarkIVSystem_TweakScale.cfg" from GameData/TweakScale/patches folder. As long you are not scaling any Mark IV parts, you will be fine - but, as always, backup your savegames. It's easier to salvage things before they are broken. The Mark IV parts will be the first I will fix and I will post the corrected file here.

You can overlook the issue here: https://github.com/net-lisias-ksp/TweakScale/issues/49

A new release will be issued as soon as possible with this problem fixed, as well any other I find in the mean time: https://github.com/net-lisias-ksp/TweakScale/milestone/7

 

Woops.  Looked at the file I did share. and somehow did not get the correct file.  :P Here is the KSP log if you still need it.

https://drive.google.com/file/d/1gUFY2pIzGKxKbWtuFHQhGs3tkg5gu-b3/view?usp=sharing

Edited by Vaga

Share this post


Link to post
Share on other sites
Posted (edited)
7 hours ago, Vaga said:

Woops.  Looked at the file I did share. and somehow did not get the correct file.  :P Here is the KSP log if you still need it.

https://drive.google.com/file/d/1gUFY2pIzGKxKbWtuFHQhGs3tkg5gu-b3/view?usp=sharing

Thank you! With that very nice collection of Add'Ons you have installed, and only my owns borks listed as **FATAL**, I can be somewhat confident that by fixing my patches I would reach a pretty decent amount of flawless installments.

With my own installment getting me that 182 fatalities (I think I 'm running a pretty uncommon collection of Add'Ons! :P ), once I fix it I can rush 2.4.3.1 into release and retake the publishing schedule.

Edited by Lisias
I'm eating words! Literally! :P

Share this post


Link to post
Share on other sites

Its TweakScale - TweakScale/PluginData/KSPeLight.DLL

Share this post


Link to post
Share on other sites
Posted (edited)
4 hours ago, zer0Kerbal said:

always like seeing what mods other use: what is "KSPe Light v2.1.0.10"?

It's a trimmed down small subset of KSPe (my personal library for KSP with some tools and extensions to make my life easier) that is safe for broad usage. Essentially, every "official" mod of mine that needs KSPe service will have its own KSPe.Light embedded. I'm pretty tired of maintaining two forks, one without and another with KSPe and since I don't have time for now to overcome the bugs of that freaking pestilence called Mono's runtime (yeah, I'm pretty " liquided " with that thing), I came to this stunt. It's far from being what I want, but it will do for now.

I would not use them if you are an Add'On Author. It will change on every release (it's tailored for TweakScale), and I hope to throw it away as soon as I deal with the problems I mentioned.

 

3 hours ago, Vaga said:

Its TweakScale - TweakScale/PluginData/KSPeLight.DLL

Yup. On the hurry to publish the thing I forgot to properly name the file, it should be KSPe.Light.TweakScale.dll - it will be fixed on the next minor release.

Edited by Lisias
Adding link to the source!! O forgot to mention it on the README!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.