Lisias

[>= 1.4] TweakScale - Under Lisias' Management - 2.4.3.7 - 2019-1011

Recommended Posts

3 hours ago, Lisias said:

When I did this stunt, I was thinking everything would be fixed by now. :P I thought the really heavy lifting on support would happen on 2.5, then I will shove :FOR[TweakScale] on the patches and then getting TweakScale out of the LEGACY patching. :P

I jokingly "advise" to add a HOTFIX value so an AlertBox would remind you about the hack, so you don't risk forgetting this when TweakScale starts supporting them. :sticktongue:

I understand - and fully support what you did/are doing. I tried to make some light/humor.

 

hotfix value? why, I'd never forget I patched this. :P

Share this post


Link to post
Share on other sites
15 hours ago, Lisias said:

@DodoOnTheMün, I will need to handle this the hard way - by manually inspecting the Add'Ons patches, this is going to take more time than I have available right now. I will come back to it by night.

alright, good thing I made notes of all my planned vehicles and scenarios expecting this to take a while

Share this post


Link to post
Share on other sites
7 hours ago, zer0Kerbal said:

I understand - and fully support what you did/are doing. I tried to make some light/humor.

I understood. And I joked back, "advising" you to use another stunt that would trigger another Alert Box - I was hopping you would try it... :sticktongue:

But I thought it would be a good opportunity to explain why this thing is lingering for so much time. Murphy was a prophet! :)

Share this post


Link to post
Share on other sites
10 hours ago, IronKerbal said:

@LisiasDo you have a guide to Using realchute with your mod?
Realchute does not scale with tweakscale

But stock chutes Do

RealChutes, as far as I know, use its own Module. So you will need a custom TWEAKSCALEEXPONENTS to it.

Something like this in a CFG file somewhere.

TWEAKSCALEEXPONENTS
{
	name = RealChuteModule
	caseMass = 3		// Cubic expoent
	spareChutes = 2		// Quadratic expoent
	PARACHUTE
	{
		preDeployedDiameter = 1.8	// You can use fractional expoents too, but this can be tricky!
		deployedDiameter = 2.5 		// You need to make a lot of tests on it!
	}
}

Then you need to add the TweakScale module to the part:

@PART[RC_cone]:NEEDS[RealChute]
{
	%MODULE[TweakScale]:NEEDS[TweakScale]
	{
		%type = stack
		%defaultScale = 1.25 // Or whatever is the default size of the part
	}
}
		

Please note that I made this from heart, I don't have a clue if this will work as is - it will probably not.

Good luck!

Share this post


Link to post
Share on other sites
30 minutes ago, Lisias said:

I understood. And I joked back, "advising" you to use another stunt that would trigger another Alert Box - I was hopping you would try it... :sticktongue:

But I thought it would be a good opportunity to explain why this thing is lingering for so much time. Murphy was a prophet! :)

*chuckle* yes, Murphy was / is (pop culture reference)  a purple prophet!

and :faceplant: am too lazy to do that. :P

Share this post


Link to post
Share on other sites
2 hours ago, DodoOnTheMün said:

alright, good thing I made notes of all my planned vehicles and scenarios expecting this to take a while

Uh… I completely missed this:

Folders and files in GameData:
AirplanePlus
B9AnimationModules
B9PartSwitch
B9_Aerospace
B9_Aerospace_HX
B9_Aerospace_Legacy
BDArmory
Firespitter
GameData
JSI
SMArmory
SmokeScreen
Stock folder: Squad

Do you see that "GameData" below Firespitter? It should not be there. It's probably a mistake on installing things. You have some Add'Ons there:

[LOG 13:37:56.318] AssemblyLoader: Loading assembly at C:\Program Files (x86)\Steam\steamapps\common\Kerbal Space Program\GameData\GameData\KTech\Plugins\KTechCategoryMaster.dll
<cut>
[WRN 13:40:38.470] Texture resolution is not valid for compression: 'C:\Program Files (x86)\Steam\steamapps\common\Kerbal Space Program\GameData\GameData\LShipPartsRequired\Agencies\FNE_scaled.png' - consider changing the image's width and height to enable compression

Please move KTech and LShipPartsRequired (and everything else if more) from GameData\GameData to GameData.

This doesn't appears to be related to this issue, but this can cause some other problems (mainly on parts trying to reuse assets).

I'll try an installment using the currently available Add'Ons (some of yours are not available for downloading anymore, and they are ARR!). I'm specially curious about some parts having TweakScale shoved on it without an "Applying update" log from Module Manager!

Share this post


Link to post
Share on other sites

Question, I did a clean install of KSP and reinstalled my Mods now I am seeing a few weird issues scaling. For example, OPT Wing Type C used to be lets say "2.25" and then I could adjust it. It now says "2" and when I move it the wing shrinks. The same happens to MK2 parts and a bulk of other parts no longer have the inch scale for the tweaking, just a number range. I must have done something wrong I installed this via CKAN and did no CFG editing.

Share this post


Link to post
Share on other sites
5 hours ago, KIMCHI said:

Question, I did a clean install of KSP and reinstalled my Mods now I am seeing a few weird issues scaling. For example, OPT Wing Type C used to be lets say "2.25" and then I could adjust it. It now says "2" and when I move it the wing shrinks. The same happens to MK2 parts and a bulk of other parts no longer have the inch scale for the tweaking, just a number range. I must have done something wrong I installed this via CKAN and did no CFG editing.

I will need your full KSP.log and ModuleManager.ConfigCache in order to check what's happening. It sounds like something patched these parts with "type = free", that it's the scaling that does what you describes.

The Standard TweakScale distribution is working fine for Mk2.

WjEkUim.png

The Add'On I know that does that is All Tweak!! . Did you have it installed?

ERRATA

Nope, All Tweak uses stack, just checked. I need your KSP.log and ModuleManager.ConfigCache to figure out what's happening

Edited by Lisias
Errata

Share this post


Link to post
Share on other sites
4 hours ago, Lisias said:

I will need your full KSP.log and ModuleManager.ConfigCache in order to check what's happening. It sounds like something patched these parts with "type = free", that it's the scaling that does what you describes.

The Standard TweakScale distribution is working fine for Mk2.

WjEkUim.png

The Add'On I know that does that is All Tweak!! . Did you have it installed?

ERRATA

Nope, All Tweak uses stack, just checked. I need your KSP.log and ModuleManager.ConfigCache to figure out what's happening

https://1drv.ms/u/s!ApS4szxClp5oiJYvsHjSvmZoe8spAg?e=6Pxh6n

Both files are there. Let me know if you have issues grabbing them. I went through the logs myself and saw a slew of errors.

Share this post


Link to post
Share on other sites
On 9/16/2019 at 6:21 PM, Epox75 said:

I mean my savegame  broke 4 months ago, It broke again today.

The hard part of the deal is that, in reality, things were probably "broke" for almost a year. What's changing on the TweakScale 2.4.3 series is that, now, TweakScale knows about the breakage and yells every time it finds something that can do some damage. A (somewhat) comprehensive essay about the known issues can be found here.

There're many reasons these things happens, but IMHO the most commons are:

  • People borks. All the time. But sometimes we fail to detect and fix the borks.
  • Things change. Not always for better, but they change. But usually we fail to cope with the changes.
  • The Eco System changed. The Add'On Scene we have today is way different from the Scene at the 1.3.1 times.
    • Some things are better, some others are "worse". Usual stuff, nothing special about it.
  • Communication failures.
    • And Language Barrier can be a Sun on our Beach sometimes.
    • Not to mention cultural differences.
  • Complexity. Boy, this KSP thingy is complex, believe me.
    • Windows 95 level of complexity. Yes, I'm that old. :D 
    • Spoiler

       

 

Most (if not virtually all) problems, nowadays, are happening due the interaction between Add'Ons. Every single one of them usually works pretty fine by themselves (we are not too much stupid :P , we detect obvious problems fast), but when you shove a bunch on them on an installment, friction starts and eventually the subsequent heat melts something.

What makes things hard is that we can easily detect what had melted, but it's pretty hard to detect what was causing the heat, when the engine stops and everything is cool down (assuming the thing didn't exploded, right Elon?).

What doesn't means that we cannot do something about. The key word is "we". We need to work together to be able to detect and fix most of the problems we have now.

Please publish your KSP.log and ModuleManager.ConfigCache so we can try to figure out what's happening. In the worst case scenario, we can cook HotFixes and Overrules to keep your savegame ongoing in a sane way while we can't effectively fix the problem (it can happens sometimes, and until the moment, always by non technical reasons).

Share this post


Link to post
Share on other sites
4 hours ago, KIMCHI said:

https://1drv.ms/u/s!ApS4szxClp5oiJYvsHjSvmZoe8spAg?e=6Pxh6n

Both files are there. Let me know if you have issues grabbing them. I went through the logs myself and saw a slew of errors.

Your installment is somewhat messy. There're some missing dependencies for some Add'Ons, but your man source of problems right now is two different TweakScale installments on your GameData! :)

[WRN 13:24:34.521] Cannot create config from file 'D:\Games\Steam\steamapps\common\Kerbal Space Program\GameData\GameData\TweakScale\Examples.cfg'.
<CUT>
[WRN 13:24:38.486] Cannot create config from file 'D:\Games\Steam\steamapps\common\Kerbal Space Program\GameData\TweakScale\Examples.cfg'.
<CUT>
Version 4.0.2.0 D:\Games\Steam\steamapps\common\Kerbal Space Program\GameData\GameData\ModuleManager.4.0.2.dll
Version 3.1.1.0 D:\Games\Steam\steamapps\common\Kerbal Space Program\GameData\ModuleManager.3.1.1.dll

There are some Add'Ons mistakenly installed on GameData/GameData . Move everything inside GameData/GameData to GameData (delete what's duplicated), and at least the worst problems should go way.

If anything persists, publish a new KSP.log and ModuleManager.ConfigCache for further analysis. 

Share this post


Link to post
Share on other sites
On 9/16/2019 at 5:16 PM, Zorg said:

It says automated Spacedock submission. But the mod has been deleted by the author from spacedock (probably because TS got updated for MH) which is why you cant find it.  But for some reason CKAN is still picking up and distributing it.

If you wish, you can contact the original author and ask them to resolve this with the CKAN people

I just installed CKAN (it now works fine on Mac! Nice!), but didn't found a way to install it yet. I will try to forge an entry for the TMHC and see what happens. Chances are that CKAN is using a local cache for that file, however - I think it's hairy for Spacedock allowing downloading of deleted Add'Ons.

About the original author, it's not his fault and I don't see why I should bother him - at least, yet. He deleted his Add'On from the Scene, he had act to prevent the mess. I don't think it's reasonable to tell the CKAN guys to delete the entry from the CKAN database neither. This Add'On once existed, it's part of the CKAN's history, and I don't like deleting history as a way to solve present problems. Not to mention that this one may had bit me in the SAS now, but who knows if this would not be useful later? 

The inherent problem is older, deprecated Add'Ons being installed and breaking things, not TMHC - and, definitively, not the older, deprecated Add'Ons that still work.

I think that a new feature on CKAN would be a better idea: a blacklist to be updated by the Community, not by the Add'On Authors, listing incompatibilities that are discovered over time.

But I'm brainstorming on the thing, perhaps a yet better idea exists.

Share this post


Link to post
Share on other sites
4 hours ago, Lisias said:

Your installment is somewhat messy. There're some missing dependencies for some Add'Ons, but your man source of problems right now is two different TweakScale installments on your GameData! :)


[WRN 13:24:34.521] Cannot create config from file 'D:\Games\Steam\steamapps\common\Kerbal Space Program\GameData\GameData\TweakScale\Examples.cfg'.
<CUT>
[WRN 13:24:38.486] Cannot create config from file 'D:\Games\Steam\steamapps\common\Kerbal Space Program\GameData\TweakScale\Examples.cfg'.
<CUT>
Version 4.0.2.0 D:\Games\Steam\steamapps\common\Kerbal Space Program\GameData\GameData\ModuleManager.4.0.2.dll
Version 3.1.1.0 D:\Games\Steam\steamapps\common\Kerbal Space Program\GameData\ModuleManager.3.1.1.dll

There are some Add'Ons mistakenly installed on GameData/GameData . Move everything inside GameData/GameData to GameData (delete what's duplicated), and at least the worst problems should go way.

If anything persists, publish a new KSP.log and ModuleManager.ConfigCache for further analysis. 

 

I should have known better than to trust CKAN. Manually installed everything and so far so good it appears. Which dependencies are missing? CKAN does weird things sometimes where you can't install certain things (red boxes appear over it.) Ill just manually install whatever is missing.

Edited by KIMCHI

Share this post


Link to post
Share on other sites
2 hours ago, KIMCHI said:

I should have known better than to trust CKAN. Manually installed everything and so far so good it appears. Which dependencies are missing? CKAN does weird things sometimes where you can't install certain things (red boxes appear over it.) Ill just manually install whatever is missing.

Well, since the CKAN guys released a ready to use APP for the Mac, I though exactly as you and made a test on my machine to see if it was a bug on the CKAN ou netkan files. Well, at least for TweakScale it worked as expected on my tests, so things are a bit more complicated than that.

If this is a CKAN bug, it's something very hairy hidden somewhat on the code - simple tests worked fine for me.

I don't think it's something on the netkan file because on my test TweakScale was installed correctly - and on the past, when I messed up the netkan, what ended up installed was the Extras directory contents, not the TweakScale binaries.

Talk to the CKAN guys about this issue, explain every step you did and give this same KSP.log to them so they can try to reproduce the problem.

Share this post


Link to post
Share on other sites
18 hours ago, Lisias said:

The hard part of the deal is that, in reality, things were probably "broke" for almost a year. What's changing on the TweakScale 2.4.3 series is that, now, TweakScale knows about the breakage and yells every time it finds something that can do some damage. A (somewhat) comprehensive essay about the known issues can be found here.

There're many reasons these things happens, but IMHO the most commons are:

  • People borks. All the time. But sometimes we fail to detect and fix the borks.
  • Things change. Not always for better, but they change. But usually we fail to cope with the changes.
  • The Eco System changed. The Add'On Scene we have today is way different from the Scene at the 1.3.1 times.
    • Some things are better, some others are "worse". Usual stuff, nothing special about it.
  • Communication failures.
    • And Language Barrier can be a Sun on our Beach sometimes.
    • Not to mention cultural differences.
  • Complexity. Boy, this KSP thingy is complex, believe me.
    • Windows 95 level of complexity. Yes, I'm that old. :D 
    •   Reveal hidden contents

       

 

Most (if not virtually all) problems, nowadays, are happening due the interaction between Add'Ons. Every single one of them usually works pretty fine by themselves (we are not too much stupid :P , we detect obvious problems fast), but when you shove a bunch on them on an installment, friction starts and eventually the subsequent heat melts something.

What makes things hard is that we can easily detect what had melted, but it's pretty hard to detect what was causing the heat, when the engine stops and everything is cool down (assuming the thing didn't exploded, right Elon?).

What doesn't means that we cannot do something about. The key word is "we". We need to work together to be able to detect and fix most of the problems we have now.

Please publish your KSP.log and ModuleManager.ConfigCache so we can try to figure out what's happening. In the worst case scenario, we can cook HotFixes and Overrules to keep your savegame ongoing in a sane way while we can't effectively fix the problem (it can happens sometimes, and until the moment, always by non technical reasons).
 

I am glad I have the chance to say that I am really sorry for what happened. I should have counted to 66865 before posting 

Unfortunately my KSP.log is gone, I started a new game and noticed that the negative weight of parts (only thrust parts for what I've seen: RCS and engines) was coming up right away.

My career log was saying something about the impossibility to create config files for Tweakscale and it started by affecting my saved spacecrafts: while loading a spacecraft there was a warning of a missing tweakscale module, yet the spacecraft was loadable and editable; the "only" problem I encountered after that warning is that all the thrust part I was attaching to the spacecraft had negative weight. 
Anyway after a day of "cool down" :P, i decided to go a for a stock/modded career also to try out some new mods and the last expansion, there's not much space on my ssd so I had to remove the RO/RSS/RP-1 installation... I should have kept the log... silly me :)

The first thing I've noticed it's how much you were right about the "weird" interactions between the RO suite and tweakscale. For instance in RO i didn't get any sanity check warning window / tweakscale support withdrawn at the game start menu. 

Thanks for you availability I will for sure ask for you support if I have any problem during my actual gameplay and about Windows 95... I miss those times when games were running like clockwork or not run at all :D

Share this post


Link to post
Share on other sites
15 hours ago, iskela45 said:

Tweakscale detected 52 fatal errors, link to KSP.log below:

https://gist.github.com/iskela45/13713f40c8c214b097b0c1140a835d6e

Got it:

[LOG 09:26:14.222] [TweakScale] INFO: WriteDryCost Concluded : 1511 parts found ; 0 checks failed ; 0 parts with hotfixes ; 0 parts with issues overruled ; 51 Show Stoppers found; 9 Sanity Check failed; 560 unscalable parts.

As usual, 9 Sanity Check failed meaning 9 parts that TweakScale needs to be updated to learn how to cope with them, and until there I had withdraw support to prevent some carnage. TweakScale 2.4.4.x series will solve that.

About that 51 Show Stoppers:

[LOG 09:26:13.710] [TweakScale] ERROR: **FATAL** Part Decoupler.1p5 (TD-18 Decoupler) has a fatal problem due having duplicated properties - see issue [#34]( https://github.com/net-lisias-ksp/TweakScale/issues/34 ).
[LOG 09:26:13.711] [TweakScale] ERROR: **FATAL** Part Decoupler.4 (TD-50 Decoupler) has a fatal problem due having duplicated properties - see issue [#34]( https://github.com/net-lisias-ksp/TweakScale/issues/34 ).
[LOG 09:26:13.711] [TweakScale] ERROR: **FATAL** Part Separator.1p5 (TS-18 Stack Separator) has a fatal problem due having duplicated properties - see issue [#34]( https://github.com/net-lisias-ksp/TweakScale/issues/34 ).
[LOG 09:26:13.712] [TweakScale] ERROR: **FATAL** Part Separator.4 (TS-50 Stack Separator) has a fatal problem due having duplicated properties - see issue [#34]( https://github.com/net-lisias-ksp/TweakScale/issues/34 ).
[LOG 09:26:13.712] [TweakScale] ERROR: **FATAL** Part Size1p5.Strut.Decoupler (Size 1.5 Decoupler) has a fatal problem due having duplicated properties - see issue [#34]( https://github.com/net-lisias-ksp/TweakScale/issues/34 ).
[LOG 09:26:13.713] [TweakScale] ERROR: **FATAL** Part LiquidEngineKE-1 (Kerbodyne KE-1 "Mastodon" Liquid Fuel Engine) has a fatal problem due having duplicated properties - see issue [#34]( https://github.com/net-lisias-ksp/TweakScale/issues/34 ).
[LOG 09:26:13.714] [TweakScale] ERROR: **FATAL** Part LiquidEngineLV-T91 (LV-T91 "Cheetah" Liquid Fuel Engine) has a fatal problem due having duplicated properties - see issue [#34]( https://github.com/net-lisias-ksp/TweakScale/issues/34 ).
[LOG 09:26:13.715] [TweakScale] ERROR: **FATAL** Part LiquidEngineLV-TX87 (LV-TX87 "Bobcat" Liquid Fuel Engine) has a fatal problem due having duplicated properties - see issue [#34]( https://github.com/net-lisias-ksp/TweakScale/issues/34 ).
[LOG 09:26:13.717] [TweakScale] ERROR: **FATAL** Part LiquidEngineRE-I2 (RE-I2 "Skiff" Liquid Fuel Engine) has a fatal problem due having duplicated properties - see issue [#34]( https://github.com/net-lisias-ksp/TweakScale/issues/34 ).
[LOG 09:26:13.717] [TweakScale] ERROR: **FATAL** Part LiquidEngineRE-J10 (RE-J10 "Wolfhound" Liquid Fuel Engine) has a fatal problem due having duplicated properties - see issue [#34]( https://github.com/net-lisias-ksp/TweakScale/issues/34 ).
[LOG 09:26:13.719] [TweakScale] ERROR: **FATAL** Part LiquidEngineRK-7 (RK-7 "Kodiak" Liquid Fueled Engine) has a fatal problem due having duplicated properties - see issue [#34]( https://github.com/net-lisias-ksp/TweakScale/issues/34 ).
[LOG 09:26:13.720] [TweakScale] ERROR: **FATAL** Part LiquidEngineRV-1 (RV-1 "Cub" Vernier Engine) has a fatal problem due having duplicated properties - see issue [#34]( https://github.com/net-lisias-ksp/TweakScale/issues/34 ).
[LOG 09:26:13.720] [TweakScale] ERROR: **FATAL** Part monopropMiniSphere (Stratus-V Minified Monopropellant Tank) has a fatal problem due having duplicated properties - see issue [#34]( https://github.com/net-lisias-ksp/TweakScale/issues/34 ).
[LOG 09:26:13.720] [TweakScale] ERROR: **FATAL** Part Size1p5.Monoprop (FL-R5 RCS Fuel Tank) has a fatal problem due having duplicated properties - see issue [#34]( https://github.com/net-lisias-ksp/TweakScale/issues/34 ).
[LOG 09:26:13.720] [TweakScale] ERROR: **FATAL** Part Size1p5.Size0.Adapter.01 (FL-A150 Fuel Tank Adapter) has a fatal problem due having duplicated properties - see issue [#34]( https://github.com/net-lisias-ksp/TweakScale/issues/34 ).
[LOG 09:26:13.721] [TweakScale] ERROR: **FATAL** Part Size1p5.Size1.Adapter.01 (FL-A151L Fuel Tank Adapter) has a fatal problem due having duplicated properties - see issue [#34]( https://github.com/net-lisias-ksp/TweakScale/issues/34 ).
[LOG 09:26:13.721] [TweakScale] ERROR: **FATAL** Part Size1p5.Size1.Adapter.02 (FL-A151S Fuel Tank Adapter) has a fatal problem due having duplicated properties - see issue [#34]( https://github.com/net-lisias-ksp/TweakScale/issues/34 ).
[LOG 09:26:13.721] [TweakScale] ERROR: **FATAL** Part Size1p5.Size2.Adapter.01 (FL-A215 Fuel Tank Adapter) has a fatal problem due having duplicated properties - see issue [#34]( https://github.com/net-lisias-ksp/TweakScale/issues/34 ).
[LOG 09:26:13.722] [TweakScale] ERROR: **FATAL** Part Size1p5.Tank.01 (FL-TX220 Fuel Tank) has a fatal problem due having duplicated properties - see issue [#34]( https://github.com/net-lisias-ksp/TweakScale/issues/34 ).
[LOG 09:26:13.722] [TweakScale] ERROR: **FATAL** Part Size1p5.Tank.02 (FL-TX440 Fuel Tank) has a fatal problem due having duplicated properties - see issue [#34]( https://github.com/net-lisias-ksp/TweakScale/issues/34 ).
[LOG 09:26:13.722] [TweakScale] ERROR: **FATAL** Part Size1p5.Tank.03 (FL-TX900 Fuel Tank) has a fatal problem due having duplicated properties - see issue [#34]( https://github.com/net-lisias-ksp/TweakScale/issues/34 ).
[LOG 09:26:13.722] [TweakScale] ERROR: **FATAL** Part Size1p5.Tank.04 (FL-TX1800 Fuel Tank) has a fatal problem due having duplicated properties - see issue [#34]( https://github.com/net-lisias-ksp/TweakScale/issues/34 ).
[LOG 09:26:13.722] [TweakScale] ERROR: **FATAL** Part Size1p5.Tank.05 (FL-C1000 Fuel Tank) has a fatal problem due having duplicated properties - see issue [#34]( https://github.com/net-lisias-ksp/TweakScale/issues/34 ).
[LOG 09:26:13.722] [TweakScale] ERROR: **FATAL** Part Size3.Size4.Adapter.01 (Kerbodyne S3-S4 Adapter Tank) has a fatal problem due having duplicated properties - see issue [#34]( https://github.com/net-lisias-ksp/TweakScale/issues/34 ).
[LOG 09:26:13.723] [TweakScale] ERROR: **FATAL** Part Size4.EngineAdapter.01 (Kerbodyne Engine Cluster Adapter Tank) has a fatal problem due having duplicated properties - see issue [#34]( https://github.com/net-lisias-ksp/TweakScale/issues/34 ).
[LOG 09:26:13.723] [TweakScale] ERROR: **FATAL** Part Size4.Tank.01 (Kerbodyne S4-64 Fuel Tank) has a fatal problem due having duplicated properties - see issue [#34]( https://github.com/net-lisias-ksp/TweakScale/issues/34 ).
[LOG 09:26:13.723] [TweakScale] ERROR: **FATAL** Part Size4.Tank.02 (Kerbodyne S4-128 Fuel Tank) has a fatal problem due having duplicated properties - see issue [#34]( https://github.com/net-lisias-ksp/TweakScale/issues/34 ).
[LOG 09:26:13.723] [TweakScale] ERROR: **FATAL** Part Size4.Tank.03 (Kerbodyne S4-256 Fuel Tank) has a fatal problem due having duplicated properties - see issue [#34]( https://github.com/net-lisias-ksp/TweakScale/issues/34 ).
[LOG 09:26:13.723] [TweakScale] ERROR: **FATAL** Part Size4.Tank.04 (Kerbodyne S4-512 Fuel Tank) has a fatal problem due having duplicated properties - see issue [#34]( https://github.com/net-lisias-ksp/TweakScale/issues/34 ).
[LOG 09:26:13.723] [TweakScale] ERROR: **FATAL** Part roverWheelM1-F (RoveMax M1-F Rover Wheel) has a fatal problem due having duplicated properties - see issue [#34]( https://github.com/net-lisias-ksp/TweakScale/issues/34 ).
[LOG 09:26:13.723] [TweakScale] ERROR: **FATAL** Part Size1to0ServiceModule (SM-6A Service Module) has a fatal problem due having duplicated properties - see issue [#34]( https://github.com/net-lisias-ksp/TweakScale/issues/34 ).
[LOG 09:26:13.724] [TweakScale] ERROR: **FATAL** Part ServiceModule18 (SM-18 Service Module) has a fatal problem due having duplicated properties - see issue [#34]( https://github.com/net-lisias-ksp/TweakScale/issues/34 ).
[LOG 09:26:13.724] [TweakScale] ERROR: **FATAL** Part ServiceModule25 (SM-25 Service Module) has a fatal problem due having duplicated properties - see issue [#34]( https://github.com/net-lisias-ksp/TweakScale/issues/34 ).
[LOG 09:26:13.724] [TweakScale] ERROR: **FATAL** Part kv1Pod (KV-1 'Onion' Reentry Module) has a fatal problem due having duplicated properties - see issue [#34]( https://github.com/net-lisias-ksp/TweakScale/issues/34 ).
[LOG 09:26:13.725] [TweakScale] ERROR: **FATAL** Part kv2Pod (KV-2 ‘Pea’ Reentry Module) has a fatal problem due having duplicated properties - see issue [#34]( https://github.com/net-lisias-ksp/TweakScale/issues/34 ).
[LOG 09:26:13.725] [TweakScale] ERROR: **FATAL** Part kv3Pod (KV-3 'Pomegranate' Reentry Module) has a fatal problem due having duplicated properties - see issue [#34]( https://github.com/net-lisias-ksp/TweakScale/issues/34 ).
[LOG 09:26:13.725] [TweakScale] ERROR: **FATAL** Part Mk2Pod (Mk2 Command Pod) has a fatal problem due having duplicated properties - see issue [#34]( https://github.com/net-lisias-ksp/TweakScale/issues/34 ).
[LOG 09:26:13.726] [TweakScale] ERROR: **FATAL** Part MEMLander (Munar Excursion Module (M.E.M.)) has a fatal problem due having duplicated properties - see issue [#34]( https://github.com/net-lisias-ksp/TweakScale/issues/34 ).
[LOG 09:26:13.726] [TweakScale] ERROR: **FATAL** Part EquiTriangle0 (SP-T06 Structural Panel) has a fatal problem due having duplicated properties - see issue [#34]( https://github.com/net-lisias-ksp/TweakScale/issues/34 ).
[LOG 09:26:13.726] [TweakScale] ERROR: **FATAL** Part EquiTriangle1 (SP-T12 Structural Panel) has a fatal problem due having duplicated properties - see issue [#34]( https://github.com/net-lisias-ksp/TweakScale/issues/34 ).
[LOG 09:26:13.726] [TweakScale] ERROR: **FATAL** Part EquiTriangle1p5 (SP-T18 Structural Panel) has a fatal problem due having duplicated properties - see issue [#34]( https://github.com/net-lisias-ksp/TweakScale/issues/34 ).
[LOG 09:26:13.726] [TweakScale] ERROR: **FATAL** Part EquiTriangle2 (SP-T25 Structural Panel) has a fatal problem due having duplicated properties - see issue [#34]( https://github.com/net-lisias-ksp/TweakScale/issues/34 ).
[LOG 09:26:13.727] [TweakScale] ERROR: **FATAL** Part Panel0 (SP-S06 Structural Panel) has a fatal problem due having duplicated properties - see issue [#34]( https://github.com/net-lisias-ksp/TweakScale/issues/34 ).
[LOG 09:26:13.727] [TweakScale] ERROR: **FATAL** Part Panel1 (SP-S12 Structural Panel) has a fatal problem due having duplicated properties - see issue [#34]( https://github.com/net-lisias-ksp/TweakScale/issues/34 ).
[LOG 09:26:13.727] [TweakScale] ERROR: **FATAL** Part Panel1p5 (SP-S18 Structural Panel) has a fatal problem due having duplicated properties - see issue [#34]( https://github.com/net-lisias-ksp/TweakScale/issues/34 ).
[LOG 09:26:13.727] [TweakScale] ERROR: **FATAL** Part Panel2 (SP-S25 Structural Panel) has a fatal problem due having duplicated properties - see issue [#34]( https://github.com/net-lisias-ksp/TweakScale/issues/34 ).
[LOG 09:26:13.727] [TweakScale] ERROR: **FATAL** Part Triangle0 (SP-R06 Structural Panel) has a fatal problem due having duplicated properties - see issue [#34]( https://github.com/net-lisias-ksp/TweakScale/issues/34 ).
[LOG 09:26:13.728] [TweakScale] ERROR: **FATAL** Part Triangle1 (SP-R12 Structural Panel) has a fatal problem due having duplicated properties - see issue [#34]( https://github.com/net-lisias-ksp/TweakScale/issues/34 ).
[LOG 09:26:13.728] [TweakScale] ERROR: **FATAL** Part Triangle1p5 (SP-R18 Structural Panel) has a fatal problem due having duplicated properties - see issue [#34]( https://github.com/net-lisias-ksp/TweakScale/issues/34 ).
[LOG 09:26:13.728] [TweakScale] ERROR: **FATAL** Part Triangle2 (SP-R25 Structural Panel) has a fatal problem due having duplicated properties - see issue [#34]( https://github.com/net-lisias-ksp/TweakScale/issues/34 ).
[LOG 09:26:13.729] [TweakScale] ERROR: **FATAL** Part HeatShield1p5 (Heat Shield (1.875m)) has a fatal problem due having duplicated properties - see issue [#34]( https://github.com/net-lisias-ksp/TweakScale/issues/34 ).

However…  I know these 51 parts,  this had happen before! :) And looking for the right substring on your log, I found 51 instances of this log line:

[LOG 09:22:10.606] Config(@PART[Decoupler_1p5]) TweakscaleMakingHistoryConfigs/Coupling/@PART[Decoupler_1p5]
[LOG 09:22:10.606] Config(@PART[Decoupler_4]) TweakscaleMakingHistoryConfigs/Coupling/@PART[Decoupler_4]
<49 more>

So yeah. TweakscaleMakingHistoryConfigs strikes again. :) Delete GameData/TweakscaleMakingHistoryConfigs and everything will be fine. If you are using CKAN, make sure to uninstall it from there, so CKAN don't install it back.

On 9/20/2019 at 1:24 AM, Epox75 said:

Thanks for you availability I will for sure ask for you support if I have any problem during my actual gameplay

Welcome!

On 9/20/2019 at 1:24 AM, Epox75 said:

and about Windows 95... I miss those times when games were running like clockwork or not run at all :D

Me too! :)

Spoiler

 

 

Share this post


Link to post
Share on other sites
On 9/20/2019 at 4:24 AM, Epox75 said:

 Windows 95... I miss those times when games were running like clockwork or not run at all

Ah yes - the BSOD every 10 minutes, the 3.5" floppy installs with what 20 floppies, and having to swap in the same floppy every couple minutes.... and don't forget needing to reboot every hour or three.

but at least it wasn't calling home to report its spying on you every second because the dial up was so slow and had to be manually initiated. :P

I do miss the sounds of a good handshake. :P:o:o:o:cool::D

Edited by zer0Kerbal

Share this post


Link to post
Share on other sites
8 hours ago, Lisias said:

As usual, 9 Sanity Check failed meaning 9 parts that TweakScale needs to be updated to learn how to cope with them, and until there I had withdraw support to prevent some carnage. TweakScale 2.4.4.x series will solve that.

 

Looking forward to it, the amount of work you put into the mod is amazing.

8 hours ago, Lisias said:

However…  I know these 51 parts,  this had happen before! :) And looking for the right substring on your log, I found 51 instances of this log line:


[LOG 09:22:10.606] Config(@PART[Decoupler_1p5]) TweakscaleMakingHistoryConfigs/Coupling/@PART[Decoupler_1p5]
[LOG 09:22:10.606] Config(@PART[Decoupler_4]) TweakscaleMakingHistoryConfigs/Coupling/@PART[Decoupler_4]
<49 more>

So yeah. TweakscaleMakingHistoryConfigs strikes again. :) Delete GameData/TweakscaleMakingHistoryConfigs and everything will be fine. If you are using CKAN, make sure to uninstall it from there, so CKAN don't install it back.

Now that you've pointed it out I feel like an idiot for not realizing that all of those parts are from Making History, probably gonna go eat some glue now.

Share this post


Link to post
Share on other sites
9 hours ago, zer0Kerbal said:

Ah yes - the BSOD every 10 minutes, the 3.5" floppy installs with what 20 floppies, and having to swap in the same floppy every couple minutes.... and don't forget needing to reboot every hour or three.

You can be happy then that you didn't have to load games from cassette player, need to rewind it on exact spot, listen similar noise as handshake during loading, adjusting azimuth of reading head with screwdriver if load fail, etc. It was necessary to do all kind of stunts for most simple games on C64. I was a kid back then and didn't mind any of those, with a side effect that I was learned bunch of other things just due to kid's desire to play games.

Share this post


Link to post
Share on other sites
1 hour ago, kcs123 said:

You can be happy then that you didn't have to load games from cassette player, need to rewind it on exact spot, listen similar noise as handshake during loading, adjusting azimuth of reading head with screwdriver if load fail, etc. It was necessary to do all kind of stunts for most simple games on C64. I was a kid back then and didn't mind any of those, with a side effect that I was learned bunch of other things just due to kid's desire to play games.

*chuckle* yes, the cassette player - Ti994a and so much else.

please don't make me go any further back, like when HDD's were the size of commercial washing machines - and held a whopping 5 mb.... or even further back... :P those were the days...

Share this post


Link to post
Share on other sites
1 hour ago, kcs123 said:

You can be happy then that you didn't have to load games from cassette player, need to rewind it on exact spot, listen similar noise as handshake during loading, adjusting azimuth of reading head with screwdriver if load fail, etc. It was necessary to do all kind of stunts for most simple games on C64. I was a kid back then and didn't mind any of those, with a side effect that I was learned bunch of other things just due to kid's desire to play games.

Most of the games I played on my C64 were typed in from Compute! magazine. I at least had a floppy drive though.

Share this post


Link to post
Share on other sites
52 minutes ago, sturmhauke said:

Most of the games I played on my C64 were typed in from Compute! magazine. I at least had a floppy drive though.

I was a bit spoiled I guess... I got the C128 with the twelve additional keys, the 10-key pad, could run at TWO megahertz, and display 80 columns of text! But then I didn't get either the 1530 Dataset tape drive or the 1571 DSDD 5 ¼" drive when my parents gave it to me, (nor a proper monitor... and my mother didn't want me monopolizing the TV so I was relegated to using her old 12" B&W set... all that beautiful VIC II chip's 16 color wonders gone to waste!) so I could write programs, but the minute the power bumped or it was time to go to bed, it was all gone! (I later bought a 1530 with my allowance, then the next Christmas I got the 1571 drive with 360kb of storage! Hot stuff!)

The only game I ever bought for it was Project: Space Station... so I guess not much has changed for me! :^Þ

If I could have the thousands of hours I spent writing programs and music in 8502 Machine Language I... well... I could play as much KSP as I already have over again!

Share this post


Link to post
Share on other sites

Hi there,

First time posting, not sure if my problem fits in here.

Im using KSP 1.6.1.2401 (Tweakscale v2.4.3.4) with around 60+ mods (mainly around RSS-stuff)

And got this warning a few days ago, played two or three times on it (nothing bad happened), until now. My electrical charge by solar production is getting less, when normally on other mod-sets (and vanilla) it got more, as usual. So my solar panels are working, but the energy-count is depleting instead of rising again. Any ideas on that?

Secondly there is this second thing, where it asks me to get in touch with you guys here, since there "isnt an possible automated fix for the problem" regarding some "fatal error" of tweakscale. I dont know if thats connected to the electric-charge-problem.

Screenshots: https://imgur.com/a/rLvnbp3

KSP.log via mega: https://mega.nz/fm/tiwS2KSK

 

Any ideas at all? I tried to localize the problem, by taking a few mods off, to see if the error would go away and the electric-charge would go up again - but no luck.

 

Thanks in Advance, first post, but have been in this forum a few times already, great stuff!

Edited by Atmo

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.