Jump to content

[KSP >= 1.3.0] TweakScale - Under Lisias' Management - 2.4.6.18r3 - 2022-1126


Lisias
 Share

Recommended Posts

@Lisias I hate to bug you with this, but I am seeing exceptions in 1.10 from TweakScale 2.4.3.15 installed from CKAN. Otherwise TweakScale seems to work fine.

I get an exceptions in the VAB:

  1. Placing parts
  2. Removing parts
  3. Rescaling parts
  4. Right Click a part.

Log and MM.ConfigCache  I do not have Recall installed since you indicated it was unnecessary in 1.10 and TS seems to work without it.

I haven't had time to try isolating a minimal set of mods.  I'm hoping you might see something from the log. This is from my fully modded game install that's was started in 1.7.  

[ERR 17:32:29.829] Exception handling event onEditorShipModified in class TweakScale:System.NullReferenceException
  at (wrapper managed-to-native) UnityEngine.Behaviour.get_enabled(UnityEngine.Behaviour)
  at TweakScale.TweakScale.OnEditorShipModified (ShipConstruct ship) [0x00000] in <c3d11dd12519438cafd8dbec2a0a0668>:0 
  at EventData`1[T].Fire (T data) [0x000b0] in <c168e21ec56346b082f89043e76162e1>:0 

[EXC 17:32:29.830] NullReferenceException
	TweakScale.TweakScale.OnEditorShipModified (ShipConstruct ship) (at <c3d11dd12519438cafd8dbec2a0a0668>:0)
	EventData`1[T].Fire (T data) (at <c168e21ec56346b082f89043e76162e1>:0)
	UnityEngine.DebugLogHandler:LogException(Exception, Object)
	ModuleManager.UnityLogHandle.InterceptLogHandler:LogException(Exception, Object)
	UnityEngine.Debug:LogException(Exception)
	EventData`1:Fire(ShipConstruct)
	EditorLogic:SetBackup()
	EditorLogic:<SetupFSM>b__195_29()
	KerbalFSM:RunEvent(KFSMEvent)
	KerbalFSM:updateFSM(KFSMUpdateMode)
	KerbalFSM:UpdateFSM()
	EditorLogic:Update()

I think your Houston warning is also throwing errors, but these aren't a big deal.

Unable to use a named GUIStyle without a current skin. Most likely you need to move your GUIStyle initialization code to OnGUI

 

Link to comment
Share on other sites

17 minutes ago, Tonka Crash said:

@Lisias I hate to bug you with this, but I am seeing exceptions in 1.10 from TweakScale 2.4.3.15 installed from CKAN. Otherwise TweakScale seems to work fine.

I get an exceptions in the VAB:

  1. Placing parts
  2. Removing parts
  3. Rescaling parts
  4. Right Click a part.

Check if the 999_Scale_Redist.dll is on the GameData, if not, manually install it. You are not the first to complain about this, and the last one haven't the file on the place (and also used CKAN). [forget that, just check it - it's there!]

17 minutes ago, Tonka Crash said:

I think your Houston warning is also throwing errors, but these aren't a big deal.

Ignore this. It's something to fix indeed, but it's on the very end of the priority list. :)

-- POST EDIT -

Apparently, things started to go through the tubes on mk2LanderCabin.v2 :

[LOG 17:09:12.432] Adding default item(s) into seat's 0 inventory of part [Part:mk2LanderCabin.v2 (id=C4293790632)]: KIS.electricScrewdriver,KIS.evapropellant
[LOG 17:09:12.433] Adding default item(s) into seat's 1 inventory of part [Part:mk2LanderCabin.v2 (id=C4293790632)]: KIS.electricScrewdriver,KIS.evapropellant
[ERR 17:09:12.436] Exception handling event onEditorShipModified in class TweakScale:System.NullReferenceException
  at (wrapper managed-to-native) UnityEngine.Behaviour.get_enabled(UnityEngine.Behaviour)
  at TweakScale.TweakScale.OnEditorShipModified (ShipConstruct ship) [0x00000] in <c3d11dd12519438cafd8dbec2a0a0668>:0
  at EventData`1[T].Fire (T data) [0x000b0] in <c168e21ec56346b082f89043e76162e1>:0
  
<yada yada yada>

[LOG 17:09:12.596] [AttitudeAdjuster] Initialized for mk2LanderCabin.v2
[ERR 17:09:12.611] Exception handling event onEditorShipModified in class TweakScale:System.NullReferenceException
  at (wrapper managed-to-native) UnityEngine.Behaviour.get_enabled(UnityEngine.Behaviour)
  at TweakScale.TweakScale.OnEditorShipModified (ShipConstruct ship) [0x00000] in <c3d11dd12519438cafd8dbec2a0a0668>:0
  at EventData`1[T].Fire (T data) [0x000b0] in <c168e21ec56346b082f89043e76162e1>:0

<yada yada yada>

[LOG 17:09:30.425] Adding default item(s) into seat's 0 inventory of part [Part:mk2LanderCabin.v2 (id=C4293786244)]: KIS.electricScrewdriver,KIS.evapropellant
[LOG 17:09:30.426] Adding default item(s) into seat's 1 inventory of part [Part:mk2LanderCabin.v2 (id=C4293786244)]: KIS.electricScrewdriver,KIS.evapropellant
[ERR 17:09:30.428] Exception handling event onEditorShipModified in class TweakScale:System.NullReferenceException
  at (wrapper managed-to-native) UnityEngine.Behaviour.get_enabled(UnityEngine.Behaviour)
  at TweakScale.TweakScale.OnEditorShipModified (ShipConstruct ship) [0x00000] in <c3d11dd12519438cafd8dbec2a0a0668>:0
  at EventData`1[T].Fire (T data) [0x000b0] in <c168e21ec56346b082f89043e76162e1>:0

I'm working on it.

Edited by Lisias
Humm.. I was wrong...
Link to comment
Share on other sites

14 minutes ago, Lisias said:

Check if the 999_Scale_Redist.dll is on the GameData, if not, manually install it. You are not the first to complain about this, and the last one haven't the file on the place (and also used CKAN).

I do have the 999_Scale_Redist.dll in GameData.

Since I first posted I went and set up a stripped install Squad+Expansions, MM and TweaskScale.  No other mods. I started a new sandbox game.

I still get exceptions. On a new start (new game or loaded save) it does not start throwing exceptions until I remove a part from the craft. I can go into the VAB and start building a craft, add parts to it, right click a part and I get no exceptions.  Once I remove a part then every change or right click throws an exception.

Edit: I can leave the VAB and reenter and exceptions happen on first part.  It seems the only time I don't get exceptions is first time into the VAB from start of KSP.

Edited by Tonka Crash
Link to comment
Share on other sites

11 hours ago, Tonka Crash said:

Edit: I can leave the VAB and reenter and exceptions happen on first part.  It seems the only time I don't get exceptions is first time into the VAB from start of KSP.

Yep. I confirm the problem.

I don't know yet if TweakScale is failing on unregistering itself from the OnShipModified event list (and if yes, why it was working before?) when its part dies, or if something changed on the PartModule's life cycle (intentionally or by accidente) on KSP 1.10.

I will work on it tomorrow.

Thanks for the report!

-- -- -- post edit -- -- -- 

Uh... I borked on that. This will be fixed on the next TweakScale release.

https://github.com/net-lisias-ksp/TweakScale/issues/119

Edited by Lisias
Hit "Save" too soon.
Link to comment
Share on other sites

4 hours ago, renejant said:

think I have a suspect, but I want to get more information before saying what I have in mind.

Please send me ModuleManager.ConfigCache on your GameData, I want to compare its values with what I found on your craft.

Link to comment
Share on other sites

Hello, I'm relatively new here (Though I've played KSP for years). 

I got an ERROR message that said "Houston, we have a problem..." It was regarding a FATAL ERROR upon loading up my game. I've found the KSP.log portion that it referred to and I wanted to post it here to see what it was about. Thanks.
 

[LOG 11:26:56.851] [TweakScale] WARNING: **FATAL** Found a showstopper problem on .Knes.STEAM.CrystalLab (STEAM "Laputa" ScienceLab Module).
[LOG 11:26:56.851] [TweakScale] ERROR: **FATAL** Part .Knes.STEAM.CrystalLab (STEAM "Laputa" ScienceLab Module) has a fatal problem due having duplicated properties - see issue [#34]( https://github.com/net-lisias-ksp/TweakScale/issues/34 ).

Link to comment
Share on other sites

54 minutes ago, HDSpanky said:

Hello, I'm relatively new here (Though I've played KSP for years). 

I got an ERROR message that said "Houston, we have a problem..." It was regarding a FATAL ERROR upon loading up my game. I've found the KSP.log portion that it referred to and I wanted to post it here to see what it was about. Thanks.
 

[LOG 11:26:56.851] [TweakScale] WARNING: **FATAL** Found a showstopper problem on .Knes.STEAM.CrystalLab (STEAM "Laputa" ScienceLab Module).
[LOG 11:26:56.851] [TweakScale] ERROR: **FATAL** Part .Knes.STEAM.CrystalLab (STEAM "Laputa" ScienceLab Module) has a fatal problem due having duplicated properties - see issue [#34]( https://github.com/net-lisias-ksp/TweakScale/issues/34 ).

That is telling you that the part is being Tweak'd twice (or more) and being withheld.

You should post the full KSP.log so we can see what other TSconfigs are modifying that part.

Link to comment
Share on other sites

43 minutes ago, TranceaddicT said:

That is telling you that the part is being Tweak'd twice (or more) and being withheld.

You should post the full KSP.log so we can see what other TSconfigs are modifying that part.

I am trying but the KSP.log file is too large for me to quote it here. Could I email it to someone perhaps? 

**EDIT**

Nevermind, I found a way to link it with my Google Drive: https://drive.google.com/file/d/1ApNYvgdkV0E2bRBhZSxkivWUDIXkg8W-/view?usp=sharing

Edited by HDSpanky
Link to comment
Share on other sites

3 hours ago, HDSpanky said:

I am trying but the KSP.log file is too large for me to quote it here. Could I email it to someone perhaps? 

**EDIT**

Nevermind, I found a way to link it with my Google Drive: https://drive.google.com/file/d/1ApNYvgdkV0E2bRBhZSxkivWUDIXkg8W-/view?usp=sharing

Sorry, I should have requested this too, so can you do the same with your GameData\ModuleManager.ConfigCache

I zip them before upload.  It's a lot faster.

 

EDIT: You may not have one with these errors.

 

EDIT DeuX: Okay, here's the deal...

You can't do anything about these; it's a work in progress. You'll just have to do without scaling on these parts, for right now.

  1. So, create a new folder called  GameData\TweakScale\Workarounds
  2. And put VariantsWithMass.cfg inside.

 

Also, you've got the same problem I do with the FSbouyancy module.  There's a fix for that on the way so do sweat those either.

Edited by TranceaddicT
Link to comment
Share on other sites

On 7/4/2020 at 3:17 PM, HDSpanky said:

**EDIT**

Nevermind, I found a way to link it with my Google Drive: https://drive.google.com/file/d/1ApNYvgdkV0E2bRBhZSxkivWUDIXkg8W-/view?usp=sharing

Yeap... I borked on that one. Somehow, I leaked a double patch on the Knes-Launcher_TweakScale.cfg file when I pulled a request to Knes.

Well, i fixed and just submit a new pull request. It should be available soon, but if you are in a hurry, download this file (click on Raw Button) and replace the one on your Knes/GameData/Knes/Compatibility/Tweakscale/ folder.

 

On 7/4/2020 at 4:52 PM, renejant said:

uploaded to the server lisias! https://renejant36.porton.nl:7001/sharing/8244UHHXe

Nothing new. The only difference on your config cache and mine is depicted below:

Mine:
		MODULE
		{
			name = ModulePartInfo
			originalPartName = SYdecouplerRadial1
		}
		MODULE
		{
			name = TweakScale
			type = surface
		}
		MODULE
		{
			name = TweakScale
			type = surface
			HOTFIX = https%3A%2F%2Fforum.kerbalspaceprogram.com%2Findex.php%3F%2Ftopic%2F179030-ksp-141-tweakscale-under-lisias-management-24315-2020-0622%2F%26do%3DfindComment%26comment%3D3812504
		}

yours:
		MODULE
		{
			name = TweakScale
			type = surface
		}
		MODULE
		{
			name = TweakScale
			type = surface
		}

It's not something on the patching mechanism, it's code on runtime. Well, that ruled out all my suspects but one, ReStock - it's the only thing on your GameData that I think can cause this problem on the texture.

I'm downloading the latest ReStock to give it a try, I will come back to you soon.

 

On 7/4/2020 at 6:39 PM, TranceaddicT said:

You can't do anything about these; it's a work in progress. You'll just have to do without scaling on these parts, for right now.

  1. So, create a new folder called  GameData\TweakScale\Workarounds
  2. And put VariantsWithMass.cfg inside.

@HDSpanky, I don't advise creating custom patches inside TweakScale main folder (as well on any other Add'On).

Completely removing the previous version of TweakScale before applying the new version is the current recommendation (not only from me, but from a lot of Add'On maintainers), and by doing this you risk deleting your customisations on updates.

I push GameData/__LOCAL/TweakScale/Workarounds because __LOCAL is pretty easy to locate on GameData using Windows Explorer, Finder or even the Midnight Commander tool I use - it's always the first or the last entry on an ordered list.

But anything will do as long you correctly use :AFTER, :BEFORE, :FIRST, :LAST or :FINAL. Some people like zzz_PERSONAL-PATCHES or something.

Just don't shove custom patches inside Add'Ons folders. This force you to remember things while updating Add'Ons when doing manual updates, as well tricks CKAN to keep the Add'On folder alive when deinstalling the thing, fooling everybody on believing the Add'On are still installed and failing patches that relies on :AFTER, :BEFORE, :FIRST, :LAST or :FINAL.

Edited by Lisias
Brute force post merging
Link to comment
Share on other sites

8 hours ago, TranceaddicT said:

Yep. My bad.

I missed the __LOCAL part.

P.S.  I'm working on a few other workaround patches just to silence the other issues as well. (Using your VariantsWithMass as a template.)

Not a problem. Everybody Borks :) And some people don't like the __LOCAL, you may be one of them, and this is perfectly fine. Just avoid changing things inside the "official" Add'On folders due the situations I described above and everything will work fine for everybody.

 

11 hours ago, renejant said:

uploaded to the server lisias! https://renejant36.porton.nl:7001/sharing/8244UHHXe

YES! I managed to reproduce the problem! :)

This is what I got after installing ReStock on an already ongoing savegame (with the rogue module and without the workaround):

MODULE
{
    name = TweakScale
    isEnabled = True
    currentScale = 1
    defaultScale = 1
    defaultTransformScale = (0, 0, 0)
    DryCost = 888
    stagingEnabled = True
    EVENTS
    {
    }
    ACTIONS
    {
    }
    UPGRADESAPPLIED
    {
    }
}
MODULE
{
    name = TweakScaleRogueDuplicate // Programatically tainted due duplicity or any other reason that disabled this instance. Only the first instance above should exist. This section will be eventually deleted once the craft is loaded and saved by a bug free KSP installment. You can safely ignore this section.
    isEnabled = True
    currentScale = 1.53999996
    defaultScale = 1
    defaultTransformScale = (1, 1, 1)
    DryCost = 3243.20996
    stagingEnabled = True
    EVENTS
    {
    }
    ACTIONS
    {
    }
    UPGRADESAPPLIED
    {
    }
}

This is my worst nightmarea perfectly valid and working Module Section being ruled out because something shoved a different one ahead of it, and then everything else started to use it instead of that previous, good one. We would not had detected this without my Rogue Stunt, and in the past I'm pretty sure TweakScale took the blame for the problem in the past - nobody would diagnose it at that time.

The only way to fix this mess is to manually remove all instances of the first, defaulted TweakScale module sections and then rename the Rogue ones back - what's pretty unfeasible on a big savegame. :/ On my testbed, not only the defaultScale was changed to (0,0,0) (what results on some "interesting" renderings on code that relies on this thing being different than Zero), but also it descaled the part. And suddenly descaled parts became suddenly weaker, and weaker parts blows up when suddenly have to withhold de load that a a bigger, stronger one was withholding. (sigh).

I still don't know why this happens, and so I don't know how to work around it. But at least now I know WHAT is happening.

Unfortunately, my only advice for now is take a deep breath and try to ignore the annoying messages about the missing TweakScaleDuplicatedRogue module on loading things. Trying to fix this, now, on your savegame is leading to worst results.

I need to read and understand ReStock source code in order to understand what's happening to make a proper fix first - what will take a bit, because I have a ton of tasks (not only on TweakScale, but on RL too) to carry on and I already spent too much time on this issue.

I don't know how in hell Kerbals manage to do something useful on 6 hours days, I need at least 32 on my ones. :sticktongue:

Feel free to kick me here (or anywhere else) in 3 or 4 days for this issue if I stay silent that much - as I have a somewhat big backlog of things to do, I frequently end up forgetting a thing or two - but rest assured, I want to solve this one in a way or another. I don't take easily savegame corruptions!

-- -- POST EDIT -- -- 

I think I need to update the message on the SFS file. This is not safely ignorable anymore, there're situations in which ignoring it is worse. Oh well... We learnt something new today. :) 

Edited by Lisias
post edit
Link to comment
Share on other sites

14 minutes ago, Lisias said:

I don't know how in hell Kerbals manage to do something on 6 hours days, I need at least 32 on my ones. :sticktongue:

LoL, don't we all?

14 minutes ago, Lisias said:

Feel free to kick me 3 or 4 days for the issue if I stay silent that much - as I have a somewhat big backlog of things to do, I frequently end up forgetting a thing or two - but rest assured, I want to solve this one in a way or another. I don't take easily savegame corruptions!

Psssst, dude, it's a holiday weekend. 

Crack a cold one 

grab some popcorn 

and tune-in a movie 

(Hamilton is on Disney+)

Edited by TranceaddicT
Link to comment
Share on other sites

4 minutes ago, Lisias said:

Not a problem. Everybody Borks :) And some people don't like the __LOCAL, you may be one of them, and this is perfectly fine. Just avoid changing things inside the "official" Add'On folders due the situations I described above and everything will work fine for everybody.

 

YES! I managed to reproduce the problem! :)

This is what I got after installing ReStock on an already ongoing savegame (and without the workaround):

MODULE
{
    name = TweakScale
    isEnabled = True
    currentScale = 1
    defaultScale = 1
    defaultTransformScale = (0, 0, 0)
    DryCost = 888
    stagingEnabled = True
    EVENTS
    {
    }
    ACTIONS
    {
    }
    UPGRADESAPPLIED
    {
    }
}
MODULE
{
    name = TweakScaleRogueDuplicate // Programatically tainted due duplicity or any other reason that disabled this instance. Only the first instance above should exist. This section will be eventually deleted once the craft is loaded and saved by a bug free KSP installment. You can safely ignore this section.
    isEnabled = True
    currentScale = 1.53999996
    defaultScale = 1
    defaultTransformScale = (1, 1, 1)
    DryCost = 3243.20996
    stagingEnabled = True
    EVENTS
    {
    }
    ACTIONS
    {
    }
    UPGRADESAPPLIED
    {
    }
}

This is my worst nightmarea perfectly valid and working Module Section being ruled out because something shoved a different one ahead of it, and then everything else started to use it instead of that previous, good one. We would not had detected this without my Rogue Stunt, and in the past I'm pretty sure TweakScale took the blame for the problem in the past - nobody would diagnose it at that time.

The only way to fix this mess is to manually remove all the first, defaulted TweakScale module sections and then rename the Rogue ones back - what's pretty unfeasible on a big savegame. :/ On my testbed above, not only the defaultScale was changed to (0,0,0) (what results on some "interesting" renderings on code that relies on this thing being different from Zero), but also it descaled the part. And suddenly descaled parts became suddenly weaker, and weaker parts blows up when suddenly have to withhold de load of a bigger, stronger one. (sigh).

I still don't know why this happens, and so I don't know how to work around it. But at least now I know WHAT is happening.

Unfortunately, my only advice for now is take a deep breath and try to ignore the annoying messages about the missing TweakScaleDuplicatedRogue module on loading things. Trying to fix this, now, on your savegame is leading to worst results.

I need to read and understand ReStock source code in order to understand what's happening to make a proper fix first - what will take a bit, because I have a ton of tasks (not only on TweakScale, but on RL too) to carry on and I already spent too much time on this issue.

I don't know how in hell Kerbals manage to do something on 6 hours days, I need at least 32 on my ones. :sticktongue:

Feel free to kick me 3 or 4 days for the issue if I stay silent that much - as I have a somewhat big backlog of things to do, I frequently end up forgetting a thing or two - but rest assured, I want to solve this one in a way or another. I don't take easily savegame corruptions!

At least! i am happy that you have found the problem!!! Solving it, is another issue, which i am happy to wait for it! I still can play with the current problem about the "TweakScaleDuplicatedRogue" problem... I will ignore this problem for the time being until you have got the time to patch it correctly. I can't demand anything more from you than this. I understand that you are quite busy with everything else on your mind... So i just have to wait until you got the time for it to bring it out! Real life issues comes first, no matter what! Just give me a little notification upon completion, so i know when it is ready! 

Thanks Alot M8! i really appreciate your effort on this matter!!!!

Link to comment
Share on other sites

5 hours ago, Lisias said:

 

@HDSpanky, I don't advise creating custom patches inside TweakScale main folder (as well on any other Add'On).

Completely removing the previous version of TweakScale before applying the new version is the current recommendation (not only from me, but from a lot of Add'On maintainers), and by doing this you risk deleting your customisations on updates.

I push GameData/__LOCAL/TweakScale/Workarounds because __LOCAL is pretty easy to locate on GameData using Windows Explorer, Finder or even the Midnight Commander tool I use - it's always the first or the last entry on an ordered list.

But anything will do as long you correctly use :AFTER, :BEFORE, :FIRST, :LAST or :FINAL. Some people like zzz_PERSONAL-PATCHES or something.

Just don't shove custom patches inside Add'Ons folders. This force you to remember things while updating Add'Ons when doing manual updates, as well tricks CKAN to keep the Add'On folder alive when deinstalling the thing, fooling everybody on believing the Add'On are still installed and failing patches that relies on :AFTER, :BEFORE, :FIRST, :LAST or :FINAL.

@HDSpanky As someone who writes new parts based upon old for his own save, I have to agree that you do not want to keep patches or new configs on the folders of other mods. @Lisias has a great recommendation. I offer the counter of having your own folder for your special mods so that you don't accidentally delete them. For that matter, I've written one to move Laythe to where Minmus is and Minmus is now in orbit around Laythye. 

But my ramblings aside,  I reiterate, use either Lisias or my method of where to store your patches. Also, learn how to use 

Quote

:AFTER, :BEFORE, :FIRST, :LAST or :FINAL.

correctly. Huge headache savers. Also, adding a % in front of a string that alters a variable will force its change. For your install and save saftey, I implore that you back everything up and copy your install to a new location and run from that location while you use your new configs until you are sure everything is QA'd to the Large Magellanic Cloud and back before you risk your main install. Even then, keep a back up.

 

Post edit:

Spoiler

So I just realized that I am a lot closer to writing that mod to try to fix a kracken bug that stops spinning than I thought I was. I need to study some other mods like Hooligan Labs in how they place a tool bar button to access the GUI. What I want to do is make a button that kills all of the current information in rotational values for Pitch, Yaw, and Roll. I'm sure that if I spend a good chunk of tomorrow searching for the proper values, I can kill those. Even if I have to create a part and hot key it first. But that might be a bit ... beyond my current skill.  Mostly because some moduels requite a node to be in the craft's model, like one for thrust. For example, you can't take an RCS and make it a thruster. Unless you can edit a model to replace the node. Now I might be using the wrong terminology. Once I learn how to use Blender, I'm going to start making models for my OMNI SCI mod.

That'll be good, the anti-kracken SAS. "This SAS moduel does nothing until a kracken attack happens, then if you hit it with a hammer, you can halt the attack in process"

As a last side note, I am willing to start a thread and github for a Laythe orbiting Kerbin, and being tidally locked. Or other way around with Laythe in Kerbin's orbit with Kerbin tidally locked to Kerbin. If people want this. Send me DMs, not choke up this thread if you are interested. That's why I did this as a spoiler. Also, I'll create one tomorrow if I find what I need for the anti-kracken SAS and get it working in 1.10

 

Edited by Azic Minar
SO I just realized something
Link to comment
Share on other sites

12 hours ago, Azic Minar said:

@HDSpanky As someone who writes new parts based upon old for his own save, I have to agree that you do not want to keep patches or new configs on the folders of other mods. @Lisias has a great recommendation. I offer the counter of having your own folder for your special mods so that you don't accidentally delete them. For that matter, I've written one to move Laythe to where Minmus is and Minmus is now in orbit around Laythye. 

But my ramblings aside,  I reiterate, use either Lisias or my method of where to store your patches. Also, learn how to use 

correctly. Huge headache savers. Also, adding a % in front of a string that alters a variable will force its change. For your install and save saftey, I implore that you back everything up and copy your install to a new location and run from that location while you use your new configs until you are sure everything is QA'd to the Large Magellanic Cloud and back before you risk your main install. Even then, keep a back up.

 

Post edit:

  Hide contents

So I just realized that I am a lot closer to writing that mod to try to fix a kracken bug that stops spinning than I thought I was. I need to study some other mods like Hooligan Labs in how they place a tool bar button to access the GUI. What I want to do is make a button that kills all of the current information in rotational values for Pitch, Yaw, and Roll. I'm sure that if I spend a good chunk of tomorrow searching for the proper values, I can kill those. Even if I have to create a part and hot key it first. But that might be a bit ... beyond my current skill.  Mostly because some moduels requite a node to be in the craft's model, like one for thrust. For example, you can't take an RCS and make it a thruster. Unless you can edit a model to replace the node. Now I might be using the wrong terminology. Once I learn how to use Blender, I'm going to start making models for my OMNI SCI mod.

That'll be good, the anti-kracken SAS. "This SAS moduel does nothing until a kracken attack happens, then if you hit it with a hammer, you can halt the attack in process"

As a last side note, I am willing to start a thread and github for a Laythe orbiting Kerbin, and being tidally locked. Or other way around with Laythe in Kerbin's orbit with Kerbin tidally locked to Kerbin. If people want this. Send me DMs, not choke up this thread if you are interested. That's why I did this as a spoiler. Also, I'll create one tomorrow if I find what I need for the anti-kracken SAS and get it working in 1.10

 

A lot to consider, but I appreciate all the help!

Link to comment
Share on other sites

11 hours ago, MKSheppard said:

Is it possible to implement limits on Tweakscale, i.e. you can scale a part up to make it bigger, but you can't scale it down to make it smaller?

Yes and no, it depends on how and where you want to implement the thing.

On Career, you can use the TechTree. A minimalist walkthrough can be found here. Note: I didn't tested any of this.

On the other hand, if you want to set hard limits for the scaling disregarding anything else. you can brute force your way replacing scaleFactors and incrementSlides on a part that uses stack or stack_square on the scaleType:

@PART[LiquidEngineKE-1]:AFTER[TweakScale] // Kerbodyne KE-1 'Mastodon' Liquid Fuel Engine
{
	%MODULE[TweakScale]
	{
		// type = stack - Only apply this to parts with stack or stack_square
		// defaultScale = 2.5 this part is originally sized 2.5 meters 
		%scaleFactors   = 2.5,  3.75, 5.0, 7.5, 10, 20
		%incrementSlide = 0.05, 0.05, 0.1, 0.1, 0.2
        
		%freeScale = false // Add this if you want to force the scales to 'snap' on a predetermined scaleFactor
	}
}

Now the Kerbodyne KE-1 will only scale upwards, and only on the predetermined scaleFactors unless you delete the %freeScale thingy.

type = surface can also be restraint this way, but you need to use a normalised scaleFactor values (0.4, 1.0, 1.5, etc, where 1.0 is the "defaultScale").

type = free is the same, but it uses percentage instead of a normalised value (what I find kinda of weird the need for this, multiplying the normalised scale by 100 would accomplish the same on the User Interface - but whatever).

Edited by Lisias
tyops! Surprised?
Link to comment
Share on other sites

Hello @Lisias, it's KallangoVerde from Brazil. So ... I installed KSP Recall, but yesterday this alert appeared on the screen.

"Unfortunately TweakScale encountered 16 problems with ** FATAL ** in its KSP installation! This will likely corrupt your games sooner or later!

KSP.log is listing all parties committed to your parcel, look for lines with '[TweakScale] ERROR: ** FATAL **' in the log line. Be aware that the reported parties are not to blame, but the Screaming Victims. There is no automated solution possible for this.

This is a problem with the Show Stooper. Your best course of action is to click the OK button to ask for help in the TweakScale thread on the forum (the KSP will be closed). We will help you to diagnose the Add'On that is bothering you. Publish your KSP.log to some file sharing service and mention it in the post.

If you choose to ignore this message and click Cancel to continue, remember that your saved games can be corrupted at any time, even when things seem to be working now - and recovery can be more difficult.

Back up everything * NOW * if you choose to ignore this message and continue - it is recommended to use S.A.V.E. to automate this task for you. "

I would like help, what should I do?
I am using version 1.9.1 of the game.

 

Link to comment
Share on other sites

3 minutes ago, KallangoVerde said:

Hello @Lisias, it's KallangoVerde from Brazil. So ...

[baita cut]

I would like help, what should I do?
I am using version 1.9.1 of the game.

 

Salutos!  (Hehe, couldn't hold myself!)

Something is double patching some parts. Publish the full KSP.log on dropbox, google drive or something and I will give a look to identif who is stomping toes this time.

Recently I moved some configs on TweakScale, and since most people don't clear the old files on updating, KIS ended up double patched after the update (as the oldie KIS patch ended up lingering together the new one). If TweakScale was recently updated, completly remove TweakScale folder and then install it again and see if the problem is solved. If not, send me the KSP.log.

Cheers! 

Link to comment
Share on other sites

36 minutes ago, KallangoVerde said:

Hi @Lisias ... I installed it again but still has the same warning. I'm sending the log if you want to take a look. It's the first time I try to send this ... I hope it's the correct file, kkkk

https://drive.google.com/file/d/1D7Cm3o_VMntetsuWhC212zoY-M4EV9NQ/view?usp=sharing

You have the same problem just addressed.

It's a bad config in Knes.

Read everything from here down.

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...