Jump to content

[KSP >= 1.3.0] TweakScale - Under Lisias' Management - 2.4.6.20 - 2023-0126


Lisias
 Share

Recommended Posts

5 hours ago, Lisias said:

Not being weird enough the Unity Editor being loaded on your KSP,

I suspect a botched installation of Scatterer:

Spoiler
[LOG 23:13:03.341] AssemblyLoader: Loading assembly at C:\Program Files (x86)\Steam\steamapps\common\Kerbal Space Program\GameData\scatterer\Scatterer.dll
[LOG 23:13:03.344] Load(Assembly): scatterer/bin/Release/scatterer
[LOG 23:13:03.344] AssemblyLoader: Loading assembly at C:\Program Files (x86)\Steam\steamapps\common\Kerbal Space Program\GameData\scatterer\bin\Release\scatterer.dll
[LOG 23:13:03.346] Load(Assembly): scatterer/OldShaders/scattererShaders/Library/PackageCache/[email protected]/net35/unity-custom/nunit.framework
[LOG 23:13:03.346] AssemblyLoader: Loading assembly at C:\Program Files (x86)\Steam\steamapps\common\Kerbal Space Program\GameData\scatterer\OldShaders\scattererShaders\Library\PackageCache\[email protected]\net35\unity-custom\nunit.framework.dll
[LOG 23:13:03.348] Load(Assembly): scatterer/OldShaders/scattererShaders/Library/ScriptAssemblies/Assembly-CSharp-Editor
[LOG 23:13:03.348] AssemblyLoader: Loading assembly at C:\Program Files (x86)\Steam\steamapps\common\Kerbal Space Program\GameData\scatterer\OldShaders\scattererShaders\Library\ScriptAssemblies\Assembly-CSharp-Editor.dll
[LOG 23:13:03.349] Load(Assembly): scatterer/OldShaders/scattererShaders/Library/ScriptAssemblies/Assembly-CSharp
[LOG 23:13:03.349] AssemblyLoader: Loading assembly at C:\Program Files (x86)\Steam\steamapps\common\Kerbal Space Program\GameData\scatterer\OldShaders\scattererShaders\Library\ScriptAssemblies\Assembly-CSharp.dll
[LOG 23:13:03.351] Load(Assembly): scatterer/OldShaders/scattererShaders/Library/ScriptAssemblies/Unity.CollabProxy.Editor
[LOG 23:13:03.351] AssemblyLoader: Loading assembly at C:\Program Files (x86)\Steam\steamapps\common\Kerbal Space Program\GameData\scatterer\OldShaders\scattererShaders\Library\ScriptAssemblies\Unity.CollabProxy.Editor.dll
[LOG 23:13:03.352] Load(Assembly): scatterer/OldShaders/scattererShaders/Library/ScriptAssemblies/Unity.Rider.Editor
[LOG 23:13:03.352] AssemblyLoader: Loading assembly at C:\Program Files (x86)\Steam\steamapps\common\Kerbal Space Program\GameData\scatterer\OldShaders\scattererShaders\Library\ScriptAssemblies\Unity.Rider.Editor.dll
[LOG 23:13:03.353] Load(Assembly): scatterer/OldShaders/scattererShaders/Library/ScriptAssemblies/Unity.TextMeshPro
[LOG 23:13:03.353] AssemblyLoader: Loading assembly at C:\Program Files (x86)\Steam\steamapps\common\Kerbal Space Program\GameData\scatterer\OldShaders\scattererShaders\Library\ScriptAssemblies\Unity.TextMeshPro.dll
[LOG 23:13:03.356] Load(Assembly): scatterer/OldShaders/scattererShaders/Library/ScriptAssemblies/Unity.TextMeshPro.Editor
[LOG 23:13:03.356] AssemblyLoader: Loading assembly at C:\Program Files (x86)\Steam\steamapps\common\Kerbal Space Program\GameData\scatterer\OldShaders\scattererShaders\Library\ScriptAssemblies\Unity.TextMeshPro.Editor.dll
[LOG 23:13:03.357] Load(Assembly): scatterer/OldShaders/scattererShaders/Library/ScriptAssemblies/Unity.Timeline
[LOG 23:13:03.357] AssemblyLoader: Loading assembly at C:\Program Files (x86)\Steam\steamapps\common\Kerbal Space Program\GameData\scatterer\OldShaders\scattererShaders\Library\ScriptAssemblies\Unity.Timeline.dll
[LOG 23:13:03.359] Load(Assembly): scatterer/OldShaders/scattererShaders/Library/ScriptAssemblies/Unity.Timeline.Editor
[LOG 23:13:03.359] AssemblyLoader: Loading assembly at C:\Program Files (x86)\Steam\steamapps\common\Kerbal Space Program\GameData\scatterer\OldShaders\scattererShaders\Library\ScriptAssemblies\Unity.Timeline.Editor.dll
[LOG 23:13:03.361] Load(Assembly): scatterer/OldShaders/scattererShaders/Library/ScriptAssemblies/Unity.VSCode.Editor
[LOG 23:13:03.361] AssemblyLoader: Loading assembly at C:\Program Files (x86)\Steam\steamapps\common\Kerbal Space Program\GameData\scatterer\OldShaders\scattererShaders\Library\ScriptAssemblies\Unity.VSCode.Editor.dll
[LOG 23:13:03.362] Load(Assembly): scatterer/OldShaders/scattererShaders/Library/ScriptAssemblies/UnityEditor.TestRunner
[LOG 23:13:03.362] AssemblyLoader: Loading assembly at C:\Program Files (x86)\Steam\steamapps\common\Kerbal Space Program\GameData\scatterer\OldShaders\scattererShaders\Library\ScriptAssemblies\UnityEditor.TestRunner.dll
[LOG 23:13:03.364] Load(Assembly): scatterer/OldShaders/scattererShaders/Library/ScriptAssemblies/UnityEditor.UI
[LOG 23:13:03.364] AssemblyLoader: Loading assembly at C:\Program Files (x86)\Steam\steamapps\common\Kerbal Space Program\GameData\scatterer\OldShaders\scattererShaders\Library\ScriptAssemblies\UnityEditor.UI.dll
[LOG 23:13:03.365] Load(Assembly): scatterer/OldShaders/scattererShaders/Library/ScriptAssemblies/UnityEngine.TestRunner
[LOG 23:13:03.365] AssemblyLoader: Loading assembly at C:\Program Files (x86)\Steam\steamapps\common\Kerbal Space Program\GameData\scatterer\OldShaders\scattererShaders\Library\ScriptAssemblies\UnityEngine.TestRunner.dll
[LOG 23:13:03.367] Load(Assembly): scatterer/OldShaders/scattererShaders/Library/ScriptAssemblies/UnityEngine.UI
[LOG 23:13:03.367] AssemblyLoader: Loading assembly at C:\Program Files (x86)\Steam\steamapps\common\Kerbal Space Program\GameData\scatterer\OldShaders\scattererShaders\Library\ScriptAssemblies\UnityEngine.UI.dll
[LOG 23:13:03.369] Load(Assembly): scatterer/OldShaders/scattererShaders/obj/Debug/Assembly-CSharp-Editor
[LOG 23:13:03.369] AssemblyLoader: Loading assembly at C:\Program Files (x86)\Steam\steamapps\common\Kerbal Space Program\GameData\scatterer\OldShaders\scattererShaders\obj\Debug\Assembly-CSharp-Editor.dll
[LOG 23:13:03.369] Load(Assembly): scatterer/OldShaders/scattererShaders/obj/Debug/Assembly-CSharp
[LOG 23:13:03.369] AssemblyLoader: Loading assembly at C:\Program Files (x86)\Steam\steamapps\common\Kerbal Space Program\GameData\scatterer\OldShaders\scattererShaders\obj\Debug\Assembly-CSharp.dll
[LOG 23:13:03.370] Load(Assembly): scatterer/OldShaders/scattererShaders/obj/Release/Assembly-CSharp
[LOG 23:13:03.370] AssemblyLoader: Loading assembly at C:\Program Files (x86)\Steam\steamapps\common\Kerbal Space Program\GameData\scatterer\OldShaders\scattererShaders\obj\Release\Assembly-CSharp.dll

 

 

@EndAllFilms check the "scatterer" folder. There is stuff in there that doesn't belong there. It looks like you unpacked the whole source repository and not the release archive. I'd suggest to remove it, download the mod from spacedock and install it again.

Edited by HansAcker
Link to comment
Share on other sites

5 hours ago, Lisias said:

Well, you were bitten by that nasty KSP's Assembly Loader/Editor!

[ERR 23:13:03.749] AssemblyLoader: Exception loading 'Assembly-CSharp-Editor': System.Reflection.ReflectionTypeLoadException: Exception of type 'System.Reflection.ReflectionTypeLoadException' wa
  at (wrapper managed-to-native) System.Reflection.Assembly.GetTypes(System.Reflection.Assembly,bool)
  at System.Reflection.Assembly.GetTypes () [0x00000] in <9577ac7a62ef43179789031239ba8798>:0
  at AssemblyLoader.LoadAssemblies () [0x000e6] in <0435390348b6470d8166bd1c53b4b100>:0

Additional information about this exception:

 System.IO.FileNotFoundException: Could not load file or assembly 'UnityEditor, Version=0.0.0.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies.
File name: 'UnityEditor, Version=0.0.0.0, Culture=neutral, PublicKeyToken=null'

[ERR 23:13:03.804] AssemblyLoader: Exception loading 'Unity.CollabProxy.Editor': System.Reflection.ReflectionTypeLoadException: Exception of type 'System.Reflection.ReflectionTypeLoadException'
  at (wrapper managed-to-native) System.Reflection.Assembly.GetTypes(System.Reflection.Assembly,bool)
  at System.Reflection.Assembly.GetTypes () [0x00000] in <9577ac7a62ef43179789031239ba8798>:0
  at AssemblyLoader.LoadAssemblies () [0x000e6] in <0435390348b6470d8166bd1c53b4b100>:0

Not being weird enough the Unity Editor being loaded on your KSP, I also found this:

[ERR 23:13:03.810] ADDON BINDER: Cannot resolve assembly: netstandard, Culture=neutral, PublicKeyToken=cc7b13ffcd2ddd51

[ERR 23:13:03.815] AssemblyLoader: Exception loading 'Unity.TextMeshPro': System.Reflection.ReflectionTypeLoadException: Exception of type 'System.Reflection.ReflectionTypeLoadException' was thr
own.
  at (wrapper managed-to-native) System.Reflection.Assembly.GetTypes(System.Reflection.Assembly,bool)
  at System.Reflection.Assembly.GetTypes () [0x00000] in <9577ac7a62ef43179789031239ba8798>:0
  at AssemblyLoader.LoadAssemblies () [0x000e6] in <0435390348b6470d8166bd1c53b4b100>:0

Additional information about this exception:

 System.TypeLoadException: Could not load file or assembly 'netstandard, Version=2.0.0.0, Culture=neutral, PublicKeyToken=cc7b13ffcd2ddd51' or one of its dependencies. assembly:netstandard, Vers
ion=2.0.0.0, Culture=neutral, PublicKeyToken=cc7b13ffcd2ddd51 type:<unknown type> member:(null) signature:<none>

What's the last nail on this coffin.

KSP (and TweakScale) supports up to .net 4.6 (and things compiled on 3.5 also works fine), there's no support for netstandard on KSP, and so there's no support from TweakScale on it neither. I will probably work, but I can't support this environment.

I don't have the slightest idea about what you had installed that is using NetStandard, but whatever it is, you need to find it and call the maintainer for help. I don't compile my add'ons with NetStandard, I don't have the slightest idea about what's happening on your rig.

Keep in mind that TweakScale is not the one causing problems. It's the one telling you about the problems. You can remove TweakScale from your rig to get rid of the message, but not of the problem, it will linger on your rig causing problems silently on your game - it's up to you do decide what to do.

Good Luck!

So what are you saying?

Link to comment
Share on other sites

7 minutes ago, EndAllFilms said:

So what are you saying?

That there's something else on your rig screwing up, and since I can't support 3rd parties, I can only tell you what is happening but not who is borking on it.

Fellow Kerbonaut @HansAcker knows a bit more about Scatterer and hinted that perhaps it would be badly installed (thanks for the tip, dude!). Completely remove the Scatterer folder and see if the problem goes away. If this works, you need to install Scatterer again, following the installing instructions this time.

If even by removing Scatterer the problem persists, send me a new KSP.log and let's keep digging.

Link to comment
Share on other sites

58 minutes ago, MeeMic said:

tweakscale has done it again. Can someone help me fix this?

image pf error: https://imgur.com/gallery/L3yXgzk

Send me your KSP.log on dropbox and I will check it.

(and it's not TweakScale. KSP-Recall is the one complaining - KSP dos not work correctly when the PWD is different from the KSPUtil.ApplicationRoot)

 

Link to comment
Share on other sites

8 hours ago, Lisias said:

Well, you were bitten by that nasty KSP's Assembly Loader/Editor!

[ERR 23:13:03.749] AssemblyLoader: Exception loading 'Assembly-CSharp-Editor': System.Reflection.ReflectionTypeLoadException: Exception of type 'System.Reflection.ReflectionTypeLoadException' wa
  at (wrapper managed-to-native) System.Reflection.Assembly.GetTypes(System.Reflection.Assembly,bool)
  at System.Reflection.Assembly.GetTypes () [0x00000] in <9577ac7a62ef43179789031239ba8798>:0
  at AssemblyLoader.LoadAssemblies () [0x000e6] in <0435390348b6470d8166bd1c53b4b100>:0

Additional information about this exception:

 System.IO.FileNotFoundException: Could not load file or assembly 'UnityEditor, Version=0.0.0.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies.
File name: 'UnityEditor, Version=0.0.0.0, Culture=neutral, PublicKeyToken=null'

[ERR 23:13:03.804] AssemblyLoader: Exception loading 'Unity.CollabProxy.Editor': System.Reflection.ReflectionTypeLoadException: Exception of type 'System.Reflection.ReflectionTypeLoadException'
  at (wrapper managed-to-native) System.Reflection.Assembly.GetTypes(System.Reflection.Assembly,bool)
  at System.Reflection.Assembly.GetTypes () [0x00000] in <9577ac7a62ef43179789031239ba8798>:0
  at AssemblyLoader.LoadAssemblies () [0x000e6] in <0435390348b6470d8166bd1c53b4b100>:0

Not being weird enough the Unity Editor being loaded on your KSP, I also found this:

[ERR 23:13:03.810] ADDON BINDER: Cannot resolve assembly: netstandard, Culture=neutral, PublicKeyToken=cc7b13ffcd2ddd51

[ERR 23:13:03.815] AssemblyLoader: Exception loading 'Unity.TextMeshPro': System.Reflection.ReflectionTypeLoadException: Exception of type 'System.Reflection.ReflectionTypeLoadException' was thr
own.
  at (wrapper managed-to-native) System.Reflection.Assembly.GetTypes(System.Reflection.Assembly,bool)
  at System.Reflection.Assembly.GetTypes () [0x00000] in <9577ac7a62ef43179789031239ba8798>:0
  at AssemblyLoader.LoadAssemblies () [0x000e6] in <0435390348b6470d8166bd1c53b4b100>:0

Additional information about this exception:

 System.TypeLoadException: Could not load file or assembly 'netstandard, Version=2.0.0.0, Culture=neutral, PublicKeyToken=cc7b13ffcd2ddd51' or one of its dependencies. assembly:netstandard, Vers
ion=2.0.0.0, Culture=neutral, PublicKeyToken=cc7b13ffcd2ddd51 type:<unknown type> member:(null) signature:<none>

What's the last nail on this coffin.

KSP (and TweakScale) supports up to .net 4.6 (and things compiled on 3.5 also works fine), there's no support for netstandard on KSP, and so there's no support from TweakScale on it neither. I will probably work, but I can't support this environment.

I don't have the slightest idea about what you had installed that is using NetStandard, but whatever it is, you need to find it and call the maintainer for help. I don't compile my add'ons with NetStandard, I don't have the slightest idea about what's happening on your rig.

Keep in mind that TweakScale is not the one causing problems. It's the one telling you about the problems. You can remove TweakScale from your rig to get rid of the message, but not of the problem, it will linger on your rig causing problems silently on your game - it's up to you do decide what to do.

Good Luck!

The tweakscale thing worked but the Scatterer ocean itself didn't even work If you need logs let me know

Link to comment
Share on other sites

12 hours ago, EndAllFilms said:

The tweakscale thing worked but the Scatterer ocean itself didn't even work If you need logs let me know

So it was really Scatterer that by some reason was triggering the KSP's Assenbly Loader/Resolver bug.

If you have CKAN, I would suggest to use it. If by some reason you don't want to use CKAN, I want to suggest you to create a disposable KSP installment and use it on CKAN to install Scatterer. Then you see what CKAN did, and do the same on your playing KSP. Tell CKAN to install only Scatterer, so you will have an idea of all the dependencies it needs (as they are installed automatically).

I can't help more because I don't use Scatterer myself, so I don't know what's happening and can't tell you what's wrong - but if our friend above is right, you probably downloaded the wrong zip file from github. So go to this link https://spacedock.info/mod/141/scatterer and click on the Download button on the top right, below the banner. This one should work for sure.

Cheers!

Edited by Lisias
tyops!
Link to comment
Share on other sites

ANNOUNCE

Release 2.4.6.18r2 2.4.6.18r3 is available for downloading, with the following changes:

  • The very same 2.4.6.18 release, but with an updated KSPe.Light with the KSPe#37 fix.
  • The very same 2.4.6.18 release, but with a yet another updated KSPe.Light with the KSPe#37 fix. Again...

 

Disclaimer

By last, but not the least...

Spoiler

No Module Manager was harmed during the development of TweakScale.

 

This Release will be published using the following Schedule:

  • GitHub, reaching first manual installers and users of KSP-AVC. Right now.
  • CurseForge. Right Now.
  • SpaceDock (and CKAN users). Right Now.

Since I already had published two versions in a row, I think it's better to ask for help on testing this one before doing it again and stressing users with multiple updates!!

Edited by Lisias
2.4.6.18r3 is on the wild. All your Distribution Channels are belong to us!!
Link to comment
Share on other sites

  • 3 weeks later...
5 minutes ago, ThatHomelessGuy said:

Hi I have been trying to install tweakscale and I'm getting the error "more than one 999_Scale_Redist.dll In ksp install, Delete all but one" However I have searched and searched and can only find one copy that is in my GameData folder. 

I am pulling my hair out over this honestly. 

Any ideas?

Send me a full KSP.log (exit KSP before copying it) using dropbox or something, and I will inspect it. Sometimes the freaking doppelgänger is under a different filename!!

Link to comment
Share on other sites

7 minutes ago, Lisias said:

Send me a full KSP.log (exit KSP before copying it) using dropbox or something, and I will inspect it. Sometimes the freaking doppelgänger is under a different filename!!

Ok let me reinstall the watchdog and restart KSP and dump it into google docs. Might take a while though my launch is about 20 minutes.

Oddly enough with the watchdog removed it loads fine and tweakscale appears to work just fine. That said I have played enough modded ksp to know that a single launch isn't enough to confirm that something is actually working.

Link to comment
Share on other sites

31 minutes ago, Lisias said:

Send me a full KSP.log (exit KSP before copying it) using dropbox or something, and I will inspect it. Sometimes the freaking doppelgänger is under a different filename!!

Ok so I just decided to scan the log myself for "scale" and I found Scale_Redist.dll in both the ferram plugins and magicsmokeindustries plugins so I deleted them and the error is gone. I assume this was the correct course of action since the error is now gone, and I assume it probably won't break ferram or infernal robotics "Next".

I'm just checking in to see if you agree that I made the correct call or not. 

I also appreciate the fast response you gave. Very impressed.

Link to comment
Share on other sites

2 hours ago, ThatHomelessGuy said:

I'm just checking in to see if you agree that I made the correct call or not. 

Yes, its exactly that. You solved the issue! :)

 

2 hours ago, ThatHomelessGuy said:

I also appreciate the fast response you gave. Very impressed.

I felt a disturbance in the Force and then logged here… :sticktongue:

Nah. Pure chance, I was checking my mail when the notification about your post just arrived and then just clicked on the link! :)

Cheers!

Edited by Lisias
tyops as usulla...
Link to comment
Share on other sites

1 minute ago, Lisias said:

Yes, its exactly that. You solved the issue! :)

 

I felt a disturbance in the Force and then logged here… :sticktongue:

Nah. Pure chance, I was checking my mail when the notification about your post just arrived and then just clicked on the link! :)

Cheers!

Great work by the way. Keep it up it's much appreciated.:kiss:

Link to comment
Share on other sites

I'm seeing a weird behavior on 1.12.4 with (most recent) TweakScale, and I'm reasonably confident it is a conflict with (most recent) B9 part switch fuel switching. I believe this because on a clean install (only TweakScale, ts companions, Recall) it doesn't occur, and when I add b9 part switch and CryoTanks (which applies fuel switching to tanks so I don't have to), along with CryoTanks' dependencies (CRP + dynamic battery storage), it can be reproduced very easily. I don't *think* it has to do with CryoTanks' boiloff module, because I'm not testing on parts to which that module was applied (I think), but I guess that might be another possibility.

Anyhoo, to reproduce, simply install B9 Part Switch, CryoTanks, and CryoTanks dependencies with TweakScale on a clean KSP and:

  1. Place part in VAB.
  2. Place a fuel tank that has a B9 Part Switch tank switching module applied to it; use radial symmetry and place 2 or more of that tank.
  3. Tweak the size of one of the tanks in the symmetry group just created,
  4. Pick up one of the tanks, then place it again (still in symmetry), and
  5. The tank under the mouse (the one at the point of placement) will have the correct increased volumes, but all of its 'symmetry clones' (not sure of the right term there) will have incorrect volumes equal to the original volume of the part.

Just FYI!

The workaround is: don't pick up and re-place anything in symmetry after scaling.

Edited by AccidentalDisassembly
Link to comment
Share on other sites

Hello.

After 4 years of no KSP I decided to reset my laptop and get it up and running again from scratch.  latest version and 180 mods later the game loads but comes up with a big warning about a fatal Tweakscale error that needs fixing, and recommends I ask you guys if you know what I should do? (the game doesn't crash)

Error message here: https://imgur.com/gallery/TqTbFtd

KSP.log here: https://we.tl/t-bwNFX8FR12

Also a screenshot of first page of ksp.log with errors: https://imgur.com/gallery/pjv1LCg

Would really appreciate your input here. Many thanks!

Edited by nick533a
Link to comment
Share on other sites

24 minutes ago, nick533a said:

Hello.

After 4 years of no KSP I decided to reset my laptop and get it up and running again from scratch.  latest version and 180 mods later the game loads but comes up with a big warning about a fatal Tweakscale error that needs fixing, and recommends I ask you guys if you know what I should do? (the game doesn't crash)

Error message here: https://imgur.com/gallery/TqTbFtd

KSP.log here: https://we.tl/t-bwNFX8FR12

Also a screenshot of first page of ksp.log with errors: https://imgur.com/gallery/pjv1LCg

Would really appreciate your input here. Many thanks!

I think that is a good Idea to make a reference to @Lisias

Link to comment
Share on other sites

7 hours ago, nick533a said:

Thanks, I'll also show a screenshot of the report if it helps.

HtXmfzL.png

 

Message from KSP:

QOz9GRo.png

@Lisias is this something you're familiar with? 

I need the full KSP.log in order to check for the problem, as well the files Logs/ModuleManager/MMPatch.log and GameData/ModuleManager.ConfigCache .

Whatever is happening, is leaving breadcrumbs on these files and by following them I will be able to tell you where and who is borking the patches. Most problems are already diagnosed by now, chances are that the fix will be a simple install, perhaps something from TweakScale Companion Program!

— — POST EDIT — — 

I just notices your log above! Working on it!

— — POST POST EDIT — — 

@nick533a, I found them:

[LOG 11:52:17.046] [TweakScale] ERROR: **FATAL** Part Thoroughbred (SRB-25-060 "Thoroughbred" Solid Fuel Booster (12m)) has a fatal problem due having duplicated properties - see issue [#34]( https://github.com/net-lisias-ksp/TweakScale/issues/34 ). at error:0
[LOG 11:52:17.046] [TweakScale] ERROR: **FATAL** Part Clydesdale (SRB-25-123 "Clydesdale" Solid Fuel Booster (22m)) has a fatal problem due having duplicated properties - see issue [#34]( https://github.com/net-lisias-ksp/TweakScale/issues/34 ). at error:0
[LOG 11:52:17.047] [TweakScale] ERROR: **FATAL** Part Shrimp (SRB-06-07 "Shrimp" Solid Fuel Booster (4m)) has a fatal problem due having duplicated properties - see issue [#34]( https://github.com/net-lisias-ksp/TweakScale/issues/34 ). at error:0
[LOG 11:52:17.047] [TweakScale] ERROR: **FATAL** Part Mite (SRB-06-03 "Mite" Solid Fuel Booster (1.8m)) has a fatal problem due having duplicated properties - see issue [#34]( https://github.com/net-lisias-ksp/TweakScale/issues/34 ). at error:0
[LOG 11:52:17.091] [TweakScale] INFO: WriteDryCost Concluded : 2111 parts found ; 0 checks failed ; 0 parts with hotfixes ; 0 parts with issues overruled ; 4 Show Stoppers found; 0 Sanity Check failed; 1084 unscalable parts.

And I also found the culprit:

[LOG 11:43:35.037] Applying update BladeTweaks/Squad-TweakScale/@PART[Thoroughbred]:FOR[TweakScale] to Squad/Parts/Engine/solidBoosterS2-17/solidBoosterS2-17.cfg/PART[Thoroughbred]

BladeTweakes's TS patches didn't aged very well, remove the file GameData/BladeTweaks/Squad-TweakScale.cfg and you will be allright!

Cheers!

— — — — 

On 12/19/2022 at 11:12 PM, AccidentalDisassembly said:

I'm seeing a weird behavior on 1.12.4 with (most recent) TweakScale,

Thanks for the report, I have it recorded on the relevant issue.

Currently I'm waiting my vacations in order to go back to KSP development - some happenings around my country are demanding some careful tracking on day-job.

Cheers!

Edited by Lisias
Brute force post merge.
Link to comment
Share on other sites

Hi, I've recently looked into modds with KSP, and I've installed about half a dozen of mods so far, and I've already ran into some errors. The game launches successfully, but a message pops up saying my tweakscale mod has 5 fatal errors, and when clicking OK it directs me to here. anybody got any idea as to why this is happening and how I can fix it? Thanks in advance!

KSP Log: https://drive.google.com/file/d/1AyLc1Jyt0y6A0mgdUQ4Ms6upfoVZCgPc/view?usp=sharing

Error message screenshots: https://postimg.cc/nMQ24wXy     https://postimg.cc/QFjqr8fD

 

Link to comment
Share on other sites

5 hours ago, Hehe04 said:

Hi, I've recently looked into modds with KSP, and I've installed about half a dozen of mods so far, and I've already ran into some errors. The game launches successfully, but a message pops up saying my tweakscale mod has 5 fatal errors, and when clicking OK it directs me to here. anybody got any idea as to why this is happening and how I can fix it? Thanks in advance!

KSP Log: https://drive.google.com/file/d/1AyLc1Jyt0y6A0mgdUQ4Ms6upfoVZCgPc/view?usp=sharing

Error message screenshots: https://postimg.cc/nMQ24wXy     https://postimg.cc/QFjqr8fD

Your KSP.log was truncated, this happens when you try to copy it with KSP still running (the last 16K or so of text is still in memory and not flushed into the disk yet…). Send me another one, after quitting KSP, so I can check the parts affected.

In time, you have MM Errors also on your rig!

Link to comment
Share on other sites

1 hour ago, Lisias said:

Your KSP.log was truncated, this happens when you try to copy it with KSP still running (the last 16K or so of text is still in memory and not flushed into the disk yet…). Send me another one, after quitting KSP, so I can check the parts affected.

In time, you have MM Errors also on your rig!

Hi, thank you for replying! while waiting for a reply, I decided to try and troubleshoot a little and see if I could isolate which mod was causing the issues by removing them one by one, but in the process of doing so, I think I might've messed some files up, and now I've ran into another issue entirely. The game is now shooting me an error message about not detecting the modulemanager.dll file in the Game Data folder, where it's supposed to be in, despite having multiple different versions of modulemanager.dll in there already. Could my tweekscale mod issue be related to this modulemanager thingy? Because now that I think about it, its a little strange that I have so many versions of the modulemanager folder in my folder. 
Here's a screenshot of all the nonsense that I've jammed into my GameData folder: https://postimg.cc/6y1Y0Frw
And here's the new KSP log with KSP closed properly: https://drive.google.com/file/d/1AyLc1Jyt0y6A0mgdUQ4Ms6upfoVZCgPc/view?usp=sharing

Link to comment
Share on other sites

4 hours ago, Hehe04 said:

Hi, thank you for replying! while waiting for a reply, I decided to try and troubleshoot a little and see if I could isolate which mod was causing the issues by removing them one by one, but in the process of doing so, I think I might've messed some files up, and now I've ran into another issue entirely. The game is now shooting me an error message about not detecting the modulemanager.dll file in the Game Data folder, where it's supposed to be in, despite having multiple different versions of modulemanager.dll in there already. Could my tweekscale mod issue be related to this modulemanager thingy? Because now that I think about it, its a little strange that I have so many versions of the modulemanager folder in my folder. 
Here's a screenshot of all the nonsense that I've jammed into my GameData folder: https://postimg.cc/6y1Y0Frw
And here's the new KSP log with KSP closed properly: https://drive.google.com/file/d/1AyLc1Jyt0y6A0mgdUQ4Ms6upfoVZCgPc/view?usp=sharing

Well, I think I know what happened.

1) You have a pretty old ModuleManager installed. DEmote the ModuleManager.2.8.dl and install ModuleManager.4.2.2.dll (fetch it from this thread).

2) ModuleManagerWatchDog is installed wrongly. Aside the 666_ModuleManagerWatchDog.dll, everything else needs to be installed on the GameData/ModuleManagerWatchDog directory. Please remove all MMWD files (but the 666_* one) from the GameData and install MMWD on its own directory!

Cheers!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...