Lisias

[KSP >= 1.4.1] TweakScale - Under Lisias' Management - 2.4.3.10 - 2019-1030

Recommended Posts

I'm a fan of VS Code these days. It's lightweight, handles multiple languages well, and has a good collection of plugins.

Share this post


Link to post
Share on other sites
2 hours ago, Commodoregamer118 said:

Will this mod have support for 1.8??

i-find-your-5c003f.jpg

Unfortunately, somewhat accurate too. :P 

The Good News is that apparently I managed to keep KSPe (a bag of tricks I intend to use as a KSP abstraction layer and service provider for my Add'Ons) working on Unity 2019 - what's not exactly a surprise, as I could inspect the Unity's and .NET APIs in advance to see any problems. So, yeah. TweakScale is still whinny. :D And yes, this is TweakScale 2.4.3.7 , released on the last weekend. :cool:

0001.jpg

 

The interesting news is that Crafts you made on previous KSP versions appears to be scaling correctly when loading on KSP 1.8. Mass, fuel, etc, are still scaled after loading them on KSP 1.8. 

0010.jpg

 

And the damn thing is working:

Spoiler

And KSP 1.8 is apparently performing way better on my Mac Potato (and this thing is terrible!). So, yeah. I kinda of happy - besides what follows:

The bad news is that the UI is kaput. You just can't edit any tweakscaled part on KSP 1.8, you must do the work on the KSP 1.7.3 and import the craft.

0009.jpg

 

2 hours ago, Commodoregamer118 said:

If yes when will be released?

I will tell you something: the UI breakage got me with my pants down. I was fearing some change on KSP guts due Unity 2019 changes, but that apparently is working fine. But I didn't expected borking on something simple as a UI widget.

I will try to find time to check this before the weekend, but, frankly, don't hold your breath. We are on a very frantic rhythm on my work (black Friday is coming!), so I can't promise I will spend some time on it on the workdays.

 — — POST EDIT — — 

Apparently is something simple to fix, just add a dependency to the project and recompile. Or, perhaps I can cook some stunt that will make thins easier… :sticktongue:

Note to myself (it's way past the sleeping time here)

  <Reference Include="UnityEngine.CoreModule">
       <HintPath>..\..\..\Managed\UnityEngine.CoreModule.dll</HintPath>
     </Reference>

 

Edited by Lisias
Forum bitten me!!!! Need to cut down some extra postings….

Share this post


Link to post
Share on other sites

Thank you Lisias for all the work you do regarding mod support. 1.8 seems to have the largest impact of mods since I've been playing KSP (1.4.2). Maybe more than 1.3 -> 1.4.

Share this post


Link to post
Share on other sites
9 hours ago, Lisias said:

Apparently is something simple to fix, just add a dependency to the project and recompile. Or, perhaps I can cook some stunt that will make thins easier… :sticktongue:

Other than adding the reference to UnityEngine.CoreModule.dll (which basically every mod with code in it will have to do), you may need to add some other references as well. It depends on which bits of Unity functionality your mod is using. (In my own case, only one of my mods needed to do that.)

You'll also want to update your .NET version to something 4.x.

Other than that, hopefully you don't have to touch any actual code (fingers crossed). ;)

Share this post


Link to post
Share on other sites
1 hour ago, Snark said:

You'll also want to update your .NET version to something 4.x.

Other than that, hopefully you don't have to touch any actual code (fingers crossed). ;)

One very interesting thing that had bitten me hard in the SAS when I first published something I did was exactly these libraries stunt. Believe or not, if I compile my DLLs using the Mac's Unity libraries, the damn thing only works on Mac. Windows and Linux bork. If I compile the DLLs against the Windows libraries, everybody runs happy.

Go figure it out. :P

Well, I was victim of my own naiveness. I focused on the API changes and plain forgot this DLL stunt. Oh well - KSPe was Unity 2019 ready after all. :sticktongue:

 

1 hour ago, Snark said:

You'll also want to update your .NET version to something 4.x.

If you plan to publish different binaries to each KSP version, yep. This is probably the wiser move as you will have access to the new CIL opcodes, better compiler optimisations et all.

But, if you are willing to compromise by reusing the same binaries on less demanding Add'Ons (and TweakScale is very undemanding, it's essentially basic math running on a trigger using some very clever data structures!), sticking on 3.5 will make your deploying easier - if you manage to overcome that DLL linking problem.

(What must be possible, see the Mac vs the World DLL stunt!)

Edited by Lisias
Grammars. Don't you hate this thing?

Share this post


Link to post
Share on other sites
2 hours ago, DarkNounours said:

Thank you Lisias for all the work you do regarding mod support. 1.8 seems to have the largest impact of mods since I've been playing KSP (1.4.2). Maybe more than 1.3 -> 1.4.

To tell you the true, it's more os less the same impact. 1.3 to 1.4 switched Unity5 with Unity 2017, and Unity changed very used things on the API - as Texture Loading. KSPe managed to solve that by abstracting that API changes and dynamically calling the correct one by reflection. If you are on Unit5, "invoke this way", if you are on 2017 (and now 2019), "invoke this other way". It's simple at the end, the hard part is realizing the problem at first place. :)

This new change must had some API changes as well, but perhaps a bit less dramatic. The ones I use most apparently didn't changed, so the code "survived". The current breakage is due a DLL reorganization on Unity's internals - what appears to be something similar to what they did on Mac OS version of the DLLs (see above).

A DLL is just a indexed list of code structures on a file (at the very beginning, all we had was the index of the call - nowadays, the DLL has also metadata with the call's name and formal parameters - before that, we had to provide a HEADER file with that information too, so now we can link by name, what can allow some stunts by manipulating the DLLs on the deployment!), and the linking is done on loading time (not compile time) so you don't really need to recompile everything just because a new DLL came - unless they had changed the formal parameters of some of the used calls, or they had moved them out of the damn DLL. :D

See the stunt about Mac's DLLs. They probably have something else that is not there on Windows and Linux, and once you compile against them, your code doesn't cope with the latter's DLLs due that missing thing. But once you compile on the latter, you can link them against the former's DLL because your code would not be trying to link that extra calls (inside the DLL, God Knows what happens!).

Well… I will issue TweakScale 2.4.3.8 until the end of the day, with a dedicated compile to 1.8 so you guys can play. But I'm aiming to try to make again an "Universal" binary as fast as I can. By smartly manipulating the DLL search path, perhaps it would be possible to "fake" an Unity 2017 interface for old Add'Ons so they can run on 2019 without even a recompile? That would be epic!

Edited by Lisias
Grammars. Don't you hate this thing?

Share this post


Link to post
Share on other sites

That's the thing: I ran out of time before figuring out what's preventing TweakScale's UI to work.

I managed to add the References to the new DLLs (as a lot of things changed on Unity 2019) and managed to build a binary - but no dice, the problem persists. It's interesting to note that the TweakScale's DLL was being loaded and executed (it executed the Sanity Checks, right?).

Frankly, it is not that what is borking TweakScale's on the UI. there's something else. Perhaps an error on TweakScale itself (I was hinted about a mistake on the PartModule's event handling, but RL and some support ended up preventing me from tacking it up - and that thing was not bitting too much.. until now).

The aftermath is that I choose to lock the current TweakScale from running on Unity 2019 for now. The weekend is coming, a lot of people is going to install KSP 1.8 and I don't want be the one breaking their games. I will try to negotiate with RL (aka, boss) some spare time to pursue this problem today, but work comes first - so I can't promise I will have a solution in time for the weekend party time.

— EDIT : S.A.V.E. appears to work fine on KSP 1.8! :) Tested the basic functions, and no apparent flaw.

Well….

ANNOUNCE.

@Lisias Lisias released this 26 minutes ago · 0 commits to master since this release

  • This Release locks TweakScale to run only on KSP versions greater or equal 1.4.1 and less than 1.8 .
  • Updated KSPe Light for TweakScale:
    • Checking against incompatible Unity Versions
    • And this thing worked fine on Unity 2019.2 ! :)
  • Closing or reworking the following issues:
    • #79 Prevent TweakScale from running on Incompatible Unity versions

Warning

This release breaks the TweakScale's long tradition of being compatible with multiple KSP versions. This release will work only for KSP releases before 1.8.

This is not critical or mandatory if you are not planning to migrate your savegames to KSP 1.8, but newer installations should download this version and I need to prevent TweakScale from running on Unity 2019 for now.

KSP 1.8 compatibility is already Work In Progress - but it will give me a bit more work than I though. This appears to be a bug on TweakScale, not a breakage on KSP or Unity. Yeah, I'm bitting my tongue. :)

KSP 1.8 compatibility is already Work In Progress - but it will give me a bit more work than I though. It was confirmed that it's a bug on KSP on a very base feature used on UI, and some Add'Ons (TweakScale included) was relying on it. It's uncertain at this point if the best line of action if to wait for KSP 1.8.1 or just rework the UI.

(I made a mistake by thinking I had made a mistake!! :sticktongue:)

Edited by Lisias
Tyops! And they gone into production! Marvelous!! =D

Share this post


Link to post
Share on other sites

All we can do is say thank you for your work and patience. Really seems like a little thing compared to the time you put in this.  How do we donate to you, do you have paypal?

Share this post


Link to post
Share on other sites

@Lisias I would like to suggest a plugin that disables conflicting TweakScale modules Because I find that the most common fatal error is issue #34: Duplicated properties | It would be a good addon. 
Example: If x.cfg has Module[Tweakscale] for z part and y.cfg has Module[Tweakscale] for z part, they will confilct. 
N.dll would disable one of the tweakscale modules to prevent conficts.

Correct me if I have suggested this already

Edited by IronKerbal

Share this post


Link to post
Share on other sites
11 hours ago, Lisias said:

That's the thing: I ran out of time before figuring out what's preventing TweakScale's UI to work.

I managed to add the References to the new DLLs (as a lot of things changed on Unity 2019) and managed to build a binary - but no dice, the problem persists. It's interesting to note that the TweakScale's DLL was being loaded and executed (it executed the Sanity Checks, right?).

KSP 1.8 compatibility is already Work In Progress - but it will give me a bit more work than I though. This appears to be a bug on TweakScale, not a breakage on KSP or Unity. Yeah, I'm bitting my tongue. :)

Lisias 

FYI- i had installed tweakscale last night and had no issues. the ui was working perfectly. my install had beside the making history and breaking ground mods the following

Better burn time 

Real chute

Mechjeb-dev

KJR-Next

USI-LS

Tweakscale

So i don't think the problem is tweakscale

 

 

Share this post


Link to post
Share on other sites
1 hour ago, IronKerbal said:

@Lisias I would like to suggest a plugin that disables conflicting TweakScale modules Because I find that the most common fatal error is issue #34: Duplicated properties | It would be a good addon. 

This is a patching problem. And once one of these is triggered, there's no way to know what should be dissbled or not.

The simple cases are handled by TweakScale already - you will note a TweakScaleRogueDuplicate when loading crafts and savegames 'infected' that were created on a sick installment.

But there are a huge amount of different ways to bork an installment, and it's a fool's errand to try to detect each one of them in order to code a workaround. The simple ones are already coded.

However, there's only a very few ways to do things right. So it's way easier (not to mention feasible) to just scream when something weird is detected. It's what TweakScale does now.

46 minutes ago, Rafael acevedo said:

Lisias 

FYI- i had installed tweakscale last night and had no issues. the ui was working perfectly.  [Cut by me]

So i don't think the problem is tweakscale

Damn. Perhaps a new glitch on different environments? I'm running on MacOS and did that stunt to use Windows libraries to compile against, as this is what works on Unity 5 and 2017.

Thanks for the heads-up!

Share this post


Link to post
Share on other sites

I can say definitively that the interface doesn't work on Windows 10 with nothing but Stock 1.8.0 + 2 expansions + Module Manager + TweakScale.

6yY7glj.png

 

However, if you click on the janky little white box (hidden behind normal blue buttons), it does actually manage to scale parts, which can be picked up and place, and which retain their scale in the flight scene...

 

fVYtMfD.png

 

Share this post


Link to post
Share on other sites
7 minutes ago, AccidentalDisassembly said:

I can say definitively that the interface doesn't work on Windows 10 with nothing but Stock 1.8.0 + 2 expansions + Module Manager + TweakScale.

6yY7glj.png

 

However, if you click on the janky little white box (hidden behind normal blue buttons), it does actually manage to scale parts, which can be picked up and place, and which retain their scale in the flight scene...

 

fVYtMfD.png

 

I can confirm this.

%90 of the white box scales down the object

The very left %10 part of the box scales up the object.

Although you can only go between the scale presets and not fine tune the size of course.

Lisias said not to hold our breaths, but I am :D I believe the fix is near.

Share this post


Link to post
Share on other sites

That's what I got to now: I still don't now what's the problem, but I know what's not. :P

I switched .NET framework versions (from the 3.5 to every 4.x the VS allowed me). No dice.

I poked around the API, and added every possible option on KSPField to see if it would be something left uninitialised on the constructor..

-        [KSPField(isPersistant = false, guiActiveEditor = true, guiName = "Scale")]
+        [KSPField(isPersistant = false, guiActiveEditor = true, guiName = "Scale", advancedTweakable = false, category = "TS", groupDisplayName = "TS", groupName = "TS", groupStartCollapsed = false, guiActiveUnfocused = false, unfocusedRange = 1)]

Nope. The new options works, of course, but the widget is still kaput.

wQroD28.png

But the button works (the "Debug" thing).

Fooling around with the problem, I confirm the report from @AccidentalDisassembly:

3 hours ago, AccidentalDisassembly said:

I can say definitively that the interface doesn't work on Windows 10 with nothing but Stock 1.8.0 + 2 expansions + Module Manager + TweakScale.

6yY7glj.png

You know what? 

This stunt appears to be an initialization error. Something is missing when the PartModule is being instantiated, or perhaps is being done before or after ir should. The thing appears to being drawn before the code that configure the Look&Fell gets the chance to do its work, or perhaps the code is borking because it needs something to be happening, and this thing is not. 

Well, there`s no easy way out of this. I need to do my housekeeping for once. But for today, that's it - I`m awake for too much time already, I need to rest in order to do some productive, something that I'm not able for some hours already! :P At least, all of this is grunt work, one don't need to exercise his intellect (or the lack of) in order to do it, so it's not a waste of time. I will not waste good productive hours tomorrow with grunt work, this was already done. :D 

TL;DR : it appears to be something on TweakScale, indeed. And this can explain some weird issues I got to known with some Add'Ons, including on my gaming.

Well… Good night. :)

 

3 hours ago, Problemless Mods Wanter said:

Lisias said not to hold our breaths, but I am :D I believe the fix is near.

This is not the "So what song is stuck in your head today?" thread, but...

Spoiler

 

 

Edited by Lisias
Changing the video for a neutral one. :P

Share this post


Link to post
Share on other sites
6 minutes ago, Problemless Mods Wanter said:

I so wanna know what you originally posted!!!
:D

The "official" clipe, with cuts from the Movie. Technically, there were scenes that would infringe some forum rules. Search on YouTube for "tim capello i still believe", it's the first video on my last search. :D

Share this post


Link to post
Share on other sites
5 minutes ago, Lisias said:

The "official" clipe, with cuts from the Movie. Technically, there were scenes that would infringe some forum rules. Search on YouTube for "tim capello i still believe", it's the first video on my last search. :D

On that note, i gift you this song and thank you for yours;       ^.^

 

Share this post


Link to post
Share on other sites

Well. going back to topic. :D

I managed to reorganize the event handling. Not sure if for the better, but at least it wasn't for the worst. I just tested the thing, no perceptible change on the TweakScale's behaviour. Unfortunately, not on the misbehaviour neither.

It's not something I'm doing wrong (at least for this), but can still be something I'm not doing right. My next line of action is to get back to grunt work I did last night: messing up with everything I had forked in order to try to make the thing to BREAK. The moment I manage to break something the same way it's happening with TweakScale now, it will be the moment I will learn what I need to do on TweakScale.

For people willing to try their luck :sticktongue:, there's a snaphop available here. This is a SNAPSHOT, it's not even a beta release. The code is currently committed here, but it can change fast as I publish new snapshots. I will keep this. post updated.

In time, I think I found a bug on KSP? To make things faster, I dropped the Texture Quality to the lowest (1/8th), and the digits of the altimeter and stage displays are gone. Can anyone confirm this? It can be something specific for my machine's configuration.

Spoiler

67147344-8b5b9180-f26a-11e9-930b-318c65f

 

19 hours ago, Rafael acevedo said:

Lisias 

FYI- i had installed tweakscale last night and had no issues. the ui was working perfectly. my install had beside the making history and breaking ground mods the following

[cut by me]

So i don't think the problem is tweakscale

You are no fool, man. Neither the other guys that confirmed the problemon their machines. I'm pretty convinced you all are right. And these ones is where I will eventually hack my way with my merciless axe keyboard.

— — — — — 

Please, fellow Add'On Authors, can you forgive this poor Old Fart that still relies on Empiricism for trouble hunting, and then will need to fork your Projects, and them hack them, and them commit them so I can, eventually, ask people to try the stunt on their machines in order to get confirmation? I would not be allowed to do that here on Forum without committing this butchery somewhere. Thank you.

Share this post


Link to post
Share on other sites

Yes there is a bug with the altimeter. It cannot be resized under 99% without vanishing at least in my installation (stock 1.8 with only eve and KER). Happens with maximum video quality (including texture). 

Edited by DarkNounours

Share this post


Link to post
Share on other sites

I have been reluctant to pop in - but this is what has been nagging me:

did you add PAW grouping? (I like if you did) because the white triangle (arrow) says you did.

if so - could this issue be concerning PAW grouping? if so (and have only been skimming the posts) then could be as simple a that.

Share this post


Link to post
Share on other sites

Not sure if this has been resolved yet but I received a [Tweakscale] ERROR: **FATAL** message. Here is the short part...

[LOG 15:57:27.567] [TweakScale] WARNING: **FATAL** Found a showstopper problem on batteryBankMini (Z-200 Rechargeable Battery Bank).
[LOG 15:57:27.567] [TweakScale] ERROR: **FATAL** Part batteryBankMini (Z-200 Rechargeable Battery Bank) has a fatal problem due having duplicated properties - see issue [#34]( https://github.com/net-lisias-ksp/TweakScale/issues/34 ).

And here is the long part...

https://www.dropbox.com/s/n2007k1qvlpuuow/KSP_10-19-2019_1558-TWEAKSCALE-FATAL.log?dl=0

If you need me to respond back with a MM dump, please provide the command line structure. It has been quite some time and cannot recall the format for doing said dump.

Kind regards,

~G

Share this post


Link to post
Share on other sites
5 hours ago, zer0Kerbal said:

I have been reluctant to pop in - but this is what has been nagging me:

did you add PAW grouping? (I like if you did) because the white triangle (arrow) says you did.

On the "stock" TweakScape, I don't use PAW. I used on the test just to see what I could get (in the hope to see the behaviour changing). I'm flying low and on the dark here, and the altimeter is blank too!! :D

I'm just trying to figure out things as I used to do on my times as a Black Box tester for Siemens Mobile. This is, indeed, "grunt work". I'm looking on every Add'On out there that it' working, and trying to break them in order to figure out what should be done in reverse from my side. I already have some ideas about what could be happening, but not solid until the moment.

 

4 hours ago, FuzzyG said:

Not sure if this has been resolved yet but I received a [Tweakscale] ERROR: **FATAL** message. Here is the short part...

[LOG 15:57:27.567] [TweakScale] WARNING: **FATAL** Found a showstopper problem on batteryBankMini (Z-200 Rechargeable Battery Bank).

Yo, the first FATALity on the day. Let's check this log. AND WOW!! 55 MEGABYTES ! :) Good thing I handle these logs with UNIX command line tools!

[LOG 15:57:27.567] [TweakScale] WARNING: **FATAL** Found a showstopper problem on batteryBankMini (Z-200 Rechargeable Battery Bank).
[LOG 15:57:27.567] [TweakScale] ERROR: **FATAL** Part batteryBankMini (Z-200 Rechargeable Battery Bank) has a fatal problem due having duplicated properties - see issue [#34]( https://github.com/net-lisias-ksp/TweakScale/issues/34 ).

Well, just one. Confirmed. And good Lord, what a patching fest you have here!! 

Spoiler

[LOG 15:18:39.996] Applying update DeepSky/ThorTech/Patches/dstt_shieldnir/@PART:HAS[!MODULE[ModuleAblator],#category[Electrical]] to Squad/Parts/Electrical/z-200Battery/z-200Battery.cfg/PART[batteryBankMini]
[LOG 15:18:42.233] Applying update FMRS/FMRS_MM/@PART[*] to Squad/Parts/Electrical/z-200Battery/z-200Battery.cfg/PART[batteryBankMini]
[LOG 15:20:00.612] Applying update RecoveryController/RecoveryController_MM/@PART[*]:HAS[!MODULE[ModuleAnchoredDecoupler],!MODULE[ModuleDecouple],!MODULE[USDecouple]]:NEEDS[StageRecovery] to Squad/Parts/Electrical/z-200Battery/z-200Battery.cfg/PART[batteryBankMini]
[LOG 15:20:02.378] Applying update REPOSoftTech/AmpYear/MMConfigAmpYear/@PART[*]:HAS[!MODULE[KerbalEVA],!MODULE[FlagSite]]:NEEDS[AmpYear] to Squad/Parts/Electrical/z-200Battery/z-200Battery.cfg/PART[batteryBankMini]
[LOG 15:20:04.114] Applying update RN_Soviet_Rockets/RN_Soviet_Rockets_TU/@PART[*]:NEEDS[TexturesUnlimited] to Squad/Parts/Electrical/z-200Battery/z-200Battery.cfg/PART[batteryBankMini]
[LOG 15:21:34.488] Applying update TweakScale/patches/Squad/Squad_Util/@PART[batteryBankMini] to Squad/Parts/Electrical/z-200Battery/z-200Battery.cfg/PART[batteryBankMini]
[LOG 15:21:49.352] Applying update VenStockRevamp/Squad/Parts/Electrical/@PART[batteryBankMini] to Squad/Parts/Electrical/z-200Battery/z-200Battery.cfg/PART[batteryBankMini]
[LOG 15:22:29.654] Applying update DeadlyReentry/DeadlyReentry/@PART[*]:HAS[@MODULE[ModuleAblator]]:AFTER[DeadlyReentry] to Squad/Parts/Electrical/z-200Battery/z-200Battery.cfg/PART[batteryBankMini]
[LOG 15:22:43.191] Applying update FerramAerospaceResearch/_FARPartModule/@PART[*]:HAS[!MODULE[LaunchClamp]]:FOR[FerramAerospaceResearch] to Squad/Parts/Electrical/z-200Battery/z-200Battery.cfg/PART[batteryBankMini]
[LOG 15:22:49.385] Applying update FerramAerospaceResearch/_FARPartModule/@PART[*]:HAS[!MODULE[FARWingAerodynamicModel],!MODULE[FARControllableSurface]]:AFTER[FerramAerospaceResearch] to Squad/Parts/Electrical/z-200Battery/z-200Battery.cfg/PART[batteryBankMini]
[LOG 15:23:47.078] Applying update RealismOverhaul/RealismOverhaul_Global_Config/@PART[*]:HAS[~crashTolerance[>12]]:BEFORE[RealismOverhaul] to Squad/Parts/Electrical/z-200Battery/z-200Battery.cfg/PART[batteryBankMini]
[LOG 15:23:47.734] Applying update RealismOverhaul/RealismOverhaul_Global_Config/@PART[*]:HAS[~gTolerance[<50]]:BEFORE[RealismOverhaul] to Squad/Parts/Electrical/z-200Battery/z-200Battery.cfg/PART[batteryBankMini]
[LOG 15:23:48.114] Applying update RealismOverhaul/RealismOverhaul_Global_Config/@PART[*]:HAS[~maxPressure[<4000]]:BEFORE[RealismOverhaul] to Squad/Parts/Electrical/z-200Battery/z-200Battery.cfg/PART[batteryBankMini]
[LOG 15:23:48.320] Applying update RealismOverhaul/RealismOverhaul_Global_Config/@PART[*]:HAS[~breakingForce[]]:BEFORE[RealismOverhaul] to Squad/Parts/Electrical/z-200Battery/z-200Battery.cfg/PART[batteryBankMini]
[LOG 15:23:49.466] Applying update RealismOverhaul/RealismOverhaul_Global_Config/@PART[*]:HAS[!MODULE[ModuleAblator],@MODULE[ModuleHeatShield]]:BEFORE[RealismOverhaul] to Squad/Parts/Electrical/z-200Battery/z-200Battery.cfg/PART[batteryBankMini]
[LOG 15:26:09.194] Applying update RealismOverhaul/RO_SuggestedMods/Squad/RO_Squad_Electrical/@PART[batteryBankMini]:FOR[RealismOverhaul] to Squad/Parts/Electrical/z-200Battery/z-200Battery.cfg/PART[batteryBankMini]
[LOG 15:26:37.442] Applying update RealismOverhaul/RealismOverhaul_Global_Config/@PART[*]:HAS[@MODULE[ModuleAblator],!MODULE[ModuleHeatShield]]:NEEDS[DeadlyReentry]:AFTER[RealismOverhaul] to Squad/Parts/Electrical/z-200Battery/z-200Battery.cfg/PART[batteryBankMini]
[LOG 15:27:43.495] Applying update RealismOverhaul/RO_SuggestedMods/RO_RCS_Config/@PART[*]:AFTER[RO-RCS] to Squad/Parts/Electrical/z-200Battery/z-200Battery.cfg/PART[batteryBankMini]
[LOG 15:32:33.794] Applying update RealismOverhaul/RealismOverhaul_Global_Config/@PART[*]:HAS[#RSSROConfig[*],!MODULE[ModuleAeroReentry]]:NEEDS[DeadlyReentry]:FOR[zzzRealismOverhaul] to Squad/Parts/Electrical/z-200Battery/z-200Battery.cfg/PART[batteryBankMini]
[LOG 15:32:35.822] Applying update RealismOverhaul/RO_RadialEnginesAttach/@PART[*]:HAS[#node_attach[*],#attachRules[1,0,1,1,0]]:FOR[zzzRealismOverhaul] to Squad/Parts/Electrical/z-200Battery/z-200Battery.cfg/PART[batteryBankMini]
[LOG 15:32:43.310] Applying update RealismOverhaul/RealismOverhaul_Global_Config/@PART[*]:HAS[#RSSROConfig[*]]:FOR[zzzTagCleanup] to Squad/Parts/Electrical/z-200Battery/z-200Battery.cfg/PART[batteryBankMini]
[LOG 15:32:45.760] Applying update VenStockRevamp/PathPatches/Aero-PathPatches/@PART[*]:FOR[zzzVSRPathPatch] to Squad/Parts/Electrical/z-200Battery/z-200Battery.cfg/PART[batteryBankMini]
[LOG 15:32:47.732] Applying update VenStockRevamp/PathPatches/Command-PathPatches/@PART[*]:FOR[zzzVSRPathPatch] to Squad/Parts/Electrical/z-200Battery/z-200Battery.cfg/PART[batteryBankMini]
[LOG 15:32:50.276] Applying update VenStockRevamp/PathPatches/Electrical-PathPatches/@PART[*]:FOR[zzzVSRPathPatch] to Squad/Parts/Electrical/z-200Battery/z-200Battery.cfg/PART[batteryBankMini]
[LOG 15:32:53.391] Applying update VenStockRevamp/PathPatches/Engines-PathPatches/@PART[*]:FOR[zzzVSRPathPatch] to Squad/Parts/Electrical/z-200Battery/z-200Battery.cfg/PART[batteryBankMini]
[LOG 15:32:56.265] Applying update VenStockRevamp/PathPatches/FuelTanks-PathPatches/@PART[*]:FOR[zzzVSRPathPatch] to Squad/Parts/Electrical/z-200Battery/z-200Battery.cfg/PART[batteryBankMini]
[LOG 15:32:59.087] Applying update VenStockRevamp/PathPatches/Structural-PathPatches/@PART[*]:FOR[zzzVSRPathPatch] to Squad/Parts/Electrical/z-200Battery/z-200Battery.cfg/PART[batteryBankMini]
[LOG 15:33:03.243] Applying update VenStockRevamp/PathPatches/Utility-PathPatches/@PART[*]:FOR[zzzVSRPathPatch] to Squad/Parts/Electrical/z-200Battery/z-200Battery.cfg/PART[batteryBankMini]
[LOG 15:33:16.773] Applying update DeadlyReentry/DeadlyReentry/@PART[*]:HAS[@MODULE[ModuleAeroReentry],#leaveTemp[*]]:FINAL to Squad/Parts/Electrical/z-200Battery/z-200Battery.cfg/PART[batteryBankMini]
[LOG 15:33:54.096] Applying update Kopernicus/Config/SolarPanels/@PART:FINAL to Squad/Parts/Electrical/z-200Battery/z-200Battery.cfg/PART[batteryBankMini]

 

Well, historically, one of your Add'Ons triggered this FATALity in the past, but since there're so many different Add'Ons patching the battery, it's not impossible that it could be something else. Or yet, more than one at once (it happened once, got a run for my money on that one).

Let's try this first:

  • Download this file.
  • Place it somewhere on the GameData. I suggest GameData/__LOCAL/TweakScale/HotFixes but anywhere will do. Try to remember where you put it, as we may need to delete it if things doesn't work as expected.
  • Lanuch KSP and check if the FATALity is still there
    • If not, problem solved! 
    • If yes, delete the file, launch KSP again and send me both KSP.log and ModuleManager.ConfigCache - it's a new one, and I will need them to harvest a solution from these files.

Let me know in a way or another!

Edited by Lisias
some entertaining grammars made less entertaining.

Share this post


Link to post
Share on other sites
On 10/18/2019 at 3:38 PM, IronKerbal said:

@Lisias I would like to suggest a plugin that disables conflicting TweakScale modules Because I find that the most common fatal error is issue #34: Duplicated properties | It would be a good addon. 
Example: If x.cfg has Module[Tweakscale] for z part and y.cfg has Module[Tweakscale] for z part, they will confilct. 
N.dll would disable one of the tweakscale modules to prevent conficts.

Correct me if I have suggested this already

DUDE, I HAD MISREAD YOU. Since I have focused all my (mental) resources on the problem at hand, I didn't dissociated your suggestion from it. And ended up answering the wrong question!! Sorry!

YES, what you are asking would be a very important Add'On around here. It would be also one of the most difficult to maintain, as the list of "weird things" that should not be are somewhat… vast. But since usually 80% of the problems have their root on 20% of the issues, the tool wold be useful anyway -it would, at the very worst, reduce the calls for support as the tool would diagnose some problems itself.

Yes, someone had already suggested this in the past (probably you!). I remember mentioning a (dead in the water for now) idea for an Add'On called "McLisias AntiKraken" or something silly like that. :D

The hard part will be keeping the Knowledge Base of the "Krakens". I think it would be something very near what CKAN is nowadays, a discrete GITHUB repo or something with a huge list of "Receipts" about how to detect problems and how to fix once it happen. I think that Python would be a good choice for the tool, as the thing is highly dynamic and we could write that Receipts on the Python itself - we can even easily load them at runtime - not to mention that the language is way easier to cope than C#. So non developers could help writing receipts themselves. This would reduce the load of the Maintainer to curate the receipts instead of writing them.

Nice idea. And sorry by not answering it correctly on the first time!

Share this post


Link to post
Share on other sites

News from the front. Boy, this is frustrating. :D

7prlMBa.png

I found LaserDist working flawlessly. Frustrating. But then I realized that this guy had some problems with the UI_FloatRange min and max values, he commented about it on the release notes. And this matches with the behaviour I'm getting, with the widget completely shrunk as the Min and Max values would be.. Zero.  Interesting enough, LaserDist got this problem on KSP 1.7.3.

Well, apparently my grunt work gave me some results. Time to rest, and live to fight another day. :)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.