• 1
Michel Bartolone

VAB symmetry issue

Question

I checked the forums, but have not found anything similar to this. Running 1.5.1, with a bunch of mods. Upgraded KIS yesterday, and now, I attach radial decouplers with 4 way symmetry, but when I try to attach fuel tanks using the same symmetry mode, I only get 1. SRBs are still working, but not fuel tanks. I have not tried any other parts yet. Has anyone seen this?

Additional info. 2 way symmetry is partially working...I put on two radial decouplers using symmetry, I can put on two tanks, BUT the physical offset of the one on the "back" is to the connector facing the central tank instead of the outer one. If I don't use a decoupler, the tanks go where they belong. If I change to 3, 4, 6 or 8 way, the decoupler attaches to the central object (tank) just fine, but I when I attempt to attach tanks to those decouplers, I only get one tank. Also, with 3,4,6 or 8 way symmetry, even without the decouplers, I only get one.

Here is my mod list:
[x] Science! (xScience vV5.17)
ABookCase Orbital Reference System (ABCORS 0.5.0.3)
Astrogator (Astrogator v0.8.1)
AT Utils (AT-Utils v1.6.2)
AutomatedScienceSampler (AutomatedScienceSampler 1.3.5)
B9 Part Switch (B9PartSwitch v2.4.5)
BetterBurnTime (BetterBurnTime 1.7)
BetterTimeWarpContinued (BetterTimeWarpCont 2.3.10.2)
Blast Awesomeness Modifier (BAM) (BAMCont 1.3.2.3)
BurnTogether Continued (BurnTogetherContinued 0.0.7.4)
ClickThrough Blocker (ClickThroughBlocker 0.1.6.9)
Community Resource Pack (CommunityResourcePack 1.0.0.0)
Community Tech Tree (CommunityTechTree 1:3.3.3)
Configurable Containers (ConfigurableContainers 2.4.3.4)
Configurable Containers Core (ConfigurableContainers-Core 2.4.3.4)
Craft Manager (CraftManager 1.1.4)
CraftHistory (CraftHistory 2.2.1)
DarkSideTechnology Continued. (DarkSideTechnology 1.1)
DMagic Orbital Science (DMagicOrbitalScience 1.4.1)
DMModuleScienceAnimateGeneric (DMagicScienceAnimate v0.20)
Docking Port Alignment Indicator (DockingPortAlignmentIndicator 6.8.2)
Docking Port Sound FX (DockingPortSoundFX v2.1.12)
Dr. Jet's Chop Shop (ChopShop 1:0.11.4.3)
Draggable Altimeter (DraggableAltimeter v1.0.1)
Draggable Navball (DraggableNavball v1.0.1)
Easy Vessel Switch (EVS) (EasyVesselSwitch 1.9)
Editor Extensions Redux (EditorExtensionsRedux 3.3.19.9)
EVA Enhancements Continued (EVAEnhancementsContinued 0.1.13.3)
Eva Follower (EvaFollower 1.1.0.5)
EVA Struts (EVAStruts 5.0)
EVA Transfer (EVATransfer 8.1)
FASA RCS Stock-Like Mini Mod (FASA-RCS 1.3)
Firespitter Core (FirespitterCore v7.9.0)
Fuel Tank Expansion Rebuilt (MunarIndustriesFTX 0.9.6.2)
GravityTurn Continued (GravityTurnContinued 2:1.7.7)
HangerExtender (HangerExtenderExtended 3.5.3.3)
HullcamVDS Continued (HullcamVDSContinued 0.1.9.6)
Impact! (Impact v1.6.4)
Improved Chase Camera (ImprovedChaseCamera v1.6.2.1)
IndicatorLights (IndicatorLights 1.4)
Kerbal Attachment System (KAS 1.1)
Kerbal Dust Experiment (KDEX v1.11.2)
Kerbal Inventory System (KIS 1.16)
KerboKatzUtilities (KerboKatzUtilities 1.5.2)
KrakenScience (KrakenScience 0.8)
KSP AVC (KSP-AVC 1.2.0.6)
KSP ExtendedAntennaProgression (ExtendedAntennaProgression v0.1.1)
KSP Wheel (KSPWheel 0.12.10.28)
Lithobrake Exploration Technologies (LithobrakeExplorationTechnologies 0.4)
LongStrut (LongStrut 0.0.1)
MagiCore (MagiCore 1.3.1.3)
MandatoryRCS Part Pack (MandatoryRCSPartPack 1.1)
Maneuver Node Evolved (ManeuverNodeEvolved 4.0)
MechJeb 2 (MechJeb2 2.8.1.0)
MechJeb and Engineer for all! (MechJebForAll 1.3.0.4)
Module Manager (ModuleManager 3.1.0)
Navball Docking Alignment Indicator CE-2 (NavballDockAlignIndCE 1.0.4.3)
NavBallAdjustor (NavBallAdjustor 1.9)
Nehemiah Engineering Orbital Science (NehemiahEngineeringOrbitalScience 0.8.0)
Orbital Survey Plus (OrbitalSurveyPlus 2.3.6)
Patch Manager (PatchManager 0.0.16.2)
Precise Maneuver (PreciseManeuver 2:2.4.1)
QuickSearch (QuickSearch 1:3.2.1.1)
RasterPropMonitor (RasterPropMonitor 1:v0.30.5)
RasterPropMonitor Core (RasterPropMonitor-Core 1:v0.30.5)
RealChute Parachute Systems (RealChute v1.4.7.1)
SCANsat (SCANsat v18.8)
Science - Full reward! (NMSG 3.0)
Science Revisited Revisited (ScienceRevisitedRevisited 1.7.1)
Selectable Data Transmitter Module (SelectableDataTransmitter 0.1.4.2)
Settings Master (SettingsMaster 0.0.2.2)
Solar Science (SolarScience v1.06)
Space Launch System Part Pack (SpaceLaunchSystemPartPack 1.4.3.3)
Structural Disks (StructuralDisks 1.2.0.1)
Structural Tubing Restructured (StructuralTubing 1.0.7.2)
Surface Mounted Lights (surfacelights 1.9)
TakeCommandContinued (TakeCommandContinued 1.4.12.2)
Textures Unlimited (TexturesUnlimited 1.1.2.15)
Toolbar (Toolbar 1.7.17.13)
Toolbar Controller (ToolbarController 1:0.1.6.18)
Tough Love (ToughLove 0.0.1)
Tracking Station Evolved (TrackingStationEvolved 4.0)
Trajectories (Trajectories vKSP1.4.2-v2.2.0)
TweakScale - Rescale Everything! (TweakScale v2.4.0.6)
UbioZur Welding Ltd. Continued (UbioWeldContinued 2.5.3)
UNDOCKINATOR (UNDOCKINATOR v0.9.0)
Wheels Collection (formerly rollkage & better wheels)  (WheelsCollection 1.3)
WorldStabilizer (WorldStabilizer 0.9.3)

If I can figure out how to attach screen shots, I've got a few, showing I can use 2x symmetry sort of...it turns out the second tank is actually only getting attached to the same radial coupler as the first tank, the second radial coupler can have another tank (or two) attached to it separately. Attaching tanks to tanks works just fine in 2x symmetry, decouplers themselves work with 2x, 3x, 4x, 6x, and 8 x symmetry, but nothing (other than engines) will attach in any of the radial decouplers in any symmetry mode other than 2x.

 

 

I also found the following message (multiple times...a lot of multiple times) in the log:
Parameter name: index
    System.Collections.Generic.List`1[PartResource].get_Item (Int32 index)
    DictionaryValueList`2[System.Int32,PartResource].At (Int32 index)
    PartResourceList.get_Item (Int32 index)
    Part.OnCopy (.Part original, Boolean asSymCounterpart)
    EditorLogic.createSymmetry (Int32 mode, .Attachment attach)
    EditorLogic.<SetupFSM>m__D ()
    KerbalFSM.UpdateFSM ()
    EditorLogic.Update ()
[EXC 09:21:28.918] ArgumentOutOfRangeException: Argument is out of range.
 

Edited by Michel Bartolone
additional info

Share this post


Link to post
Share on other sites

5 answers to this question

Recommended Posts

  • 0

I came here looking for answers to the exact same issue.

My mods list is about 20% as long as yours, so it may help to narrow things down.

I got:

  • Near Future Everything
  • B9PartSwitch
  • DeployableEngines
  • Mk4
  • KIS
  • KAS-1.0 Beta10
  • TextureReplacer
  • Kopernicus
  • Galileo Planets
  • Universal Storage II
  • Dmagic Science
  • Scansat
  • EVE
  • Station Parts Redux
  • MKS with USI and Ground Construction
  • ASET
  • MechJeb2
  • Kerbal Atomics
  • Astrogator
  • Final Frontier
  • KSTS

I can't see anything on my own list that would mess with that find of functionality.  KAS maybe...I'll remove it and see what happens.

----

Removed KAS and everything works peachy now.

Update 2:

Did even more testing.  KAS again, for sure, is broken.  However, no issue is reported I could find on his Github or his thread.  It may be an interaction with another mod, but I couldn't figure out which without breaking my game entirely.  The only conflicting mod I know could be MKS that uses the same logic for its strut tubes, but that's not on your list.

Short term answer is no more KAS.

Edited by PolecatEZ
Found the culprit

Share this post


Link to post
Share on other sites
  • 0

I was just about to post a new topic for this issue, luckily I found this first.

I have pretty much the same mod list as OP.

Here's the output_log: output_log.txt

If KAS is really the problem, and the only solution is to unistall it, that'd be a real bummer.

Thank you in advance for your help!

Edited by Bartholomew

Share this post


Link to post
Share on other sites
  • 0

I take it back.  The bug returned even with KAS out, it just took longer to pop up in a building session.

I'm doing a full mod strip to see if its a stock problem.

Updates:

Fully stripped the game to pure stock, could not get the bug to trigger.

I have 2 more suspects on my list, Dmagic and B9 Part Switcher, also fresh game vs updated save from 1.4.5 to 1.5.1

 

Update 2:

Dmagic eliminated as a cause.  Its safe.  Ditto for KAS and KIS.

B9 Part Switcher will be fun to test.

 

Update 3:

Took out B9 part switcher, but it removed all the fuel from my stock tanks.  In hunting down the cause for that, I found and eliminated the CryoTanks folder that came from various Nertea mods.

Put B9 switcher back in.

I can no longer reproduce the bug.  I also can no longer switch fuels on the stock tanks, but that's not something I ever really used anyways.

I'll keep testing to see if its just that config script or the .dll that's the problem.

 

Update 4: Conclusion

CryoTanksFuelTankSwitcher.cfg was the source of my own issues, located in the Cryotanks/Patches folder

Its not bad per se, but it basically causes B9 Part Switcher to conflict with Squad's Stock color switcher.

I assume anything that overrides Squad stock parts by messing with their fuel may also cause this kind of issue, even if you're not using Cryotanks or Cryoengines from NFT or FFT packs.

Since taking out that patch, I've been hitting the VAB pretty hard for about an hour and haven't seen the bug reproduced.  All other mods are in and working just fine.

 

Edited by PolecatEZ
Concluded

Share this post


Link to post
Share on other sites
  • 0

Latest B9 Partswitch and 1.5 version of Nertea's Cryotanks seems to have fixed everything now also.

 

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.