Jump to content

[1.8-1.12] Ferram Aerospace Research Continued: v0.16.0.3 "Mader" 27/06/21


dkavolis
 Share

Recommended Posts

Re launching vessels from SPH/VAB compared to revert to launch, can you try FAR from dev branch? FAR was voxelizing parts too eagerly, before KSP was done with disabling unused models like engine fairings on scene changes so it was working fine on return to launch. FAR now waits for physics to kick in before voxelizing so it should no longer voxelize what you can't see.

20 hours ago, Krzeszny said:

Sorry, FARc only counts connected clamps as part of the vessel. Which is still a bug. As you said, clamps aren't for flying so FARc should ignore them. I know I can detach them when tweaking stability, but I don't see why FAR shouldn't do that by default.

Launch clamps will be mostly ignored in editor in the next release, there's still a barely noticeable effect on stability derivative values left that I'm not sure where it comes from. For now, you can use the dev branch version.

For all the other issues, please provide KSP.log, ModuleManager.ConfigCache, the affected craft file and mod list in addition to description of the problem. Ideally, open an issue on github with all of the above.

Link to comment
Share on other sites

I have noticed that it takes a lot of thrust to get some things moving on water. I was playing with a sub earlier that needed nearly 300kn to start moving, but as soon as it hit 1m/s 30kn kept it accelerating. Suggests that maybe far too much drag is being applied at low speeds.

Link to comment
Share on other sites

On 5/7/2020 at 7:15 PM, dkavolis said:

Re launching vessels from SPH/VAB compared to revert to launch, can you try FAR from dev branch? FAR was voxelizing parts too eagerly, before KSP was done with disabling unused models like engine fairings on scene changes so it was working fine on return to launch. FAR now waits for physics to kick in before voxelizing so it should no longer voxelize what you can't see.

Launch clamps will be mostly ignored in editor in the next release, there's still a barely noticeable effect on stability derivative values left that I'm not sure where it comes from. For now, you can use the dev branch version.

For all the other issues, please provide KSP.log, ModuleManager.ConfigCache, the affected craft file and mod list in addition to description of the problem. Ideally, open an issue on github with all of the above.

Does the Dev Branch work in 1.8.1?

Link to comment
Share on other sites

Having an issue with FAR on a realism overhaul game in 1.8. I launch a vessel, and after a few seconds or around 150m/s i lose control. The F3 log shows that the root part has been ripped off due to airflow. Weird as the root part remains connected and its right-click menu remains accessible. However, physics just kinda stops. My altiude is locked, my speed is 0, the apoapsis increases rapidly. There is a repeated log spam of:

Spoiler

[LOG 01:07:56.013] [FAR v0.15.11.3] Disabling FARVesselAero on command-25-landing-1 (Cerus Hop) due to no FARGeometryModules on board
[LOG 01:07:56.013] [FAR v0.15.11.3] Updating vessel voxel for Cerus Hop
[ERR 01:07:56.013] [FAR v0.15.11.3] Voxel Volume was infinity; ending voxelization

[ERR 01:07:56.015] TimingFI threw during FixedUpdate: System.ArgumentOutOfRangeException: Index was out of range. Must be non-negative and less than the size of the collection.
Parameter name: index
  at System.ThrowHelper.ThrowArgumentOutOfRangeException (System.ExceptionArgument argument, System.ExceptionResource resource) [0x00029] in <ad04dee02e7e4a85a1299c7ee81c79f6>:0
  at System.ThrowHelper.ThrowArgumentOutOfRangeException () [0x00000] in <ad04dee02e7e4a85a1299c7ee81c79f6>:0
  at FlightIntegrator.UpdateOcclusionSolar () [0x00220] in <9d71e4043e394d78a6cf9193ad011698>:0
  at FlightIntegrator.UpdateOcclusion (System.Boolean all) [0x0001c] in <9d71e4043e394d78a6cf9193ad011698>:0
  at ModularFI.ModularFlightIntegrator.UpdateOcclusion (System.Boolean all) [0x00007] in <1a5eb41924ae4dfca6d5042557592b79>:0
  at FlightIntegrator.FixedUpdate () [0x0035f] in <9d71e4043e394d78a6cf9193ad011698>:0
  at ModularFI.ModularFlightIntegrator.TimedFixedUpdate () [0x00015] in <1a5eb41924ae4dfca6d5042557592b79>:0
  at (wrapper delegate-invoke) <Module>.invoke_void()
  at TimingFI.FixedUpdate () [0x00023] in <9d71e4043e394d78a6cf9193ad011698>:0

[ERR 01:07:56.017] [FAR v0.15.11.3] Logged exception:

[EXC 01:07:56.019] KeyNotFoundException: The given key was not present in the dictionary.
    System.Collections.Generic.Dictionary`2[TKey,TValue].get_Item (TKey key) (at <ad04dee02e7e4a85a1299c7ee81c79f6>:0)
    FerramAerospaceResearch.FARAeroComponents.FARAeroSection.UpdateAeroSection (System.Single potentialFlowNormalForce, System.Single viscCrossflowDrag, System.Single diameter, System.Single flatnessRatio, System.Single hypersonicMomentForward, System.Single hypersonicMomentBackward, UnityEngine.Vector3 centroidWorldSpace, UnityEngine.Vector3 xRefVectorWorldSpace, UnityEngine.Vector3 nRefVectorWorldSpace, UnityEngine.Matrix4x4 vesselToWorldMatrix, UnityEngine.Vector3 vehicleMainAxis, System.Collections.Generic.List`1[T] moduleList, System.Collections.Generic.List`1[T] dragFactor, System.Collections.Generic.Dictionary`2[TKey,TValue] partWorldToLocalMatrixDict) (at <6338ca968c7c4c8a971a01d858e759df>:0)
    FerramAerospaceResearch.FARAeroComponents.VehicleAerodynamics.CalculateVesselAeroProperties () (at <6338ca968c7c4c8a971a01d858e759df>:0)
    FerramAerospaceResearch.FARAeroComponents.VehicleAerodynamics.CreateVoxel () (at <6338ca968c7c4c8a971a01d858e759df>:0)
    UnityEngine.DebugLogHandler:LogException(Exception, Object)
    ModuleManager.UnityLogHandle.InterceptLogHandler:LogException(Exception, Object)
    UnityEngine.Debug:LogException(Exception)
    FerramAerospaceResearch.FARUtils.FARLogger:Exception(Exception)
    FerramAerospaceResearch.FARThreading.ThreadSafeDebugLogger:Update()
[LOG 01:07:56.019] [FAR v0.15.11.3] Voxel Element CrossSection Area: 0
Std dev for smoothing: 0.5 voxel total vol: -Infinity filled vol: 0

I've posted this in a few other mod pages, however as I test further i'm becoming more sure the issue is to do with FAR. I have very limited understanding but it looks like FAR cant 'voxel' the pod from Near Future Spacecraft,  sets its voxel volume to infinite and this causes the issue. That could be a million miles off, as i said I really dont understand much! Would forcing FAR to use the parts colliders when calculating its volume solve the issue?

Here's my game log

Q

Edit: Further testing with different parts made me notice that right before the log spam commences and FARVesselAero is disabled, it appears TAC life support deletes the vessel?

Spoiler

[LOG 02:07:30.262] -INFO- Tac.LifeSupportController[FFEED154][788.88]: Vessel Modified: Cerus Module Mk2 Lo (5a13dbf3-f283-4b77-8c24-1096430f28a4)
[LOG 02:07:30.262] -INFO- Tac.LifeSupportController[FFEED154][788.88]: Deleting vessel 5a13dbf3-f283-4b77-8c24-1096430f28a4 - vessel does not exist anymore

The plot thickens.

Edit 2: Removing TAC did not resolve the issue.

 

Edited by Qwarkk
Link to comment
Share on other sites

  • 2 weeks later...

I've noticed a problem with robotic parts and FAR. They don't seem to re-voxilise properly if moved during flight, with both stock expansion parts and IR. I was trying to get a swing wing aircraft that used to work great working again, but as soon as the wings move away from the position the craft was loaded in it gets huge amounts of lateral lift and drag. i.e. if I load the craft with the wings out moving the wings to a swept position causes a massive amount of drag to appear from nowhere. If the craft is loaded with the wings swept, it's fine but moving them to the unswept position now causes huge amounts of drag.

Link to comment
Share on other sites

Nosing down is normal. It means your plane is stable. Apply some pitch trim (alt-s) to hold your pitch input at the level needed to maintain level flight.

For general trim:alt-wasdqe lets you adjust your current trim for the corresponding input, and alt-x clears trim.

 

Link to comment
Share on other sites

On 6/6/2020 at 4:06 AM, horace said:

It doesnt work with 1.9.1

What doesn't work with 1.9.1? I don't think you're talking about FAR, because I have been using it in 1.9.1 without any issues.

Link to comment
Share on other sites

On 6/9/2020 at 8:02 AM, taniwha said:

What doesn't work with 1.9.1? I don't think you're talking about FAR, because I have been using it in 1.9.1 without any issues.

the physics do work, but i dont get the button in 1.9.1

 

Link to comment
Share on other sites

1 hour ago, horace said:

the physics do work, but i dont get the button in 1.9.1

This implies you somehow didn't install FAR properly. Double check that FAR, ModularFlightIntegrator, and ModuleManager are all correctly installed. Hmm, also that KSP is not installed in ProgramFiles (not sure it's relevant here, but good practice anyway).

Link to comment
Share on other sites

7 hours ago, taniwha said:

This implies you somehow didn't install FAR properly. Double check that FAR, ModularFlightIntegrator, and ModuleManager are all correctly installed. Hmm, also that KSP is not installed in ProgramFiles (not sure it's relevant here, but good practice anyway).

It is in steam which is in Program Files x86

but also i install it correctly, with module manager and Modular Flight Intergrator

Link to comment
Share on other sites

Hi guys, just tried to install FAR to KSP 1.9 and The control surfaces aren't responding as expected from the menu. All control surfaces are deflecting different amounts, even though I've set them up as flaps/ailerons/elevators etc. Any idea what is causing this/how to fix it. Can't see anthing related in the last couple of pages, and searching only brings up control surface tutorials rather than bug fixes.

Link to comment
Share on other sites

  • 2 weeks later...

Hi,

Does somebody know if one can easily "rescale" drag in FAR? Basically, that would be dividing general drag by a number or dividing a flap drag when it's deployed.

Same question for general lift?

I ask for it because if I build an aircraft with a realistic TWR - let's say 0.3 for an airliner - it will hardly fly. Indeed, if I use some flaps with realistic size, they will strongly brake the airplane when deployed. Even with full thrust, the engines will not be able to compensate that huge drag.

Edited by Hippodingo
Link to comment
Share on other sites

17 hours ago, Hippodingo said:

Hi,

Does somebody know if one can easily "rescale" drag in FAR? Basically, that would be dividing general drag by a number or dividing a flap drag when it's deployed.

Same question for general lift?

I ask for it because if I build an aircraft with a realistic TWR - let's say 0.3 for an airliner - it will hardly fly. Indeed, if I use some flaps with realistic size, they will strongly brake the airplane when deployed. Even with full thrust, the engines will not be able to compensate that huge drag.

The problem with trying to build vehicles with realistic sizes/TWR in KSP with FAR isn't so much that there is too much drag, it's that overall the parts are much too heavy, if you look at the total mass of your airliner it will likely be much heavier than an actual airliner.

 

At least this was the case back when I was playing regularly in 1.3.1, you might want to go back to your airliner and see if you can adjust it's weight into a reasonable range and then see about adjusting down your thrust to see if it will fly reasonably. Additionally make sure you have enough wing area, this is typically hard to judge visually, a common mistake is building a large plane with too little wing area.

Edited by Akira_R
Link to comment
Share on other sites

1 hour ago, Akira_R said:

The problem with trying to build vehicles with realistic sizes/TWR in KSP with FAR isn't so much that there is too much drag, it's that overall the parts are much too heavy, if you look at the total mass of your airliner it will likely be much heavier than an actual airliner.

 

At least this was the case back when I was playing regularly in 1.3.1, you might want to go back to your airliner and see if you can adjust it's weight into a reasonable range and then see about adjusting down your thrust to see if it will fly reasonably. Additionally make sure you have enough wing area, this is typically hard to judge visually, a common mistake is building a large plane with too little wing area.

Thanks for your answer!

I don't think my plane is that heavy, it's basically an A380 replica (double deck made with NeistAir mod) and it weighs 168T without fuel - much less than a real empty A380 which weighs 277T. Do you think 168T is already too heavy for the KSP/FAR gameplay, knowing that the wing area is currently 1.14e3m²? Besides, my plane's length and width are both 70m.

Strangely, I even would have said that my plane is not heavy enough: drag is independant of weight, so if I keep same TWR and at the same time I increase plane mass, I will get more thrust without increasing drag. It would mean that my aircraft would need less throttle to compensate deployed flap drag. I know I am not considering lift here, which would of course need to be increased if I my plane's mass was higher.

Link to comment
Share on other sites

  • 2 weeks later...

I tried using the mod 'FAR v0.15.11.4' with the mod 'Trajectories v2.3.3' on KSP 1.10.0, and there is 'stuttering' during flights.
A brief look at the logs shows some sort of casting problem.

Spoiler
> InvalidCastException: Specified cast is not valid.
>   at Trajectories.FARModel.ComputeForces_Model (Vector3d airVelocity, System.Double altitude)

 

Google drive link to 'Player.log' text file.
https://drive.google.com/file/d/1xkmiGlzFhucQhzRrOH93MKGq8DGgorFp/view?usp=sharing

In my case, this is a not a pressing issue. So consider this as an FYI to others who may encounter the same problem.

I have made a post on the 'Trajectories' topic as well.

Edited by The-Grim-Sleeper
2.3.2 -> 2.3.3
Link to comment
Share on other sites

  • 2 weeks later...
On 5/8/2020 at 8:22 PM, Citizen247 said:

I have noticed that it takes a lot of thrust to get some things moving on water. I was playing with a sub earlier that needed nearly 300kn to start moving, but as soon as it hit 1m/s 30kn kept it accelerating. Suggests that maybe far too much drag is being applied at low speeds.

I too am having major issues building anything that can move under water in 1.9.1 with FAR, Like you say it's almost impossible to get it moving underwater but once it does it's like all the drag is removed and it moves normally. I read through some earlier comments that said the FAR water model was changed a while back to give it much higher drag to make it more deadly to planes landing/crashing in the sea, I guess unfortunately this means it's now impossible to make subs. I've looked through the config and can't find anything that appears to address the drag model in water. If anyone know a work around other than just not using FAR for underwater shenanigans please let me know!

Link to comment
Share on other sites

17 minutes ago, ss8913 said:

does the current version work in 1.10?  didn't see any posts about that, but, there are a lot to look through...

Seems to work fine.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...