Jump to content

[1.8-1.12] Ferram Aerospace Research Continued: v0.16.0.5 "Mader" 03/04/22


dkavolis
 Share

Recommended Posts

Not sure if this is actually a FAR issue/solution, but I have been having constant yellow slow mode issues. I Decided to have a look at the console and seeing constant part voxelization spam related to the new circular panels. Same behavior with small and big crafts. 

Solution: I went to settings from main menu and turned off "verbose logging". Voilà, massive crafts launch smoothly and only occasionally flash yellow. Haven't yet checked real numbers, but launches seem proceed at about double (mission time vs. real time elapsed). Console also seems to  be clear of spurious messages.

So the lesson is try to remember to turn off debugging tools once the mods are playing nicely and no longer needed.:sealed:

Link to comment
Share on other sites

  • 2 weeks later...

So it seems like my game doesn't have any aerodynamics at all. I think it worked fine earlier.

I downloaded some basic mods for the latest 1.12.2 version and then tested the game. It worked just fine and FAR was one of those mods. After a few hours I downloaded a whole bunch of other mods and tried testing it again. It seemed to be working fine until I started reentry and realized I wasn't slowing down at all! The reentry heat was there, my ablator was tearing up just like normal but I had no drag. So I tested launching an airplane and this is what I found out with the F12 overlay:

?imw=1024&imh=576&ima=fit&impolicy=Lette

No drag, no lift, nothing...

So before I start digging through GameData for hours I thought I'd ask if there's any known incompatibility that may cause this. This is my mod folder:

tsG729o.png

Edited by lodiped
Link to comment
Share on other sites

17 hours ago, lodiped said:

 

So before I start digging through GameData for hours I thought I'd ask if there's any known incompatibility that may cause this. This is my mod folder:

It is hard to tell for me just on the first sight if there is something wrong. It seems to be fine, however, it is always possible that some 3rd party moded parts does not have proper FAR data for wings (similar thing happened with APP mod in past, you can look back in this tread for more info abut it). You can find somewhere buried in this thread custom MM patch that marks incomplete parts for FAR if you already don't have this.

You have "Custom_FARAeroData.cfg" file, though, that is unknown what it does. KSP.log file may reveal much more what went wrong. It will be much easier for anyone to help you with log file.

 

Link to comment
Share on other sites

On 9/3/2021 at 4:04 PM, kcs123 said:

You have "Custom_FARAeroData.cfg" file, though, that is unknown what it does. KSP.log file may reveal much more what went wrong. It will be much easier for anyone to help you with log file.

 

wait so I'm not supposed to have this "Custom_FARAeroData.cfg" in my folder?

Link to comment
Share on other sites

10 hours ago, lodiped said:

wait so I'm not supposed to have this "Custom_FARAeroData.cfg" in my folder?

Well, there is "CustomFARAeroData.cfg" within "FerramAerospaceResearch" folder that is shiped with FAR. You have "Custom_FARAeroData.cfg" file in main GameData folder that is certainly not shiped with FAR. Note a slightly different file name.

You got this file most probably from some other mod, I can only guess. Should you need that file or not, depends what is written in that file. It might be that some mod require it, but also may be a case of badly written patch that cause your issues. Hard to tell just from picture.

EDIT:

Well, it would more precise answer that there was "CustomFARAeroData.cfg" within "FerramAerospaceResearch" folder with older FAR versions. I don't know if it is shiped with latest releases or it is maybe autogenerated on the first run of KSP with FAR. I no longer recall and can't check with latest KSP, so take that with grain of salt. But, I'm 99% certain that your file in gamedata folder is not part of official FAR.

Edited by kcs123
Link to comment
Share on other sites

5 hours ago, kcs123 said:

You got this file most probably from some other mod, I can only guess. Should you need that file or not, depends what is written in that file. It might be that some mod require it, but also may be a case of badly written patch that cause your issues. Hard to tell just from picture.

This is what's in it:

@FARAeroData:FOR[FerramAerospaceResearch]
{
	%massPerWingAreaSupported = 0.040000000000000001
	%massStressPower = 0.84999999999999998
	%ctrlSurfTimeConstant = 0.25
	%ctrlSurfTimeConstantFlap = 10
	%ctrlSurfTimeConstantSpoiler = 0.75
	!BodyAtmosphericData,*
	{
	}
	BodyAtmosphericData
	{
		index = 0
		viscosityAtReferenceTemp = 1.7893999999999998E-05
		referenceTemp = 288
	}
	BodyAtmosphericData
	{
		index = 1
		viscosityAtReferenceTemp = 2.0000000000000002E-05
		referenceTemp = 288
	}
	BodyAtmosphericData
	{
		index = 2
		viscosityAtReferenceTemp = 1.7893999999999998E-05
		referenceTemp = 288
	}
	BodyAtmosphericData
	{
		index = 3
		viscosityAtReferenceTemp = 1.7893999999999998E-05
		referenceTemp = 288
	}
	BodyAtmosphericData
	{
		index = 4
		viscosityAtReferenceTemp = 1.7893999999999998E-05
		referenceTemp = 288
	}
	BodyAtmosphericData
	{
		index = 5
		viscosityAtReferenceTemp = 6.9999999999999994E-05
		referenceTemp = 194.5
	}
	BodyAtmosphericData
	{
		index = 6
		viscosityAtReferenceTemp = 6.9999999999999994E-05
		referenceTemp = 194.5
	}
	BodyAtmosphericData
	{
		index = 7
		viscosityAtReferenceTemp = 1.7893999999999998E-05
		referenceTemp = 288
	}
	BodyAtmosphericData
	{
		index = 8
		viscosityAtReferenceTemp = 8.6378063581472534E-06
		referenceTemp = 288
	}
	BodyAtmosphericData
	{
		index = 9
		viscosityAtReferenceTemp = 1.7893999999999998E-05
		referenceTemp = 288
	}
	BodyAtmosphericData
	{
		index = 10
		viscosityAtReferenceTemp = 1.7893999999999998E-05
		referenceTemp = 288
	}
	BodyAtmosphericData
	{
		index = 11
		viscosityAtReferenceTemp = 1.7893999999999998E-05
		referenceTemp = 288
	}
	BodyAtmosphericData
	{
		index = 12
		viscosityAtReferenceTemp = 1.7893999999999998E-05
		referenceTemp = 288
	}
	BodyAtmosphericData
	{
		index = 13
		viscosityAtReferenceTemp = 1.7893999999999998E-05
		referenceTemp = 288
	}
	BodyAtmosphericData
	{
		index = 14
		viscosityAtReferenceTemp = 1.7893999999999998E-05
		referenceTemp = 288
	}
	BodyAtmosphericData
	{
		index = 15
		viscosityAtReferenceTemp = 1.7893999999999998E-05
		referenceTemp = 288
	}
	BodyAtmosphericData
	{
		index = 16
		viscosityAtReferenceTemp = 1.7893999999999998E-05
		referenceTemp = 288
	}
}

I don't know much about how FAR works but could these numbers mean much in relation to the "no drag" situation I mentioned?

Link to comment
Share on other sites

3 hours ago, lodiped said:

This is what's in it:

(snip)

I don't know much about how FAR works but could these numbers mean much in relation to the "no drag" situation I mentioned?

That looks like legit FAR config file, but for some reason is in unusual folder. I can only guess (and probably others) what is happening without log files. It could be conflict with other FAR config files and cause issues. Without logs that can tell much more what is going on, you can try to delete that file, uninstall FAR, delete "FerramAerospaceResearch" folder and install FAR again. If that does not help, provide log file, so that someone be able to help you.

Link to comment
Share on other sites

This Mod causes me to not be able to enter VAB/SPH

I don't know If anyone is getting this problem but this mod causes me to no be able to enter the VAB /SPH or launch directly from the runway or pad from the screen you first load into the game.

I can also enter the astronaut complex but I cant exit it. I have this mod installed using CKAN, I have 70 mods installed on CKAN and have narrowed it down to this one,

I want to use this mod because its apart of realism overhaul, although for now I have to manually remove this mod from the GameData folder.  Im also running the latest version of KSP   1.12.2

I have also verified the intergrity of the game files many times and for some reason there are always some files that are missing and need to be replaced after playing the game, although I dont think its anything critical.   

Any ideas?

And Im also wondering if this mod is even nessesarry anymore because the game had received updates when it comes to aerodynamics.

Edit: I also uninstalled realism overhaul because It changed the size of many parts when I would rather change it to a realistic size with tweakscale so Im not planning to use FAR anymore even if the problem gets resolved.

Edited by Pennywise9492
Link to comment
Share on other sites

On 9/5/2021 at 3:51 PM, kcs123 said:

That looks like legit FAR config file, but for some reason is in unusual folder. I can only guess (and probably others) what is happening without log files. It could be conflict with other FAR config files and cause issues. Without logs that can tell much more what is going on, you can try to delete that file, uninstall FAR, delete "FerramAerospaceResearch" folder and install FAR again. If that does not help, provide log file, so that someone be able to help you.

Just an update: I deleted the mod and that particular cfg file and played a little with stock aero. The next day I reinstalled FAR and it just worked. I tried replicating the flight I noticed the bug but I wasn't able to. So... yeah. Weird but alright, it's perfect now.

Link to comment
Share on other sites

5 hours ago, Pennywise9492 said:

This Mod causes me to not be able to enter VAB/SPH

I don't know If anyone is getting this problem but this mod causes me to no be able to enter the VAB /SPH or launch directly from the runway or pad from the screen you first load into the game.

I can also enter the astronaut complex but I cant exit it. I have this mod installed using CKAN, I have 70 mods installed on CKAN and have narrowed it down to this one,

I want to use this mod because its apart of realism overhaul, although for now I have to manually remove this mod from the GameData folder.  Im also running the latest version of KSP   1.12.2

I have also verified the intergrity of the game files many times and for some reason there are always some files that are missing and need to be replaced after playing the game, although I dont think its anything critical.   

Any ideas?

And Im also wondering if this mod is even nessesarry anymore because the game had received updates when it comes to aerodynamics.

Just came here to post that I am having the exact same issue. 

 

I install it, and start up a new sandbox game and cannot enter the VAB or SPH. I quit, uninstall FAR, and then start a new sandbox game and everything is fine. Quit again, and install FAR again to doublecheck and I can't enter the VAB or SPH

 

Before I do any serious digging I figured I would first post about this to see if anybody else has experienced it. I definitely didn't have the issue in KSP 1.11. 

 

Also, this is a completely fresh install of KSP. When I decided to finally move to the latest version, I installed it and then went and installed all of my mods over again, confirming compatibility first of each of them with 1.12.

 

 

Edited by Hudsonkm
Link to comment
Share on other sites

So.... Was looking at the debugger, and eventually saw something which led me to try uninstalling Kronometer. Restarted the game and could once again enter the VAB and SPH, and leave the astronaut complex. The problem did not happen when Kronometer was installed WITHOUT FAR, but the two of them together at least in my case seemed to be causing the issue.  These strange FAR toolbar errors only would happen in my install when both are installed.  Once I uninstalled Kronometer I didn't see these errors in the console.

I am not even sure if these errors should even be causing the problem? Somebody that knows more about this may have a better idea of what is going on. These errors do not show when I click on VAB or SPH and try to enter but cant. They pop up when I enter the astronaut complex and try to leave back to the KSC.

But yeah, they only show up with both Kronometer and FAR installed... At least in my case.

 

vqufc7p.jpeg

 

Edited by Hudsonkm
Link to comment
Share on other sites

18 hours ago, Pennywise9492 said:

 

I don't know If anyone is getting this problem but this mod causes me to no be able to enter the VAB /SPH or launch directly from the runway or pad from the screen you first load into the game.

 

14 hours ago, Hudsonkm said:

Just came here to post that I am having the exact same issue. 

Check previous page. Most likely you don't have Toolbar controler properly installed. Double check if you have all dependency properly installed.

If that does not help, provide log files, it is hard to help anyone without it.

 

 

Link to comment
Share on other sites

21 minutes ago, kcs123 said:

 

Check previous page. Most likely you don't have Toolbar controler properly installed. Double check if you have all dependency properly installed.

If that does not help, provide log files, it is hard to help anyone without it.

 

Alright will try that! TY for the info.

Edited by Hudsonkm
Link to comment
Share on other sites

  • 2 weeks later...

Hello,

I have built a stock replica of a Bf 109. It flies fantastic, however, I want to test it out with realistic aerodynamics. My airplane relies heavily on KAL-1000 to automatically adjust trim and to spin up the engine in a realistic manner. When I install FAR, my code for elevon deploy angle and RPM/Torque for the engine disappears from KAL-1000. Moreover, the option to assign deployment angle to KAL-1000 in the action group menu is not visible, nor is it visible upon right clicking the control surface. When FAR is uninstalled, the code reappears in KAL-1000.

I tried conducting a search regarding this issue, but nothing turned up. Can you help me out please?

Link to comment
Share on other sites

  • 2 weeks later...
On 9/26/2021 at 1:07 PM, LiudvikasLTU said:

Hello,

I have built a stock replica of a Bf 109. It flies fantastic, however, I want to test it out with realistic aerodynamics. My airplane relies heavily on KAL-1000 to automatically adjust trim and to spin up the engine in a realistic manner. When I install FAR, my code for elevon deploy angle and RPM/Torque for the engine disappears from KAL-1000. Moreover, the option to assign deployment angle to KAL-1000 in the action group menu is not visible, nor is it visible upon right clicking the control surface. When FAR is uninstalled, the code reappears in KAL-1000.

I tried conducting a search regarding this issue, but nothing turned up. Can you help me out please?

I'm not a very expert on FAR (I tried in the past, but not using it recently):
if FAR still patches wings, ailerons and aerodynamic parts like in the past, it could be very likely the fact that it removes a lot of the stock "deflecting" modules, change them to its own.

So, with FAR installed, it could be that KAL-1000 cannot recognize the FAR modules related to deflection.
(It's just an educated guess, as said I do not have FAR in my game, recently)

Link to comment
Share on other sites

  • 3 weeks later...

New Realism Overhaul RP1 install following the RO RP1 guide. No additional mods. Atmospheric viscosity seems to have not loaded correctly leading to an absence of drag, lift etc. In game it shows as 0.00002 whereas at 288K it should be more like 1.17894? Ive fed back this issue on the RO thread and let them know Ive done the same here. I used the debug tool to manually adjust viscosity and it works fine now. I mention this in case of others who might have similar issues.

 

Edited by Sunscreen
update
Link to comment
Share on other sites

Not sure if this is a FAR problem or if its something I'm doing on my part but I get this error everytime I try to use OPT parts with the FAR mod. 

 

Spoiler

Resource System Error: Resource id 197105542 does not exist in part
 
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 35)

NullReferenceException: Object reference not set to an instance of an object
  at FerramAerospaceResearch.FARGUI.FARFlightGUI.PhysicsCalcs.CalculateEngineAndIntakeBasedParameters (System.Double vesselSpeed) [0x0012e] in <5703ae4062a541a09eeee98e1716f5d5>:0 
  at FerramAerospaceResearch.FARGUI.FARFlightGUI.PhysicsCalcs.UpdatePhysicsParameters () [0x00081] in <5703ae4062a541a09eeee98e1716f5d5>:0 
  at FerramAerospaceResearch.FARGUI.FARFlightGUI.FlightGUI.FixedUpdate () [0x00009] in <5703ae4062a541a09eeee98e1716f5d5>:0 
UnityEngine.DebugLogHandler:Internal_LogException(Exception, Object)
UnityEngine.DebugLogHandler:LogException(Exception, Object)
ModuleManager.UnityLogHandle.InterceptLogHandler:LogException(Exception, Object)
UnityEngine.Logger:LogException(Exception, Object)
UnityEngine.Debug:CallOverridenDebugHandler(Exception, Object)
 
(Filename: <5703ae4062a541a09eeee98e1716f5d5> Line: 0)

0x00007FFD030521FD (UnityPlayer) UnityMain
0x00007FFD0304FED5 (UnityPlayer) UnityMain
0x00007FFD03271279 (UnityPlayer) PAL_Thread_YieldExecution
0x0000022CA013BE4A (Mono JIT Code) (wrapper managed-to-native) UnityEngine.Mesh:Internal_Create (UnityEngine.Mesh)
0x0000022CA013BDBB (Mono JIT Code) UnityEngine.Mesh:.ctor ()
0x0000022CA013B823 (Mono JIT Code) TMPro.TextMeshProUGUI:Awake ()
0x0000022C8E72DB70 (Mono JIT Code) (wrapper runtime-invoke) object:runtime_invoke_void__this__ (object,intptr,intptr,intptr)
0x00007FFD19B2BC80 (mono-2.0-bdwgc) mono_get_runtime_build_info
0x00007FFD19AB1D92 (mono-2.0-bdwgc) mono_perfcounters_init
0x00007FFD19ABAD8F (mono-2.0-bdwgc) mono_runtime_invoke
0x00007FFD031DB19D (UnityPlayer) PAL_Thread_YieldExecution
0x00007FFD031D871A (UnityPlayer) PAL_Thread_YieldExecution
0x00007FFD031D87DE (UnityPlayer) PAL_Thread_YieldExecution
0x00007FFD031FE4B5 (UnityPlayer) PAL_Thread_YieldExecution
0x00007FFD031BCFB0 (UnityPlayer) PAL_Thread_YieldExecution
0x00007FFD031BC1AD (UnityPlayer) PAL_Thread_YieldExecution
0x00007FFD031BC50C (UnityPlayer) PAL_Thread_YieldExecution
0x00007FFD03210BDB (UnityPlayer) PAL_Thread_YieldExecution
0x00007FFD02F7A8CE (UnityPlayer) UnityMain
0x00007FFD02F7AF39 (UnityPlayer) UnityMain
0x00007FFD03238C18 (UnityPlayer) PAL_Thread_YieldExecution
0x0000022CA015861A (Mono JIT Code) (wrapper managed-to-native) UnityEngine.Object:Internal_CloneSingle (UnityEngine.Object)
0x0000022CA0158483 (Mono JIT Code) UnityEngine.Object:Instantiate<T_REF> (T_REF)
0x0000022F01EECDE3 (Mono JIT Code) TextMeshQueue/TextMeshQueueItem:AddLine (string)
0x0000022F01EECBC3 (Mono JIT Code) TextMeshQueue:AddLine (string)
0x0000022F05E76243 (Mono JIT Code) KSP.UI.Screens.DebugToolbar.DebugScreenConsole:OnMemoryLogUpdated (string)
0x0000022CA0198051 (Mono JIT Code) KSPLog:LogToMemory (string,string,UnityEngine.LogType)
0x0000022CA0197DD3 (Mono JIT Code) (wrapper delegate-invoke) <Module>:invoke_void_string_string_LogType (string,string,UnityEngine.LogType)
0x0000022CA0180CEC (Mono JIT Code) KSPLog:LogCallback (string,string,UnityEngine.LogType)
0x0000022CA0180AFC (Mono JIT Code) UnityEngine.Application:CallLogCallback (string,string,UnityEngine.LogType,bool)
0x0000022CA0180BC3 (Mono JIT Code) (wrapper runtime-invoke) <Module>:runtime_invoke_void_object_object_int_byte (object,intptr,intptr,intptr)
0x00007FFD19B2BC80 (mono-2.0-bdwgc) mono_get_runtime_build_info
0x00007FFD19AB1D92 (mono-2.0-bdwgc) mono_perfcounters_init
0x00007FFD19ABAD8F (mono-2.0-bdwgc) mono_runtime_invoke
0x00007FFD031DB19D (UnityPlayer) PAL_Thread_YieldExecution
0x00007FFD031D871A (UnityPlayer) PAL_Thread_YieldExecution
0x00007FFD031D592E (UnityPlayer) PAL_Thread_YieldExecution
0x00007FFD0317DA0F (UnityPlayer) PAL_Thread_YieldExecution
0x00007FFD0362BFF5 (UnityPlayer) PAL_Memory_Free
0x00007FFD0362BE67 (UnityPlayer) PAL_Memory_Free
0x00007FFD03220C72 (UnityPlayer) PAL_Thread_YieldExecution
0x0000022CA00F99BE (Mono JIT Code) (wrapper managed-to-native) UnityEngine.DebugLogHandler:Internal_Log (UnityEngine.LogType,UnityEngine.LogOption,string,UnityEngine.Object)
0x0000022CA00F96BB (Mono JIT Code) UnityEngine.DebugLogHandler:LogFormat (UnityEngine.LogType,UnityEngine.Object,string,object[])
0x0000022CAFAC3887 (Mono JIT Code) ModuleManager.UnityLogHandle.InterceptLogHandler:LogFormat (UnityEngine.LogType,UnityEngine.Object,string,object[])
0x0000022CA00F9490 (Mono JIT Code) UnityEngine.Logger:Log (UnityEngine.LogType,object)
0x0000022CA00F91FA (Mono JIT Code) UnityEngine.Debug:Log (object)
0x0000022F92517123 (Mono JIT Code) KerbalEngineer.VesselSimulator.Simulation:CalculateRCS (double,bool)
0x0000022F9250BC03 (Mono JIT Code) KerbalEngineer.VesselSimulator.Simulation:RunSimulation (KerbalEngineer.LogMsg)
0x0000022F9250AF43 (Mono JIT Code) KerbalEngineer.VesselSimulator.SimManager:RunSimulation (object)
0x0000022F9250AE09 (Mono JIT Code) System.Threading.QueueUserWorkItemCallback:WaitCallback_Context (object)
0x0000022CAFAC7536 (Mono JIT Code) System.Threading.ExecutionContext:RunInternal (System.Threading.ExecutionContext,System.Threading.ContextCallback,object,bool)
0x0000022CAFAC733B (Mono JIT Code) System.Threading.ExecutionContext:Run (System.Threading.ExecutionContext,System.Threading.ContextCallback,object,bool)
0x0000022F9250AD23 (Mono JIT Code) System.Threading.QueueUserWorkItemCallback:System.Threading.IThreadPoolWorkItem.ExecuteWorkItem ()
0x0000022CB0B6C922 (Mono JIT Code) System.Threading.ThreadPoolWorkQueue:Dispatch ()
0x0000022CB0B6C103 (Mono JIT Code) System.Threading._ThreadPoolWaitCallback:PerformWaitCallback ()
0x0000022CB0B6C30D (Mono JIT Code) (wrapper runtime-invoke) <Module>:runtime_invoke_bool (object,intptr,intptr,intptr)
0x00007FFD19B2BC80 (mono-2.0-bdwgc) mono_get_runtime_build_info
0x00007FFD19AB1D92 (mono-2.0-bdwgc) mono_perfcounters_init
0x00007FFD19AD8BA1 (mono-2.0-bdwgc) mono_threads_set_shutting_down
0x00007FFD19ADB221 (mono-2.0-bdwgc) mono_threads_set_shutting_down
0x00007FFD19AD57D8 (mono-2.0-bdwgc) mono_threads_set_shutting_down
0x00007FFD19AD5566 (mono-2.0-bdwgc) mono_threads_set_shutting_down
Resource System Error: Resource id 197105542 does not exist in part
 
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 35)

NullReferenceException: Object reference not set to an instance of an object
  at FerramAerospaceResearch.FARGUI.FARFlightGUI.PhysicsCalcs.CalculateEngineAndIntakeBasedParameters (System.Double vesselSpeed) [0x0012e] in <5703ae4062a541a09eeee98e1716f5d5>:0 
  at FerramAerospaceResearch.FARGUI.FARFlightGUI.PhysicsCalcs.UpdatePhysicsParameters () [0x00081] in <5703ae4062a541a09eeee98e1716f5d5>:0 
  at FerramAerospaceResearch.FARGUI.FARFlightGUI.FlightGUI.FixedUpdate () [0x00009] in <5703ae4062a541a09eeee98e1716f5d5>:0 
UnityEngine.DebugLogHandler:Internal_LogException(Exception, Object)
UnityEngine.DebugLogHandler:LogException(Exception, Object)
ModuleManager.UnityLogHandle.InterceptLogHandler:LogException(Exception, Object)
UnityEngine.Logger:LogException(Exception, Object)
UnityEngine.Debug:CallOverridenDebugHandler(Exception, Object)
 
(Filename: <5703ae4062a541a09eeee98e1716f5d5> Line: 0)

0x00007FFD4CD47034 (KERNEL32) BaseThreadInitThunk
0x00007FFD4CFC2651 (ntdll) RtlUserThreadStart

========== END OF STACKTRACE ===========

A crash has been intercepted by the crash handler. For call stack and other details, see the latest crash report generated in:
 * C:/Users/Damai/AppData/Local/Temp/Squad/Kerbal Space Program/Crashes
Resource System Error: Resource id 197105542 does not exist in part
 
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 35)

NullReferenceException: Object reference not set to an instance of an object
  at FerramAerospaceResearch.FARGUI.FARFlightGUI.PhysicsCalcs.CalculateEngineAndIntakeBasedParameters (System.Double vesselSpeed) [0x0012e] in <5703ae4062a541a09eeee98e1716f5d5>:0 
  at FerramAerospaceResearch.FARGUI.FARFlightGUI.PhysicsCalcs.UpdatePhysicsParameters () [0x00081] in <5703ae4062a541a09eeee98e1716f5d5>:0 
  at FerramAerospaceResearch.FARGUI.FARFlightGUI.FlightGUI.FixedUpdate () [0x00009] in <5703ae4062a541a09eeee98e1716f5d5>:0 
UnityEngine.DebugLogHandler:Internal_LogException(Exception, Object)
UnityEngine.DebugLogHandler:LogException(Exception, Object)
ModuleManager.UnityLogHandle.InterceptLogHandler:LogException(Exception, Object)
UnityEngine.Logger:LogException(Exception, Object)
UnityEngine.Debug:CallOverridenDebugHandler(Exception, Object)
 
(Filename: <5703ae4062a541a09eeee98e1716f5d5> Line: 0)
 

Any help would be greatly appreciated. I have the OPT Config file installed.

Edited by Lightlaw
Link to comment
Share on other sites

After uninstalling FAR all options for pitch, yaw, roll have been removed from my game. right clicking on any control surfaces  in VAB/SPH show's no options for Pitch, Yaw or Roll, all evalons act as regular parts with no movement. Tried uninstalling all mods and problems remains. It seems when you remove FAR it takes as much of your game with it as it can.

Link to comment
Share on other sites

5 hours ago, M_11 said:

After uninstalling FAR all options for pitch, yaw, roll have been removed from my game. right clicking on any control surfaces  in VAB/SPH show's no options for Pitch, Yaw or Roll, all evalons act as regular parts with no movement. Tried uninstalling all mods and problems remains. It seems when you remove FAR it takes as much of your game with it as it can.

Try removing all the control surfaces from one of your craft (I suggest choosing the simplest!), saving the craft, reloading it, and then replacing the the control surfaces. I know that's a nuisance, but I believe it will fix the problem. (You may find that craft you haven't touched since installing FAR will still be OK.)

(You may be able to edit the craft files using a text editor, but I'd have to look up the changes needed, and I am short on time. Perhaps somebody else could advise?)

Q: Why? A: FAR replaces the stock control-surface modules normally attached to parts in a craft, and replaces them with its own; uninstalling FAR doesn't remove the FAR control-surface modules in existing craft, nor replace them with the stock modules - hence the game can no longer recognize the parts as control surfaces, and the need to replace them with shiny new parts from the parts catologue.

Link to comment
Share on other sites

  • 3 weeks later...

so, odd issue, air doesn't.. work.. on eve.. works on kerbin and on duna.. on eve I'm getting the heat and the explosions, but absolutely no aero drag, and the reynolds number shows as "infinity"; what would I be looking for in the logs here that might explain it?  I'll paste logs but I don't want to spew irrelevant garbage in here, if someone has any idea of what to look for, that'd be helpful :)

Link to comment
Share on other sites

14 hours ago, ss8913 said:

so, odd issue, air doesn't.. work.. on eve.. works on kerbin and on duna.. on eve I'm getting the heat and the explosions, but absolutely no aero drag, and the reynolds number shows as "infinity"; what would I be looking for in the logs here that might explain it?  I'll paste logs but I don't want to spew irrelevant garbage in here, if someone has any idea of what to look for, that'd be helpful :)

The best way to post logs is to save them to a freebie fileserver, and then post the link. I prefer Dropbox. It gets around that appalling mass of text that can destroy the format of a forum page! OK, you need to sign up for an account, but Dropbox are a pretty responsible company and I have had no issues. The service is free for small-scale users, and as such it's ideal for those of us who occasionally need to send log files!

Link to comment
Share on other sites

8 hours ago, softweir said:

The best way to post logs is to save them to a freebie fileserver, and then post the link. I prefer Dropbox. It gets around that appalling mass of text that can destroy the format of a forum page! OK, you need to sign up for an account, but Dropbox are a pretty responsible company and I have had no issues. The service is free for small-scale users, and as such it's ideal for those of us who occasionally need to send log files!

so y'all want to see the *entire* log, not just certain relevant parts?  anyone had an issue like this before?  I've been using FAR almost since I started playing KSP in 2013 and haven't had an issue like this...

Link to comment
Share on other sites

15 minutes ago, ss8913 said:

so y'all want to see the *entire* log, not just certain relevant parts?  anyone had an issue like this before?  I've been using FAR almost since I started playing KSP in 2013 and haven't had an issue like this...

so, looking back in the log, there's nothing between the time the craft entered Eve's atmosphere and the time it exploded except for FAR's normal "voxel smoothing" messages.  Should I set the loglevel from info to debug to get more?  the FarAero config files look reasonable (I think) - anything to check for in there, any in-game settings to look for?  maybe just try it again?

Link to comment
Share on other sites

1 hour ago, ss8913 said:

so y'all want to see the *entire* log, not just certain relevant parts?  anyone had an issue like this before?  I've been using FAR almost since I started playing KSP in 2013 and haven't had an issue like this...

It's not my mod, but hypothetically speaking I would want the entire log; the crucial details aren't always the most obvious except to the creator of the code, and editing down a log might leave them out. In a previous time of my life I had to argue most sternly with a user to get a full log, and when I did I immediately saw the important detail he had thought irrelevant!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...