Sign in to follow this  

Recommended Posts

So I was going through some older mods looking for interesting things to use with stock texture switching. And I came across this awesome old ESTES parachute pack by  Narhiril . I thought it would be perfect to set up texture switching so they are all available in one part for the Mk16 chute. The mod was last updated for V-1.2.0  . This is basically just a texture pack the chutes work fine and the textures are in dds format but I get this effect in the game.MbT1O3b.png I think I have seen this before does anyone know what needs to be changed on the texture sheet to fix this ? I assume it's some layer that needs to have transparency value or a colour change to fix the problem? I'M completely incompetent when it comes to artwork or working with textures. I am also handicapped by being on Linux with Gimp "sorry" no Photoshop. I was hoping its something easy I can do by just clicking a layer and changing a value or something ? If any of you texture gurus know what I need to do I would appreciate it. If not no problems I wouldn’t expect anyone to spend any time on the problem . this was just something I was going to do for myself and if there isn’t a easy fix I'm certainly not going to.   "Thanks"       

Edited by Delbrutis

Share this post


Link to post
Share on other sites

From what I can see in your pic, everything is being rendered correctly with the exception of the bits that should be transparent so,  I strongly suspect this a shader issue rather than texture. You most likely just need to ensure that "shader = KSP/Alpha/Cutoff Bumped" is applied to the chute, which you can do inside the variant section of the config I believe from looking at other stock parts with variants. I've had similar issues when trying to adapt the stock chutes to use textures unlimited shaders.

Share this post


Link to post
Share on other sites
39 minutes ago, Manwith Noname said:

From what I can see in your pic, everything is being rendered correctly with the exception of the bits that should be transparent so,  I strongly suspect this a shader issue rather than texture. You most likely just need to ensure that "shader = KSP/Alpha/Cutoff Bumped" is applied to the chute, which you can do inside the variant section of the config I believe from looking at other stock parts with variants. I've had similar issues when trying to adapt the stock chutes to use textures unlimited shaders.

Thank,s That was the original stand alone part. I was going to try and fix the issue before I played with setting up the variant,s. Still might be the problem? I can try adding that to the original config and see if it helps. Oh and speaking of shaders  I love your recolouring mod Thanks for the suggestion and taking the time to reply.   

Edited by Delbrutis

Share this post


Link to post
Share on other sites

Alrighty. I've downloaded the mod, put it in my install and loaded the game. For me, the chutes work and display correctly without any changes, well, the one I tried which was the "red" one based on what I saw in your screenshot. I guess that something you have installed is interfering with them. My first hunch would be anything that is capable of modifying textures and shaders like Textures Unlimited or one of the many Texture Replacers. Do you have TU configs other than TURD?

Share this post


Link to post
Share on other sites

That's Interesting Because I took that screen shot in a completely stock install ? It was a game instance I was using for testing ? I suppose I might have missed deleting a part pack but I am 100% sure it was a clean copy without ever using TU or any configs ? I'm away from my gaming rig at work but I'll check it on a totally clean install and see what's going on when I get time. I run under Linux and my batch launcher uses  -force-glcore   Taskset and a bunch of other parameters to optimize the game. Did you test with TU installed and are you windows with DX11 or Glcore? Seems like I remember seeing this chute cord bug before ? I wonder if its a Linux thing?  Thank's for looking into it! Really appreciate it. I'll  do a clean install and try out the fix you posted above  when I get a chance probably this Weekend. And thanks again for taking the time to respond.    

 

Edited by Delbrutis

Share this post


Link to post
Share on other sites

So I re-downloaded the file to make sure I had the right version and I tested it in four different totally clean fresh installs going back to 1.2.2 because that is what the mod was released for. And still got the Black cute cords in every test? I then loaded the Purple DDS into Gimp flipped it and saved it as a PNG and. ZdqEayH.png So I loaded it back into Gimp and re-flipped  it and saved it back as a DDS file. The file in the editor and the thumbnail looked jut like the old DDS ? But it loaded in game as solid white. Maybe I screwed something up in the settings converting it back? But I have 32gig of ram on my system and really don,t want to spend the time on this little mystery  PNG = problem solved . "Or at least worked around to my satisfaction" Thanks again for all the Help !   

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this