DanGSun

Telemachus Reborn [KSP v1.5.x-1.7.x ]

Recommended Posts

Posted (edited)

@FrostBird347 As you have since discovered, Telemachus does NOT have any maps of its own included in the mod. Telemachus only *displays* maps, that were seperately hosted on the old KerbalMaps website. Both projects were developed seperately. KerbalMaps was, I believe, intended *exactly*, as just a host site for those maps (with many kewl embedded features), and was availalable as a "service" to any KSP mods that wanted to access those maps. I dont know of many that did, except Telemachus.

As you found out, the *original* KerbalMaps site became either unusable or unavailable. There was someone in the forums that managed to rehost them on a different site, and they were again available for a time. THEN, someone *else*, again, came along, and picked up the project, and rehosted the site on a different domain.

The newest maintainer, and new website can be found in *this* thread:

THAT maintainer has been active recently, and is working on adding maps for other planet packs. There is a beta version of the site up for testing JNSQ maps.
That is also the site, and the developer, that I believe @DanGSun was, and now @Sidrus, is working with to get the maps working again for Telemachus.

So, yes, for what you are looking for, no need to concern yourself with Telemachus' licensing. You can work with either @CraigCottingham, or if you have managed to contact the original owner of KerbalMaps, then maybe that person.
Do me a favor, please, in any future contact you have with the *original* dev that you managed to hear from, and let them know of the thread I linked above.

 

Edited by Stone Blue

Share this post


Link to post
Share on other sites
2 hours ago, Stone Blue said:

@FrostBird347 As you have since discovered, Telemachus does NOT have any maps of its own included in the mod. Telemachus only *displays* maps, that were seperately hosted on the old KerbalMaps website. Both projects were developed seperately. KerbalMaps was, I believe, intended *exactly*, as just a host site for those maps (with many kewl embedded features), and was availalable as a "service" to any KSP mods that wanted to access those maps. I dont know of many that did, except Telemachus.

As you found out, the *original* KerbalMaps site became either unusable or unavailable. There was someone in the forums that managed to rehost them on a different site, and they were again available for a time. THEN, someone *else*, again, came along, and picked up the project, and rehosted the site on a different domain.

The newest maintainer, and new website can be found in *this* thread:

THAT maintainer has been active recently, and is working on adding maps for other planet packs. There is a beta version of the site up for testing JNSQ maps.
That is also the site, and the developer, that I believe @DanGSun was, and now @Sidrus, is working with to get the maps working again for Telemachus.

So, yes, for what you are looking for, no need to concern yourself with Telemachus' licensing. You can work with either @CraigCottingham, or if you have managed to contact the original owner of KerbalMaps, then maybe that person.
Do me a favor, please, in any future contact you have with the *original* dev that you managed to hear from, and let them know of the thread I linked above.

 

Thanks for clarifying some things, and for showing me an up-to date version of Kerbal Maps (It might be better for me to look into using the newer version instead, or at least start using some parts of it). I do not have any contact with the original owner, I contacted the person who hosted this site, but I did not even know that it was a re-upload at the time.

Share this post


Link to post
Share on other sites

I recently installed telemachus and my log has been getting spammed with this: [EXC 17:05:19.133] NullReferenceException: Object reference not set to an instance of an object
    Telemachus.TelemachusBehaviour.Update () (at <6c3d5a27a991441e960fef628a9e932b>:0). on top of that, chrome says the telemachus link refused to connect.

 anyone know how to fix this?

Share this post


Link to post
Share on other sites

When I try to load the 127.0.0.1 port on my tablet, it's giving me a "refused to connect" error, even though it's working on the desktop that runs KSP. I've been scouring the internet for fixes, but I simply haven't been able to figure it out. Do you know what might be causing this and how to fix it? 

Share this post


Link to post
Share on other sites
Posted (edited)
41 minutes ago, TheAceOfHearts said:

When I try to load the 127.0.0.1 port on my tablet, it's giving me a "refused to connect" error, even though it's working on the desktop that runs KSP. I've been scouring the internet for fixes, but I simply haven't been able to figure it out. Do you know what might be causing this and how to fix it? 

127.0.0.1 is an internal port *to the device you are running BOTH KSP and the browser on*. ie use, 127.0.0.1 in a browser thats running *ON* the same device as KSP.

You need to find the internal IP (the IP your router uses to connect to/identify the device you're running KSP on, then use *that* IP in the address bar of the browser on your *seperate* device.
You may still have to tweak/configure your firewall(s)/router properly to allow your ports to *talk*

For example, the pics in the OP, show IP as 192.168.1.64, as the IP of the machine running KSP, which you enter into the browser address, *on the device you are trying to run the Telemachus browser session on*

EDIT: also, the Telemachus User Guide is a little outdated. Its refers to port :8080 ... Telemachus is currently set to use port :8085, now, by default
Altho it can be user configured/changed, by editing the config.xml file in /PluginData/Telemachus/

Edited by Stone Blue

Share this post


Link to post
Share on other sites
Posted (edited)
14 hours ago, Weimaraner said:

I recently installed telemachus and my log has been getting spammed with this: [EXC 17:05:19.133] NullReferenceException: Object reference not set to an instance of an object
    Telemachus.TelemachusBehaviour.Update () (at <6c3d5a27a991441e960fef628a9e932b>:0). on top of that, chrome says the telemachus link refused to connect.

 anyone know how to fix this?

Do you know which version of Telemachus you have?
One thing you could try, if you haven't already, is to remove the Telemachus folder and re-install it.

To be sure, check https://github.com/TeleIO/Telemachus-1/releases for the current fork/version. It seems the OP has a few links to the original github page.

44 minutes ago, TheAceOfHearts said:

When I try to load the 127.0.0.1 port on my tablet, it's giving me a "refused to connect" error, even though it's working on the desktop that runs KSP. I've been scouring the internet for fixes, but I simply haven't been able to figure it out. Do you know what might be causing this and how to fix it? 

If you open the http://127.0.0.1:8085/telemachus/information.html page on the PC that runs KSP, does it open the Telemachus page?
If so, in the About tab, there are IP addresses. The third one listed (for me at least) is the IP address I use to connect from my tablet. On the tablet, I type that address followed by :8085 in the browser address bar and it works.
As Stone Blue mentions, your router or firewall may interfere, but for me they do not.

Edited by RowBear

Share this post


Link to post
Share on other sites
5 hours ago, RowBear said:

Do you know which version of Telemachus you have?
One thing you could try, if you haven't already, is to remove the Telemachus folder and re-install it.

To be sure, check https://github.com/TeleIO/Telemachus-1/releases for the current fork/version. It seems the OP has a few links to the original github page.

If you open the http://127.0.0.1:8085/telemachus/information.html page on the PC that runs KSP, does it open the Telemachus page?
If so, in the About tab, there are IP addresses. The third one listed (for me at least) is the IP address I use to connect from my tablet. On the tablet, I type that address followed by :8085 in the browser address bar and it works.
As Stone Blue mentions, your router or firewall may interfere, but for me they do not.

I have telemachus 1.7.64 and i will try that shortly thanks.

Share this post


Link to post
Share on other sites

I have a question. Do you know how so share the link to friends? So that I can be mission control for my friend?

 

Share this post


Link to post
Share on other sites
5 hours ago, SpaceNemo said:

I have a question. Do you know how so share the link to friends? So that I can be mission control for my friend?

 

The host would have to set up their router to forward external TCP request for port 8085 to the host computer and give the guest their external (public) IP address.  A static IP address for the host computer and a Dynamic DNS service is recommended for this.

Share this post


Link to post
Share on other sites
2 hours ago, Rayden said:

The host would have to set up their router to forward external TCP request for port 8085 to the host computer and give the guest their external (public) IP address.  A static IP address for the host computer and a Dynamic DNS service is recommended for this.

Thanks.

Share this post


Link to post
Share on other sites

Does Telemachus use real threads to do all the communication, or it is in co-routines?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.