Jump to content

[1.3.1 <= KSP <= 1.12.2] KAX - Kerbal Aircraft Expansion KAX — Under Lisias' Management — v2.8.1.0 [2021-0824]


Lisias
 Share

Recommended Posts

KAX 2.8.0.4 is on the wild!

Changes:

  • Fixing a warning related to a redundant pass specifier on the patch for FAR.
  • Fixing a pretty stupid mistake on the `.version` that was there since the begining of time!

— — — — 

This is a maintenance minor release, fixing a glitch on a patch as described here. Thanks for the heads up, @ssd21345 - this was fixed 4 months ago, but I completely forgot about.

Edited by Lisias
2.8.0.4
Link to comment
Share on other sites

8 hours ago, Lisias said:

KAX 2.8.0.3 is on the wild!

Changes:

  • Fixing a warning related to a redundant pass specifier on the patch for FAR.

— — — — 

This is a maintenance minor release, fixing a glitch on a patch as described here. Thanks for the heads up, @ssd21345 - this was fixed 4 months ago, but I completely forgot about.

the dl link you put in KSP-AVC is wrong. You put https://github.com/net.lisias.ksp/ instead of https://github.com/net-lisias-ksp/

Link to comment
Share on other sites

  • 2 months later...
On 5/7/2020 at 6:30 AM, sergeikat said:

Hi!
After reading the previous posts a while back, canyou confirm that KAX now works with 1.8./1.9? This is by far one of the best mods and would really like it for the latest versions! Thanks!

On KSP 1.8 it was working fine, any trouble I had with it came from something else (as Firespitter or TweakScale).

BUT... I didn't really tested it (I'm not even playing KSP anymore these months, all my free time is on handling KSP 1.9 new issues on TweakScale), so I choose not to state it works fine on KSP 1.8 besides not facing any problems on the few test sessions exactly because of it: it was only a few test sessions, no real playing where the real problems sparks.

If you can spend some time testing it in a myriad of ways using a disposable KSP instalment (just in case, "sheet happens"), I would be grateful for any bug reports you find on it (being on the parts, being on the dependencies).

Link to comment
Share on other sites

I was not able to test KAX on KSP 1.9.x either, but from the expirience in the past, each time KSP was updated KAX was worked fine whenever firespitter plugin was properly updated too. There was very few exceptions when something was not worked as intended. In doubt, create backup of your files and then try KAX, just in cse that something goes wrong.

Link to comment
Share on other sites

3 hours ago, Lisias said:

On KSP 1.8 it was working fine, any trouble I had with it came from something else (as Firespitter or TweakScale).

BUT... I didn't really tested it (I'm not even playing KSP anymore these months, all my free time is on handling KSP 1.9 new issues on TweakScale), so I choose not to state it works fine on KSP 1.8 besides not facing any problems on the few test sessions exactly because of it: it was only a few test sessions, no real playing where the real problems sparks.

If you can spend some time testing it in a myriad of ways using a disposable KSP instalment (just in case, "sheet happens"), I would be grateful for any bug reports you find on it (being on the parts, being on the dependencies).

Thanks for the reply! I would be happy to give some things a test, just downloaded the latest version of everything as needed, and the game launches and runs OK. 1.8 will be the version that causes problems if any arise, as that was when the game was updated to the new version of Unity, with 1.9 being mainly a graphics and performance based mod.  I have plenty of time spare, so I will give everything a check over, and report any issues back To you!

Link to comment
Share on other sites

5 hours ago, sergeikat said:

Thanks for the reply! I would be happy to give some things a test, just downloaded the latest version of everything as needed, and the game launches and runs OK. 1.8 will be the version that causes problems if any arise, as that was when the game was updated to the new version of Unity, with 1.9 being mainly a graphics and performance based mod.  I have plenty of time spare, so I will give everything a check over, and report any issues back To you!

Thank you!

In time, KSP 1.9 had, indeed, changed some things that played havoc on some Add'Ons (as TweakScale, but not only - Fuel Switches are expected to be problematic too). If you choose to test on KSP 1.9, be prepared for some problems with that Modules, and also with surface attachments on Parts with Variants (this is precisely what's bitting my SAS on TweakScale).

Link to comment
Share on other sites

  • 1 month later...
  • 5 weeks later...
13 hours ago, SomeoneWhoLikesTrains said:

There's a glitch in 1.10 where the part select menu is all glitched, and one of the categories (Either engines or fuel tanks) doesn't work at all. This addon needs to be fixed.

Nope, there's nothing to be fixed. KAX works fine from KSP 1.3.1 to 1.7.3, where I said it's meant to work. ;) 

I could agree it are in need to be updated to 1.10, however, if you would be kind enough to explain what's broken? It looks fine to me:

QTJYQap.png

Link to comment
Share on other sites

4 hours ago, SomeoneWhoLikesTrains said:

I'll need to install the mod back and take a video to show what i mean.

Edit:This is the second time something like this has happened to me. I say something is broken, but all of a sudden it works again. That was what happened in this case.

Next time it happens, take a screenshot and publish here with KSP.log and ModuleManager.ConfigCache. I may be some bad interaction between some other add'on. It's more common than we would like, and some are pretty hard to identify.

Link to comment
Share on other sites

  • 4 weeks later...
On 8/27/2020 at 6:53 PM, Kerbalwings said:

@Lisias Are you finished working on the landing gear?

Didn't even started yet. KAX will have to wait until I deliver TweakScale 2.4.4.0 - can't handle both at the same time. :)

-- -- POST EDIT -- -- (one week later)

@Kerbalwings, that's the history: there's a (dirty) trick that would accelerate resurrecting that gorgeous landing gear of KAX : making World Stabilizer an optional dependency.

If you have it installed, the gears will be available. If you don't, you will have no gears but will an Warning saying you need to install World Stabilizer in order to have access to all parts every time you install or delete something on the GameData.

Doing this way, I will not have to rework the mesh, all it's needed is to adapt it to the new wheels modules from KSP.

Do you would compromise with such a stunt? (it would be needed to a lot of add'ons too, as Firespitter anyway)

 

Edited by Lisias
post edit
Link to comment
Share on other sites

  • 2 months later...
11 hours ago, keptin said:

Very cool to see my old mod being kept alive. Your hard work is appreciated @Lisias. Let me know if you need any of the original assets...or perhaps some new ones ;)

Hey, nice to see you around here! :)

Some of the original assets were lost in time due accidents, I'm relying to Blender and io_object_mu to reverse engineer them. In special, I'm fighting to bring back that gorgeous landing gears! :)

Link to comment
Share on other sites

12 hours ago, Lisias said:

Hey, nice to see you around here! :)

Some of the original assets were lost in time due accidents, I'm relying to Blender and io_object_mu to reverse engineer them. In special, I'm fighting to bring back that gorgeous landing gears! :)

Just sent you a package of the original assets and unity project. Hope that helps! If doesn't include the original PSD files used to build the textures, I can pack those up as well. The models are in Maya .mb. Let me know if you'd like them converted to an FBX or OBJ common format for Blender.

Edited by keptin
Link to comment
Share on other sites

  • 3 weeks later...

hello, folks. 

I'm just wondering if KAX is still supported?
Now at 1.10 I got this:
And KSP cannot load.

[LOG 10:56:30.662] PartLoader: Part 'KAX/Parts/KAX_electricProp/KAX_electricProp/KAXelectricprop' has no database record. Creating.
[LOG 10:56:30.662] [DragCubeSystem]: Drag cubes not found or cannot be read for part Part. Generating New drag cubes.
[LOG 10:56:30.670] DragCubeSystem: Creating drag cubes for part 'KAXelectricprop'
[EXC 10:56:30.712] NullReferenceException: Object reference not set to an instance of an object
	ModuleResourceIntake.GetInfo () (at <c1858a3f77504bd1aaa946fdccf84670>:0)
	PartLoader.CompilePartInfo (AvailablePart newPartInfo, Part part) (at <c1858a3f77504bd1aaa946fdccf84670>:0)
	PartLoader+<CompileParts>d__56.MoveNext () (at <c1858a3f77504bd1aaa946fdccf84670>:0)
	UnityEngine.SetupCoroutine.InvokeMoveNext (System.Collections.IEnumerator enumerator, System.IntPtr returnValueAddress) (at <5aeafee3fea24f37abd1315553f2cfa6>:0)
	UnityEngine.DebugLogHandler:LogException(Exception, Object)
	ModuleManager.UnityLogHandle.InterceptLogHandler:LogException(Exception, Object)
	UnityEngine.Debug:CallOverridenDebugHandler(Exception, Object)

 

Link to comment
Share on other sites

On 11/19/2020 at 5:06 AM, Adoelrome said:

hello, folks. 

I'm just wondering if KAX is still supported?
 

KAX is fully supported from KSP 1.3.1 to 1.7.3 .

KAX is known to work fine from KSP 1.8.0 to 1.9.1 - at least, I didn't got any issues on the minimalistic tests I did. But since these tests were minimalistic, I refrain myself from advertising it as fully supported on these KSP versions.

KSP 1.10 was currently unknown, until your report. Now I know it doesn't works.

This will be tackled down as soon as I managed to kick TweakScale 2.4.4.0 through the door.

Link to comment
Share on other sites

17 hours ago, Lisias said:

KAX is fully supported from KSP 1.3.1 to 1.7.3 .

KAX is known to work fine from KSP 1.8.0 to 1.9.1 - at least, I didn't got any issues on the minimalistic tests I did. But since these tests were minimalistic, I refrain myself from advertising it as fully supported on these KSP versions.

KSP 1.10 was currently unknown, until your report. Now I know it doesn't works.

This will be tackled down as soon as I managed to kick TweakScale 2.4.4.0 through the door.

I've had no issues with KAX on 1.10.1 though.

Link to comment
Share on other sites

5 hours ago, boribori said:

I've had no issues with KAX on 1.10.1 though.

Interesting... Oukey, time to burn some time from the lunch :sticktongue: and do a test. KSP 1.11 is on the corner already!

-- hack hack hack - reboot! - hack hack hack -- 

Yeah, @boribori is right!

@Adoelrome, this is an excerpt from my KSP.log from my KSP 1.10.1 test bed:

Quote

[LOG 12:36:34.116] [KSPe Binder] Looking for TestFlightCore.dll on GameData/000_KSPAPIExtensions/Plugins/PluginData...
[LOG 12:36:34.122] PartLoader: Part 'KAX/Parts/KAX_electricProp/KAX_electricProp/KAXelectricprop' has no database record. Creating.
[LOG 12:36:34.122] [DragCubeSystem]: Drag cubes not found or cannot be read for part Part. Generating New drag cubes.
[LOG 12:36:34.127] DragCubeSystem: Creating drag cubes for part 'KAXelectricprop'
[LOG 12:36:34.165] PartLoader: Compiling Part 'KAX/Parts/KAX_jumpJet/KAX_jumpJet/KAXjumpJet'
 

No NullReferenceException! It worked fine on my rig. Cristal clear!

Thanks for the heads up, @boribori! You saved me some debugging time! :)

 

On 11/19/2020 at 5:06 AM, Adoelrome said:

Now at 1.10 I got this:
And KSP cannot load.

@Adoelrome, I misdiagnosed your case. Please send me the whole KSP.log so I can try to figure out what's borking your KSP instalment. It's not KAX for sure, but it may be something KAX uses - or something that changes KAX in a way that lead to the bork.

In a way or another, I need the full KSP.log in order to diagnose the problem.

Link to comment
Share on other sites

oh folks.. Am really grateful that u invested time and effort to the tests but mayb it's just not that serious.

Actually I do not have this log now - the problem was only with one part, so i just deleted it and everything go back on.

The matter is that the log was normal, without errors or warnings, and it just stops at the place that I showed. It freezes and nothing else happens.

So my life is totally ok without this part and u can just leave it.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...