UomoCapra

Kerbal Space Program 1.6: “To Vee or not To Vee” Grand Discussion Thread

UomoCapra

1.6 has just been released! Please do not ask for mod updates - give the authors some time

Message added by UomoCapra

Recommended Posts

I'm noticing some bugs with the parachutes, the mk16 I think they're called. Don't know how to explain, have screenshots tho. Also a little feedback: when detaching a payload, SAS will occasionally shut off, like when im flying the Stratolauncher or Satellite Launcher... this is in stock game w/out mods. In addition to this, I'm a little upset over how the probe modules got nerfed, especially since i mostly play sandbox mode. The Octo barely has any useful functionality.RqTaTXs.png

Share this post


Link to post
Share on other sites
1 hour ago, TrackerAerospace said:

In addition to this, I'm a little upset over how the probe modules got nerfed, especially since i mostly play sandbox mode. The Octo barely has any useful functionality.

Nerfed? Nerfed how? I haven't noticed any difference at all in the probe cores' behavior. Am I missing something?

Share this post


Link to post
Share on other sites

Yeah it's on by default in career but off in sandbox. But you can change it in both.

Share this post


Link to post
Share on other sites
6 hours ago, TrackerAerospace said:

I'm noticing some bugs with the parachutes, the mk16 I think they're called. Don't know how to explain, have screenshots tho. Also a little feedback: when detaching a payload, SAS will occasionally shut off, like when im flying the Stratolauncher or Satellite Launcher... this is in stock game w/out mods. In addition to this, I'm a little upset over how the probe modules got nerfed, especially since i mostly play sandbox mode. The Octo barely has any useful functionality.RqTaTXs.png

My mod, OldPartsRedux, adds classic versions of the probe cores based off their 1.5 counterparts. They should be immune to the changes affecting the 1.6 versions.

Share this post


Link to post
Share on other sites

i love the revamp. i love the variants and new colors. and that we can shrink some engines one diameter smaller with one of the variants.

and i love the 2 nozzled poodle. but i would also love to switch between 1 or 2 nozzles. on landers or small docking crafts it looked great with the "small" 1 nozzled engine :)

Share this post


Link to post
Share on other sites

Can anyone confirm a bug I have with the Mk2LanderCan? Apparently, while all my right click menus are working fine with MM and a bunch of mods, trying to use the Right Click Menu on the Mk2 Lander Can in the VAB/SPH immediately triggers a long list of variant switch menus, NullRefs and disables menus for every part. It was fixed when I entered another building, but I want to see whether this applies to me or to everybody. I run MM 3.1.0

Share this post


Link to post
Share on other sites
On 1/6/2019 at 4:58 PM, TriggeredSnake said:

My mod, OldPartsRedux

I feel like your self advertising across the platforms gets a bit bothersome.
 

1 minute ago, Xurkitree said:

Can anyone confirm a bug I have with the Mk2LanderCan? Apparently, while all my right click menus are working fine with MM and a bunch of mods, trying to use the Right Click Menu on the Mk2 Lander Can in the VAB/SPH immediately triggers a long list of variant switch menus, NullRefs and disables menus for every part. It was fixed when I entered another building, but I want to see whether this applies to me or to everybody. I run MM 3.1.0

You are a bit late on that.
Using MM on 1.6 causes an odd bug with the partdatabase cfg.
Whenever you remove or add a partmod, which both edits that cfg, the Landercan bug gets triggered (this also affects a variety of modded animations). 
Closing the game and loading it a second time without removiing or adding anything, results in temporaly disabling that bug (until you again add or remove a mod)

Share this post


Link to post
Share on other sites
17 minutes ago, GrandProtectorDark said:

I feel like your self advertising across the platforms gets a bit bothersome.
 

You are a bit late on that.
Using MM on 1.6 causes an odd bug with the partdatabase cfg.
Whenever you remove or add a partmod, which both edits that cfg, the Landercan bug gets triggered (this also affects a variety of modded animations). 
Closing the game and loading it a second time without removiing or adding anything, results in temporaly disabling that bug (until you again add or remove a mod)

Nope it doesn't for me. This is after I've run 1.6 with MM multiple times, and I only experienced it today.

To check whether this is a mod conflict or not, I fired up my stock install with just MM,MJ,KER and MJ and KER for all, and tried right clicking the Lander Can. I did this twice - same result.

So something is going very wrong somewhere...

Share this post


Link to post
Share on other sites
Just now, Xurkitree said:

Nope it doesn't for me. This is after I've run 1.6 with MM multiple times, and I only experienced it today.

To check whether this is a mod conflict or not, I fired up my stock install with just MM,MJ,KER and MJ and KER for all, and tried right clicking the Lander Can. I did this twice - same result.

So something is going very wrong somewhere...

Did you verify your game first? 

Share this post


Link to post
Share on other sites

There have been lots of games on steam - inc. KSP - that pulled a very small update, but I cannot see what was done.

Can anyone help?

Share this post


Link to post
Share on other sites
1 minute ago, KerbMav said:

There have been lots of games on steam - inc. KSP - that pulled a very small update, but I cannot see what was done.

Can anyone help?

1.6.1 bug fix update

  • Like 1

Share this post


Link to post
Share on other sites
2 hours ago, GrandProtectorDark said:

1.6.1 bug fix update

I keep missing these announcements ...

Share this post


Link to post
Share on other sites
17 minutes ago, KerbMav said:

I keep missing these announcements ...

They are in another part of the forum called.... Announcements. But it does seem like they downplay the bugfix releases.

Share this post


Link to post
Share on other sites
6 hours ago, Xurkitree said:

Can anyone confirm a bug I have with the Mk2LanderCan? Apparently, while all my right click menus are working fine with MM and a bunch of mods, trying to use the Right Click Menu on the Mk2 Lander Can in the VAB/SPH immediately triggers a long list of variant switch menus, NullRefs and disables menus for every part. It was fixed when I entered another building, but I want to see whether this applies to me or to everybody. I run MM 3.1.0

I believe they just patched that in the 1.6.1 release today.

  • Like 1

Share this post


Link to post
Share on other sites
21 hours ago, GrandProtectorDark said:

I feel like your self advertising across the platforms gets a bit bothersome.
 

You are a bit late on that.
Using MM on 1.6 causes an odd bug with the partdatabase cfg.
Whenever you remove or add a partmod, which both edits that cfg, the Landercan bug gets triggered (this also affects a variety of modded animations). 
Closing the game and loading it a second time without removiing or adding anything, results in temporaly disabling that bug (until you again add or remove a mod)

Maybe. I’ll stop if anyone else complains; so far you are the only one and I’ve introduced quite a few people to OldPartsRedux who have been really enjoying it.

Share this post


Link to post
Share on other sites
On 1/6/2019 at 11:53 PM, Snark said:

Nerfed? Nerfed how? I haven't noticed any difference at all in the probe cores' behavior. Am I missing something?

So in sandbox prior to 1.6, all the probe cores had full SAS functionality when fully upgraded. Now the smaller ones only have retrograde or prograde hold, and the octo just has attitude hold

On 1/7/2019 at 4:58 AM, TriggeredSnake said:

My mod, OldPartsRedux, adds classic versions of the probe cores based off their 1.5 counterparts. They should be immune to the changes affecting the 1.6 versions.

I’ll keep that in mind, but I’m still using 1.5 for modded saves because not everyone has updated their mods

On 1/7/2019 at 12:12 AM, Mythical Donuts said:

@Snark he means the new feature where you can set it so not all probe cores have all SAS modes

@TrackerAerospace  you can change that in the difficulty settings from the pause menu

I’m sorry, I looked but I might need help finding that setting 

Share this post


Link to post
Share on other sites
23 minutes ago, TrackerAerospace said:

So in sandbox prior to 1.6, all the probe cores had full SAS functionality when fully upgraded. Now the smaller ones only have retrograde or prograde hold, and the octo just has attitude hold

I’ll keep that in mind, but I’m still using 1.5 for modded saves because not everyone has updated their mods

I’m sorry, I looked but I might need help finding that setting 

so when you create a save, you know the difficulty options thing? go into Advanced in that and it says All SAS Modes in Probe Cores or something like that, just tap the button next to it

  • Like 1

Share this post


Link to post
Share on other sites
7 hours ago, Mythical Donuts said:

so when you create a save, you know the difficulty options thing? go into Advanced in that and it says All SAS Modes in Probe Cores or something like that, just tap the button next to it

Copy that, thanks

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now